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Welcome
Welcome

The HyperCard® application is a software construction tool. You use it to 
create your own way of doing things on your computer. This book is a 
reference to everything you need to know to use HyperCard, including how
use and create “smart” documents called stacks. Stacks can do many of the 
things that ordinary application programs can do, and more—you can dec
for yourself how you want your stacks to work without knowing a word of 
programming. 

If you do know something about programming, or if you’re just curious, yo
can learn about the HyperTalk® programming language that’s built into 
HyperCard. For details, see the HyperCard Script Language Guide included in 
this package.
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HyperCard Documentation 
HyperCard contains the following documentation:

■ HyperCard Reference (the book you are reading now) is a reference to 
consult as you work with HyperCard. It also contains brief tutorials on 
working with HyperCard and on building scripts with HyperTalk.

■ HyperCard Script Language Guide is a book that gives detailed referenc
information about scripts and the HyperTalk language. It’s written for 
people with some programming or scripting experience.

■ HyperCard Quick Reference Guide is a booklet that gives many keyboard
shortcuts for HyperCard and HyperTalk operations, and presents a 
summary of HyperTalk messages, keywords, and commands.

■ New Features is a stack that describes the features added to this versio
HyperCard.

■ Hypercard Help is a stack that answers your questions as you’re using
HyperCard.

■ HyperTalk Reference is a stack that provides easy access to information
about HyperTalk for people who use HyperCard’s programming langua

■ AppleEvents Primer is a stack that demonstrates how to exchange 
information between applications in an Apple events-aware environme
(such as System 7).

■ QuickTime Tools is a stack that provides tools and external commands 
using QuickTime to produce multimedia presentations.

■ HyperCard AppleScript Reference is a stack that describes the basics of 
using AppleScript with HyperCard, and includes explanations of 
AppleScript statements as well as demonstration scripts.

■ AppleScript Samples is a folder of stacks that present examples of 
AppleScript in HyperCard.
Welcome xvi
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What You Need to Know 
This book assumes that you know how to use your Macintosh. You shoul
know how to: 

■ use the mouse and keyboard 

■ choose from a menu 

■ use command keys 

■ copy files and disks 

■ open disks, folders, applications, and documents 

■ do simple text editing 

■ use the directory dialog box to locate files 

If you’re not sure how to do any of the tasks listed, go through the 
documentation that came with your computer before you do anything else

How to use this book
This book is designed to help you find answers to your questions quickly. 
organized according to tasks. Use the table of contents or the index to loc
instructions for specific tasks. You can also use the index to find informat
about individual topics and commands. 

Descriptions of specific tasks often include numbered steps. Each step is m
up of a short instruction in boldface type, often followed by further explanat
in plain type. Depending on your level of expertise with the Macintosh, you 
speed through some or all of the instructions by reading just the boldface s
Welcome xvii
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The book contains the following chapters: 

■ Chapter 1, “Using HyperCard,” describes how to use HyperCard 
stacks—“smart” documents created with HyperCard. This chapter also
explains how to use stacks stored on file servers and compact discs. 

■ Chapter 2, “Learning HyperCard Basics,” is a tutorial on the most comm
HyperCard features. While it won’t make you a HyperCard expert, it w
give you practice using basic stack-building tools and techniques.

■ Chapter 3, “A Taste of HyperTalk,” is a tutorial on HyperCard’s built-in
scripting language. If you find that you enjoy writing scripts and you wa
to learn more, you can use the HyperCard Script Language Guide, also 
included in this package.

■ Chapter 4, “Creating and Modifying Stacks,” provides information abo
building stacks. This chapter includes specific instructions for working
with a stack as a whole. 

■ Chapter 5, “Working with Cards and Backgrounds,” explains how to cre
and modify individual cards and backgrounds. 

■ Chapter 6, “Working with Buttons,” explains how to create and modify
buttons and use them to link related pieces of information. 

■ Chapter 7, “Working with Text and Fields,” explains how to create and
modify fields (the places you create to hold text), how to enter text into
fields, and how to format text. 

■ Chapter 8, “Working with Graphics,” describes HyperCard Paint tools a
commands, and shows you how to use them to create graphics. 

■ Chapter 9, “Printing,” explains how to print the information in a stack. 
xviii Welcome
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Where to Get HyperCard Stacks
A HyperCard stack can be as simple as a collection of information, or as 
complex as any application program. You can use the stacks that come w
HyperCard, create stacks yourself, or get stacks from a variety of other sou

■ You can find HyperCard stacks for sale at your local computer 
software store. 

■ You can check with your local user group to find out the meeting time 
the HyperCard special interest group. Members often share their stac
with each other. 

■ You can subscribe to online electronic information services such as 
CompuServe, GEnie, America Online, and The Well (to name a few), 
which have HyperCard special interest groups. These groups have sta
you can get free, except for the service’s time charges. 

About user groups
Computer user groups can be a great source of information about HyperC
and about your computer. Members of user groups meet to share ideas, d
problems, and exchange software and information. By attending user gro
meetings, you can learn more about HyperCard and see how others are us

Ask your authorized Apple dealer for the name of the user group nearest 
or call (800) 538-9696. 
Welcome xix
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1

Using HyperCard     

This chapter begins with a brief summary of what HyperCard is and what 
can do with it. The remainder of the chapter describes what you need to k
to effectively use HyperCard stacks (the name for documents that you create
with HyperCard), including how to: 

■ use the Home stack 

■ open, explore, and close stacks 

■ use HyperCard on a file server and on a CD-ROM

To do the tasks described in this chapter, you need to have your user level set 
to Typing or higher. The user level determines what HyperCard tools and 
capabilities are available to you. HyperCard comes with the user level pres
Typing. Unless someone has changed the setting, you don’t have to be 
concerned with it for the moment. 

For a tutorial on many of the features described in this chapter, turn to 
Chapter 2, “Learning HyperCard Basics.”
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What Is HyperCard?    
You use HyperCard to create your own way of doing things on your compu
HyperCard is unlike most application programs, which are designed to perf
one task (such as word processing or creating graphics). You can use 
HyperCard for many different tasks. Here are a few examples: 

■ Gather information and organize it in any way you like. 

■ Browse through information you’ve assembled yourself, or information
gathered by someone else. Follow links to topics you want to know m
about, skip over things you’re not interested in, and search for specific f
or text. 

■ Create HyperCard stacks that meet your own specific needs—for exam
stacks to keep track of your expenses, help you learn a new language
organize a collection of electronic clip art, or present information store
a videodisc. 

■ Customize your computer work space so that, for example, with a sing
mouse click, you can log onto another computer, launch an applicatio
hidden away in a folder, or send a message to a friend. 

Using HyperTalk, HyperCard’s English-like script language, you can gain 
even more control over your HyperCard environment whether or not you h
prior programming experience. You can tap the power of HyperTalk witho
knowing anything about how it works. For example, without writing a word 
HyperTalk, you can link a button to a stack, automatically creating a script 
tells the button to take you to that stack. And HyperCard comes with read
made scripts you can copy and paste.     

The more you learn about HyperCard, the more uses you’ll see for it. 
HyperCard provides you with a creative environment that’s limited only by
your imagination. 
1-2 Chapter 1: Using HyperCard



   

. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .

    

 
he 

ally 
 the 
Cards and stacks   
In HyperCard, information appears on cards. A HyperCard card is much like a
paper index card on which you jot notes or any other kind of information. T
card is the fundamental unit of information in HyperCard. 

A card can contain both text and pictures.      

Cards are grouped together into stacks. The cards within a stack are usu
related to one another, or based on a common theme. They usually have
same look and contain similar information. 
Chapter 1: Using HyperCard 1-3
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Every stack has a name. An icon for each stack appears in the Finder: 

You can learn a lot about the power of HyperCard just by exploring the sta
that come with it. These stacks provide good examples of the kinds of thi
HyperCard can do. You can get additional stacks from electronic bulletin 
boards and from user groups. 

HyperCard includes tools for modifying and creating stacks. With these to
you create and manipulate the building blocks that make up stacks. You c
arrange the information on cards in any way you like. And you can tie toge
related information by creating links so that a single click takes you 
immediately to the information you want, whether it’s in the same stack o
different one.      

Starting HyperCard      
Before you start HyperCard, make sure you have a backup copy of each 
that comes with it; write-protect these backup disks. It’s particularly import
to do this with HyperCard, because HyperCard automatically saves any 
changes you make to stacks without asking. (There is no way to turn off t
feature.) Keep a backup copy of each stack that comes with HyperCard so
you can always retrieve the original.   

Starting from the Home stack     
The Home stack serves as a home base whenever you use HyperCard, a
a good place to start exploring. It includes a visual directory of other 
HyperCard stacks and provides easy access to them.
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There are two ways to start HyperCard so that it opens the Home stack: 

You may have to close windows or open folders to find the HyperCard ico
the Home icon.     

❖ Where is Home?HyperCard does its best to find the Home stack. Whe
you start HyperCard, it looks for a stack named “Home” in the System
Folder, in the folder that contains HyperCard, and in any folder named
HyperCard Stacks that’s at the same directory level as HyperCard. Th
looks on the top level of your disk directory—that is, on the current dis
among the files that aren’t in any folders. If it can’t find Home in any o
these places, HyperCard displays the directory dialog box and asks w
Home is.

You can designate any stack to be the Home stack, even if the stack’s n
isn’t “Home.” If HyperCard can’t find a stack named “Home” when you
start it, the directory dialog box appears. Click the stack’s name that y
want to act as temporary home.❖

In the Finder, 
double-click the 
HyperCard icon …

… or double-click
the Home icon.
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For more information about using the directory dialog box, see the 
documentation that came with your computer. 

Starting with a stack other than Home    
You can start HyperCard so that it opens to a particular stack other than H
Just double-click the icon of that stack, or select it and choose Open from
File menu.

❖ Padlock ( ) in the menu bar:Sometimes you see a padlock in the men
bar to the right of the rightmost HyperCard menu title. The padlock me
the stack is locked so you can’t make changes to it. The sections “Ope
a Write-Protected Stack” and “Opening a Stack Built in an Earlier Vers
of HyperCard” later in this chapter give information about working with
such stacks.❖     

Home Stack    
Home is the HyperCard central stack. You can return to it easily from any o
stack at any time. Most people use the Home stack as their base of opera
a jumping-off point for their work in HyperCard. This section describes the
Home stack that comes with HyperCard. 

This is the current directory level. To see higher levels 
in your disk directory (if there are any), drag down 
from here and select a folder.

To move up one 
level in your disk 
directory, click here.

To open a stack or
folder in this list,

double-click it.
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The cards in the Home stack contain information vital to HyperCard 
performance: 

■ The first cards in the Home stack, called the Home cards, are designe
hold buttons that take you to stacks. 

■ The Search Paths cards tell HyperCard where to find stacks, applicati
and documents that you use frequently. 

■ The Preferences card customizes the way you interact with HyperCar

Home cards      
The first cards in the Home stack contain buttons that take you to all the st
that come with HyperCard, from collections of electronic art to special sta
building tools. 

There are also blank Home cards. As you become more comfortable with
HyperCard, you can add buttons to these cards, or to new ones that you c
to link your Home cards to your favorite cards, stacks, and applications. 
Collectively, the Home cards provide a visual directory for your stacks.    

➤  See also: “Customizing Your Home Stack” in Chapter 4.       

These buttons go to
stacks that come
with HyperCard.

These buttons move
through the cards in

the Home stack.
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User levels and options        
You adjust the settings on the Preferences card to customize the way you
interact with HyperCard. To go to the Preferences card:

1. Go to the Home stack (if you’re not already there) by doing one of the following:

■ Choose Home from the Go menu.

■ Press x-H. 

2. Choose Last from the Go menu.

Preferences is the last card in the Home stack.

Setting your user level
On the Preferences card, click the user level that matches what you want 
in HyperCard: 

Each level gives you all the features from the previous levels, plus additio
capabilities. For example, the features available at the Browsing level are
available at the Typing level; the features available at the Browsing and Typ
levels are also available at the Painting level; and so on. 

This column explains what you 
can do at each user level.

You type your name here.
1-8 Chapter 1: Using HyperCard
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The higher the user level you choose, the more you can do with HyperCa
Unless a stack has been specially protected (using methods you’ll read a
later), you can change your user level at any time.     

User level What you can do 

 1     Browsing      Open, close, and browse through stacks, search for tex
click buttons, move between stacks, save copies of stac
and print the information in stacks. 

 2      Typing  In addition to all of the things you can do at the Browsing
level, you can type, edit, and add styles to text in existin
fields, set the Arrow Keys in Text option on the 
Preferences card (explained in the “Arrow Keys in Text 
Option” later in this chapter), add and delete cards, and
compact stacks.    

 3      Painting  In addition to all of the things you can do at the Typing 
level, you can set stack protection, edit icons from the Ed
menu, delete stacks, create graphics with the Paint tools
the Tools menu, edit graphics and patterns using the Pa
and Options menus (which appear when a Paint tool is 
selected), move between the background layer and the
card layer, and use the Power Keys (explained in “Powe
Keys Option” later in this chapter).    

 4      Authoring     In addition to all of the things you can do at the Painting
level, you can create, modify, and delete buttons, links,
fields, cards, backgrounds, and stacks using the Button
tool, the Field tool, and commands in the Objects menu

 5      Scripting  In addition to all of the things you can do at the Authoring
level, you can write, edit, and debug scripts, and use th
Blind Typing option (explained in “Blind Typing Option” 
later in this chapter).     
Chapter 1: Using HyperCard 1-9
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❖ User preferences and stack protection:The tools and commands you have
at your disposal while you’re using a specific stack are determined by b
the user level you set on your Preferences card and the stack’s user lev
in the Protect Stack dialog box. When a stack is set to a different user l
than the one set on the Preferences card, HyperCard uses the lower s
(the one closer to Browsing). For information on setting and changing
stack’s user level, see “Protecting Your Stack” in Chapter 4.❖         

Arrow Keys in Text option  
When you click any user level button on the Preferences card except Brow
a checkbox labeled Arrow Keys in Text appears. You turn this option on or
by clicking it. 

File and Edit menus when your user level is 
Browsing or Typing

File and Edit menus when your user level is 
Painting, Authoring, or Scripting
1-10 Chapter 1: Using HyperCard
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When this option is turned off, the arrow keys on the keyboard move you 
through cards in a stack. When this option is turned on and the insertion p
is blinking in a field or in the Message box (a place where you give instructions
to HyperCard), the arrow keys move the insertion point through text just a
they do in word processors.               

Go to the previous 
card in the current 
stack.

Go to the next card 
in the current stack.

Go back through 
cards you’ve seen.

Go forward through 
cards you’ve 
reviewed.

Move the insertion 
point left over text.

Move the insertion 
point right over text.

Move the insertion 
point down through 
lines in a field, or to 
the end of the line in 
the Message box.

Move the insertion 
point up through lines 
in a field, or to the 
beginning of the line in 
the Message box.
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When Arrow Keys in Text is turned on, you can use the arrow keys to mo
through a stack as long as the insertion point is not in a field or in the Mes
box. If it’s in either of those places, you can still use the arrow keys to navig
through cards by pressing the Option key in combination with the arrow k
you want to use:

➤  See also: “Moving Around in a Stack” in this chapter.              

Power Keys option            
When you select Painting (or a higher user level) on the Preferences card
checkbox labeled Power Keys appears. Checking this box turns on the P
Keys option. With it, you can use specific keys on the keyboard instead o
using menu commands to make changes to graphics. 

➤  See also: “Using Power Keys” in Chapter 8.

Blind Typing Option           
When you select Scripting on the Preferences card, a checkbox labeled B
Typing appears. When this option is turned on, you can type into the Mes
box even when it’s hidden (as long as the insertion point isn’t in a field). 
Entering commands through the Message box sends instructions to Hyper

To go to the previous card in 
the current stack

To go to the next card in the 
current stack

To go back through cards 
you’ve seen

To go forward through cards 
you’ve reviewed
1-12 Chapter 1: Using HyperCard
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You select or deselect the Blind Typing option by checking it. When the Bl
Typing option is turned off, you can type into the Message box only when 
see it on the screen; HyperCard beeps (or the menu bar flashes) if you tr
type into the Message box when it’s hidden. 

How HyperCard finds stacks    
When you tell HyperCard to open a document, an application, or a stack 
clicking an icon on one of the Home cards, for example), HyperCard sear
for the file by first looking in the folder that contains the current stack. The
checks the Search Paths cards in the Home stack to see where else to lo
the requested file. 

To see one of the Search Paths cards:

1. Go to the Home stack (if you’re not already there) by doing one of the following:

■ Choose Home from the Go menu.

■ Press x-H.

2. Do one of the following:

■ Click the Right Arrow icon at the bottom of the screen several times

■ Choose Search Paths from the Home menu.

The Home stack has three Search Paths cards. One tells HyperCard in w
folders to look for stacks, another tells it where to look for applications, an
third tells it where to look for documents. These cards contain lists of search 
paths (pathways through the folders on your disk) that HyperCard should 
follow to retrieve a stack, application, or document. 

If you ask HyperCard for a file it can’t find (that is, one whose search path i
recorded on the appropriate Search Paths card), it displays a directory di
box and asks you where the file is. Once you’ve located the file, HyperCa
notes the disk, folder, and any subfolder in which the file resides, and rec
it on the appropriate Search Paths card in the Home stack. The next time
ask for that file, HyperCard knows where to look for it without having to as
you. (HyperCard asks again, however, if you’ve renamed the file or chang
the name of the disk or folder that contains it.)     
Chapter 1: Using HyperCard 1-13
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You can also add search paths to these cards yourself. For example, if yo
move a stack into a folder named Old Stacks within the HyperCard Stack
folder, you can type the following line on the stacks’ Search Path card:

:HyperCard Stacks:Old Stacks: 

Include no spaces between the last character in a folder’s name, the colon
the first character in the name of the enclosed folder. When you rename a
folder, or file, you can change its name on the appropriate Search Paths 
Or, if you prefer not to deal directly with these cards, you can always use
directory dialog box to help HyperCard locate the files you need.    

❖ Occasional housecleaning:HyperCard keeps a record of each search pa
until you erase it. Erasing a search path you no longer use frees that s
on the Search Paths card and helps HyperCard operate more efficientl
erase a search path, drag to select it and choose Clear Text from the 
Edit menu.❖                  
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Opening and Closing Stacks
HyperCard provides several ways to open and close a stack.

Opening a stack              
Use any of these methods to open a stack: 

Double-click the stack’s
icon in the Finder.

Click a button that’s
linked to the stack (if
there is such a button).

Choose Message from the 
Go menu to open the Message 
box, type go to stack

and the stack’s name (in 
quotation marks), and press 
Return or Enter.     

Choose Open Stack
from the File menu
and open the stack.    
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When you choose the Open Stack command, HyperCard displays a direc
dialog box and waits for you to tell it which stack to open:

If you check “Open stack in new window,” HyperCard opens the stack in a n
window and leaves your current stack open in another window. If the opti
“Open stack in new window” is turned off (that is, there’s no mark in the 
checkbox), HyperCard opens the stack in the current window.    

❖ Shortcut for opening a stack in a new window:Press x-Shift-O, or hold 
down the Shift key while you choose Open Stack from the File menu. T
directory dialog box appears with the “Open stack in new window” opti
already selected. (This shortcut doesn’t work when the insertion point
blinking in a field.) ❖

This is the current directory level. You see higher levels in your 
disk directory (if there are any) by pressing and holding the 
mouse button here; then you drag down to select a folder.

Click here to move up one 
level in your disk directory.

Click here if the stack you 
want to open is on the 
desktop or another disk.

Locate the stack you
want by double-clicking to

open folders in this list.

Click here if you want to open the stack in a new window and 
have your current stack remain open.
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When you click a button or type into the Message box to open a stack, 
HyperCard looks for the stack using the strategy described in “How HyperC
Finds Stacks” earlier in this chapter. If it can’t find the stack, HyperCard 
displays the directory dialog box and asks you to tell it where the stack is

Opening a stack protected with a password       
Some stacks can only be opened if you know the password. When you te
HyperCard to open a stack that’s set for restricted access, you see the follo
dialog box: 

To open the stack, you must enter the password correctly, character for 
character. (Capitalization doesn’t matter.) If you launch HyperCard by tryi
to open the protected stack and the password you enter isn’t correct, Hyper
opens the Home stack instead. If HyperCard is already running and you g
the wrong password when you try to open the protected stack, you stay a
current card.

Type the password here 
and click OK. 
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Opening a write-protected stack    
When you open a stack that’s write-protected, a small padlock ( ) appears in
the menu bar:      

You can read and copy information from a write-protected stack, but if you
to make any changes to it, the following dialog box appears: 

An example of a write-protected stack is one for which Can’t Modify Stack
selected in the Protect Stack dialog box.

The small padlock tells 
you that the stack is 
write-protected, so you 
can’t make any 
changes to it.
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Opening a stack built in an earlier version of HyperCard     
When you open a stack that was created in a version of HyperCard earlier
2.0, a small padlock ( ) appears in the menu bar. You can use such a st
but you can’t make any changes to it (including typing into fields) until you
convert it to the new HyperCard file format.    

If you try to make any changes to an unconverted stack, you see a dialog
telling you that you must first convert the stack. 

❖ A converted stack can’t be unconverted.Once you convert a stack to the
new HyperCard file format, it can’t be “unconverted” and you can’t use
with an earlier version of HyperCard. If you want to use the stack with
earlier version of HyperCard, make a copy of the stack before you con
it. (Choose Save a Copy from the File menu to make a copy of the 
stack.) ❖

To convert a stack:    

1. Make a copy of the stack in its unconverted form.

This is an optional, although prudent, step.

2. Choose Convert Stack from the File menu.

Convert Stack takes the place of another command in the File menu, 
Compact Stack, when you’re working in an unconverted stack.

3. Click OK to convert the stack when the confirmation dialog box appears. 

Once HyperCard has converted the stack, the padlock disappears from th
menu bar and you can make any changes you want.    
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Opening more than one stack at a time    
The number of windows you can have open at the same time depends on
amount of RAM you have allocated to HyperCard—five windows for each
200K. This window count includes all windows that HyperCard uses—stac
the Tool palette, external windows, and so on. The more memory that’s 
available for HyperCard, the more stacks you can have open at the same

If you try to open more stacks than you have memory for, a dialog box app
telling you so.    

Here’s how to open another stack without closing the current stack:     

1. Choose Open Stack from the File menu. 

The directory dialog box appears. 

2. Check the “Open stack in new window” option to select it. 

3. In the directory dialog box, locate and open the additional stack you want to use. 

When the stack opens, it appears in a new window, and previously opene
stacks remain open.   

Once you open all the stacks you want to see, you can resize their window
move them around. “Moving and Resizing the Card Window” later in this 
chapter tells you how. 

You move between open stacks by choosing Next Window from the Go me
by pressing x-L, or by clicking in the window of the stack you want to go to.
1-20 Chapter 1: Using HyperCard
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Closing a stack      
There are several ways to close a stack: 

■ When you have more than one stack open, activate the window of the s
you want to close by clicking it; then choose Close Stack from the File
menu. You can also click the window’s close box or press x-W.

■ If you have only one stack open, you can either open another stack with
“Open stack in a new window” option unchecked, or quit HyperCard. S
“Opening a Stack” earlier in this chapter for instructions.

■ No matter how many stacks are open, you can close them all by choo
Quit HyperCard from the File menu. As the stacks close, HyperCard sa
any changes you’ve made to them. 

❖ Before you close a stack:It’s a good idea to choose Compact Stack from
the File menu before you close a stack that you’ve changed in any wa
This rearranges the current stack on the disk, removing any unused s
so that it fits into the smallest possible space. The Compact Stack comm
is available when your user level is Painting or higher.❖

❖ Note: When you’re working with a stack that was created in a version 
HyperCard earlier than 2.0, the Compact Stack command is replaced 
Convert Stack. You must convert such a stack before you can compa
“Opening a Stack Built in an Earlier Version of HyperCard” earlier in th
chapter gives instructions for converting a stack.❖   

Looking through stacks      
One of the best ways to learn about HyperCard is to explore stacks, inclu
the stacks that come with HyperCard.

Many stacks have a button you click to learn about the stack. It usually lo
like one of these:

Clicking any of these 
buttons gets information 
about the stack.
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Displaying the menu bar
You may encounter stacks in which the menu bar is hidden. To see the hi
menu bar, press x-spacebar. (To hide the menu bar again, press x-spacebar 
again.) 

If pressing x-spacebar doesn’t make the menu bar appear, a special Hyper
script is probably in effect keeping the menu bar hidden.        

Stack menus    
Stack developers can use HyperTalk commands to customize the menus
appear with a stack, so it’s likely that you’ll encounter stacks that have on
more of their own menus. Because menus can be customized, you may a
encounter stacks in which some of the standard HyperCard menus are mi
or contain different commands. 

Customizing menus requires a knowledge of HyperTalk. For information 
about customizing menus, see the HyperCard Script Language Guide and the 
HyperTalk Reference Stack. 

Moving around in a stack
Moving around in HyperCard stacks—moving from card to card, going to 
other stacks, and so on—is called browsing. 

There are several ways to browse through stacks: 

■ Choose commands from the Go menu or type their x-key equivalents. 

■ Click icons on the navigator palette (described later in this chapter). 

■ Press arrow keys on the keyboard. 

■ Enter commands through the Message box. 

■ Use the Find command to search for specific text. 
1-22 Chapter 1: Using HyperCard



. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .

. To 

 it 
 
user 

nt 
 and 
Sometimes you can browse by clicking buttons designed for that purpose
do so, you must first choose the Browse tool. 

❖ Can’t see the Tools menu?If you can’t see the menu bar, you can make
appear by pressing x-spacebar. If you can see the menu bar but not the
Tools menu, you can make the Tools menu appear by changing your 
level to Painting, Authoring, or Scripting. (For instructions, see “User 
Levels and Options” earlier in this chapter.)❖

Using commands in the Go menu      
You use the commands in the Go menu to look through cards in the curre
stack, look for specific text, go to another stack, or go back through cards
stacks you’ve already seen.

Click here to choose
the Browse tool.
Chapter 1: Using HyperCard 1-23
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❖ Prev versus Back:The Prev command takes you to the previous card in 

current stack; Back takes you to the card you last looked at, which ma
in another stack.❖           

Command
x-key 
equivalent Use it to do this    

Back x-~ Go back to the last card you saw.

Home x-H Go to the Home stack.

Help x-? Go to the HyperCard Help stack.

Recent x-R Review up to the last 42 cards you saw. 

First x-1 Go to the first card in the current stack. 

Prev x-2 Go to the previous card in the current stack. 

Next x-3 Go to the next card in the current stack. 

Last x-4 Go to the last card in the current stack.      

Find x-F Search for specific text. 

Message x-M Navigate through commands you type into the Message bo

Scroll x-E Resize card windows and scroll around on large cards. 

Next Window x-L Move from one open stack to another.    
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The cards in a stack are arranged as if they were looped on a ring. When y
looking at the last card in the stack, choosing Next from the Go menu takes
back to the first card in the stack. When you’re looking at the first card, the P
command takes you to the last card of the stack.       

Using the navigator palette 
The navigator palette contains icons that are equivalent to commands in th
menu. You can click these icons to move around in HyperCard stacks. You
also leave the navigator palette open while you work, so you have easy a
to all navigator commands. 

To make the navigator palette appear, follow these steps:

1. Open the Message box by doing one of the following:

■ Choose Message from the Go menu.

■ Press x-M.      

2. Type palette "navigator" .

3. Press Return or Enter. 

Second card

First card

Last card

A stack is structured
like a circular card file.
Chapter 1: Using HyperCard 1-25



. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .

s the 

 to 
s can 
button 

wse, 
y 
The navigator palette appears. Clicking an icon in the navigator palette doe
same thing as choosing the corresponding command from the Go menu: 

To make the navigator palette disappear, click its close box.          

Clicking buttons to move around        
A stack can have many different kinds of buttons. Some buttons take you
another place in the stack (or to another stack) when you click them. Other
play sounds, make messages appear, or create visual effects. (To make a 
do something, you first choose the Browse tool.)

❖ Where are the buttons?Sometimes it’s not obvious which items on the 
screen are buttons. To find the buttons on a card, select the Button, Bro
or Field tool; then hold down the x and Option keys at the same time. Gra
rectangles appear around the buttons.❖ 

Home Help

Next

Next WindowMessage

Find

Last

Recent

Prev
First

Back

Browse Tool
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Clicking buttons is one of the most effective ways to explore a stack. Here
some buttons you’ll often see for moving around in stacks: 

❖ Click only once.One click is usually enough to make a HyperCard butto
work. When you double-click a HyperCard button, sometimes HyperC
remembers the second click until another card appears. Then you may
that you’ve accidentally clicked a button you didn’t mean 
to click. ❖          

Clicking text to move around         
In some stacks, you can click text in fields to make things happen. For exam
you can click text to see a glossary definition or additional information on 
topic, hear a sound, or see something else happen on your screen. Clickin
can do the same kinds of things that clicking buttons can do. 

Stacks that take advantage of this feature usually let you know what to do

Using the arrow keys to move around      
You might be able to move from card to card by pressing the arrow keys,
depending on the setting for the Text option on the Home stack’s Prefere
card. See “Arrow Keys in Text Option” earlier in this chapter for details. 

First 
card in 
stack

Previous 
card in 
stack

Next 
card in 
stack

Last 
card in 
stack

Go back Home
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Going to a specific card         
If you know the name, number, or ID of a specific card in a stack, you can
to the card directly by using the Go command in the Message box. (You us
Message box to send instructions to HyperCard.)

You find the name, number, or ID of the current card by choosing Card In
from the Objects menu. (To see the Objects menu, you must have your u
level set to Authoring or Scripting. “User Levels and Options” earlier in thi
chapter gives instructions for changing your user level.) 

To get to a specific card from any other card in the same stack (or from ano
stack, such as the Home stack), follow these steps:    

1. Open the Message box (if it isn’t already open) by choosing Message from the Go menu.
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2. Type any of the following, substituting the name, number, or ID of the card you want to go to: 

3. Press Return or Enter. 

To hide the Message box, click its close box or press x-M.    

Seeing all cards in a stack
You can get a quick look at a stack by flipping through all of its cards quick
Follow these steps: 

1. Choose Message from the Go menu (or press x-M). 

2. Type show all cards and press Return. 

HyperCard shows you all the stack’s cards quickly, one after the other
stop flipping through the cards, either press the mouse button or pressx-. 
(x-period).

Go to the card in the current stack 
with the specified name.

Go to the card in the current 
stack with the specified number.

Go to the card in the current 
stack with the specified ID. 

Go to the card with 
the specified name in 
the specified stack. 
(Specify the stack 
name only when the 
card you want to go 
to is in another 
stack.)
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To hide the Message box, click its close box or press x-M.         

Some stacks have a button you can click to see all cards. It usually looks
like this:            

Looking for specific text              
You can also move around in a stack by searching for specific text. This m
it easy to find just the information you need in a stack, no matter how large
stack is. You can search an entire stack for the text you want, or search on
a specific field. 

Finding text anywhere in a stack 
1. Choose Find from the Go menu (or press x-F). 

HyperCard displays the Message box with the Find command in it: 

2. Type the text you want to find. 

Make sure you type the text you want to find between the quotation ma
that appear after the word “Find” in the Message box. 

Unless you add the word “international” before the quotation marks (as 
find international "schøél" ), HyperCard pays no attention to 
diacritical marks during a search: “apple,” “Apple,” and “ÅPPLË” are a
considered the same.

Another way to enter text in the Message box is to hold down the x key 
while you click a word in a field. If you x-drag across several words, you
can place up to one line of text in the Message box. 

Insertion point
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3. Press the Return key or the Enter key. 

HyperCard displays the first card containing a word or words that beg
with the specified text. (It looks for the first card that contains everythin
between the quotation marks, even if the words are in a different orde
in different fields.) HyperCard puts a box around the first word that sta
with the text you’re looking for. 

If HyperCard can’t find the text, it beeps, or the menu bar flashes once
If this happens, check the text in the Message box for typos and 
spelling errors. 

4. If you want to find the next occurrence of the same text, press Return or Enter again. 

You can repeat this step as many times as you like to find additional 
occurrences of the same text. 

To stop a search in progress, press x-. (x-period).  To search for the same tex
again press Return or Enter. To search for different text, type the text you w
to find, then press Return or Enter. 

❖ To speed your search:If you’re looking for specific text in a very large 
stack, it’s best to give HyperCard a large enough portion of the target 
to distinguish it from other text in the stack. This prevents HyperCard fr
displaying cards that don’t have the complete text you’re trying to find
HyperCard also finds text faster when you specify the target text in stri
of three characters (or multiples of three), not counting spaces.❖        

When you’re through with the Message box, you can put it away by clicki
its Close box. The next time you choose Find, the Message box reappears
the last text you typed between the quotation marks. (This “last Find text 
saved” feature clears when you quit HyperCard.)
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Some text isn’t searched
HyperCard doesn’t look for text:

■ in fields for which the option Don’t Search is checked in the Field Info 
dialog box (described in “Excluding a Field from Text Searches” in 
Chapter 7)

■ in background fields that belong to backgrounds for which either the Do
Search Background in the Bkgnd Info dialog box or the Shared Text op
in the Field Info dialog box is checked (described in “Excluding 
Background Fields from Text Searches” in Chapter 5)

■ in card or background fields on cards that have Don’t Search Card che
in the Card Info dialog box

■ that isn’t in a field, such as text that names a card or button

■ created with the Paint Text tool (described in Chapter 8, “Working with
Graphics”)

Finding text in a specific field             
If you want to search for text only in a specific field, you need to know the
name, number, or ID of the field. 

To find out a field’s name, number, or ID, follow these steps:

1. Be sure your user level is set to Authoring or Scripting.

2. Choose the Field tool ( ) from the Tools menu.

3. Click the field to select it.
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4. Choose Field Info from the Objects menu (or double-click the field). 

To search for text only in a specific background field, follow these steps:

1. Choose Find from the Go menu (or press x-F). 

2. Type the text you want to find. 

3. Click after the last quotation mark in the Message box. 

4. Type a space, and then type in background field and the name (in quotation 
marks), number, or ID of the field in which you want to search. 

Field’s name

Field number

Field’s ID
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5. Press the Return key or the Enter key. 

HyperCard displays the first card containing a word (or words) in the 
specified background field that begins with the specified text, and puts
box around that word. 

When HyperCard can’t find the text, it beeps or flashes once. If this 
happens, check the text in the Message box for typos and spelling err

6. To find the next occurrence of the same text, press Return or Enter again. 

You can repeat this step as many times as you like to see additional 
occurrences of the same text. 

To stop a search in progress, press x-. (x-period).

❖ Some fields are not searched.HyperCard doesn’t look for text under 
certain conditions. For a list of circumstances, see “Some Text Isn’t 
Searched” earlier in this chapter.❖        

Finding a whole word or phrase          
To search for a specific whole word or phrase anywhere in a stack, follow
these steps:

1. Press x-Shift-F.

The Message box appears with the Find Whole command in it: 
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2. Type the word or phrase you want to find.

3. Press the Return key or the Enter key. 

For the Find Whole command to find a match, all the characters must be in
same field on a card, and they must be in the same consecutive order as
appear between the quotation marks. For example, this command tells 
HyperCard to find cards that have the phrase “Apple Corp” on them:

find whole "Apple Corp"

It doesn’t find “Apple Corporation” or “This Corporation is Apple.” (The Find
command without Whole finds matches for all three cases.)

Find Whole won’t stop on cards that have only partial matches. For exam
this command doesn’t find “Edward”:

find whole "Ed"

To stop a search in progress, press x-. (x-period).

As with Find, you can use Find Whole to search for text in a specific 
background field (as previously described in “Finding Text in a Specific 
Field”). The HyperTalk Reference stack and HyperCard Script Language 
Guide describe other ways to search for text in stacks.           

Moving and resizing the card window    
Each HyperCard stack opens in a window. A HyperCard window always 
displays only one card at a time. This section explains how to change the
of a card window and move it around on the screen.      

A HyperCard window is different from a standard Macintosh window in tha
has neither scroll bars nor a visible size box. 

Moving a card window     
You move a HyperCard window around on the screen the same way you m
any Macintosh window—by dragging its title bar. 
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Resizing a card window           
You can easily change the size of a card window. Resizing the card wind
doesn’t change the size of the card; it only changes how much of the card
can see. If you make the card window smaller than the card, you see only
of the card. You can see the entire card, if your screen is large enough, b
making the card window the same size as the card. (The next section, “Vie
Large Cards,” explains how to view cards that are larger than your screen

To change the size of the card window, you can either resize the card win
directly or resize it via the Scroll window. 

To resize a card window directly, follow these steps: 

1. Press x-Shift-E.

A size box appears in the lower-right corner of the window.

2. Drag the size box to resize the window: 

When you release the mouse button, the size box disappears. If you wan
resize the window several times in succession, x-drag the size box until the 
window is the size you want it. 

❖ Note: You can’t make the card window larger than the card itself.❖

To resize a card window by using the Scroll window, follow these steps:  

1. Choose Scroll from the Go menu (or press x-E). 

The Scroll window appears. 
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2. Drag from any edge or corner of the rectangle (or the blank region, if there’s no rectangle) 
inside the Scroll window. 

When you resize this rectangle, the card window is resized. 

To make the card window the same size as the card, you can either double
inside the Scroll window, or click the zoom box of the card window. (If the ca
is larger than your screen, the card window becomes about the same size
the screen.) 

To hide the Scroll window, click its close box or press x-E.    

When you move the pointer over the edges and corners of the rectangle, 
it becomes a double-headed arrow. Drag with the double-headed arrow 
to resize the card window.

The blank area represen
the entire card.

The rectangle represents
the card window.

Resizing the card 
window vertically

Resizing the card 
window horizontally

Resizing the card 
window diagonally
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Viewing large cards                        
When you open a stack whose cards are larger than the screen, you see 
portion of a card at a time. To look at other parts of the card, use either o
following techniques: 

■ Press x-Shift-E. The pointer turns into a hand when it’s over the card; u
it to drag the card around in the card window. When you release the mo
button, the hand disappears. To move around on the card several tim
succession, press and hold the x key until you’re finished.     

■ Open the Scroll window by choosing Scroll from the Go menu, or by 
pressing x-E. Use the Scroll window to scroll to other parts of the card

To limit the scrolling to either horizontal or vertical movement, hold down t
Shift key while you drag. 

To hide the Scroll window, click its close box or press x-E.    

❖ Keep the card window smaller than the screen.When you use a stack 
whose cards are larger than the screen, it’s a good idea to keep the c
window small enough to fit on your screen. If you make the card windo
larger than the screen, you can’t scroll around to see all parts of the car❖

To scroll to other
parts of the card,

drag from the middle
of the rectangle.

The rectangle inside the blank 
region represents the part of the 
card you see on your screen.

The blank area represents 
the entire card.
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Moving from one stack to another
You can move easily from one stack to another. If the stack you want to g
is already open, click that stack’s window. Or, you can choose Next Wind
from the Go menu (or press x-L) until the stack’s window becomes active—
that is, until the window is visible and narrow horizontal lines appear in its
title bar.    

Whether or not the stack is already open, you can get to it by doing any o
following:     

■ Choose Message from the Go menu, type go " stack name ",  and press 
Return. (Replace stack name with the name of the stack.)    

■ Choose Open Stack from the File menu and use the directory dialog bo
locate and open the stack.    

■ Click a button in the current stack or in the Home stack that’s linked to 
stack you want to go to (if there is such a button). 

Looking through cards you’ve seen        
As you go from card to card and stack to stack, HyperCard automatically ke
a record of where you’ve been. 

When you want to back up and review the cards you’ve seen, you can ch
Back from the Go menu, or press the tilde (~) or Esc key, to go to the last 
you saw, no matter what stack it’s in. To continue retracing your steps, cho
Back (or press the tilde or Esc key) again. You can review up to the last 1
cards you viewed, in reverse order.     

❖ If the tilde key doesn’t take you back:Chances are you have one of the 
Paint tools selected. While you’re working with the Paint tools, press 
x-tilde to go back to the last card you saw. (Pressing the tilde key alo
while using a Paint tool undoes your last action.)❖

After you review the cards, you can press the up arrow to come forward a
through the reviewed cards (or press Option–up arrow, if Arrow Keys in T
is checked on your Preferences card).
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Choose Recent from the Go menu to see miniature versions of the cards y
seen most recently (up to the last 42 cards you’ve looked at). A card minia
appears just once, even if you’ve gone to the card more than once. (If you
computer’s memory is low, you may only see one card miniature.) Click a
miniature to go to the card it represents.       

Returning Home    
No matter where you are in HyperCard, you can always get back to the H
stack. Here are four ways to do it: 

         

A box surrounds the card you’re currently on. 
(Click it to cancel the Recent command.)

Choose Home from the 
Go menu.         

Press x-H. Click any button 
with the house 
icon, or another 
button that’s 
linked to the 
Home stack.

Choose Message 
from the Go 
menu, type 
go "Home" , 
and press Return.    
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Entering Text     
The most common way to add text to a card is by typing into fields.    

❖ Check your user level:To type and edit text in stacks, you must have yo
user level set to Typing (2) or higher. ❖

To type text into fields, make sure that the Browse tool ( ) is selected:

With your user level set to Typing (or higher), the Browse tool becomes a
I-beam ( ) when you move it over a field you can type into: 

To enter text into a field, move the I-beam over the field, click, and start typ

Choose this tool to type
text into a field …

… not this tool.

The I-beam pointer over 
an editable text field
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You edit field text in HyperCard the same way you edit any Macintosh tex
You can click anywhere in the field and begin typing, or drag to select text
copying, moving, deleting, or replacing. 

To fix typing mistakes while you’re editing text in a field, you can do any o
the following:      

■ Choose Undo from the Edit menu to undo your last text editing operat
(including a text style change). 

■ Press the Delete or Backspace key to delete characters to the left of t
insertion point, one character at a time. 

■ Drag the I-beam over the incorrect text to select it, and then retype or 
delete it.                

Opening Applications     
You can launch an application from HyperCard by following 
these steps: 

1. To open the Message box (if it isn’t already open), choose Message from the Go menu (or 
press x-M). 

2. Type one of the following messages into the Message box, substituting the names of the 
application and document you want to open:

3. Press Return or Enter. 

HyperCard may display the directory dialog box and ask you where on
these files is.

This message launches the 
specified application.

This message launches the 
specified application and opens 
the specified document.    
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❖ If nothing happens:If you try to open an application and nothing happen
it’s probably because there’s not enough memory. If you have other 
applications open, try quitting one or more of them to free enough 
memory. ❖   

When you quit the application you’ve opened, HyperCard takes you back to
card from which you launched the application. 

If you try to open a document with an application that’s already open, the
application comes to the front, displaying its current document. If you wan
open a document other than the current one, you have to open it from wit
the application; it doesn’t open automatically. 

You may encounter stacks with buttons that launch applications. When yo
launch an application by clicking one of these buttons on a card, HyperCa
takes you back to the same card after you quit the application. 

Getting Help  
You can get help anytime you’re using HyperCard. You can use Balloon H
and you can use the HyperCard Help or HyperTalk Reference stacks. 
HyperCard Help covers all areas of HyperCard through the Authoring lev
HyperTalk Reference provides reference and conceptual information abo
HyperTalk.

To get to the HyperCard Help stack, do any one of the following:

■ Choose Help from the Go menu.

■ Press x-?.

■ Type help into the Message box and press Return or Enter. 

■ Click the HyperCard Help icon on the first card of the Home stack.

To get to the HyperTalk Reference stack, do one of the following:

■ Type HyperTalk into the Message box and press Return or Enter.

■ Click the HyperTalk Reference icon on the second card of the Home s
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Using a Stack on a File Server    
If your Macintosh is part of a network that includes AppleShare file server
you can use HyperCard stacks stored on file server volumes. Note the 
following:   

■ As with any file on a file server, you must have the appropriate access
privileges to use the stack. For information about access privileges, con
your network administrator. 

■ If the stack is on a locked medium—a locked disk, a CD-ROM, or a lock
folder on the file server—or if it’s locked in the Finder (that is, if its Locke
option is selected in the Get Info dialog box), any number of network us
can use the stack at the same time. No one, however, can make chan
the stack.    

■ When a stack is unlocked on a file server, only one person can use it 
time. As the sole user, you can make changes to the stack, but no one
on the server can use it until you log off. 

Using a Stack on a CD-ROM         
You can use any HyperCard stacks you have on a CD-ROM just as you w
other stacks. But changes you make to a stack aren’t saved. If you want y
changes saved, copy the stack to an unlocked disk and open the stack 
from there. 

Running HyperCard from a CD-ROM (or from any other locked medium),
using a Home stack on a locked disk, can have some limitations: 

■ If your Home stack is on a locked disk, HyperCard can’t update the Sea
Paths cards when you tell it where to find stacks. So each time you wa
go to a new stack, HyperCard has to ask for directions. 

■ When you’re running HyperCard from a locked disk under the Finder i
System 6 and you launch an application, HyperCard returns you to the
card of the Home stack when you quit the application instead of to the c
from which you launched the application. This is because HyperCard c
mark your place when you leave, as it does if it were on an unlocked dis
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Quitting HyperCard        
To quit HyperCard, choose Quit HyperCard from the File menu, or press x-Q. 
HyperCard doesn’t ask whether you want to save changes, because it sa
your information automatically as you work. 
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Chapter 2
Learning HyperCard Basics

This chapter gives you step-by-step exercises for many of HyperCard’s 
features. It’s designed to provide you with active experiences as opposed
passive information. You should read it sitting in front of your computer, do
each exercise as you come to it. 

The exercises build upon one another, so you should do them in order. W
you still can learn a lot about HyperCard by skipping through the chapter,
you’ll learn most by doing all the exercises in the order that they’re presen

If you’ve already installed HyperCard, you’re ready to get going. If you 
haven’t, follow the instructions on the box that HyperCard came in, and th
return to this chapter.
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Starting Up and Taking the Tour
The best way to learn HyperCard is to start using it. In this exercise, you’ll o
HyperCard and take the HyperCard tour. The HyperCard tour presents ba
information and gives you some immediate experience.

1. Double-click your hard disk’s icon to open it (if it’s not open already).

2. Open the HyperCard folder (if it’s not open already).

You may have to use the scroll bars before you can see the folder. 

3. Double-click the HyperCard icon to open it. 

The Home stack opens and you see the first card.

4. Click the HyperCard tour to open it. 

When the opening card for the tour appears, click the card to continue
Another card appears with information for you to read.

Click here to take the tour.
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5. Follow the instructions that appear on each card to move through the tour. 

If you like, you can leave the tour at the end of the first section by click
the Topics button and then clicking the Home button. (In fact, you can 
this method to leave the tour at any time.)

6. At the end of the tour, click the Home button. 
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Opening HyperCard Files
Each HyperCard file is called a stack, and each stack contains one or mo
cards. You can open stacks either by using the Open Stack command (wh
like the Open command in other programs) or by clicking buttons. 

Opening stacks by clicking buttons
In this exercise, you’ll click a button to open the Practice stack and then c
another one to return to the Home stack.

1. To open the Practice stack, click the Practice button on the first card of the Home stack. 

Notice that you click the button just once.

After you click, HyperCard closes the Home stack and opens the Prac
stack. You see the first card of the Practice stack with John Chapman
name on it. 

2. Without clicking the mouse button, roll the mouse around to see the different pointer shapes.

The pointer changes shape depending on which part of the screen it’s 

3. Click the Home button to return to the Home stack. 

The Home button is linked to the Home stack. By clicking the button, y
close the Practice stack and open the Home stack again. (When you o
new stack, the old one will often close.) 

Browse tool pointer is 
over a card (but not 
over editable text).

Arrow pointer is 
over any area 
outside the card.

I-beam pointer is 
over text you can 
edit.

The Home
button
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Opening stacks using the Open Stack command
In the last exercise, you opened the Practice stack by clicking a button. In
exercise, you’ll open it again, this time using the Open Stack command. (E
way, the result is the same.)

1. Pull down the File menu and choose Open Stack. 

The Open Stack command works like the Open command in many oth
programs. (Notice that the shortcut for Open Stack is x-O.)

After you choose the Open Stack command, you see the directory 
dialog box.

2. Double-click HyperCard Stacks.

You’re looking for the Practice stack, which is within the HyperCard 
Stacks folder, so you need to open that folder’s icon to find the stack.

3. Double-click Practice. 

If necessary, use the scroll bar to find the word “Practice.”

After you double-click, HyperCard closes the Home stack, opens the 
Practice stack, and displays its first card, just as in the last exercise.
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Looking at Cards
You’ve learned a couple of ways to open stacks. But so far, you’ve seen 
the first card of each stack. In this section, you’ll learn how to browse throu
the cards in a stack.

1. Click the Practice stack’s right arrow button once, and then again. 

Each time you click the right arrow button, you move to the next card in 
stack. Two clicks take you to the third card of the stack. This stack ha
seven cards in it.

2. Click the left arrow button twice to go back to the first card, which has John’s address on it.

Each time you click the left arrow button, you go to the previous card. 
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3. Click the left arrow button one more time. 

When you’re on the first card and then go back a card, you move to the
card in the stack—in this case, the card for Zuzana Mrkova. The cards
HyperCard stack are arranged in a circular fashion, so the first card in
stack and the last card in a stack are next to each other. 

4. Click the right arrow button once to return to the first card.

You see John’s card again.

Now you know the basics of how to get around in HyperCard. You use but
or the Open Stack command to move from one stack to another, and you
arrow buttons to move forward and backward through a stack.

Knowing only that much, you can browse through almost any stack you h
But if you learn how to use the Go menu, you’ll find it easier to move arou
in HyperCard.

Second card

First card

Last card
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Using the Go Menu
The Go menu contains commands for navigating through stacks and mov
from one stack to another. In this exercise, you’ll gain experience using si
the commands you’ll use most often from the Go menu. 

1. Choose Next from the Go menu.

The Next command takes you to the next card in the stack, just like the r
arrow button did in the previous exercise. 

2. Choose Prev from the Go menu.

The Prev command, like the left arrow button, takes you to the card in
stack immediately before the one you are looking at. (Prev is short for
previous.) 

3. Choose Last from the Go menu.

As you might expect, the Last command takes you to the last card of 
whatever stack you are viewing (in this case, Zuzana’s card).

4. Choose First from the Go menu.

The First command takes you to the first card of the stack, and you se
John’s card again.

5. Choose Home from the Go menu.

The Home command, like the Home button, takes you back to the Ho
stack. Whenever you get lost, you can return Home by choosing this 
command.

6. Choose Back from the Go menu.

You return to John’s card. 

The Back command returns you to the last card you looked at, even if
card was in an entirely different stack.
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7. Choose the Back command once again.

You go to Zuzana’s card. 

The Back command retraces your steps through the cards you just vie
one card at a time.

8. Choose the Home command.

You end up back at the Home stack.

Typing
In most stacks, you can do much more than just look at the cards. The exe
in this section show you how to include your own information by adding a
editing text.

If you’ve used a Macintosh word processor—or any other program that 
involves typing—you already know most of what you need to know. The m
differences you’ll notice when working with text in HyperCard are that you
can’t use tabs to indent or line up columns, and you can’t always use the a
keys to move through text.

Entering text
You can type text only in certain areas on a card. Each card is like a form 
rectangular areas where you can fill in information. In HyperCard, each o
these areas is called a field.

The Practice stack has three fields in which you can type:

Notes

Phone Number

Name & Address
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In this exercise, you’ll fill in the Notes field for Ginny’s card.

1. Use the arrow buttons to find the card for Ginny Sae Kwa.

Click the right or left arrow buttons to find Ginny’s card (the sixth card 
the stack).

2. To indicate where you want to type, click the upper-left corner of the Notes field.

Your pointer changes to the I-beam pointer when it’s over a field. Whe
you click, the vertical bar that marks the insertion point blinks at the 
beginning of the field.

If you click too far down in the field, use the Delete or Backspace key 
get back to the top of the field. If you click in the wrong field altogether
just try again.

3. Type a note. 

Something like “Business hours between 10 and 4, local time” will do.

Don’t press the Return key as you type. The text automatically wraps to
next line. 

❖ No need to save:Unlike most applications where you explicitly need to 
take some action to save what you create, HyperCard automatically s
your work as you go along.❖

Editing text
You edit text in HyperCard fields the same way you edit any text on your 
Macintosh. In this exercise, you’ll use the standard techniques to copy, pa
and bold text.

1. Use the arrow keys to find Wally Lab’s card.

Wally’s card is the fifth card in the stack. 

2. Select the second line of the address by dragging through it.

3. Choose Cut Text from the Edit menu (or press x-X).

The text is removed from the card and placed on the invisible Clipboa

I-beam pointer
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4. Click once just before “San Francisco.”

5. Choose Paste Text from the Edit menu (or press x-V). 

The line you previously cut is pasted in.

6. Go to John’s card by choosing First from the Go menu.

7. Select the word “product” in the Notes field by double-clicking it.

After you double-click, the word is highlighted.

8. Choose Bold from the Style menu.

The word becomes bold.

Adding a New Card
You can add new cards to your stack whenever you like.

1. Starting from John’s card (Card 1) in the Practice stack, choose New Card from the Edit menu. 

HyperCard creates a new, blank card, places it after the card you wer
looking at, and displays the new card. 

2. Click the upper-left corner of the Name & Address field and type your name and address.

Press Return after the first and second lines.

Name & Address

Phone Number

Notes
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3. Click in the upper-left corner of the Phone Number field and type your phone number.

4. Press the Tab key on the keyboard to move to the next field.

The insertion point begins to blink in the upper-left corner of the 
Notes field.

To stop typing in one field and begin typing in another, you can use th
mouse to move the insertion point (as you did before), or you can use
Tab key (as you did this time).

5. Add a note without pressing the Return key.

The text breaks at appropriate spaces even though you don’t press th
Return key. 

Manipulating Windows
So far, you’ve only had one HyperCard window open at a time. Whenever 
opened a new stack, the old one closed. In this section, you’ll learn how t
display more than one stack at a time, how to arrange them on your screen
how to close them.

When you use a button to open a stack, you don’t have a choice about wh
to close the old stack (the person who creates the button makes that cho
When you use the Open Stack command, however, the choice is yours. 

1. Go Home by clicking the Home button or choosing Home from the Go menu.

2. Choose Open Stack from the File menu.

The Directory dialog box appears.

3. Click the “Open stack in new window” checkbox to select it. 

An X in the checkbox instructs HyperCard to place the stack in a new 
window, keeping the current window (and the current stack) open. 
2-12 Chapter 2: Learning HyperCard Basics
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4. Double-click the name “HyperCard Stacks” to open the folder.

5. Double-click the name “Practice” to open the stack.

You’ll see both stacks open at the same time.

6. Move the Practice stack’s window to the bottom of your screen by dragging it by its title bar.

7. Make the Home stack’s window active by clicking anywhere in the part of it you can see.

When you click the Home stack’s window, it moves in front of the Pract
stack’s window.

Only one window can be active at a time. A window must be active bef
you can do anything to it, such as type or click buttons. 

8. Choose Close Stack from the File menu.

The active window, in this case the Home stack’s window, closes. No 
longer hidden by the Home stack, the Practice stack is visible once ag

You can also close a stack by clicking its close box at the upper-left co
of the title bar. (You only see a close box when more than one stack is o
at a time.)

The stripes that indicate the Practice stack’s window is active.

Home stack

A close box appears when more
than one stack is open.

Practice stack
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Saving Stacks
Unlike most Macintosh software, HyperCard automatically saves changes
you make them. In this exercise, you’ll see that there is no Save comman
the File menu.

1. Pull down the File menu but don’t choose any commands.

2. Release the File menu.

The Home Stack
The Home stack will usually be your starting place when you start up 
HyperCard. Take the time to get to know it. In this section, you’ll learn abo
two important parts of the Home Stack—the Home cards, which contain a
collection of buttons that take you to your favorite stacks, and the Prefere
card, which you use to adjust some HyperCard settings.

First, you need to go to the Home stack by choosing Home from the Go m

There’s no Save
command . . .

. . . but you can make a copy of 
your file for safekeeping with 
the Save a Copy command.
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The Home cards
When you open the Home stack, you see the first of five Home cards, cal
Welcome to HyperCard. Each Home card has buttons that can quickly take
to any of your favorite stacks. 

1. Go to the Stack Kit card by clicking its button at the bottom of the first Home card.

The Stack Kit card appears. Clicking any of the icons on this card takes
to a different stack—each one filled with different elements you can us
construct your own stack.

2. Go to the Home card called Card 5 by clicking its button.

Like Card 3 and Card 4, Card 5 gives you ample room to add your ow
buttons. (You can add buttons to the first two Home cards as well.)

The Welcome card has buttons
that take you to the basic stacks.

The Stack Kit card has buttons
that take you to advanced

stacks you can use when you’re
ready to create your own stacks.

The other cards give you lots of
room to add your own buttons.
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3. Choose Rename This Card from the Home menu.

A dialog box appears for you to type the new name.

4. Type the name My Space (or any other name that you like) and click OK.

5. Click the “Welcome to...” button at the bottom of the card to return to the Home card.

The Preferences card
HyperCard has five user levels. You use the Preferences card in the Home
to choose the user level where you want to work. When you first install it,
HyperCard is set up to work at the second level: Typing. At the Typing lev
you can look at cards and type on them, but you can’t draw graphics on c
or modify buttons or fields.

In this exercise, you’ll select the highest user level, called Scripting, so that
can see and use all the menus and commands HyperCard has to offer. (Y
need to be at this highest level so that you can do the exercises in the ne
chapter.) You’ll also add your name to the Preferences card.

. . . and on the button.

The new name of the 
card appears here . . .
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1. Choose Preferences from the Home menu.

You move to the Preferences card.

2. Click the button for the Scripting level.

When you move to the Scripting level, HyperCard adds two extra menu
the menu bar: the Tools menu and the Objects menu. It also adds 
commands to some of the other menus.

▲ Important: When you set your user level to Scripting, you can use cert
commands that temporarily disable the Browse tool. If you lose the Brow
tool and can’t type text or click buttons, you can choose the Browse to
from the Tools menu at any time.▲

3. Click the blank after “Your Name:” at the top of the card and type your name.

4. Choose First from the Go menu to return to the first card of the Home stack.

By changing the Preferences card in this exercise, you’ve gained access 
the commands and features HyperCard has to offer. When you finish this
chapter, you can come back to this card and change your user level again 
like. Leave it at this level if you intend to go on to Chapter 3 to learn abou
scripting.

Click here.
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The Message Box
The Message box is a special window in HyperCard. It looks like this: 

It has room for one line of text. You can type commands called messages
HyperCard can type replies. 

Controlling the Message box
Here’s how to display the Message box, move it, and hide it:

1. Choose Message from the Go menu.

HyperCard opens the Message box.

2. Drag the Message box. 

You move the Message box by placing the pointer on the bar at the to
the box and dragging it where you want it to go, just as you drag any 
window. 

3. Close the Message box by clicking its close box. 

Because the close box is small, make sure you’ve got the tip of the ar
in the close box before you click.

Using the Message box
In this exercise, you’ll type some messages into the Message box. When
Message box is visible and the insertion point isn’t blinking in one of the fie
on the card, anything you type goes into the Message box. 

Drag areaClose box
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1. Click the Practice button on the first Home card to go to the Practice stack.

2. Choose Message from the Go menu to open the Message box again.

Don’t worry if there’s text in the Message box. It will disappear as soon
you start typing.

3. Type the words the date and then press Return. 

If you make a mistake while typing in the Message box, you can corre
using the Delete or Backspace key.

HyperCard puts today’s date into the Message box.

❖ Note: If the date is wrong, your Macintosh has the wrong date in its 
internal calendar. Correct the date in the Control Panel. (For details, se
documentation that came with your computer.)❖

4. Type 12+5 and press Return. 

The date in the Message box disappears when you start typing, and 
HyperCard places the correct answer, 17, in the Message box. 

5. Type flash 3 and press Return.

This message makes the card flash three times.

6. Type go home and press Return.

You go back to the Home card.

7. Type go back and press Return.

HyperCard returns you to the Practice stack.

8. Type userName  and press Return.

HyperCard replaces what you typed with your name—just as you ente
it on the Preferences card. (Be sure that userName  is all one word.)

You’ve just learned your first words of HyperTalk. If you want to learn mo
about this powerful, easy-to-learn programming language, do the exercis
the next chapter when you’ve finished with this one. 
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Finding Text
Many HyperCard stacks contain hundreds of cards. Even so, you can find
particular card quickly by using the Find command. 

1. With John’s card in the Practice stack on the screen, choose Find from the Go menu. 

HyperCard opens the Message box (if it was closed), types the Find 
command, and places the insertion point between two quotation mark
(This is exactly the same as if you typed the command yourself.)

2. Type the word Gossard .

The word appears between the quotation marks.

3. Press the Return key.

As soon as you press the Return key, HyperCard searches the Practice
for the word “Gossard.” (You can find text in only one stack at a time. 
HyperCard searches only the stack that’s active when you enter the F
message.) 

4. Choose Find from the Go menu again (or press x-F).

When you choose the Find command again, it enters the last word yo
looked for and highlights it.

5. Type selma .

As soon as you start typing, the old word “Gossard” disappears. 

HyperCard finds a card with
the word “Gossard” on it,

displays the card, and puts a
box around the word.
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6. Press the Return key.

When you press the Return key, HyperCard finds the next card in the s
with the word “Selma” on it (in this case, Kevin’s card).

7. Press the Return key again without typing anything.

Each time you press Return, HyperCard finds the next use of the 
word “Selma.” 

8. Close the Message box by doing one of the following:

■ Click its close box.

■ Choose Message from the Go menu again.

Copying and Pasting a Picture
In this exercise, you’ll copy a picture of a pencil from the Art Bits stack to 
Wally’s card.

Copying the picture
Start by finding the right picture and copying it:

1. Choose Home from the Go menu.

Click the “Welcome to...” button if the Welcome card is not displayed.

2. Go to the Art Bits stack by clicking its button.

3. Go to the “Odds and ends” section by clicking its button.

 It’s the second one down in the right column.

4. Choose the Lasso tool from the Tools menu. 

You use the Lasso tool to select an irregularly shaped object without 
including any of the extra white space around it.

5. Use the Lasso tool to select the picture of the pencil.

To select with the Lasso tool, drag a line around the pencil. If the naviga
palette is in your way, you can move it by dragging its top bar. 
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After you release the mouse button, the pencil is surrounded by a mov
dashed line (sometimes called “marching ants”) to indicate that it’s 
selected. If you make a mistake, click once anywhere else on the card
try again.

6. Choose Copy Picture from the Edit menu.

A copy of the picture is placed on the invisible Clipboard. The original 
remains on the card.

If the art disappears from the card, you probably chose Cut Picture ins
of Copy Picture. Choose Undo from the Edit menu and try again.

Pasting the picture
Now you’ll return to the Practice stack (using a new method to get there), 
Wally’s card, and paste the picture:

1. Go back to the Practice stack by using the Recent command from the Go menu.

Click an image in the Recent dialog box that looks like a card from the
Practice stack. (Your Recent dialog box may look different.) 

The Recent dialog box keeps track of up to the last 42 cards that you vis

2. Move to Wally’s card by using the Find command.

3. Choose Paste Picture from the Edit menu.

The picture appears and is selected.

If you accidentally click the card, you’ll deselect the picture. If this 
happens, use the Lasso tool to select it again.

4. Choose Flip Horizontal from the Paint menu.

The picture “flips” to face the other way.

Click an image that looks like this one.
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5. Move the picture to a different position by dragging it.

6. When the pencil is where you want it, choose the Browse tool from the Tools menu to complete 
the exercise. 

Choosing the Browse tool sets the pencil in place and allows you to cl
buttons (which you will do in the next exercise).

Redesigning a Stack
Once you’re comfortable exploring stacks created by other people, you ca
change existing stacks and create new ones to meet your own needs. Th
process is called authoring.

In this section, you’ll make changes to the Practice stack and rearrange it 
in a smaller window. 

To start, you need to make a copy of the stack so that you don’t change t
original one, and create a button on the Home stack to take you to the co

Before After
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Saving a copy
Whenever you make major changes to a stack, you should first make a co
the stack in case you make a mistake that’s difficult to correct.

1. Go to the Practice stack.

2. Choose Save a Copy from the File menu.

3. Name the stack Tiny Addresses and click Save.

You now have two copies of the same file on your disk—Practice and Tin
Addresses. You’re still looking at the Practice stack, which is the original; 
you want to work with the copy.

Adding a new button to the Home stack
To make it easier to open your new stack, you’ll create a new button on the
card of the Home stack that takes you to the new stack.

1. Do one of the following to go Home:

■ Click the Home button.

■ Choose Home from the Go menu.

■ Press x-H.

This is the name of the disk. 
Yours is probably different.

As soon as you start
typing the new name,

the old one disappears.
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2. Choose the New Link to Stack command from the Home menu in the Home stack.

A directory dialog box appears.

You use the New Link to Stack command, available only in the Home 
stack, to create new buttons that take you to stacks.

3. Find and double-click the name “Tiny Addresses.”

You may have to use the scroll bar to find it. The new button appears,
flashing, in the middle of the card.

4. Drag the new button to a convenient place on the card.

As soon as you release the mouse button, the new button becomes fi
in place.

❖ Note: If you make a mistake, delete the button and redo the exercise.
Luckily, that’s easy to do: Choose the Button tool from the Tools menu a
click the new button once; choose the Clear Button from the Edit men
then choose the Browse tool. Now you’re ready to try again.❖

5. Try the new button.

Click the new Tiny Addresses button. The stack appears with the Hom
stack still on the screen. Look at the title bar of the stack you just opene
make sure you opened the right one (it should say Tiny Addresses).

Working with the background
A background holds the elements that a number of cards have in common
Most of the changes you’ll make to the Tiny Addresses stack have to do w
these common elements, so you’ll be working with the background a lot.

1. With the Browse tool active, click the right arrow button until you see Wally’s card (the one 
with the pencil on it).

As you move through the cards, notice what the cards have in commo

The cards in this stack have more similarities than differences. In fact,
about all that changes from card to card is the text. The rest—the thre
buttons, the arrangement of the fields, and the gray paint—stays the s
That’s the idea of a background. A background is what all the cards h
in common.
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2. Choose Background from the Edit menu.

When you choose the Background command, HyperCard hides the ca
and shows just the background. The menu bar becomes striped.

3. Choose Background from the Edit menu again (or press x-B). 

Choosing the command a second time shows the card again. The stri
disappear from the menu bar.

4. Choose Bkgnd Info from the Objects menu.

HyperCard displays a dialog box with information about the backgroun
you’re viewing.

This background is shared by eight cards, one for each of the address

The stripes in the
menu bar remind you

that you’re viewing
the background.

The text and the pencil 
are on the card, not in 
the background.

Backgrounds often have 
names. This one is called 
“Address Template.”

This background contains five 
fields: Name & Address, 
Phone Number, Notes, Card 
Number, and Stack Title.

This background contains five
buttons: Home, left arrow,

right arrow, light bulb, and
an invisible Find button.
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5. Click Cancel.

So what you see when you look at a card is a composite of two layers: th
background layer (which contains the elements shared by all the cards) a
the foreground or card layer (which contains only the elements unique to 
each card).

Deleting a Background button
You’ll start by deleting the light bulb button. In general, the way you delet
things is to select them and then press the Delete or Backspace key. 

1. Choose the Button tool from the Tools menu.

To modify buttons, you must use the Button tool. While you use the But
tool, the pointer will be arrow-shaped and you won’t be able to type in
fields or make buttons do what they’re programmed to do. 

2. Click the light bulb button once to select it.

When a button is selected, it’s framed by a moving dashed line.

Notice that the button doesn’t do what it normally does—it doesn’t giv
you an overview of the stack. Instead, clicking a button with the Button t
selects it.

3. Press the Delete or Backspace key.

The button disappears. 

❖ Working with background objects from the card layer:This button was in 
the background; so why didn’t you first have to choose the Backgroun
command to delete it? You could do that, but HyperCard lets you to e
existing buttons and fields without first choosing the Background 
command.❖
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Moving and changing the Home button 
Next you’ll move the Home button onto the white part of the card and cha
its size and style. 

1. With the Button tool active, drag the Home button to its new location.

2. Drag the button’s corner to make it smaller.

Remember the general rule that to move something you drag its midd
to change its shape, you drag its corner. (“Middle to move; corner to 
change.”)

3. Choose Button Info from the Objects menu.

The button’s Info dialog box appears.

❖ Note: If the Button Info command is dimmed, it means the button is no
longer selected. Click the button once to select it.❖

Place the pointer over the
middle of the button and

drag it to here.
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4. Choose Transparent from the Style pop-up menu to change the button’s style; then click OK.

Changing the style changes the appearance of the button. In this case
shadowed box is removed. 

Rearranging the arrow buttons
Now you’ll move the two arrow buttons to their new locations, make them
smaller, and change their style to Transparent.

1. Drag each arrow button to its new location.
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2. Make the arrow buttons smaller.

3. Double-click the left arrow button to open its Info dialog box.

Double-clicking a button with the Button tool is a shortcut for selecting
and choosing the Button Info command.

4. Choose Transparent from the Style pop-up menu and then click OK.

5. Open the right arrow’s Info dialog box, set its style to Transparent, and then click OK.

Modifying the Find button
In this exercise, you’ll assign the invisible Find button an icon and move i
into place.

1. With the Button tool active, press x-option to see the Find button’s outline. 

You’ll see the outlines of all the buttons on the card.

2. Double-click the invisible Find button to open its Info dialog box.

3. Click the Icon button in the Info dialog box.

The Icon Chooser window appears.

Double-click here.
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4. Select the appropriate icon.

5. Click OK.

The icon appears on the button.

6. Move the button into place and resize it.

Copying a button from another stack
One easy way to enhance your stack is to borrow work done by others. In
section, you’ll turn your stack into an automatic dialer by copying a button
from another stack.

Start by finding and copying the button:

1. Choose the Browse tool ( ) from the Tools menu.

2. Go Home.

3. Go to the Stack Kit card by clicking the Stack Kit button at the bottom of the Home card.

4. When the Stack Kit card appears, click Readymade Buttons.

The Readymade Buttons stack contains buttons you can use in your s

Use the scroll bar to 
find the Search icon . . .

. . . then click the icon 
to select it. (Your Icon 
dialog box may look 
different.)
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5. Click “Do various things” to get to the card with the Dial button on it.

6. With the Button tool active, click the Dial button once to select it. 

7. Choose Copy Button from the Edit menu.

Now use the following steps to return to the Tiny Addresses stack, paste 
button, and move it into place:

1. Use the Recent command to return to the Tiny Addresses stack.

Choose Recent from the Go menu and click any miniature picture tha
looks like it’s from the Tiny Addresses stack.

❖ Check the stack:Your Tiny Addresses stack still looks a lot like the 
original Practice stack. Check the title bar to be sure you’re in the corr
stack. If not, try the Recent command again.❖

2. Choose Background from the Edit menu (or press x-B).

Make sure you see the stripes in the menu bar.

Because this button should be shared by all the cards in the stack, you
to paste it into the background. 

3. Choose Paste Button from the Edit menu.

The button appears in the background.

4. Double-click the button to open its Info dialog box.

5. Click the Show Name checkbox to deselect it, and then click OK.

When you click the Show Name checkbox, the X disappears from the b
This tells HyperCard not to place the button’s name under the icon.

6. Move the button into place and resize it. 

7. Choose Background again from the Edit menu (or press x-B). 

You leave the background layer, and the stripes disappear from the 
menu bar.

8. Choose the Browse tool from the Tools menu to see how it all looks.

The new Dial button partially obscures the phone number, but you’ll fi
that in a later exercise.
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Deleting fields
You don’t need a card number field, so you’ll delete it in this exercise. Dele
HyperCard fields is similar to deleting HyperCard buttons: You select the 
object and then press the Delete or Backspace key.

1. Choose the Field tool from the Tools menu.

2. Click the Card Number field once to select it. 

As a shortcut, HyperCard lets you select and manipulate background fi
even when you’re not in the background.

3. Press Delete or Backspace.

4. When the Confirmation box appears, click Delete to confirm your decision.

When you delete a background field, you also delete all the text typed 
it for every card in the stack that shares the same background. Becau
deleting a background field by mistake can be a catastrophe, HyperCa
asks if you’re sure.

You also need to delete the field at the bottom of the card—the one with
stack’s title in it.

5. With the Field tool active, click the Stack Title field once. 

6. Press Delete or Backspace.

7. Click Delete to confirm your decision.

Modifying the Phone Number field
You need to make the Phone Number field smaller to compensate for the s
that the Telephone icon takes up. To keep things in scale, you also need 
reduce the field’s font size.

1. With the Field tool active, double-click the Phone Number field to open its Info dialog box.

This is the same as selecting the field and choosing Field Info from th
Objects menu.
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2. Click the Text Style button.

The Text Style dialog box appears.

3. Set the text size to 9 and then click OK.

4. Drag the lower-left corner of the Phone Number field up and to the right until the field is 
the correct size. 

Click 9 here…

…or type 9 here.

Drag the corner of the field
so it isn’t covered by the
telephone and has room

for two lines of text.
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Creating a Birth Date field
To gain experience working with new fields, you’ll add a field in which you
can type people’s birthdays. In the next two exercises, you’ll create the fie
and test it by filling in some dates.

In this first exercise you create the field:

1. Choose Background from the Edit menu.

To have the birthday field show on all the cards, you need to create it in
background. You can confirm you’re working in the background by see
if the menu bar is striped.

2. Choose New Field from the Objects menu.

HyperCard places a new field in the middle of the window.

3. Double-click the new field to open its Info dialog box.

4. Choose Transparent from the Style pop-up menu to set the field’s style.

5. Type Birth Date to name the field.

6. Click Text Style.

The Text Style dialog box appears.

7. Set the text style for the field to 9-point Geneva, aligned Center, and click OK.

The Text Style dialog box closes and you return to the background lev

8. Resize the field and move it into position.

Resize it so that you can see just one dotted line at the base of the field
a little empty space.
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In this second exercise you type some dates into your new field to test it:

1. With the Browse tool active, choose Background from the Edit menu (or press x-B) to move 
back to the card level.

The stripes in the menu bar disappear.

2. Choose First from the Go menu to go to the first card in the stack.

You return to John Chapman’s card.

3. Click once in your new field to set the insertion point (or press the Tab key until the field is 
highlighted).

4. Type 9/26/74 .

5. Click the right arrow button to move to the next card.

Note that the date you typed into the Birth Date field isn’t there. This is
because, even though the field that you created appears on every card
you type into a field appears only on the card where you typed it. 

If you want, click the left arrow button to move back to the first card to s
that the date you typed is still there; then click the right arrow button to
come back to the second card.

6. Click the Birth Date field and type 1/3/58 .

Now that you know your field is working properly, you’re ready to create a
label for it.

Creating the label for the Birth Date field
In the next two exercises, you will add the word “Birthday” above the field th
contains the birth date, and make it appear on every card.

When you need to have the same text appear on every card in a backgro
you can either paint it or use a shared text field, a kind of field where the same
text appears in that field on every card in the background. In this case, yo
make the label a shared text field.

Instead of creating the field from scratch, you’ll make a duplicate of the Bi
Date field and modify the duplicate as necessary.
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1. Choose the Field tool from the Tools menu.

2. Press and hold the Option and Shift keys while you drag the Birth Date field up.

Dragging the field while you hold down the Option key creates an exa
duplicate of the field. Dragging the field while you hold down the Shift ke
restricts your movement of the field to either straight up and down or 
straight left and right. Dragging the field while you hold down both key
produces both effects.

❖ Note: Be careful not to create extra fields. Every time you click the fiel
with the Option key down, you create another field. Delete any extra fie
by selecting them and then pressing the Delete or Backspace key.❖

3. Double-click the new field to open its Info dialog box.

4. Type Birthday Label to name the field.

5. Check Shared Text.

When you check Shared Text, the Don’t Search option is automaticall
checked as well.

6. Click Text Style.

7. Click Bold and then click OK.

Putting text in a shared text field
You enter and edit text in a shared text field by using the Browse tool in th
background.

1. Choose Background from the Edit menu.

You should see stripes in the menu bar.
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2. Choose the Browse tool.

You need the Browse tool to type in the field. 

3. Press the Tab key once.

The insertion point will blink in the shared text field.

4. Type Birthday .

5. Choose Background from the Edit menu to return to the card layer. 

The stripes disappear from the menu bar and you see all the card text

Look at a few cards to make sure the text is in fact shared. Click the left a
right arrow buttons to move forward and back.

Rearranging the Notes field
The last change you have to make to the fields is to move the Notes field
one running along the right edge of the card) and turn it into a scrolling fie

1. Choose the Field tool from the Tools menu.

2. Double-click the Notes field to open its Info dialog box.

3. Choose Scrolling from the Style pop-up menu and then click OK to change the field’s style.

A scroll bar appears in the field.
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4. Adjust the Notes field’s size and move it. 

5. Choose the Browse tool.

6. Flip through the cards in the stack to see how your changes look.

Finishing touches
Now that you’ve created and arranged the fields and buttons, all that rem
is to make the stack smaller.

1. Choose Stack Info from the Objects menu.

2. Click the Resize button.

The Resize dialog box opens.

Change the field’s size so 
it is just tall enough to 
show the two arrows of 
the scroll bar . . .

. . . then move it just 
below the white part of 
the card and make it the 
same width.
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3. Adjust the size of the stack. 

4. Click OK. 

The stack is resized. Your final stack should look like this: 

If the size isn’t right, you can repeat this exercise to readjust it.

Drag this handle up
and to the left…

…until the size is 288 
pixels across by 200 
pixels high.
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Starting from Scratch
In this, the final part of your tutorial, you’ll create a stack from scratch. Yo
stack will be used to review new cars for possible purchase. Here’s what it
look like when you’re finished: 

The first step is to create a new stack:

1. Go Home.

2. Choose New Stack from the File menu.

The New Stack dialog box appears.

3. Double-click the name “HyperCard Stacks” to open that folder.

When you create the stack, it will go into the HyperCard Stacks folder
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4. Name the stack Car Report, and set the card size to fit on a Classic 9” screen. 

Make sure that the two option boxes at the bottom of the dialog box a
unchecked.

5. Click New to create the stack.

The new stack’s window opens, absolutely blank.

Next you’ll lay out a background that contains three elements: art, buttons
and fields.

Copying the background art
The background art for this stack is supposed to look like a spiral noteboo
You could use the Paint tools to draw your own; but to make things easie
you’ll go to the Background Art stack and copy the art from there.

1. Click the Background Art button on the Home stack’s Stack Kit card.

The Background Art stack opens.

2. Click the “Books and notebooks” category.

You move to the Books & Notebooks section. A navigation palette appe
over the card.
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3. Click the right arrow of the palette once to see the second card.

4. Press Option-Tab to convert the Tools menu to a palette.

You can do things with the Tools menu turned into a palette that you c
otherwise do. Place the Tools palette wherever you like.

5. Double-click the Selection tool in the Tools palette to select all the art.

A moving dashed line surrounds the card, telling you that the art is sele

6. Choose Copy Picture from the Edit menu (or press x-C).

Next you’ll return to your new stack using the Open Stack command.

7. Choose Open Stack from the File menu and double-click the name “Car Report.”

8. Choose Background from the Edit menu (or press x-B).

Confirm that you’re working in the background by seeing if the menu b
is striped.

9. Choose Paste Picture from the Edit menu (or press x-V).

You’ve finished the background art.
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Copying the background buttons
In this section, you’ll put three buttons—Home, left arrow, and right 
arrow—into the background. You’ll copy them from the Addresses stack.

Copying the left arrow
You’ll start by opening the Addresses stack in a second window; then you
copy and paste the left arrow button by switching back and forth between
two windows. 

1. Choose the Open Stack command from the File menu.

2. Click the “Open stack in new window” checkbox to select it.

Checking this box tells HyperCard to open the stack in a new window 
without closing the Car Report stack’s window.

You may not be able to see both of them, but you now have two 
windows open. 

3. Choose the Button tool from the Tools menu.

4. Click the left arrow button once to select it.

A moving dashed line surrounds the selected button.

5. Choose Copy Button from the Edit menu.

These are the three 
buttons you need to 
copy to the background 
of the Car Report stack.
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6. Choose Next Window from the bottom of the Go menu to activate the Car Report 
stack’s window.

Alternatively, if part of the Car Report stack’s window is visible, you ca
click it to make it active. Each time you choose the Next Window 
command, HyperCard activates the window that’s behind the window 
you’re currently viewing.

7. Choose Paste Button from the Edit menu (or press x-V).

The button appears. You’ll move it into place in a later exercise.

Copying the right arrow button
You’ll now copy the right arrow button from the Addresses stack to the Ca
Report stack.

1. Press x-L to go back to the Addresses window.

This is the shortcut for the Next Window command.

2. Click the right arrow button once to select it.

3. Press x-C to copy the button.

4. Press x-L to return to the Car Report window.

5. Press x-V to paste the button.

Copying and customizing the Home button
To copy the Address stack’s Home button and paste it into your new stack
the same process as you used for the right and left arrow buttons. 

To fit the Home button into your design, you’ll have to hide its name and 
change its icon:

1. Double-click the Home button to open its Info dialog box.

2. Click Show Name to turn that option off, then click the Icon button.
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3. Change the icon to a smaller one. 

Arranging the buttons
Now you need to move the buttons to where they belong.

1. Use the Button tool to make the Home button smaller.

Drag its corner to make the button just a little bigger than the icon in 
its center.

2. Move the buttons into position. 

Move the buttons to these
locations. Be sure to drag

them by their middles, not
their corners.
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Creating the background fields
In this section, you’ll create six background fields for your new stack. Thre
will be shared text fields—a large one for the stack’s title and two small o
for the labels “Pros” and “Cons.” The other three fields are for the name of
car, the list of pros, and the list of cons.

Creating the stack’s title field
In this exercise, you’ll create a large shared text field for the stack’s title.

1. Working in the background, choose New Field from the Objects menu.

The new field appears in the middle of the window.

2. Double-click the new field to opens its Info dialog box.

3. Set the style to Transparent.

4. Click the Shared Text checkbox to select it.

5. Set the text style for the field to 24-point Palatino Bold; then click OK.

6. Resize the new field and move it into place at the top of the card.

Adding the title field text
In this exercise, you’ll fill in the shared text for the title field and draw a lin
below it. 

1. While in the background, choose the Browse tool.

2. Press the Tab key once to find the field.

The insertion point blinks in the field.

3. Type Executive Summary: New Cars .
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4. Choose the Line tool from the Tools menu. 

When you choose the Line tool, the pointer changes to a crosshair.

5. Hold down the Shift key and draw a line under the title. 

Shift-dragging makes it easier to draw a horizontal line.

Creating a Car Name field
In this exercise, you’ll create the field for the car’s name. 

1. With the Browse tool active in the background layer, choose New Field from the Objects menu.

The new field appears.

2. Double-click the new field to open its Info dialog box.

3. Set the field’s style to Transparent.

4. Set the text style for the field to 18-point Palatino Bold.

5. Resize the new field and move it into place. 

Adjust the size of the field
and place it here.
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Adding Pros and Cons fields
In this exercise, you’ll create the field for the list of pros and then duplicat
to create the field for the list of cons.

1. While in the background, use the Browse tool to choose New Field from the Objects menu.

2. Set the field style to Transparent.

3. Set the font to 14-point Palatino and click OK.

4. Resize the new field and move it into place. 

Be sure to leave enough room between the two 
fields for the label (which you’ll soon construct).

Place the field here.
(Make sure you leave
enough room for four

lines of text.)
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5. Shift-Option-drag the field to duplicate it. 

❖ Note: If you duplicate the field successfully but don’t get it in quite the
right place, delete the new field and try again. You can delete a field b
clicking it once and pressing the Delete or Backspace key.❖

Creating Pros and Cons labels
In this exercise, you’ll create the field for the Pros label and duplicate it to
create the field for the Cons label.

1. With the Browse tool active in the background, choose New Field from the Objects menu.

The new field appears.

2. Double-click the new field to open its Info dialog box.

3. Set the field’s style to Transparent.

4. Click the Shared Text box to select it.

5. Set the text style for the field to 10-point Palatino Bold and click OK.

While holding down 
the Shift and Option 
keys drag this field 
straight down . . .

. . . until the copy is 
in position here. 
(Leave room for the 
label above it.)
2-50 Chapter 2: Learning HyperCard Basics



. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .
6. Position the new field like this: 

7. Shift-Option-drag the field to duplicate it and position it above the bottom field. 

Adding label text
Finally, you’ll add labels to the fields you just created.

1. Still in the background, choose the Browse tool.

2. Press the Tab key twice and type Pros: .

3. Press the Tab key again and type Cons: .

4. Choose Background from the Edit menu to view your work.

The stripes disappear from the menu bar.

Place the field here.
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Checking your work
You’ve completed the background and should be ready to start using the s
Before going on, use the following exercise to do a quick check and make 
there are no mistakes.

1. Check your card to see if it looks like this: 

❖ Something amiss?If your card doesn’t look quite right, review the 
exercises on background art, background buttons, and background 
fields. ❖
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2. Choose Bkgnd Info from the Objects menu.

Your Info dialog box should look like this: 

The six fields are for (1) the title of the stack, (2) the name of the car, (3)
label “Pros,” (4) the list of pros, (5) the label “Cons,” and (6) the list of 
cons. The three buttons are left arrow, right arrow, and Home.

❖ Button or field count off?If you have too few buttons or fields on the 
background, you may have either skipped a step or, more likely, 
accidentally created them on the card instead of the background. Cho
the Card Info command from the Objects menu, and if the dialog box l
any buttons or fields, that’s probably what you did.

If you have too many fields, you probably duplicated an extra copy. Cho
the Field tool and click the extra field to select it. Then press the Delet
Backspace key to delete it.❖

3. Click Cancel to close the Bkgnd Info dialog box.

. . . and three buttons.

This number is probably 
different in your stack.You should have six fields

in the background . . .
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Using the stack
You use the Car Report stack just as you would use any other. In this exer
you’ll enter text for the cards and do one final stack test.

1. Choose the Browse tool.

2. Press Tab to start typing in the first field.

3. Type the name of the car: Phantasmo Operetta

4. Press Tab to move to the Pro field and type this text (press Option-8 to get the 
bullet character): 

■ Sleek aerodynamic design

■ Rotating ten-way velour seats

■ Can do up to 110 M.P.H.

5. Press Tab again to move to the bottom field and type this text: 

■ People who drive these get more speeding tickets.

■ Repairs are phenomenally expensive.

6. Choose New Card from the Edit menu and fill in the fields for the card.

Enter whatever information you’d like into each field.

7. Create a third card and enter text for it.

8. Click the arrow buttons to test them.

Getting HyperCard Help
If you have a question about how to do something in HyperCard, you can o
get the answer from the HyperCard Help stack. HyperCard Help gives you
ways to find answers: by looking through its list of topics or by searching 
for words.
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Using the list of topics
Suppose you want to learn how to change the size of HyperCard windows.
could look through the list of topics as described in this exercise:

1. Choose Help from the Go menu (or press x-?).

HyperCard opens the HyperCard Help stack. If HyperCard has enoug
memory, it leaves the original stack you were looking at open as well.

2. Click “Browsing and finding information” in the list of topics. 

Clicking a main topic shows you a list of related topics from which 
to choose.
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3. Click “Resize the card window” in the list of topics. 

You go to a card with information about the topic.

4. Click the Main Topics button to return to the first card in the Help system.

You return to the Main Topics card.

Using the Find Topic feature
If you’re not sure what topic to look under, you may want to use the Find To
feature. For this exercise, suppose you want to learn how to create a new b
for the Home stack:

1. Click the Find Topic button at the bottom of the card. 

The Find Topic card appears.

This means there 
are two cards 
describing this 
subject.
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2. Type new button . 

3. Click the Find button.

The Help stack displays a list of topics relating to new buttons.

4. Click “Add a button to your Home stack” to choose the topic.

The Help stack displays information about adding new buttons to your
Home stack.

5. Exit Help by doing one of the following:

■ If the Help stack’s window has a close box, click it. 

■ If the Help stack’s window does not have a close box, choose Hom
from the Go menu.

You type “new button”
into this box.
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Congratulations!
You now have experience with most of HyperCard’s basic features, and a
advanced ones as well. You can go on to plan and create stacks on your
using ready-made buttons, fields, and graphics from the sample stacks to
you do it. Experiment with the Paint tools to create your own graphics or t
modify existing ones.

Take the HyperTalk tutorial in the next chapter to learn how to write your o
scripts. Then use the HyperTalk Reference stack when you need help 
constructing more complex programs.

❖ Cleaning up: If you want, you can remove the button you created on th
Home card for this tutorial. When you quit HyperCard, remove the file
you created by dragging them to the Trash.❖
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Chapter 3
A Taste of HyperTalk

This chapter is made up of exercises that show you how to use HyperTalk
language that’s built into HyperCard. With HyperTalk, you can write your ow
instructions, called scripts, for HyperCard to carry out. You don’t need an
previous programming experience to write scripts. If you can read this 
paragraph, you can write a script. 

You can create, customize, and personalize HyperCard stacks without lea
how to write scripts; but scripting with HyperTalk gives you even more cont
over your computer. 

To get the most out of this chapter, you should already have read Chapter 
gone through all the exercises covered in Chapter 2. Specifically, you sho
know how to use buttons to get around in stacks and how to use the Hyper
menus and tools. You should have browsed through some stacks, looked
through part of the HyperCard Help stack, and started using a stack for y
own purposes—for example, you might have used the Addresses stack to
some information. 
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Each exercise builds on what you’ve done in previous exercises, so it’s 
important that you start with the first exercise and work through them all 
sequentially.

What You Will Build
In this chapter, you’ll learn scripting by creating a stack named “Collection
from scratch and writing scripts for it. If you work through all the exercises
order, you’ll end up with a stack you can use to catalog a collection of rec
albums, cassettes, or compact discs. Here’s a sample card from a compl
version of the Collection stack:

More importantly, you’ll learn basic scripting concepts and techniques as 
build the Collection stack. By the time you’re finished, you’ll know enough 
create scripted stacks for your own purposes.
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For example, you’ll be able to modify the Collection stack as you see fit—
keep track of books, baseball cards, computer software, your favorite 
restaurants, the inventory for a business, or anything else you might wan
catalog. You’ll also be able to change the stacks that come with HyperCa
suit your own needs. 

❖ Shortcuts abound.You used menu commands to perform most tasks in
Chapter 2’s tutorial, but in this chapter, you’ll use many shortcuts. 
Shortcuts save you a tremendous amount of time, especially if you wri
lot of scripts.❖

Getting Started
This chapter is meant to be used with HyperCard running. 

1. Start HyperCard. 

If you already have HyperCard running, go to the Home stack. 

2. Click the left arrow button or choose Preferences from the Home menu. 

The Preferences card appears.

3. Click the Scripting button on the Preferences card.

For now, leave the checkbox options Blind Typing, Power Keys, and 
Arrow Keys in Text unchecked. 
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When the user level is set to Authoring or Scripting, a new menu title, Obje
appears in the menu bar. As you saw in Chapter 2, you use commands in
menu to get information about and change properties of HyperCard 
objects—buttons, fields, cards, backgrounds, and stacks. (You’ll learn mo
about objects later.) The user level must be set to Scripting before you can
at, write, or change these objects’ scripts. 

Creating the Collection Stack
Now that you set the user level to Scripting, the next task is to create a st
Follow these steps:

1. Choose New Stack from the File menu.

A dialog box appears for you to name the stack and specify its backgro
and size. 

2. Name your stack “Collection.”

If you make a typing mistake, use the Delete or Backspace key to era
and retype. 

Click here.
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3. Navigate to the same folder that holds the Home stack.

4. Click New (or press Return).

You should see a completely blank card on your screen with the menu
at the top. This card is the first—and right now the only—card of your 
Collection stack.

When you create a new stack, you automatically get three things: the sta
itself, a background, and the first card. If you were to select the “Copy cur
background” option in the New Stack dialog box, you would also get the 
background pictures, fields, or buttons of the card you were on when you c
the New Stack command. Otherwise, as in this case, you have a blank ca
work with.

Creating Background Buttons
In the next few exercises, you’ll add buttons to the background of the 
Collection stack. 

A quick background review
As you saw in Chapter 2, each card in a stack is a composite of two layer
foreground layer (called the card layer) and a background layer. You see
elements of both layers when you look at a card, as if the card layer were
transparent layer in front of the background layer. Each layer can contain
own buttons, fields, and graphics.

You can think of the background in HyperCard as a kind of “holding area” 
general elements. Each card with the same background has the same bu
fields, and graphics in its background layer. If you put a button in the 
background, for example, you’ll have that button constantly available 
throughout a number of cards—you don’t need to re-create it on every card
this point, the Collection stack has only one background, so all the cards 
create will share that background.
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Creating a Home button
In this exercise, you’ll create a Home button (that is, a button that takes yo
the Home stack when you click it).

1. Choose Background from the Edit menu (or press x-B). 

Stripes appear in the menu bar, indicating that you’re working in the 
background.

2. Choose the Button tool from the Tools menu.

The pointing hand (Browse tool) on the screen changes to an arrow po

If you prefer, press Option-Tab to create a Tools palette on the screen

❖ Tabbing to the Button tool:You can also choose the Button tool by 
pressing x-Tab-Tab.❖

3. With the pointer anywhere on the card, x-drag (hold down the x key and drag) to create a 
small button about half an inch square.

4. Release the mouse button and the x key when the new button is about the right size. 

Don’t worry too much about the size; you can always resize a button.

The new button is automatically selected—you can tell by the moving 
dashed line around its edges. While it’s selected, you can stretch or sh
the button by dragging a corner.

5. Move the button to the lower-right corner of the background. 

To move the button, position the pointer near the button’s center and d
Because the button is in the background, it will appear in this position 
every card in the stack that shares this background.
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6. Double-click the button to see its Button Info dialog box.

A blinking vertical bar marks the insertion point in the Button Name bo
ready for you to type a name.

7. Type Home to name the button (but don’t press Return).

8. Click the Auto Hilite checkbox to select it.

The Auto Hilite option makes the button flash when it’s clicked. Leave t
Show Name checkbox deselected. You’ll assign an icon to this button 
you won’t need the button’s name to show.

9. Click Icon.

Another dialog box appears in which you can select an icon for the bu

10. Choose one of the house icons.

Scroll through the window until you find the house icons and click the o
you want.

11. Click OK.

The dialog boxes disappear. Your new button now has the house icon o
Chapter 3: A Taste of HyperTalk 3-7
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Writing the Home button’s script
Next you’ll write a script for your new Home button. You create and chang
scripts in a special window called the script editor. To see the script for the new
Home button, make sure the Button tool is selected and follow these step

1. Double-click your Home button.

The Button Info dialog box appears. 

2. Click the Script button (or x-Option-click it).

The script editor for the Home button appears. There are two lines of 
already in the window, with the insertion point blinking on an empty lin
between them. 

The title bar at the top of the script editor identifies this script as the sc
of the background button with the ID number 1 and the name Home—y
new button. 

You see a new set of menus in the script editor. Pull them down and l
at their contents now if you want (to learn more about these menus, se
HyperCard Script Language Guide).

3. Type go to stack "Home".

If you make a mistake, use the Backspace (Delete) key to erase the mi
and finish typing the script correctly. 

The script editor automatically indents lines within scripts. This indenti
helps you check your scripts. On and end should always line up at the 
left-most edge of the script editor window when you finish typing a scri
if they don’t line up, press the Tab key to check the script’s formatting
they still don’t line up, you may have left out something important; che
the script again. 
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❖ Capitalization doesn’t matter.It doesn’t matter how you capitalize 
HyperTalk words. Words that are formed from two words (such as 

mouseUp) are usually typed in small letters with a capital in the middle 
make them more readable.❖

4. Press Enter. 

The script editor disappears, and you’re looking at the Collection stack
again. By pressing Enter, you save any changes you made to the scrip
return to the stack you’re working on. If you click the close box in the 
upper-left corner of the script editor, HyperCard asks if you want to sa
changes to the script before closing the script editor.

Trying out the Home button 
Now see if the Home button works the way it’s supposed to: 

1. Press x-B to return to the card layer.

The stripes in the menu bar should disappear. If they don’t, press x-B 
again. 

2. Choose the Browse tool from the Tools menu (or press x-Tab). 

3. Click the Home button. 

The Home stack appears. 

If something else happens, such as the appearance of a dialog box sayin
“Can’t understand...,” you may have made a typing mistake. Click Script in
error dialog box to check the script. Make sure everything is correct; then p
Enter and try out the Home button again. 
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How the script works 
The script you wrote describes what should happen when someone clicks
Home button. 

Whenever you move the mouse, your computer and HyperCard software t
the movement electronically. You see the movement as a change in the po
of the pointer on the screen. When you press and release the mouse butto
mouse sends a signal to the computer. The same thing is true when you 
different keys on the keyboard. The HyperCard software interprets these 
signals from the system and translates them into HyperTalk system messages. 

MouseUp is a system message that means the mouse button has been rele
an on-screen HyperCard button receives this message when someone cli
Whether something happens when the on-screen button receives the mouseUp 

message depends on whether the button’s script contains any instruction
react to that message. 

The first line of your script, on mouseUp , signals HyperCard that instructions
for the mouseUp message exist. The next line, go to stack "Home" , tells 
HyperCard to go to the Home stack. 

The word go is a HyperTalk command; it means what you might expect. T
command go must be followed by a destination—a description of a stack o
card. In this case, you used the name of the stack Home. 

Each line in a script is called a HyperCard statement, and represents a single 
instruction. In a more complicated script, the instructions signaled by mouseUp 

could consist of many statements. The last line of your script, 

end mouseUp , indicates the end of the instructions for the mouseUp message. 

Translated into English, the instructions in your script say: “When someon
clicks this button, go to the Home stack.” 
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Adding a button to the Home stack
In this section, you’ll create a button in the Home stack that takes you dire
to your Collection stack. 

Creating the button
Make sure you’re looking at the Home stack and follow these steps: 

1. Choose the Button tool.

2. x-drag to create a new button.

Make the button about an inch wide and half an inch high. Move it to a
open space on the card.

❖ You can rearrange the Home stack.If you need room, you can move any
of the buttons in the Home stack just by clicking them with the Button to
and dragging them to a new location.❖

3. Double-click the button to see its Info dialog box.

4. Name the button “Collection.”

5. Click Show Name and Auto Hilite to select them. 

When Show Name is selected, the button’s name appears with the bu

6. Click Icon.

The Icon Chooser dialog box appears.

7. Choose the stack icon. 

8. Option-click OK.

Only the Icon Chooser dialog box closes; you end up back in the Butto
Info dialog box. As you can see in the Preview window, your new butt
now has the stack icon on it along with the name of the button. 
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Writing the script
Now you’re ready to write the script.

1. From the Button Info dialog box, click the Script button to see the script editor.

If you aren’t in the Button Info dialog box already, x-Option-click 
the button.

2. Type go to stack "Collection" .

The completed script should look like this:

on mouseUp
 go to stack "Collection"
end mouseUp

3. Press Enter. 

The Home stack appears with the Collection button in place. 

4. Try out the new button by clicking it with the Browse tool. 

If the Collection stack appears, congratulations! If something else 
happened, you may have misspelled a word or left out a space in the 
button’s script. If you got a directory dialog box asking where the stack
you may have typed the stack’s name incorrectly or saved the stack in
folder that HyperCard doesn’t know about yet. 

The words go to stack "Collection" tell HyperCard to go to the 
Collection stack. HyperTalk is a flexible language; any of these statemen
would also have worked in the button’s script:

go "Collection" 
go to "Collection"
go to card 1 of stack "Collection"
3-12 Chapter 3: A Taste of HyperTalk
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Message handlers
As you’ve seen, when an object receives a message, it can act on the me
according to instructions in the object’s script. More specifically, the objec
acts according to instructions in the message handler. 

A message handler is a set of instructions to be carried out when a partic
object receives a particular message. It’s called a handler because it “han
the message. Message handlers always begin with the word on and end with 
the word end , and both words are followed by the name of whatever mess
the handler deals with—for example, on mouseUp . Each of the scripts you 
have written so far contain only one message handler, but an object’s scrip
contain a number of handlers, each one handling a different message. The
script refers to all the handlers for a given object.

Writing a script for a HyperCard object is like training a dog. The dog is lik
HyperCard object, and a spoken command is like a message. Each of the 
tricks—the response of a particular dog to a particular command—is like 
message handler. And the sum of all the dog’s tricks represents the scrip
the dog. When the dog receives a message (for example, “fetch”), the do
searches through its script for the appropriate handler and then acts acco
to the instructions in that handler.

Script

Message handler

Object
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❖ “On” and “End” are keywords. The words on and end belong to a 
special group of HyperTalk words called keywords. Keywords are used to 
control which statements are executed in a script.❖

Putting Information into Your Stack
So far the Collection stack consists of a single card with a Home button. In
section, you’ll add fields to the background of the stack, type some text into
fields, and add some cards to the stack. 

Adding fields to the background
First you’ll add four fields to the background. When you’re finished, the 
background will look like this: 

When you place these fields in the background, they’ll appear on every ca
your stack. (Your stack has only one background.) The text contained in t
fields can be different on every card.

Category field

Artist field

Title field

Notes field
3-14 Chapter 3: A Taste of HyperTalk
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Creating the Category field
You can always get a new field by choosing New Field from the Objects me
But in this chapter you’ll use a keyboard shortcut to make fields. Follow 
these steps:

1. Press x-B to work in the background.

Stripes appear in the menu bar.

2. Choose the Field tool from the Tools menu (or press x-Tab-Tab-Tab). 

The pointing hand changes to an arrow pointer.

3. x-drag to create a new field one line high and about three inches wide.

This method for creating a field is like the one you used to create your
Home button. Release the mouse button and the x key when the field is the 
size you want. The new field is automatically selected, as indicated by
“marching ants” around it. While it’s selected, you can stretch or shrink 
field by dragging a corner.

4. Move the field to the top of the background (like the Category field in the previous figure).

To move the field, position the pointer near the center of the field and d
Because the field is in the background, it will appear in this position on
every card in the stack.
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5. Double-click the field to see its Field Info dialog box.

HyperCard fields have a variety of styles and options from which to 
choose. You customize a field’s appearance and actions through the F
Info dialog box. 

A blinking vertical bar marks the insertion point in the Field Name box
ready for you to type a name. 

6. Type Category to name the field (but don’t press Return).

If you press Return prematurely, double-click the field again to get bac
the Field Info dialog box. 

7. Choose Rectangle from the Style pop-up menu to set the field’s style.

8. Click the Text Style button.

The Text Style dialog box appears.

9. Select a font and size.

Select a font that’s easy to read, such as Times 14.

10. Click OK.

The Text Style dialog box closes, and you return to the background.
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Creating the Artist, Title, and Notes fields
Now you need to add three more fields to the background. This time you’
use a shortcut that you practiced in Chapter 2 to create each field. Make 
you’re still in the background and that the Field tool is still selected; then 
follow these steps:

1. While holding down the Option and Shift keys, position the pointer near the center of the 
Category field and drag down.

You should see an exact duplicate of the Category field move down th
screen, leaving the original Category field in place. 

Dragging the field while you hold down the Option key creates an exa
duplicate of the field. Dragging the field while you hold down the Shift ke
restricts your movement of the field to either straight up and down or 
straight left and right. Dragging the field while you hold down both key
produces both effects simultaneously. (Both of these shortcuts also w
for buttons.)

Now all you need to do is change the name, and you’ll have a new field w
the same size and other characteristics as the Category field.

2. Double-click the new field to see its Field Info dialog box, and name the field Artist.

Except for its name, numbers, and ID, the Artist field will have all the sa
characteristics as the Category field.

3. Using the same shortcut, Option-Shift-drag the Artist field to create a third background field, 
and name it Title.

4. Option-Shift-drag the Title field to create a fourth background field.

5. Enlarge the last field by dragging a corner until it’s a few inches high. 

6. Name the last field Notes and change its style to Scrolling.

Typing into the fields
Now that you’ve created all the fields for your stack, you’re ready to type so
text into them. Type in information about your own records, tapes, or 
compact discs. 
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To type text into the fields, follow these steps:

1. Press x-B to return to the card layer.

You see the first and only card in the stack. Make sure there are no st
in the menu bar.

2. Choose the Browse tool.

3. Click inside the Category field and type the recording category. 

Type “Rock,” “Jazz,” “Classical,” “Country,” or any other category you 
want to use. Don’t press Return.

4. Press the Tab key to move the insertion point to the next field.

The insertion point appears in the Artist field.

5. Type the name of the artist featured on the recording.

Type the name as you would like it to be sorted alphabetically (a featu
you’ll soon add). For example, “Johann Sebastian Bach” should be ent
as “Bach, Johann Sebastian.”

6. Press the Tab key to move to the Title field; then type the title of the recording.

7. Press the Tab key to move to the Notes field and type the names of songs or any other 
information you want to keep about the recording.

Adding more cards to the stack
Now add at least two more cards to the stack. Follow these steps:

1. Choose New Card from the Edit menu (or press x-N).

❖ Disappearing fields:If a field disappears when you create a new card, y
probably placed the field in the card layer rather than the background la
To move a field from the card layer to the background: Click the field w
the Field tool to select it; then press x-X to cut the field, press x-B to go 
to the background, and press x-shift-V to paste the field into the 
background with its text intact.❖

2. Type information about another recording into the fields on the new card.

3. Repeat steps 1 and 2 to add as many cards as you want to your stack. 

Make sure you have at least three cards before you go on to the next 
exercise.
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Buttons for Traveling
In this section, you’ll create two buttons that move forward and backward
between cards in your stack. 

Creating Next and Previous buttons
To make the Next and Previous buttons, you’ll use the same steps you follo
when you made the Home button:

1. Press x-B to work in the background.

Stripes appear in the menu bar.

2. Choose the Button tool.

3. x-drag to create two new transparent buttons.

Make each new button about the same size as the Home button.

4. Position the two new buttons side-by-side, to the right of the Home button.

Drag each button by its center to move it.

Customizing the button on the right
Make the button on the right into a Next button:

1. With the Button tool still selected, double-click the button on the right.

The Button Info dialog box appears.

2. Name the button Next.

3. Click Icon to see the available icons.

4. Choose any icon that points to the right. 

You can choose any size arrow or pointing finger. Click the one you w

5. Click OK.

The dialog boxes disappear. You should see the icon you chose on 
the button.
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Customizing the button on the left
Make the button on the left a Previous button:

1. With the Button tool still selected, double-click the button on the left. 

The Button Info dialog box appears.

2. Name the button Previous.

3. Click Icon to see the available icons.

4. Choose an icon that points to the left.

Use the same kind of arrow or pointing finger that you chose for the fir
button, but pointing the opposite way.

5. Click OK.

The two buttons now have matching icons pointing away from each ot

Writing the scripts
You want the Next button (the button on the right) to take you to the next c
in the stack, and you want the Previous button (the button on the left) to t
you to the previous card. Follow these steps to put your instructions into t
buttons’ scripts:

1. With the Button tool still selected, double-click the Next button.

The Button Info dialog box appears.

2. Click the Script button.

The script editor appears. 

3. Type go to next card.

The completed script should look like this:

on mouseUp
 go to next card
end mouseUp

4. Press Enter.

The script editor disappears. 
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Now repeat the steps for the Previous button using a slightly different 
instruction:

1. Double-click the Previous button to see its Info dialog box.

2. Click Script.

3. Type go to previous card.

The script should look like this:

on mouseUp
 go to previous card
end mouseUp

4. Press Enter.

You have completed the scripts for both buttons. Now try them out: 

1. Press x-B to return to the card layer.

2. Choose the Browse tool and click the Next button.

You should go to the next card in the stack.

❖ Disappearing buttons:If a button disappears when you go from one ca
to another, you probably placed the button in the card layer rather than
background layer. To move a button from the card layer to the backgrou
Click the button with the Button tool to select it; then press x-X to cut the 
button, press x-B to go to the background, and press x-V to paste the 
button in the background. Return to the card layer when you’re finished❖

3. Click the Previous button.

You should go to the previous card.

You can use the Next and Previous buttons to move through all the cards i
Collection stack. (Cards in a stack are arranged in a circle, so the first car
the next one after the last card.)

Moving to adjacent cards isn’t the only possibility, of course; you can crea
other buttons to take you to any card of any stack you want by specifying
script where you want to go. 
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Adding visual effects
Visual effects make the movement from one card to another more obvious
interesting. In this section, you’ll learn two ways to add visual effects to 
buttons.

Adding a visual effect to the Next button
First you’ll use a dialog box to add a visual effect to the Next button. Follo
these steps:

1. Choose the Button tool and double-click the Next button.

The Button Info dialog box appears.

2. Click the Effect button.

The Effect dialog box appears. 

You use this dialog box to choose which visual effect you want to displ
as well as how fast you want the effect to take place. The scrolling fiel
contains an alphabetical list of all the visual effects you can choose; th
buttons to the right list the available speeds.

3. Select “push left” from the list of visual effects.

The phrase visual effect push left appears at the top of the 
dialog box. 
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4. Click the Fast button to select it.

The line at the top of the dialog box should now say 

visual effect push left fast 

5. Click OK to close the dialog box.

6. Click the Next button with the Browse tool.

Watch the screen to see how the visual effect works: The next card app
to slide in from the right, pushing the current card off the screen.

Actually, you have added a visual effect command to the script for the 
Next button. You can see for yourself by opening the button’s script. It sho
look like this:

on mouseUp
 visual effect push left fast
 go to next card
end mouseUp

Press Enter when you finish looking at the script to put the script editor aw

Adding a visual effect to the Previous button
Using the Effect dialog box is one way of adding a visual effect to a script
Another way is to type the command yourself:

1. Choose the Button tool and double-click the Previous button.

The Button Info dialog box appears.

2. Click Script.

The script editor appears showing the button’s script. 

3. Click before go to set the insertion point.

Now you’re ready to type the statement that creates a visual effect.

4. Type visual effect push right fast and press Return.

The script should now look like this:

on mouseUp
 visual effect push right fast
 go to next card
end mouseUp
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5. Press Enter.

The script editor disappears.

6. Choose the Browse tool and click the Previous button.

❖ Pushing backwards:Notice that you use push left for the right arrow 
and push right for the left arrow to simulate page turning.❖

The syntax of the visual command
All languages—for people and computers—have rules of syntax. Syntax is the 
way in which words are combined to form meaningful statements. For 
example, in English the statement “Go to the store” makes sense becaus
follows the rules of English syntax. However, the statement “The go store
doesn’t make sense because it doesn’t use proper English syntax.

HyperTalk syntax is much like English syntax, which makes HyperTalk an
easy language for English speakers to use. It’s not always true, however, 
statement that makes sense in English will make sense in HyperTalk. For
example, HyperCard wouldn’t know what to make of this:

visual effect slow dissolve to black

As far as HyperCard is concerned, the command makes no sense becau
words are in the wrong order. (The correct order is visual effect dissolve 

slow to black .) You would see a “Can’t understand” dialog box: 

Clicking Script in a “Can’t understand” dialog box opens the script editor a
places the insertion point at the beginning of the statement HyperCard ca
understand. You can then correct any errors in syntax or spelling and try 
script again. 
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The syntax of a HyperTalk statement describes the general underlying stru
that a statement must follow. In order for HyperCard to understand a statem
the statement must contain the correct elements in the correct order. Cer
conventions are used everywhere in the HyperCard world to show the sy
of HyperTalk statements. For example, here’s the syntax of the visual 
command:

visual [ effect ] effectName  [ speed ] [to image ]

In the exercises in this book, syntax elements in this kind of type are 
entered exactly as they appear. 

Elements in italics are placeholders. In an actual statement, you would repl
effectName with the name of an actual visual effect, such as zoom out .

Syntax elements enclosed within brackets [ ] are optional. You don’t include 
the brackets in an actual command. There are other syntax symbols; you’
them as you go along.

Knowing a command’s syntax is as important as knowing what it does. 
Luckily, you don’t have to memorize syntax. The HyperCard Quick Reference
Guide lists the syntax of every HyperTalk command, and the HyperTalk 
Reference stack describes the syntax of each command in detail.

Skimming cards
In this section, you’ll modify the scripts for the Next and Previous buttons
that you can quickly skim through a number of cards by holding down the
mouse button.

Modifying the Next button’s script
First modify the script for the Next button. You’ll use a shortcut for seeing
button’s script. 

1. Choose the Browse tool and then hold down the x and Option keys.

Pressing these two keys lets you see the outline of all buttons on the c
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2. While holding down x and Option, click the Next button.

The script editor appears showing the button’s script. Release the keys
the script editor appears.

You use the x-Option-click shortcut to go directly to a button’s script 
without switching to the Button tool first—a handy feature when you’re
doing a lot of scripting.

❖ Editing background scripts from the card:Even though you had to switch
to the background when you created this button, you don’t have to sw
to the background to change its script.❖

3. Select mouseUp in the first line of the script.

Drag across the word to select it, or double-click the word.

4. Type mouseStillDown .

You’re changing the handler from a mouseUp handler to a 
mouseStillDown handler. The mouseUp message is sent only 
once—when the mouse button is released. The mouseStillDown message 
is sent continuously as long as the mouse button is held down.

5. Change mouseUp in the last line to mouseStillDown .

The script for the Next button should now look like this:

on mouseStillDown
 visual effect push left fast
 go to next card
end mouseStillDown

In English, the script says, “As long as the mouse button is pressed, dis
a visual effect and go to the next card.”

6. Press Enter.

Now see how the Next button behaves.
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7. Click the Next button—being sure to release the mouse button immediately.

You go to the next card, just as you did before. 

8. Press the Next button, this time holding it down for several seconds.

You skim through a number of cards.

As long as you hold down the mouse button, HyperCard repeatedly send
mouseStillDown messages to the button. The handler starting with 

on mouseStillDown executes again and again until you release the 
mouse button. 

Modifying the Previous button’s script
Now you’ll modify the Previous button. This time you’ll use one of the 
commands in the Script menu.

1. x-Option-click the Previous button.

The script for the Previous button appears.

2. Choose Replace from the Script menu.

The Replace dialog box appears. You can use this dialog box to find a
replace text within a script. In this case, you’re going to replace all 
instances of the word mouseUp with the word mouseStillDown .
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3. In the box labeled “Find,” type mouseUp (don’t press Return).

4. In the box labeled “Replace with,” type mouseStillDown (again, don’t press Return). 

5. Click Replace All.

HyperCard replaces all instances of mouseUp in the script with 
mouseStillDown . 

The script should now look like this:

on mouseStillDown
 visual effect push right fast
 go to previous card
end mouseStillDown

6. Press Enter.

You can now use the Previous button to skim backward through the card
your stack.
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Adding graphics
If you’d like to give your stack a distinctive look, you can take some time n
to design graphics for the background. Well-designed graphics can make 
stack easier to use and visually more appealing.

You can create graphics with the Paint tools (described in Chapter 8), or 
can copy clip art from the Art Bits stack. You may also want to change the fo
in the background fields or the position of the fields and buttons. (You’ll b
adding more buttons to the background later, so be sure to leave space 
for them.) 

You can leave your stack as it is, copy one of the designs suggested in the
figure, or have fun creating a design of your own. When you’re satisfied w
the way your stack looks, you can go on with this tutorial. 

Paint
tools
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Fields and Other Containers
A container is a place in the computer’s memory where you can put a valu
such as a number or some text. You can also get values out of containers 
elsewhere as needed. 

In this section, you’ll learn about three different kinds of containers: the 
Message box, fields, and variables. You’ll also learn how handlers can wo
with values in containers. You’ll add some more features to your Collectio
stack, and you’ll increase your vocabulary of HyperTalk commands.

Putting values into containers
You use the put command to put a value into a container. In the first exerci
you’ll practice using the put command to put values into the Message box
Later in this chapter, you’ll use the put command in scripts.

Putting values into the Message box
First open the Message box:

1. Press x-M to open the Message box.

The vertical bar that marks the insertion point blinks inside the Messa
box, ready for you to type. 

If for any reason you previously typed something into the box, the ear
entry will still be there. When you start typing, whatever you type will 
replace the old text. 

2. Type put "Hello" into the message box and press Return.

The word Hello appears in the Message box. 

The put command does what you would expect—it puts a value wher
you want it to go. In its most basic form, the syntax of the put command is

  put expression  [into container ]
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The placeholder expression is a word or phrase that specifies a value.
For example, the expression 2 + 2 specifies the value 4 . 

The placeholder container can be a button, a field, a variable, or the 
Message box. If you don’t specify a container, the value is put into the
Message box.

❖ The insertion point is not necessary.After you press Return, you can star
typing a new message into the Message box right away, even though
can’t see the blinking vertical bar. Whatever you type will replace the 
old text. ❖

3. Type put 2 + 2 and press Return.

The number 4 appears in the Message box. 

Including quotation marks around text characters tells HyperTalk to 
interpret literally whatever is inside. It treats whatever is inside the 
quotation marks as a string of text characters. 

If you don’t include quotation marks, HyperTalk evaluates the 
expression—that is, it replaces the expression with the value of the 
expression. For example, it replaces 2 + 2 with 4 .

4. Type put "It is now" && the time and press Return.

A text string giving the current time appears in the Message box, for 
example:

It is now 12:00 PM

The double ampersand (&&) joins two pieces of text together with a space
in between. In this case, it joins It is now with the current system time. 
If you wanted to join two pieces of text together without a space, you wo
use a single ampersand. 

5. Click the close box in the upper-left corner (or press x-M) to close the Message box.

Now that you’ve seen how the put command works, you’ll use it in a script.
Chapter 3: A Taste of HyperTalk 3-31



. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .

 Fields 

 

lay 
re in 

se 

 
rd 
rd 
Fields as containers
Fields are objects. They can receive and send messages and have scripts.
are also containers that can hold text and numbers.

Earlier in this chapter, you put text into fields by typing in the fields. In this
section, you’ll write a script that puts text into a field. 

First you need to create a background field named Label. This field will disp
the number of each card in your stack, so you can easily tell where you a
the stack.

Creating the Label field
To create the field, follow these steps:

1. Press x-B to work in the background.

Stripes appear in the menu bar.

2. Choose the Field tool.

3. x-drag to create a field one line high and about half an inch long.

Move the field to any available space in the background by dragging 
its center.

4. Double-click the field to see its Info dialog box.

5. Name the field Label and set the field’s characteristics.

Choose Rectangle in the pop-up Style menu for the field’s style. Choo
any text style you’d like.

6. Click OK.

Writing a script for the stack
You could label all cards in your stack by going to each one and typing its
number into the Label field. But you can also write a script telling HyperCa
to do it for you. The field should contain a text string with two pieces: the wo
“Card” and the number of the current card.
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To write the script, follow these steps:

1. Choose Stack Info from the Objects menu.

The Info dialog box for the stack appears.

2. Click the Script button.

The script editor for the stack appears. The line at the top of the script e
(that is, the window’s title) identifies it as the stack script.

3. Type the following script:

on openCard
  put "Card" && the number of this card into background field 
"Label"
end openCard

In English, the script says, “When a card opens, put the word ‘card’ and
number of the card into the background field named Label.”

4. Press Enter.

5. Press x-B to return to the card layer.

To test your script, choose the Browse tool, then click the Next button sev
times. Each time you go to another card, you should see the word Card in
Label field followed by the number of the current card. 

❖ If something else happened:Check the script for spelling errors and mak
sure the openCard handler is in the stack script. Also make sure that th
Label field is in the background, and that its name matches the name 
used in your script.❖

How the script works
Just as HyperCard sends the system message mouseUp every time you click 
the mouse button, it sends the message openCard every time you go to a 
different card in the stack. When you open any card in the Collection stack
openCard message handler executes and puts the number of the current 
into the Label field. Because the openCard handler is in the script for the 
stack, it affects every card in the stack—not just a particular card. 
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The advantage of using a script to label cards is that you won’t have to w
about labeling the cards yourself, even if you add or delete cards. HyperC
will take care of it for you. 

❖ Dealing with long statements:The script editor doesn’t wrap long lines 
(although it does let you scroll to see text that extends beyond the wind
In order to fit a long statement into the script editor window, you must 
manually break the statement into more than one line. You do this by 
pressing Option-Return at the end of a line. This inserts a “soft” return
character (¬ ) into your script. Although the statement appears on more
one line, HyperCard treats it as a single statement. Ordinarily, a HyperC
statement must be on a single line ending with a carriage return.❖

Creating a pop-up field
Now it’s time to give yourself a pat on the back; you’ll create a field that 
displays the credits for your stack. You’ll also create a button that makes 
field appear, and you’ll write a script that makes the field disappear when 
click it.

Creating the Credits field
You can start from any card in the Collection stack. Create the field by 
following these steps:

1. Press x-B to work in the background.

2. Create a new field.

Use any method you want. Make the field about two inches long and a
inch high. It’s okay if the field covers other fields or buttons.

3. Double-click the field to see its Info dialog box.

4. Name the field “Credits.”

5. Click Shared Text.

As you learned in Chapter 2, background fields with shared text contain
same text on every card. 
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6. Set the field’s style to Shadow.

7. Choose a text style for the field (or use the default text style, 12-point Geneva Plain).

8. Click OK. 

Now you’ll type your message into the field. Because it’s a backgroun
field with shared text, the message you type will appear on every card
the stack.

9. Choose the Browse tool.

10. Click inside the Credits field to set the insertion point; then type the credits for your stack.

Creating an About button 
Next you’ll create a button that makes the Credits field appear. Make sure
you’re still working in the background, and follow these steps:

1. Choose the Button tool and create a new button about half an inch square. 

Drag the button to any available space in the background. 

2. Name the button “About.”

3. Select Auto Hilite. 

4. Select a cartoon balloon icon from the Icon dialog box. 

A cartoon balloon icon identifies an “About this stack” button. 

5. Click OK.

6. Size the button around the balloon icon.

Credit field
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Now you’ll write the script for the About button:

1. x-Option-click the About button.

The script editor appears. 

2. Type show bg field "Credits" .

The completed script should look like this:

on mouseUp
  show bg field "Credits"
end mouseUp

The letters bg are an abbreviation for the word background .

3. Press Enter.

You must use card or cd in front of field to specify a card field. If you 
leave out card,  HyperCard assumes you mean a background field. 
Conversely, you must use background, bkgnd , or bg in front of button to 
specify a background button. Otherwise, HyperCard assumes you mean a
button. To avoid confusion, it’s a good idea to always use card or 
background (or a suitable abbreviation) when referring to fields and butto

Writing a script for the Credits field
Next you’ll write a script that makes the Credits field disappear when you
click it.

1. Choose the Field tool and double-click the Credits field to see its Info dialog box.

2. Click Script.

The script editor for the Credits field appears.

3. Type the following script:

on mouseDown
  hide me
end mouseDown

mouseDown is a system message that’s sent as soon as the mouse bu
is pressed.

The HyperTalk word me refers to the object in whose script the word 
appears. In this case, me refers to the Credits field.
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4. Press Enter.

Trying out the scripts
Now see how the About button and Credits field work:

1. Press x-B to return to the card layer.

2. Choose the Browse tool and click the Credits field.

The field disappears.

3. Click the About button.

The Credits field reappears.

❖ If something else happened:Make sure the script for the About button is
spelled correctly. Also make sure that the name of the Credits field is 
spelled correctly. If the Credits field still won’t appear when it’s suppos
to, open the Message box and type show last bg field.  The last 
background field that you created—the Credits field—appears. Then ch
the spelling of Credits in the Field Info dialog box.❖

4. Click the Credits field to make it disappear.

How the scripts work
When you click the About button, the mouseUp handler in the button’s script 
executes. The statement show bg field "Credits" makes the Credits 
field visible. 

When you press the mouse button down on the Credits field, the mouseDown  
handler in the field’s script executes. The statement hide me makes the 
Credits field disappear. 

You can send messages to a field by clicking it, only if the field is locked o
a background field with shared text. Otherwise, clicking the field merely pla
the insertion point inside the field.
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You can use the hide command to make certain elements invisible, includin
a field, a button, a window (such as the Message box), the menu bar, the
bar, the background picture (graphics in the background), or the card pict
(graphics on the card that aren’t in the background). The show command does 
just the opposite; you use show to reveal hidden elements.

Variables
A variable is a named invisible container that can have any value you cho
to put into it. You can never see a variable; but you can know, set, and ch
its contents. In this section, you’ll create a button that uses a variable in 
its script. 

Creating a Sort button
In this exercise, you’ll create a button that sorts all the cards in your stack
alphabetically. When a user clicks the Sort button, a dialog box will appear
asks the question “Sort by what?” and presents three possible replies: Cate
Title, or Artist. When the user chooses, HyperCard will sort the cards in th
stack according to the contents of the chosen field.

Follow these steps to create the Sort button:

1. Press x-B to work in the background.

2. Choose New Button from the Objects menu.

A new button appears. When you choose the New Button command, 
automatically switch to the Button tool, and the new button is automatica
selected.

3. Drag the button to any available space in the background.

4. Name the button “Sort.”

5. Select Auto Hilite. 

The Show Name option is already checked. You’ll show the name of t
button rather than assign an icon to it.

6. Click Script to see the script editor.
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7. Type the following script:

on mouseUp
  answer "Sort by what?" with "Category" or "Title" or 
"Artist"
  put It into sortReply
  sort by background field sortReply
end mouseUp

8. Press Enter.

Now try the Sort button to see how it works:

1. Press x-B to return to the card layer.

2. Choose the Browse tool and click the Sort button.

A dialog box appears: 

3. Click Artist.

HyperCard reorders the cards in the stack alphabetically according to
contents of the Artist field. Browse through your stack with the arrow 
buttons to see that the names of the artists are in alphabetical order. 

If you would rather sort your cards by category or title, you can use the S
button to do that, too. 

How the script works
The answer  command asks the user of your stack a question, and present
to three possible replies in the form of buttons in a dialog box. In this case
asks the question Sort by what? and presents three possible replies: 
Category, Title, and Artist.  The answer command always highlights 
the last reply, so it’s a good idea to list the safest or “most correct” answer 
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When someone clicks a reply in the dialog box, that reply is put into a spe
HyperTalk variable named it . For example, when you click Artist, the 
value Artist is put into it .

The next statement in the script, put it  into sortReply , puts the contents 
of it  into another variable, which you’ve named sortReply . The names of 
variables can be almost anything you choose, but it’s a good idea to name 
something that describes what’s contained in them.

If you clicked Artist , the variable sortReply would then contain the value 

Artist . Therefore, the statement

sort by background field sortReply

is evaluated as

sort by background field Artist

and HyperCard sorts all the cards in your stack according to the contents o
Artist field. 

❖ Local versus global:The variables discussed here are local variables; that 
is, they and their values exist only within the handler in which they’re 
created. As soon as the handler ends, they go out of existence. Hyper
also has global variables, whose values are available to all handlers 
everywhere. You declare a variable to be a global variable by using th
global keyword. For more information about global variables and the
global keyword, see the HyperTalk Reference stack or the HyperCard 
Script Language Guide. ❖

Putting comments into the handler
The following version of the handler for the Sort button shows comments 
describe the action of the handler’s statements. Comments are text lines typed 
into a script that are not part of the instructions. In HyperTalk, a comment m
be preceded by two hyphens (--); the double hyphens indicate to HyperC
that the text following is a comment and should be ignored.
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You don’t have to type these comments into your script; they are shown o
as an example.

-- This button sorts the stack according to a field chosen 
by the user
on mouseUp
  answer "Sort by what?" with "Category" or "Title" or 
"Artist" 
  -- The user's response is now in the variable it
  put it into sortReply   -- Response is now in sortReply
  sort by background field sortReply  -- Sorts the stack
end mouseUp

As you see, comments can appear either at the beginning of a line or follow
a statement.

Although HyperCard ignores comments, other people writing scripts gener
appreciate them. Adding comments to your scripts is an excellent way to 
document what they do. Comments not only help other scripters understa
what you’ve done, but also help you remember when you look at old scrip
long after you wrote them. 

Scripts That Make Decisions
In this section, you’ll learn how to control which statements are executed 
handler, as well as the order in which they’re executed. You’ll create som
buttons for your Collection stack and write scripts that use the HyperTalk 
words if and repeat . 

If structures
In English, we use the word “if” to talk about an action that depends on a 
certain condition. For example, we might say “If I’m hungry, then I’ll eat 
dinner.” If the condition “I’m hungry” is true, then the action “I’ll eat dinner
will be performed.

In HyperTalk, the word if is used in much the same way. if and then are 
HyperTalk keywords that work together in arrangements called if structures. 
You use if structures to test conditions and to specify different actions, 
depending on the results. 
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There are several varieties of if structures; the most basic version is

if condition  then
  action
end if

The placeholder condition  stands for the thing being tested. It’s an 
expression that HyperCard can evaluate as either true or false. The placeh
action stands for the instruction lines that follow if the condition is true. Th
last line, end if , signals the end of the structure. 

Here’s how the English example would look if it could be written in 
HyperTalk:

if I’m hungry then
  I'll eat dinner
end if

In English, the word “then” is often implied; in HyperTalk, you must alway
include it.

Creating a Quit button
In this exercise, you’ll create a button that uses an if structure in its script. 
When a user clicks the button, a dialog box will appear asking the user whe
he or she wants to quit HyperCard. The dialog box will display two option
OK and Cancel. If the user clicks OK, he or she quits HyperCard. If the us
clicks Cancel, the dialog box disappears and nothing else happens.

Follow these steps to create the Quit button:

1. Press x-B to work in the background.

2. Choose New Button from the Objects menu and move the new button to any available space 
in the background.

3. Name the button “Quit.”

4. Select Auto Hilite.

5. Click Script to see the script editor.
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6. Type the following script:

on mouseUp
  answer "Quit HyperCard?" with "OK" or "Cancel"
  if it is "OK" then
    doMenu "Quit HyperCard"
  end if
end mouseUp

The contents of the if structure are automatically indented. The 
statements beginning with if and end if should always line up. If they 
don’t line up, you may have misspelled a word or left something out. 

7. Press Enter.

Trying out the Quit button
Now try the Quit button to see how it works:

1. Press x-B to return to the card layer.

2. Choose the Browse tool and click the Quit button.

This dialog box appears: 

3. Click Cancel.

The text string Cancel is put into the variable it . 

Because the condition it is "OK" is not true, HyperCard doesn’t execute
the action specified within the if structure. The dialog box disappears, 
and nothing else happens. Now you have to test what happens if the 
condition is true.

4. Click the Quit button again.

The dialog box appears again.
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5. Click OK.

The text string OK goes into the variable it . 

The condition it is "OK" is true, so HyperCard executes the stateme
within the if structure––and you quit HyperCard. 

You use the doMenu command to execute any of the HyperCard menu 
commands from within a script. In this case, it executed the Quit HyperCa
command. (Be sure to put quotes around the name of the menu command
you use doMenu .) 

To continue with this chapter, you must start up HyperCard again and retu
the Collection stack. 

Adding an action
An if structure can specify not only an action to be taken when a conditio
true, but also an alternative action to be taken when the condition is false
if structure of this type has the general form

if condition then
  action
else
  anotherAction
end if

The placeholder anotherAction  stands for an alternative instruction line or 
lines. An example in English might be something like this: “If I’m hungry, the
I’ll eat dinner; otherwise [else] I’ll go to the movies.” Here’s how it would loo
if it could be written in HyperTalk:

if I'm hungry then
  I'll eat dinner
else
  I'll go to the movies
end if
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Modifying the Quit button’s script
In this exercise, you’ll add two statements to the script for the Quit button
You’ll add an else statement and a statement that specifies an alternativ
action for when a user clicks Cancel.

1. Open the script for the Quit button.

2. Click before end if to position the insertion point at the beginning of the next-to-last line.

3. Type the following lines (pressing Return after each line):

else
answer "Glad you reconsidered." with "No problem"

The lines automatically indent. When you press Return for the final tim 

end mouseUp should line up at the left-most margin. 

Here’s the completed script (the two new statements are shown in 
boldface type):

on mouseUp
  answer "Quit HyperCard?" with "OK" or "Cancel"
  if it is "OK" then
    doMenu "Quit HyperCard"
  else
    answer "Glad you reconsidered" with "No problem"
  end if
end mouseUp

4. Press Enter.

5. Try the Quit button.

When you click the Quit button with the Browse tool, you get the dialo
box just as before. Clicking Cancel (the choice represented by else ) 
makes another dialog box appear with a friendly comment and reply 
button—just for fun. (No further instructions are specified for the “No 
problem” button.)
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Decisions within decisions
It’s possible to specify more than two separate actions by nesting if structures 
inside other if structures. Here’s how an English example might look if it 
could be written in HyperTalk:

if I'm hungry then
  if there's some food in the house then
    I'll cook
  else
    I'll order a pizza
else
  if there's a good movie at the theater then
    I'll go to the movies
  else
    I'll watch television
end if

You can experiment with this option on your own, after you finish this chap

Repeat structures
The repeat keyword tells HyperCard to perform a command or series of 
commands over and over again. Suppose you wanted to create a sequen
which your stack moved through a series of five cards, with a one-second p
between cards. You could write the instructions this way:

wait 1 second
go to next card
wait 1 second
go to next card
wait 1 second
go to next card
wait 1 second
go to next card
wait 1 second
go to next card

Or you could write a repeat  structure, like this:

repeat 5 times
  wait 1 second
  go to next card
end repeat
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A repeat structure makes HyperCard go around in a “loop,” repeating ste
until a particular endpoint occurs. Being able to use repeat structures saves 
you from having to retype statements. 

A repeat structure comes in several varieties. The first line of a repeat 

structure can have any of these general forms: 

repeat [for] number [times]
repeat with variable = startingValue to endingValue
repeat with variable = startingValue down to endingValue
repeat until condition
repeat while condition
repeat [forever]

The statement or list of statements that you want to have repeated can fo
any of these first lines. You must include end repeat to indicate the end of 
the list. 

In this section, you’ll create a button that uses a repeat structure to generate 
an index of your stack. Each index entry will include the name of the record
artist and the title of the record.

Later in this chapter, you’ll write a script that lets you go to a card by simp
clicking an index entry. 

Entries field
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Creating the Index card
First you need to add a new card to your stack. Make sure you’re looking a
Collection stack, and follow these steps:

1. Choose New Card from the Edit menu (or press x-N).

 A new card appears.

2. Choose Card Info from the Objects menu.

The Card Info dialog box appears: 

3. Name the card “Index.”

4. Click OK.

Creating the Entries field
Now you’ll add a field to the Index card to display the list of index entries.
Make sure you aren’t in the background, and follow these steps:

1. Choose the Field tool.

2. x-drag to create a large field (like the scrolling field in the figure).

Make the field large enough to include the Category, Artist, Title, and 
Notes fields.

3. Double-click the field to see its Info dialog box.

Notice that the field is a card field, not a background field. The field 
appears only on this card.
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4. Name the field “Entries.”

5. Set the field’s style to Scrolling. 

6. Click OK.

Creating the Index button 
Now you’ll create the button that automatically generates the index. 

1. Press x-B to work in the background. 

You want the Index button to appear on every card in your stack, so m
sure you see stripes in the menu bar. 

2. Choose New Button from the Objects menu and move the new button to any available space 
in the background.

3. Name the button “Index.” 

4. Select Auto Hilite.

Writing a script that goes through all the cards
You’ll write the script for the Index button in several stages. First you’ll use 

repeat structure to go through all the cards in the Collection stack. 

Follow these steps:

1. Click Script in the Index button’s Info dialog box. 

The script editor for the Index button appears. 

2. Type the following script:

on mouseUp
  repeat with countVar = 1 to the number of cards
    go to card countVar
  end repeat
end mouseUp

The contents of a repeat structure are automatically indented. The 

repeat and end repeat statements should always line up.
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3. Press Enter.

4. Return to the card layer and click the Index button with the Browse tool to test it.

HyperCard goes to the first card in the stack, then to the second, then t
third, and so on—until it reaches the last card in the stack. 

How the script works
The handler uses a repeat structure to go through all the cards in the stack
The repeat statement uses the repeat with form, which has this syntax:

repeat with variable  = startingNumber  to endingNumber

In this case, you’ve named the variable countVar . The starting number is 1 
and the ending number is the number of cards in the stack. 

The first time through the loop, countVar equals 1. Therefore, HyperCard 
evaluates the statement

go to card countVar
as 

go to card 1

The next time through the loop, countVar equals 2, so HyperCard goes to 
card 2 of the stack. The process continues and HyperCard goes to card 3
4, and so on—until countVar  equals the number of cards in your stack. At th
point, the loop finishes and the handler moves on to the next statement, w
is end mouseUp .

Adding statements that generate the index
Now you’ll add statements to the script that put information into the index.
you go to each card, you’ll put the contents of the Artist and Title fields int
variable. Each time the handler goes to another card, it will put the entry f
that card after what is already in the variable. In this way, the variable will
accumulate all of the index entries. Finally, the handler will put the content
the variable into the Entries field.
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Follow these steps:

1. Open the script for the Index button.

2. Insert the statements shown in bold in the following script:

on mouseUp
  put empty into indexVar
  repeat with countVar = 1 to the number of cards
    go to card countVar
    put bg field "Artist" & " " & bg field "Title" & Return 
after indexVar
  end repeat
  go to card "Index"
  put indexVar into card field "Entries"
end mouseUp

Make sure everything is spelled correctly and that the statements are i
right order.

3. Press Enter.

4. Try out the Index button.

You go to the first card in the stack, then the second, and so on until y
reach the end of the stack. Then you go back to the Index card, where 
of recordings appears inside the Entries field. 

❖ If something else happened:Check your spelling and try the script again
Make sure that the names of the Index card and Entries field are spell
correctly and match the names you used in your script.❖

Each index entry consists of the contents of the Artist field, followed by sev
spaces and the contents of the Title field. 

Because you put a Return character at the end of each entry, all the entri
begin on new lines. Some entries may take up more than one line. Entries
up more than one line if they are long and wrap onto a second line or if yo
entered Return characters when you entered text into the Artist and Title fi
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Some aesthetic and efficiency touches
The index includes an entry for every card in your stack––including the In
card itself. Because the Index card has nothing in its Artist and Title fields,
entry for the Index card is a blank line. If you have any blank cards in you
Collection stack, they also appear as blank lines in the index.

Now you’ll add an if structure to the script that checks each card to see i
something has been typed into the Artist field. If the Artist field is blank, th
index won’t include that card.

You’ll also add a lock screen command at the beginning of the handler to
freeze the screen while HyperCard goes from card to card “behind the sce
This will be less distracting than having to watch all those cards flashing b
and it will take considerably less time to generate the index.

Follow these steps:

1. Open the script for the Index button.

2. Type the statements shown in bold in the following script:

on mouseUp
  lock screen
  put empty into indexVar
  repeat with countVar = 1 to the number of cards
    go to card countVar
    if bg field "Artist" is not empty then
      put bg field "Artist" & "   " & bg field "Title" & 
Return after indexVar
    end if
  end repeat
  go to card "Index"
  put indexVar into card field "Entries"
  unlock screen
end mouseUp

The put statement should indent and the if statement should line up with
the end if statement. 

3. Press Enter.
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4. Try the Index button.

After a pause, the Index card appears with the list of recordings in the
Entries field. The list should contain only cards for which you typed 
something into the Artist field.

As you probably guessed, the lock screen command locks the screen. When
you lock the screen, the screen image won’t change until either an unlock 

screen command is executed or all handlers have finished executing. Bec
HyperCard doesn’t have to redraw the screen every time the script goes 
another card in your stack, it can compile the index more quickly.

Adding a keyboard shortcut
Every time you click the Index button, HyperCard recompiles the index fo
your stack. This process can be time-consuming, especially if your stack 
contains many cards. Now you’ll modify the Index button’s script so that b
holding down the Option key as you click the button, you go directly to the
Index card, without compiling the index.

Follow these steps:

1. Open the script for the Index button and insert the statements shown in bold in the 
following script:

on mouseUp
  if the optionKey is down then
    go to card "Index"
  else
    lock screen
    put empty into indexVar
    repeat with countVar = 1 to the number of cards
      go to card countVar
      if bg field "Artist" is not empty then
        put bg field "Artist" & "    " & bg field "Title" & 
Return after indexVar
      end if
    end repeat
    go to card "Index"
    put indexVar into card field "Entries"
    unlock screen
  end if
end mouseUp
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2. Press Enter.

3. Go to any card other than the Index card.

4. Option-click the Index button with the Browse tool.

You go directly to the Index card without recompiling the index. 

When you click the Index button, HyperCard tests the condition the 

optionKey is down . If you are simultaneously pressing the Option key, yo
go directly to the Index card. Otherwise, HyperCard compiles the index.

Setting properties
The properties of a HyperCard object are characteristics of the object that y
can set. For example, every button has a name property that specifies the name
of the button, a hilite property that specifies whether the button is 
highlighted, a location property that specifies where the button appears 
the screen, and so on. 

The characteristics of the overall HyperCard environment are called global 
properties. For example, the userLevel is a global property that determines
the current user level. 

Usually, you set properties by choosing options in the object’s Info dialog b
or on the User Preferences card of the Home stack. You can also set prop
by using the set command. 

The syntax of the set  command is

set [the] property  [of object ] to expression

The placeholder property is a HyperCard property. (A complete list of 
properties appears in the HyperCard Script Language Guide.) What the 
expression  is depends on the property. 
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Here are some examples of the set command with comments describing wha
each command does:

set the hilite of bg button "Quit" to true -— highlights the 
"Quit" button
set the textFont of bg button "Quit" to "Times" -— changes 
font to "Times"
set the userLevel to 5 -— sets user level to scripting
set the cursor to "watch" -— changes the cursor to a 

wristwatch

Now you’ll add a set command to the script for the Index button.

Changing the cursor
When someone clicks the Index button, there’s a momentary delay while 
HyperCard compiles the index for the stack. In this section, you’ll write a 
command that displays the busy cursor or “spinning beach ball” while the
index is being generated. By displaying the busy cursor, you let the user of 
stack know that HyperCard is still working even though the screen isn’t 
changing. 

Follow these steps:

1. Open the script for the Index button.

2. Insert the statement shown in bold in the following script:

on mouseUp
  if the optionKey is down then
    go to card "Index"
  else
    lock screen
    put empty into indexVar
    repeat with countVar = 1 to the number of cards
      set the cursor to busy
      go to card countVar
      if bg field "Artist" is not empty then
        put bg field "Artist" & "    " & bg field "Title" & 
Return after indexVar
      end if
    end repeat
    go to card "Index"
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    put indexVar into card field "Entries"
    unlock screen
  end if
end mouseUp

3. Press Enter.

4. Click the Index button with the Browse tool. (Don’t hold down the Option key.)

The pointing finger (Browse tool) cursor changes to the busy cursor. T
cursor spins for a moment, the Index card appears, and the cursor cha
back to the Browse tool.

The global property cursor determines which cursor is displayed on the 
screen. As soon as all handlers have finished executing, the cursor chang
back to the cursor for the current tool—in this case, the Browse tool.

❖ How the beach ball spins:To make the busy cursor spin, the set the 

cursor to busy command must be inside a repeat  structure.❖

Using functions
HyperTalk contains both commands and functions. A command (such as go 

or put ) carries out an action, whereas a function returns a value of some sort.
For example, the time is a HyperCard function that returns the current tim
set in your computer. You can use names of functions in commands to ge
values without having to figure out how to write the formula as part of you
handler. 

❖ Creating your own functions:In addition to using the HyperTalk built-in 
functions, you can make up functions of your own. For instructions on h
to write your own functions, see the HyperTalk Reference stack or the
HyperCard Script Language Guide. ❖

Going from an index entry to a card
In this exercise, you’ll write a script for the Entries field. The script will use
HyperTalk function named the clickLine to determine which line a user has
clicked in the Entries field and, based on that information, find the appropr
card. You’ll write this script in stages to get a better idea of how it works. 
You’ll begin by writing a script that tells you which line of the Entries field ha
been clicked.
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Go to the Index card (if you’re not already there) and follow these steps:

1. Choose the Field tool.

2. Double-click the Entries field to see its Info dialog box.

3. Click the Lock Text and Don’t Search options to select them.

Selecting the Lock Text option locks the field so you can’t type in it. Wh
a field is locked, clicking the field with the Browse tool doesn’t place th
insertion point in the field; instead, it sends a mouseUp message to 
the field. 

Selecting Don’t Search tells HyperCard not to search this field when y
execute a find command. If you’re searching for a particular record, yo
would want to find the card for that record, not its index entry.

4. Click the Script button and type the following script for the Entries field:

on mouseUp
  put the clickLine
end mouseUp

5. Press Enter to close the script editor.

6. Try out the script by clicking any index entry with the Browse tool.

A description of the line you clicked appears in the Message box. For 
example, if you clicked the second line, the message would say:

line 2 of card field 1

❖ If something else happened:Check your spelling and try the script again
Also make sure that the Entries field is locked.❖

Because the Entries field is locked, clicking the field sends a mouseUp 

message to the field, causing the mouseUp handler in the field’s script to 
execute.

The function the clickLine returns a description of the line that you click
in a field. The statement put the clickLine puts that description into the 
Message box.
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The script now knows which line you clicked. But what does that line conta
You need a further modification to the script.

1. Open the script for the Entries field and insert the boldface words in the following script:

on mouseUp
  put the value of  the clickLine
end mouseUp

2. Press Enter to close the script editor.

3. Click an index entry with the Browse tool.

The contents of the line you clicked should appear in the Message bo

The function the value of returns the value of any expression. In this cas
it returns a text string consisting of the contents of the line you clicked—th
is, the index entry for that line.

Now that your handler knows which recording you’re interested in, the fin
step is to find the right card. You’ll use the HyperCard find command to 
do that.

1. Open the script for the Entries field, select put , and change it to find .

The completed script should look like this:

on mouseUp
  find  the value of the clickLine
end mouseUp

2. Try out the script by clicking an index entry with the Browse tool. 

If you went to the correct card, congratulations! You’re doing great. 

The find command tells HyperCard to search through the fields in the st
for a specific string of text. In this case, it searches for the index entry that
clicked. Because you selected the “Don’t Search” option for the Entries fie
it won’t search the Entries field.

❖ If something else happened:Check your spelling and try the script again
Make sure that the Lock Text and Don’t Search options are selected in
Entries field’s Info dialog box.❖
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Handling Messages
All the scripts you’ve written so far contain only one message handler; bu
scripts often contain more than one handler.

In this section, you’ll write new handlers and explore the way messages tr
between objects. And you’ll add another feature to your Collection stack—
button that plays sounds when you click it. 

How messages travel
HyperCard can send system messages to a button, a field, or the current
For example, if you click a button, HyperCard sends a mouseUp message to 
the button. If you click a locked field, HyperCard sends mouseUp to the field. 
If you click anywhere else on a card, HyperCard sends mouseUp directly to 
the card. 

A message can travel from one HyperCard object to another––until it is 
handled. For example, when someone clicks a button, a mouseUp message is 
sent to the button. If the button’s script doesn’t have a handler for mouseUp , 
the message is passed to the current card, then to the background, then 
stack, then to the Home stack, and finally to HyperCard itself. This sequen
called the message-passing order (and sometimes the message-passing

You can place handlers at different levels. Where you place a handler ha
effect on its availability. For example, when you wrote the handler to label
cards of the Collection stack, you placed it in the stack script; that placem
meant that the handler was available for every card in the stack. If you ha
placed the handler in the script for one of the cards, it would have been 
available only to that card; no other cards would have been labeled. 

Messages can come from the system; from your actions with the mouse, 
keyboard, or Message box; or even from handlers themselves. In this sec
you’ll see how messages move around in HyperCard. First you’ll make a 
button and write a message handler for the button’s script. Later you’ll mo
the handler to different levels in the message-passing order and observe 
difference in the handler’s action. 
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Creating a Sound button
In this exercise, you’ll create a button that plays sounds when you click it.
Follow these steps:

1. Press x-B to work in the background.

2. Choose New Button from the Objects menu and move the new button to any available space 
in the background.

3. Name the button “Sound.”

4. Select Auto Hilite.

5. Click Script. 

The script editor appears.

6. Type the following handler in the Sound button’s script:

on mouseUp
  play "boing"
end mouseUp

The play command lets you play sounds from within scripts. 

❖ Alternative for hearing-impaired people:If you can’t hear well, type this 
line in place of or in addition to the play statement to see the effect of 
handler:

flash 3

It makes the entire screen image flash rapidly three times when the bu
is clicked. The white parts of the card switch to black and the black part
white; then they change back again.❖

7. Press Enter.

8. Press x-B to return to the card layer.

9. Click the Sound button with the Browse tool.

You hear a “boing” sound. 
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❖ If something else happened:Check the script’s spelling and make sure 
you’ve included quotation marks in the right places. If the script is corre
make sure you have the Speaker Volume in the Control Panel set to a v
greater than zero.❖

When you click the button, a mouseUp message is sent to the button. This 
makes the mouseUp handler execute, and you hear the “boing.”

Moving the handler to the card level
Where you place a handler in HyperCard affects its action. A handler at the
level (namely, in a button script or a field script) can respond only to a mess
received by that button or field. The same handler further down in the 
message-passing order—that is, at the card, background, or stack level—
respond to a message sent by any objects higher up, unless those object
intercept the message with their own handlers. 

What the message-passing order means to you is that you can control wh
your handlers act locally—only for a particular button, for example—or mo
globally, for an entire card, background, or stack.

In this exercise, you’ll move the mouseUp handler of the Sound button to a 
different level in the message-passing order to experience the change in 
response. First notice that the handler works only if you click the Sound but
If you click anywhere else on the card, you won’t hear anything. 

The next step is to move the handler to the script for one particular card. Yo
cut the mouseUp handler from the Sound button’s script and paste it into th
script for the Index card that you created earlier. Follow these steps:

1. Go to the Index card of the Command stack.

2. x-Option-click the Sound button with the Browse tool.

You see the script for the Sound button.

3. Drag the mouse across the entire mouseUp handler to select it (or press x-A).

4. Choose Cut from the Edit menu to cut the handler and place it on the Clipboard.

The script editor should now have nothing in it. If you still see the hand
there, try steps 2 and 3 again. 
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❖ Empty scripts:Every object has a script, even if there’s nothing in it. 
Scripts with nothing in them are called empty scripts.❖

5. Press Enter to close the now-empty script for the Sound button.

Now you’ll open the script for the Index card.

6. Choose Card Info from the Objects menu.

The Card Info dialog box appears.

7. Click Script.

The script for the Index card appears. 

8. Choose Paste from the Edit menu to paste the handler into the script for the Index card.

The mouseUp handler appears in the script for the Index card.

9. Press Enter to close the script for the Index card.

Trying out the card script
Now test the effects of moving the handler to the card level:

1. Click the Sound button with the Browse tool.

The boing plays just as it did before. The mouseUp message passes through
the empty button script and goes on to the card script.

❖ A partial script is visible:“Empty” button scripts still show on mouseUp 

and end mouseUp lines. HyperCard supplies these to make it easier to wr
scripts in buttons; but if there’s nothing else in the script besides these
lines, the script is treated as if it were empty.❖

2. Click anywhere else on the card (except on a button or field).

The boing plays because whenever you click the card, mouseUp goes 
directly to the card which now contains the handler for mouseUp in 
its script.
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3. Click an entry in the index.

You go to the card for the entry you clicked, as usual—and you don’t h
the “boing.” The reason you don’t hear the boing when you click the 
Entries field is that the field has a mouseUp handler in its script. The 
mouseUp message is intercepted by the field script, so the mouseUp 

handler in the card script doesn’t execute. 

Now that you are on a card other than the Index card, notice what hap
when you click the card.

4. Click anywhere on the card (except on a button or field with a mouseUp handler).

Nothing happens because there’s no mouseUp handler in this card’s script

Moving the handler to the background level
Now you’ll take the handler out of the card script and move it to the 
background script: 

1. Go to the Index card.

2. Choose Card Info from the Objects menu.

The Card Info dialog box appears.

3. Click Script to see the script editor.

The script for the Index card appears.

❖ Keyboard shortcut: You can press x-Option-C to see the script editor of
the current card without having to go through the card’s Info dialog box❖

4. Drag the mouse across the entire handler to select it (or press x-A).

5. Choose Cut from the Edit menu to cut the script and place it on the Clipboard.

The card script should now be empty. 

6. Press Enter to close the card script.

7. Choose Bkgnd Info from the Objects menu.

The Background Info dialog box appears.
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8. Click Script.

The script for the current background appears.

❖ Keyboard shortcut:You can press x-Option-B to see the script for the 
current background without going through the background’s Info box.❖

9. Choose Paste from the Edit menu to paste the handler into the background script.

10. Press Enter to close the background script.

Trying out the background script
Now test the effects of moving the handler to the background level: 

1. Click the Sound button with the Browse tool.

You hear the boing. The mouseUp message passes through the empty 
button script and empty card script to the background script, which no
contains the handler.

2. Click anywhere else on the card (except on a button or field with a mouseUp handler).

The mouseUp message passes to the background script, and the 
boing plays.

3. Go to any other card in the stack and click anywhere on the card (except on a button or field 
with a mouseUp handler).

You should still hear the boing. The handler is now available to any ca
sharing the background.

If you moved the handler to the stack level, the same thing would happen
because the Collection stack has only one background; but if a stack has 
than one background, only a handler at the stack level or above (for exam
in the stack script of the Home stack) would be available to all cards of al
backgrounds. 
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Handlers calling handlers
All the handlers you’ve written so far respond to system messages sent b
HyperCard (such as mouseUp and openCard ). HyperCard sends system 
messages in response to events such as mouse clicks, keyboard actions, a
creation or deletion of objects. But there are other ways for handlers to “g
the message.” 

Each time HyperCard executes a statement within a handler, it sends tha
statement as a message. A message sent from one handler can make an
handler execute. It’s as though the handlers are talking to each other—with
handler telling the other to begin executing. 

In this exercise, you’ll write a handler that “calls” another handler. First you
write a handler that sends a message, then you’ll write a handler that resp
to that message. 

Writing the “calling” handler
You’ll write a script for the Sound button so that a message named playSound 

is sent whenever someone clicks the button. Later you’ll change the mouseUp 

handler in the background script so that it responds to the playSound message. 
Follow these steps:

1. Open the script for the Sound button.

2. Type playSound .

The completed script should look like this:

on mouseUp
  playSound
end mouseUp

In English, the script says, “When someone clicks this button, send a 
message named playSound. ”

The message name playSound is just a made-up word. You could use an
other word (except a HyperTalk keyword); this name seems appropria
because it describes the action of the handler. 
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❖ Alternative for hearing-impaired people:If you are using the flash 3 

alternative instead of the boing, you could use a different name, such 
razzleDazzle (but don’t use flash ). Be sure, however, that you use you
alternative name in the steps that follow.❖

3. Press Enter.

4. Click the Sound button with the Browse tool.

You see a “Can’t understand” dialog box. HyperCard can’t understand
playSound message because it can’t find a playSound handler anywhere. 
In other words, there is no handler that begins with the statement on 

playSound . 

5. Click Cancel to close the “Can’t understand” dialog box.

❖ About the Debug button:Clicking the Debug button opens the script edito
window and puts a box around the statement HyperCard can’t underst
It also adds a new menu, named the Debugger menu, which is somet
helpful in figuring out where mistakes or “bugs” are in a script.❖

Writing the “called” handler
Now you’ll create a handler that responds to the playSound message that’s 
sent when someone clicks the Sound button. You could write a handler fr
scratch, but in this case, you’ll simply change the mouseUp handler in the 
background script to a playSound handler.

1. Choose Bkgnd Info from the Objects menu.

2. Click the Script button.

The script for the background appears.

3. Select mouseUp in the first line of the handler.

Drag across the word as you would when selecting any text, or just 
double-click the word.

4. Replace it by typing playSound .
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5. Select mouseUp in the last line of the handler and replace it by typing playSound .

The completed handler looks like this:

on playSound
  play "boing"
end playSound

The name used after on must match the name after end .

You’ve now changed the handler from a mouseUp handler to a playSound 

handler. It now responds to the message playSound instead of the 
message mouseUp . 

6. Press Enter.

You’ve created a handler that sends a message named playSound , as well 
as a handler that responds to playSound . Now see how the two handlers
work together.

7. Click the Sound button with the Browse tool.

When the Sound button receives mouseUp , its handler in turn sends the 
message playSound . That message goes through the message-passin
order until it’s intercepted by the playSound handler in the background 
script. The playSound handler executes, and you hear the boing. 

First, HyperCard sends a mouseUp message to the Sound button.Then, the 
Sound button sends a playSound message. Finally, the playSound message 
is handled by the background script.

Clicking anywhere else on the card won’t cause the sound to play, becaus
background handler isn’t a mouseUp handler any more.

You’ve essentially defined a new command, which is named playSound.  The 
playSound command plays a “boing.” That’s really all there is to defining 
your own commands. Think of what you want a command to do, think of a
name for it, and write a handler that uses the name after on and end , with the 
appropriate HyperTalk statements in between. To make the command wo
send the command’s name as a message to the object that has the hand
its script. 
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❖ Use unique names.Avoid using the name of an existing HyperTalk 
command or function as the name of a command you create. (See the
HyperCard Script Language Guide for details on naming commands.)❖

Intercepting a message
When HyperCard sends a statement within a handler as a message, the m
goes first to the object that contains the handler being executed. (For exam
when the Sound button sends a playSound message, the message first goes 
the button itself.) If the object’s script doesn’t have a handler for the mess
the message travels next to the current card. If the script for the current c
doesn’t have an appropriate handler, the message continues through the
message-passing order.

Once a message is handled, it does not continue passing through the 
message-passing order. Therefore, it’s possible for an object at the start o
message-passing order to intercept a message before the message can t
objects at the end.

In this section, you’ll write a playSound handler for the script of the Index 
card. This card-level handler will make the Sound button play a different so
when you’re on the Index card.

Follow these steps to write the script:

1. Go to the Index card.

2. Choose Card Info from the Objects menu; then click the Script button to see the card’s script 
(or press x-Option-C).

3. Type the following handler:

on playSound
  play "harpsichord" "c" 
end playSound

This handler plays one note using the harpsichord sound. 

4. Press Enter.
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In this 
5. Click the Sound button with the Browse tool.

The playSound handler in the card script executes, and you hear the 
harpsichord note.

6. Go to any other card in the stack and click the Sound button.

The playSound handler in the background script executes, and you he
the boing. 

How the handlers work
When you click the Sound button, the button’s mouseUp handler sends a 
playSound message. Because there is no playSound handler in the button’s 
script, the message passes to the script for the current card.

When the Index card is the current card, the playSound handler in the card 
script handles the playSound message. The card script intercepts the messa
before it can pass to the background script.

First, HyperCard sends a mouseUp message to the Sound button.Then the 
Sound button sends a playSound message. Finally, the playSound message 
is handled by the Index card’s script. (The playSound message does not pass
to the background.)

When the Index card is not the current card and there is no playSound handler 
in the script for the current card, the playSound message continues passing
from object to object in the message-passing order until it gets to the 

playSound handler in the background script.

By writing a different playSound handler for the script of each card, you ca
play a different sound on each card in your Collection stack. 

Calling handlers from the Message box
Whenever you type something into the Message box and press Enter, the
contents of the Message box are sent as a message to the current card. 
section, you’ll use the Message box to call the playSound handler. Follow 
these steps:
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1. Open the Message box.

2. Type playSound and press Return.

A playSound message is sent from the Message box to the current ca
If you’re still on the Index card, the message is handled by the playSound 

handler in the card script, and you hear the harpsichord note. If you’re
another card, the playSound message travels to the background script, a
you hear the boing.

You can use the Message box this way when you want to test how a parti
handler works. All you do is type the name of the handler and press Retu

Handlers as building blocks
Getting things done in HyperTalk is no different from getting things done 
everyday life. When you want to perform a complex procedure, you can div
the procedure into smaller, more easily manageable parts. These smaller
of a complex procedure are called subprocedures. 

For example, suppose you want to cook spaghetti with meat sauce. You m
divide the main procedure, “cook spaghetti,” into three subprocedures: “c
pasta,” “cook sauce,” and “add sauce to pasta.” If you could describe the 
procedure of making spaghetti as a HyperTalk script, it would look someth
like this:

on makeSpaghetti
  cookPasta
  cookSauce
  addSauceToPasta
end makeSpaghetti

The handler for the main procedure (makeSpaghetti ) calls handlers for three 
subprocedures (cookPasta , cookSauce , and addSauceToPasta ). 

HyperCard handlers can be used as subprocedures in much the same wa
Understanding how handlers can call other handlers will be a big help to 
as you learn to write longer, more complex scripts.
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You’re on your way!
If you completed all the activities in this chapter as well as in Chapter 2, y
have a great start on authoring stacks. To learn more, do more!

Look again at the stacks that come with HyperCard, especially Readyma
Buttons. See what you can learn by observing how the scripts work and h
you might modify the scripts to suit your own way of doing things.

Most of all, enjoy the creative environment that HyperCard provides. 
Experiment. Build your own stacks for your own purposes, learning more
about HyperCard and HyperTalk as you need to. 

When you need help, turn to the HyperCard Help and HyperTalk Referen
stacks, or use this manual as well as the HyperCard Script Language Guide. 
But your most valuable knowledge of stack-building is likely to come from
your own rich experience.
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Chapter 4
Creating and Modifying Stacks

This chapter provides examples of the kinds of stacks you can create, tip
modifying existing stacks, and instructions for creating new stacks. This 
chapter also describes how to customize the Home stack that comes with
HyperCard. 

To do the tasks in this chapter, you must have your user level set to Scrip
For instructions on setting your user level, see “User Levels and Options”
Chapter 1. 

Using HyperCard tools, you can combine text, graphics, and numbers 
according to your own specific needs; and you can add buttons to link rel
pieces of information. 
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The next several figures show some typical cards. These cards give you an
of the kinds of stacks you can build.    

You type a name, address, 
and phone number here.

You click these 
buttons to look for 
information, or to 
add or delete cards.

This button takes you to an 
appointment stack.

This button dials the phone 
number to its right.

This button takes you 
to the Home stack.
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The name of the 
catalog item

You type information about the 
catalog item here.

A picture of the 
catalog item

This button goes 
to the next card 
in the stack.

These buttons go to different 
broad plant categories.

This button goes to the 
previous card in the stack.

Click any part of 
the drawing to 
learn about that 
part.

This button goes 
to the first card 
in the stack.

This button goes to the next 
card in the stack.

This button goes to the 
previous card in the stack.
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The stacks that come with HyperCard are examples of the kinds of stacks
can create. You can explore these stacks to find out how they work, using
techniques described in “Examining a Stack” later in this chapter. 

You click these buttons to go to the different sections 
of this presentation stack.

You click these 
buttons to 
manipulate the 
mathematical 
function shown.
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The way a stack works depends on its scripts. Scripts contain instructions
tell the parts of the stack what to do. The instructions are written in HyperT
HyperCard’s English-like programming language.

But you don’t need to know HyperTalk to create scripts. For example, with
writing a word of HyperTalk, you can link a button to another card and mak
specific visual effect happen when you click the button. The button will cont
a script that tells HyperCard which card to go to and what kind of visual eff
to display in the process. You don’t have to know anything about how the sc
works to make the button act the way you want it to.         

To learn how HyperTalk scripts work, see Chapter 3 of this book or read 
through the HyperCard Script Language Guide. 

Card Layer Versus Background Layer           
When you look at a card, you see a composite of two layers—a foregroun
layer, called the card layer, and a background layer. Both layers can cont
text, buttons, and graphics. 

The background layer

What you see when you look at a 
card is a composite of the card layer 
and the background layer.

The card layer
Chapter 4: Creating and Modifying Stacks 4-5
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Millions of cards can share the same background. Each background serv
a template for the cards that share it. The elements in a background (that i
buttons, text, and graphics) appear in the same location on all the cards 
associated with that background. If you want a button, field, or graphic to 
appear on a number of cards, you put it in the background layer. Together
elements in a background provide a unifying appearance to the cards that 
that background. 

You can see just the elements that are in the current background by pres
x-B; this brings you to the background layer. (Pressing x-B has the same 
effect as choosing Background from the Edit menu.) Pressing x-B repeatedly 
moves you back and forth (that is, it toggles) between the card layer and 
background layer.           

When you’re in the
background layer,
the menu bar has
diagonal stripes.

When you’re in the background layer, you see just the 
elements that are in the background; the elements on the 
card layer disappear temporarily.
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The elements in the card layer appear only on that card: 

What buttons, fields, and graphics do for your stacks
The elements you add to the cards and backgrounds of a stack determine
people can do with the stack:

■ You can add buttons, “hot spots” you click to make things happen. Butt
often link related information. When you click a button that’s linked to 
another card or stack, that card or stack appears. The ability to link 
information with buttons creates all kinds of interesting possibilities, 
including stacks that teach, stacks of interactive fiction, and user-contro
presentations that can include QuickTime movies.     

Buttons can also play sounds, launch applications, perform calculation
play animated sequences, control videodisc players, and much more.

The other elements are in the background layer, 
and appear on all cards with that background.

This text, part of the card layer, changes from card to card.
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■ You can create text fields to put text on cards and backgrounds. You c
set the style, size, and font of the text in a field. You edit the text in a fi
just as you would in any Macintosh word-processing program. You ca
also search for specific text in fields.             

■ You can add pictures, charts, drawings, and other graphics to enhanc
visual appeal of a stack and to help communicate the stack’s purpose. D
them yourself, copy them from the stacks that come with HyperCard, s
them in, or import them from files created in other graphic applications.

HyperCard comes with stacks that contain ready-made elements (buttons
fields, and graphics) that you can copy and paste into your stacks. The 
ready-made buttons and fields contain pre-programmed scripts that can m
your stacks more useful. You don’t need to know HyperTalk to make thes
elements work; you just need to understand what they do, so that you can
them appropriately in your stacks.                  

You can combine buttons, fields, and graphics in any number of ways to cr
a stack that looks and works the way you want it to. Chapters 6, 7, and 8 
detailed instructions for adding buttons, fields, and graphics. 

A scanned graphic

Field text

Buttons for
moving 
around
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Using HyperCard Tools           
To create and work with buttons, text, and graphics in stacks, you use the 
in the Tools menu. You can have only one tool selected at a time, and one
is always selected while you’re using HyperCard.

The Tools menu appears when your user level is set to Painting or higher
contains General tools and Paint tools. General tools are for browsing, te
editing, and working with buttons and fields. Paint tools are for creating a
editing pictures. If you’ve used a Macintosh paint program, you know how
Paint tools work. In most cases, you choose a Paint tool, and then drag to 
it work. 

General tools

Paint tools
Chapter 4: Creating and Modifying Stacks 4-9
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Browse tool 
browses through 
stacks and edits 
text.

Button tool 
works with 
buttons.

Field tool works 
with fields.

Select tool 
selects graphics.

Brush paints with 
the current 
pattern.

Spray tool spritzes 
paint onto the 
screen in the 
current pattern.

Bucket fills 
enclosed areas and 
solid black areas 
with the current 
pattern.

Paint Text tool 
types text that’s 
part of a graphic.

Lasso selects 
non-rectangular
graphics.

Eraser erases 
the part of a 
graphic you 
drag it over.

Rectangle tool 
draws 
rectangles.

Oval tool
draws ovals
and circles.

Regular
Polygon tool
creates polygons
with regular 
sides.

Pencil draws thin 
free-form lines.

Line tool draws 
straight lines.

Rounded Rectangle 
tool draws 
rectangles with 
rounded corners.

Curve tool draws 
free-form lines 
and shapes.

Polygon tool
creates polygons
with irregular sides.
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You can “tear off” the Tools menu (as shown in the following figure) to crea
a movable Tools palette. To do so, drag down past the bottom of the menu.  

The Tools palette remains visible on your screen until you click its close b
or until you press Option-Tab to make the palette disappear.

❖ A shortcut: You can make the Tools palette appear or disappear quickly
pressing Option-Tab.❖

To choose any tool in the Tools palette, click it. The tool you choose will b
highlighted and, depending on the tool, the shape of the pointer may chan

Even if you have the Tools palette open, you can still choose a tool from 
Tools menu in the menu bar; the palette reflects your menu choice. It’s a g
idea to leave the Tools palette open while you’re working on a stack so you
see which tool is active.        

Close the Tools palette by 
clicking here.

To move the 
palette, drag 
from here.

To tear off the Tools menu, drag beyond 
the bottom or side of the menu.

Click any tool to 
choose it.
Chapter 4: Creating and Modifying Stacks 4-11
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When you choose one of the Paint tools, you see three new menus—Pai
Options, and Patterns. (These menus are described in Chapter 8.) The Ob
Font, and Style menus disappear while you’re using a Paint tool. They 
reappear—and the Paint, Options, and Patterns menus go away—when y
choose any of the General tools.         

Chapters 6, 7, and 8 give specific instructions for using HyperCard tools t
create buttons, fields, and graphics, respectively.      

Selecting buttons, fields, and graphics          
To select and work with the different HyperCard elements (that is, buttons
fields, and graphics), you need to use different tools.

These menus appear
when you have a

Paint tool selected.

Selected Paint tool
4-12 Chapter 4: Creating and Modifying Stacks
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To select a button, choose the Button tool ( ) from the Tools menu and c
the button you want to work with. Whether the button is in the background
layer or the card layer, you can select it from the card layer.

To select a field, choose the Field tool ( ) from the Tools menu and click
field you want to work with:           

Choose the 
Button Tool …

… and then click
the button to select it.

When a button is selected, 
it’s surrounded by a moving dashed line.

Choose the
Field tool … 

… and then click 
the field to select it.

When a field is selected, it’s surrounded by a 
moving dashed line.
Chapter 4: Creating and Modifying Stacks 4-13
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Whether the field is in the background layer or the card layer, you can sele
from the card layer. 

There are many different ways to select a graphic. Generally, you choose e
the Select tool ( ) or the Lasso ( ) from the Tools menu and drag to sel
the graphic:          

Working with graphics is different from working with buttons and fields; yo
must be on the same layer as a graphic to select it. (For complete details
“Selecting a Graphic” in Chapter 8.)

Planning a Stack         
Before you begin building a stack, you should have a clear idea of who will
the stack and what you want the stack to do. Knowing your audience and
scope of your stack can help you make decisions about the design of your s
both before you start and while you’re building it. 

Find out what your users already know, how much experience they have 
computers and HyperCard, and their reading level and attention span. 

…and then drag 
diagonally with the Select 
tool from here … Or, drag around the 

graphic with the Lasso.

Choose the Select tool
or the Lasso…

…to here.
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An understanding of the stack’s users can help you decide how to presen
information in the stack, how much text and how many graphics to use, a
how to structure the stack. For example, a stack for teaching children 
geography skills may require lots of pictures, a simple and consistent way
move through information, and frequent reinforcement. Before you begin 
building a stack, it’s a good idea to draw a map showing the structure of t
stack, which cards are linked together, and how users move through the s
If the map looks confusing, the resulting stack will probably be confusing a
difficult to use. In such a case, you should consider simplifying the stack’s
structure. 

Depending on your stack’s subject matter, you can choose from a variety
presentation methods including a slide show, a tutorial, a game, and an 
animated QuickTime movie.

❖ Keep your stack simple.Adding lots of buttons and links in your stack 
doesn’t necessarily make information more accessible; users can get lo
confused easily in a stack that has too many links.❖

Stack-Building Process
Building a stack involves: (1) deciding how to present and structure 
information; and (2) carrying out your design decisions by creating cards,
backgrounds, buttons, text fields, graphics, and links between related piec
information. You’ll probably spend most of your stack-building time 
integrating text and graphics, and making the stack easy to search.

Evaluating a stack
As you build a stack, you need to evaluate it frequently to make sure it still d
what you’ve designed it to do. To evaluate a stack, use it yourself to carry
a specific task or set of tasks. See if you can accomplish the tasks for whic
stack is designed without getting lost or feeling confused. 

If the stack is meant to be used by others, show it to people who are simil
your users in background and level of computer experience. Give them spe
tasks to perform, and watch and listen carefully without interfering while th
try the stack.
Chapter 4: Creating and Modifying Stacks 4-15
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As you evaluate the stack and watch others use it, keep the following ques
in mind:         
■ Can you easily see what the stack is for and how to use it? The text, but

and visual images in the stack should communicate a lot about the sta
purpose. They should be understandable and consistent in appearanc
behavior and should clarify the purpose of the stack. If the stack is 
confusing, think about ways in which the text, buttons, and visual imag
can be improved to create a clearer visual message. The stack should
give the user appropriate feedback. For example, most buttons should
highlight when they’re clicked.

■ Is it easy to get around in the stack? Make sure that, as you use the s
you can tell where you are, how you got there, how to get back where 
came from, where to go next, and how to leave. If it’s easy to get lost 
trapped in the stack, consider reducing the number of links, or simplify
or clarifying the navigation scheme (for example, by using a standard s
navigation buttons in the same place on each card). 

■ Do the features work correctly? Test the buttons to see if they take yo
where they’re supposed to in all circumstances. Make sure each field 
visible and unlocked if the user needs to see it and type into it, or locke
the user just needs to read or click text in the field. The stack should pre
the user from losing information and make it clear when an action can
be reversed. 

■ Does the stack require a particular user level? The features available 
user vary with the user level (as explained in “User Levels and Options
Chapter 1). Try using the stack at every user level. If it has any features
require a certain user level, make sure the stack either sets the appro
user level (through the stack script) or tells the user to set the appropr
user level. (The HyperTalk Reference stack describes how to set the u
level through a script.)

■ Is the stack aesthetically pleasing? Stacks that are well designed have
strong aesthetic appeal that makes them pleasant to work with. Becau
HyperCard presents you with so many graphic and textual options, the
always the danger of going too far. For example, having too many differ
styles of text can confuse your users and make your stack a lot harde
work with. While the flexibility of HyperCard gives you the power to 
create masterpieces, it also gives you the power to generate chaos.
4-16 Chapter 4: Creating and Modifying Stacks
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Be sure to get feedback
Periodic evaluation and feedback from typical users are important parts o
shaping a stack. Begin evaluating a stack early in its development. HyperC
makes it easy to build a prototype of your stack; use the prototype to gath
preliminary feedback from users. Be prepared to make changes to the sta
fix problems and incorporate ideas that come out of your evaluation and 
user testing. 

When you finish building a stack, put it through a final test, checking all of 
points listed previously in “Evaluating a Stack.” 

Modifying an Existing Stack      
Modifying stacks created by other people is a great way to learn about 
HyperCard, and it is a terrific method of tailoring stacks to your needs. Th
are lots of ways to customize an existing stack. You can add text and pict
and create new links between pieces of information, make new cards and
backgrounds, or change any of the elements of a stack in any way you like.
can even delete any elements you don’t want. 

Responsibilities of change
If you want to modify stacks created by other people, you should be awar
the following considerations: 

■ Each object in a stack (that is, each button, field, card, and background
well as the stack itself) can have a script attached to it. Scripts contain
instructions that tell the different objects in a stack what to do. The scr
that belong to the different objects in a stack often interact with other 
objects and their scripts. When you delete any object that contains a sc
or move it to another part of the stack, the script goes with it. If other scr
rely on that object or its script (or vice versa), you may find that your sta
behaves unexpectedly after you move the object. For example, you 
may see messages that begin with “Never heard of …” or “Can’t 
understand…”.          
Chapter 4: Creating and Modifying Stacks 4-17
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If you see such messages (or other strange behavior) in a stack you’r
modifying, the stack’s scripts probably refer to objects that you’ve chan
in some way. If you’re familiar with HyperTalk, try fixing or rewriting the
scripts. Otherwise, consider modifying a different stack or creating a st
of your own. (If you want to learn HyperTalk, begin by going through th
tutorial in Chapter 3 of this book.)

■ As you modify a stack, HyperCard saves your changes automatically 
without asking. There’s no way to turn this feature off. Make a backup co
of a stack before you begin changing it so that you can get back to the
original if you need to. It’s also a good idea to save a copy of your modif
stack periodically while you’re working on it. That way, if you make a 
mistake that “breaks” the stack, you can go back to a recent version ra
than starting all over again.           

■ Some stacks are protected from change. A small padlock ( ) appears i
menu bar when you’re in a protected stack. In some cases, you can rem
a stack’s protection by unchecking the Locked option in the stack’s Ge
Info dialog box in the Finder or by using the Protect Stack command in
File menu. (“Protecting Your Stack” later in this chapter tells you how.)
stacks that have a password, however, you cannot change the stack’s
protection setting unless you know that password.      

Examining a stack       
Before you begin modifying a stack, you can find out what makes it work 
examining its parts. The Objects menu contains commands to help you: Bu
Info, Field Info, Card Info, Bkgnd Info, and Stack Info. Each of these 
commands presents a dialog box that shows the characteristics of the se
object including its name, number, and attribute settings. You can also us
object’s dialog box to change many of its attributes and to look at its script. 

❖ To look at scripts:You must have your user level set to Scripting. 
“User Levels and Options” in Chapter 1 explains how to change your 
user level.❖ 
4-18 Chapter 4: Creating and Modifying Stacks
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Button information
To locate and learn about the buttons in a stack, follow these steps:         

1. Choose the Button tool ( ) from the Tools menu. 

Rectangles appear around the buttons that don’t already have an outl

2. Click the button you want information about.

Clicking the button selects it.

When you choose the 
Button Tool …

… rectangles appear 
around the buttons.
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3. Choose Button Info from the Objects menu.              

You can also double-click the button in step 2, and skip this step. The
Button Info dialog box appears: 

Click here to choose visual 
effects for the button.

Click here to link the
button to another

card or stack.

Family and Auto Hilite 
determine the button’s 
highlighting behavior. 

Unless Enabled is checked, 
the button will appear 
grayed out and won’t work.

Show Name determines 
whether the button’s 
name appears on the card.

Click here to set the text 
attributes for the name.

Changes to the button
appear here as you

make them.

You can store information 
in a button.
4-20 Chapter 4: Creating and Modifying Stacks
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Field information
To locate and learn about the fields in a stack, follow these steps: 

1. Choose the Field tool ( ) from the Tools menu. 

Lines appear in all the fields except the scrolling fields: 

2. Click the field you want information about.

Clicking the field selects it.

When you choose 
the Field tool … 

… lines appear 
in the fields.
Chapter 4: Creating and Modifying Stacks 4-21
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3. Choose Field Info from the Objects menu.              

You can also double-click the field in step 2, and skip this step. The F
Info dialog box appears.:

Card information
To get information about the current card, choose Card Info from the Obje
menu. The Card Info dialog box appears:                   

This is the depth position of
the field on the card or

background in respect to
other fields and buttons.

This is what the
field looks like on

the card.

These are the 
attributes of 
the field.

If this box is checked,
the Find command

won’t look for text on
this card.

The card’s position 
number relative to the
other cards in this stac

Click here to see
the card script.    

Checking here is like
bending over the corner

of a page in a book.

Check here to
protect the card

from deletion.
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Background information
You can see what’s in the background layer of the current card (such as 
background fields, background buttons, and background graphics) by choo
Background from the Edit menu, or by pressing x-B. 

To get information about the current background whether or not you’re in 
background layer, choose Bkgnd Info from the Objects menu. The Bkgnd 
dialog box appears:

Stack information
To get information about the current stack, choose Stack Info from the Obj
menu. The Stack Info dialog box appears:             

When this box is checked, at
least one card must exist

that uses this background.

When this box is checked,
the Find command won’t

look at any fields on cards
that use this background.

The path to 
this stack

The dimensions 
of the stack’s 
cards (in pixels)Click here to change the

size of the stack’s cards.

The amount of wasted
space in the stack

reclaimable through
the Compact Stack

menu command
Chapter 4: Creating and Modifying Stacks 4-23
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Making changes to a stack created with an earlier version     
When you open a stack created with a version of HyperCard earlier than 2
small padlock ( ) appears in the menu bar. You can use such a stack, bu
cannot make changes to it until you convert it to the new HyperCard file 
format. (For instructions on converting a stack, see “Opening a Stack Bui
an Earlier Version of HyperCard” in Chapter 1.) 

Undoing Your Mistakes          
While you’re working on a stack, you can usually undo your last stack-edit
action by immediately choosing Undo from the Edit menu (or by pressing
x-Z). Choose Undo when you make a mistake, or when you change your m
about your last action. (You must choose Undo before doing anything els

To undo typing mistakes while you’re editing text in a field, do any of the 
following: 

■ Choose Undo from the Edit menu. This undoes your last text-editing 
operation (including a text style change).      

■ Press Delete or Backspace to delete characters to the left of the inser
point, one character at a time. 

■ Drag the I-beam over the incorrect text to select it, and then retype or 
delete it. 

When you’re using one of the Paint tools, pressing the tilde (~) or Escape
is the same as choosing Undo. 

Modeling Your Stack After an Existing One            
You can model a new stack after a card or stack you like by copying its 
background. When you copy a background from an existing stack, you ge
basic design of the original stack (its template) but not any of its data except for
the contents of buttons and the shared text of fields (if any). The stack ca
Stack Templates, which come with HyperCard, contains some backgroun
you can copy and use in your stacks. (For specific instructions on creatin
new stack that uses a background from an existing stack, see “Creating a
Stack” later in this chapter.)
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Before you decide whether to copy the background of an existing card or s
you can look at the background by going to that card or stack and choosi
Background from the Edit menu (or pressing x-B). This takes you to the 
background layer and shows you just the buttons, fields, and graphics tha
in the background. Pressing x-B repeatedly moves you back and forth betwee
the card layer and the background layer.         

❖ Stripes in the menu bar?To make sure you’re looking at the background
check the menu bar. When you’re in the background layer, diagonal str
appear in the menu bar.❖

Creating a New Stack        
When you’re ready to create a new stack, begin by following these steps:

1. To give your new stack the same background as an existing card or stack, go to that card 
or stack. 

The previous section, “Modeling Your Stack After an Existing One,” 
discusses why you may want to copy a background from another stac

Diagonal
stripes tell you

that you’re
looking at the

background.
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2. Choose New Stack from the File menu.       

The New Stack dialog box appears.          

3. Choose from the options in the New Stack dialog box. 

If you want your new stack to have the same background as the curre
card, check the “Copy current background” option to select it. 

If you select the option “Copy current background,” your new stack has
the same background elements as the card you were looking at when
chose New Stack. Otherwise, it’s blank. 

If you choose a card size that’s larger than your screen, HyperCard sh
as much of a card as it can; it displays the stack starting from the upper
corner. (For information on working with cards larger than your screen, 
“Working with Large Cards” in Chapter 5.) 

Click here if you want
your new stack to have

the same background
as the current card.

Your new stack is stored in this folder 
unless you choose another folder.

You can choose a card size 
from this pop-up menu.

Click here if you want the new stack to 
open in another window, leaving open 
the stacks you already have open.

You can set a custom card size by 
dragging from this corner.

The dimensions of 
the default card 
size, in pixels
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4. Type a name for your new stack.

5. Click New. 

If you’ve selected the option “Open stack in new window,” your new sta
opens in a new window. Otherwise, HyperCard opens the new stack in
active window. 

Copying parts from other stacks        
Copying parts from other stacks can make stack building easier and save 
lot of time. If you see a button that does something you like, you can copy
and paste it into your stack. Some of the stacks that come with HyperCard 
(Readymade Buttons, Readymade Fields, Art Bits, and Stack Templates)
contain ready-made parts for you to use. These parts are designed to wo
independently in a variety of stacks; they don’t depend on your stack’s ha
any particular characteristics.

When you copy a button, field, card, or background from another stack, it
script and its attributes come with it. Scripts contain instructions that tell th
parts of a stack what to do. In most cases, you want the script, because it m
the object work. (For more information about HyperCard objects, see 
“Examining a Stack” earlier in this chapter.) 

Be careful about interactions
The scripts that belong to the different objects in a stack often interact wit
other objects and scripts. An object you copy from another stack may hav
script that relies on objects in its original stack. Copying such an object ca
cause your stack to act strangely. For example, you may see messages t
begin with “Never heard of …” or “Can’t understand…”.   

If you’re familiar with HyperTalk, you can fix or rewrite the object’s script. 
Otherwise, consider deleting the script (as described next), copying a diffe
object, or creating the object yourself.

Fixing strange behavior
If you copy a button or a field from another stack and your stack begins ac
strangely, it’s best to delete the copied object and find or create another o
unless you can fix the object’s script.
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If you copy a card or background that causes trouble in your stack, and y
can’t fix the scripts, first try deleting the buttons and fields on the card or 
background, one at a time. If the problem persists, delete the script of the
and/or background by following these steps:          

1. Open the script. 

To open the script of the current card, press x-Option-C. To open the 
background script, press x-Option-B. 

2. Select all the text in the script by pressing x-A.

3. Press Delete or Backspace to delete the script. 

4. Press Enter to close the script.

A dialog box may appear asking you to confirm changes to the script. C
Yes (or press Enter).

❖ Removing a script leaves an empty shell.After you delete the buttons, 
fields, and scripts from a card or background, you’re left with just the 
picture on that card or background. Any functions associated with the c
or background are gone.❖   

Naming a stack         
When you first create a stack, you type a name for it in the New Stack dia
box. This is the name that appears for the stack in the Stack Info dialog box
in the Finder. 

HyperCard uses the stack name to identify the stack. You can use the sta
name in the Message box to move to the stack. And, you use the stack n
when you address the stack through scripts. 

You can change a stack’s name at any time. Here’s one way: 

1. Make sure you have one of the General tools active.       

The General tools are Browse ( ), Button ( ), and Field ( ). 

2. Choose Stack Info from the Objects menu. 
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3. Type a new name for the stack. 

4. Click OK. 

❖ Changing the stack name breaks links.Changing the name of a stack 
breaks any links you’ve made between a card in another stack and a ca
the renamed stack. (It may even break links within the renamed stack
itself.) When you change the name of a stack, be sure to redo all the l
to the stack. (“Linking Information” in Chapter 6 gives instructions for 
creating links.)❖     

You can also change a stack’s name in the Finder. Change the name of the
in the same way you would change the name of any file in the Finder. Chan
the stack name in the Finder also changes it in the Stack Info dialog box.

❖ Can’t change the name in the Finder?If you can’t change the name of 
the stack in the Finder, the Locked option may be checked in the stac
Get Info dialog box. To fix it, open the Get Info dialog and uncheck 
that option.❖

Changing the size of cards              
You set the size of a stack’s cards at the time you create the stack, using
New Stack dialog box. (All the cards in a stack are the same size.) The ea
way to set a stack’s size is to use the default size that HyperCard presents
as you develop the stack, you may decide you want to change the size of
cards either because your design goal has changed, or because the card
difficult to work with. 

Type the stack name here. 
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It’s easy to resize a stack’s cards. But you may have to make other chang
the stack to accommodate the new card size. When you change the card
HyperCard doesn’t scale the elements on the cards to accommodate the 
card size. Before you reduce the size of a stack’s cards, it’s a good idea t
reposition or resize the elements first so that they fit on the smaller cards

To resize a stack’s cards, follow these steps:

1. Make sure you have one of the General tools active.

The General tools are Browse ( ), Button ( ), and Field ( ). 

2. Choose Stack Info from the Objects menu.        

3. Click Resize. 

A dialog box for resizing the cards appears. 

4. Choose a new card size: 

5. Click OK. 

You see your new card size. 

The dimensions of the
card size, in pixels

To choose a card size, 
use this pop-up menu.

To make the cards a custom
size, drag from this corner.

This represents the current
card size. It changes when

you set a different card size.
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If some elements on the card are cropped or have disappeared from view
can restore them by enlarging the card to its former size with the Resize 
dialog box. 

❖ Edited graphics sometimes become fixed:If you reduce the size of a 
stack’s cards and then edit the graphics on a card or background, the
graphics that appear on the smaller card permanently replace the gra
that were on the larger card. You can’t get the larger graphics 
back. ❖                

Saving a Copy of a Stack        
It’s a good idea to make a copy of an existing stack before you begin work
with it, and to save a copy of the stack periodically as you make changes 
HyperCard automatically saves your stack, along with all your mistakes, as
work. If you encounter a major catastrophe, you can recover from it more ea
if you have a recent, working version of the stack. 

Follow these steps to copy a stack from within HyperCard:

1. While the stack is open and active, choose Save A Copy from the File menu.        

The following dialog box appears:       

2. Type a name for the stack copy if you want to give it a name different from the one shown. 

Choose Stack here; 
otherwise your new stack 
might not be compatible 
with HyperCard!

You can type a name here
for the copy of the stack;
otherwise, HyperCard will

save the copy under the
name you see.
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3. Be sure that Stack is selected in the File type pop-up menu at the bottom of the dialog box.

If you select Application, you’ll create a stand-alone application that yo
won’t be able to change. (See the next section, “Creating a Stand-Alo
Application,” for details.)

4. Click Save. 

HyperCard saves a copy of the stack, but it leaves you in the stack yo
working on. 

❖ Copying a stack in the Finder:You copy a stack in the Finder in the 
same way you duplicate any file in the Finder: Use Duplicate from the
File menu.❖

Creating a Stand-Alone Application
If you’re running HyperCard under System 7, you can use the File type pop
menu in the Save As dialog box to save a stack as a stand-alone applica
Such an application runs without the need for HyperCard.

Users of the stand-alone application you create won’t have access to 
HyperCard’s authoring or scripting abilities. Furthermore, because you can
HyperTalk to remove menus and/or menu commands as you create the s
that becomes a stand-alone, you can restrict the kinds of changes a user
make to the application.

To create a stand-alone application, follow these steps:

1. Create a stack as you normally would.

2. Choose Save a Copy from the File menu.

3. Type a new name for the stand-alone application.

Be sure to choose a different name from the stack so that you can ma
changes if you need to.

4. Select Application in the File type pop-up menu at the bottom of the dialog box.
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5. Click Save. 

A new dialog box appears. Information you type into it appears in the 
stand-alone application’s Get Info box in the Finder. Typing such 
information is optional.

6. Click OK to dismiss the dialog box and save the application.

HyperCard creates a stand-alone application based on your stack, bu
leaves you in the stack you’re working on.

❖ Note: You can also click More Choices. Doing so brings up a more 
complex dialog box of special interest to professional developers. If you
using System 7, turn on Show Balloons for contextual information abo
the fields and menus in the dialog box. (For detailed information, see 
“Create a Standalone Application” in the HyperCard Help stack.)❖       

To make changes to the new application, make your changes to the stack
save another copy of the stand-alone application.

Reclaiming Free Space in a Stack        
As you work on a stack, free space can accumulate. The more free space a
has, the slower it runs and the more space it takes up on the disk. To chec
amount of free space in a stack, make sure you have one of the General 
active, then choose Stack Info from the Objects menu.       

You can get rid of free space in a stack by choosing Compact Stack from
File menu. (To use the Compact Stack command, you must have one of 
General tools active.) When you choose Stack Info after compacting the s
the “Free in stack” number in the Stack Info dialog box is 0 K (zero K), and 
size of the stack is likely to be smaller than it was.

This is the amount of free 
(wasted) space in the stack.

This is the amount of disk 
space (including free space) 
the stack takes up.
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Protecting Your Stack       
While you’re building your stack, and/or when it is finished, you can keep
others from using or changing it. There are several different kinds of protec
for a stack: 

■ You can keep a personal stack private by preventing others from openi

■ You can limit the way people use and change a stack.

■ You can limit access to a stack’s protection settings so that no one else
change them.

■ You can prevent users from peeking at the buttons and fields in a stac

■ You can prevent users from stopping scripts that are running. 

Restricting access to a stack               
To restrict access to a stack so that no one can open it without the passw
follow these steps: 

1. Choose Protect Stack from the File menu. 

The Protect Stack dialog box appears.

2. Check the Private Access option.       

Click here to restrict
access to a stack…

… then click here to
create the password.
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3. Click Set Password.        

The dialog box for setting a password appears. 

4. Type a password. 

5. Click OK. 

The password protection you set for a stack doesn’t take effect until you re
HyperCard. 

❖ You cannot retrieve a password.Once you’ve restricted access to a stac
and set a password, the stack cannot be opened without the passwor
There’s no way to find out a password once it’s been set, so make a no
the password or use a password you won’t forget.❖

When you type the password to open the stack, it must match 
character-for-character the one you set. (HyperCard pays no attention 
to case.)       

➤  See also: “Removing a Password” later in this chapter.

Protecting a stack from changes or deletion         
To prevent others from changing or deleting the current stack, follow 
these steps:

1. Choose Protect Stack from the File menu. 

The Protect Stack dialog box appears. 

…and again here, for verification.

Clicking None or Cancel closes this 
dialog box without setting a password.

Type the password once here …
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2. Click Can’t Modify Stack or Can’t Delete Stack.

While the Can’t Modify Stack option is turned on, no one can delete th
stack or make any changes to it. Anyone can, however, copy anything f
the stack, or copy the stack itself. While the Can’t Delete Stack option
turned on, no one can delete the stack except by dragging it to the Tra

Unless you set a password, anyone can open the Protect Stack dialog
and turn off these options. 

3. To prevent others from changing your protection settings, click Set Password. 

(This step is optional.)

You see the dialog box for setting a password. 

4. Enter a password. 

(This step is optional.)

Setting a password for the stack prevents unauthorized users from ope
the Protect Stack dialog box, whether or not Private Access is selecte
you’ve selected Private Access as well as setting a password, you ne
use the same password to open the stack itself.       

5. Click OK.               

After you’ve set a password, no one can change the settings in the Pr
Stack dialog box without knowing the password unless you remove it 
explained in “Removing a Password” later in this chapter). 

Click here to prevent changes
to the stack. When you select

this option, Can’t Delete Stack
is automatically selected.

Or, click here to protect the
stack from deletion only.
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Unmodifiable stack padlock
When you’re using a write-protected stack (that is, a stack for which the C
Modify Stack option is selected in the Protect Stack dialog box), a padlock 
appears in the menu bar. The padlock means that you can’t make any ch
in the stack. 

Opening a padlock
HyperCard automatically selects the Can’t Modify Stack checkbox when t
stack is on a write-protected medium (a locked disk, CD-ROM, or locked 
folder on a file server). To make changes to such a stack, you first have t
figure out why it’s locked. If the Can’t Modify Stack checkbox is selected o
the Locked checkbox is selected in the stack’s Get Info dialog box (in the
Finder), you have to deselect these options before you can make changes
stack. In many cases, copying the stack to an unlocked disk makes the s
modifiable. 

❖ Some changes don’t last.Some stacks are designed so that, when the st
is locked, you can type into a field or paint a picture on a card or 
background; but the changes disappear as soon as you leave the curr
card. (See the userModify property in the HyperCard Script Language 
Guide for details.)❖       

Limiting user level              
You can limit the way people use and change a stack by limiting the user l
in the Protect Stack dialog box. Follow these steps:

1. Choose Protect Stack from the File menu. 

The Protect Stack dialog box appears. 
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2. Click a user level.

Browsing is the lowest level. 

The options available at the different user levels are described in “Use
Levels and Options” in Chapter 1. 

Unless you set a password as explained in the following two steps, any
can open the Protect Stack dialog box and change the user level. 

3. To prevent others from changing the stack’s user level setting, click Set Password. 

(This step is optional.) 

The dialog box for setting a password appears. 

4. Enter a password. 

(This step is optional.) 

Setting a password for the stack prevents unauthorized users from ope
the Protect Stack dialog box and changing the settings, whether or no
Private Access is selected. If you’ve selected Private Access as well a
setting a password, you need to use the same password to open the 
stack itself. 

5. Click OK. 

When this user level is different 
from the user level set in the 
user’s Home stack, the lower of 
the two levels takes precedence. 
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The tools and commands a user has access to while using the stack are 
determined by both the user level you set in the stack’s Protect Stack dialog
and the user level selected on the Preferences card of the user’s Home s
When these two settings are different, HyperCard uses the lower setting.
(Lower means “closer to Browsing.”) 

After you’ve set a password, no one can change the user level in the Pro
Stack dialog box without knowing the password (unless you remove it, as
explained in “Removing a Password” later in this chapter). You cannot find
a password once it’s been set, so make a note of the password or use on
won’t forget. 

❖ Showing the hidden Protect Stack command:When the user level is set to
Browsing or Typing (either in the Protect Stack dialog box or on the 
Preferences card in the Home stack), the Protect Stack command doe
appear in the File menu; so you can’t change any of the protection sett
To get the full File menu no matter what the user level is, press and h
the x key while you open the File menu.❖  

Preventing peeking at buttons and fields                 
When you create a stack to be used by many people, you can prevent oth
from peeking at the buttons and fields in the stack. Follow these steps: 

1. Choose Protect Stack from the File menu. 

The Protect Stack dialog box appears. 

2. Check the Can’t Peek option to select it. 

3. Click OK. 
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Preventing script interruption            
When you display a stack in a public location (for example, at a trade sho
booth or during an automated demonstration), you can prevent others fro
stopping the stack’s scripts with x-. (x-period). 

To prevent interruption of a stack’s scripts, follow these steps: 

1. Choose Protect Stack from the File menu. 

The Protect Stack dialog box appears. 

2. Check the Can’t Abort option to select it.

3. Click OK.

❖ Can’t Abort is dangerous. Use this option with discretion. If this option is
turned on, the only way to stop a script before it’s finished running is eit
to press x-Option-Esc (in System 7), or shut down the computer.❖

Removing a password       
Any password you set in the Protect Stack dialog box remains in effect for
stack until you explicitly remove it. To remove a password, follow these ste

1. Choose Protect Stack from the File menu. 

A dialog box prompts you for the password. 

2. Enter the password and click OK. 

The Protect Stack dialog box appears. 

3. Click Set Password. 

The dialog box for setting a password appears. 

4. Click None to remove the password. 

The Set Password dialog box disappears and the password protection
removed. 
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Setting user access for a stack on a file server                
You can protect a stack available to users on an AppleShare file server via
of the methods described in the preceding sections. In addition, you shou
aware of the following: 

■ As with any file on a file server, you can make the stack available to any
who has access to the network, or only to people who are registered u
of the file server. For information on setting file protection on a file serv
consult your network administrator. 

■ For a stack to be available to multiple users through a file server, the s
must be either on a locked medium (such as a locked disk, CD-ROM,
locked folder on the file server) or locked in the Finder. Selecting the Ca
Modify Stack option in the Protect Stack dialog box isn’t enough to ma
a stack available to more than one user. 

■ Any number of network users can use a locked stack at the same time
no one can make changes to the stack.    

■ When a stack is unlocked on a file server, only one person can use that 
at a time. That user can make changes to the stack unless one of the 
protection options has been set in the Protect Stack dialog box.
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Deleting a stack                 
When you delete a stack, you remove all the stack’s cards, backgrounds,
scripts. Delete a stack only when you have no further use for it. 

To delete the current stack, use the Delete Stack command from the File m
(This command is available when one of the General tools is selected at 
Painting, Authoring, or Scripting user level.) Unless the stack is protected f
deletion, you see a dialog box similar to this one:

If the stack is protected from deletion, you see the following dialog box:

When you delete a stack with the Delete Stack command, it’s as though y
dragged the stack to the Trash in the Finder and chose Empty Trash. If y
delete the only open stack, HyperCard returns you to the Home stack. 
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Customizing Your Home Stack             
You can tailor your Home stack to the way you work and to the tasks you
perform. With a few modifications, your Home stack can even serve as th
control center for all your work on the Macintosh. Your Home stack becom
a launching pad for the applications, utilities, documents, and stacks you 
regularly. 

You can organize your Home cards as you see fit. For example, you can p
the buttons you use on one card; or you can put buttons that open applica
on one card, and buttons that open stacks on another. Or you can renam
cards according to the categories you find most useful, and keep buttons o
five cards. You can rearrange the order of the Home cards and change the
each card looks.           

The first two cards in the Home stack have buttons that take you to the st
that come with HyperCard. The buttons on the first card open the stacks 
introduce you to HyperCard, including the HyperTalk reference stack, and
some stacks that help you with various office tasks. However, you can se
the Home stack any way that you like. 

As you become more comfortable with HyperCard, you can make the Ho
cards even more useful by adding buttons that are linked to your favorite 
stacks, applications, and documents. You can also create buttons that go
other cards in the Home stack itself—either to ones that already exist, or 
cards that you add. (See Chapter 6, “Working with Buttons,” for informatio
on creating new buttons.)    

Changing the appearance of Home cards       
Besides adding buttons to your Home cards, you can also change the 
appearance of the Home cards by adding text and pictures. 

When you add text or a picture to the background layer of a Home card, i
appears on all the Home cards in that background. (The Home stack has s
backgrounds.) When you add text or a picture to the card layer of a Home 
it appears only on that card. (For instructions on adding text to a card or 
background, see Chapter 7. For instructions on adding pictures, see Chap
Chapter 4: Creating and Modifying Stacks 4-43
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Using the Home stack as a control center                                            
Once you’ve added buttons to your Home stack for all the stacks, applicati
and documents you use frequently, you can use your Home stack as a st
point, or control center, for all your work on the Macintosh. 

To use the Home stack as your control center, you tell your computer to lau
HyperCard at startup time. The way you do this is determined by the type
system you have (6.x or 7).

To quick-start HyperCard under System 6.x, follow these steps:

1. Go to the Finder. 

2. Click the HyperCard icon once to select it. 

3. Choose Set Startup from the Special menu.       

A setup dialog box appears:

4. Click OK. 

Now when you start your computer, HyperCard will launch automatically a
the Home stack will open.    
4-44 Chapter 4: Creating and Modifying Stacks
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To quick-start HyperCard under System 7, follow these steps:

1. Find the HyperCard icon.

2. Create an alias for HyperCard.

3. Go to the Finder. 

4. Find the Startup Items folder in the System Folder. 

5. Drag the HyperCard alias to the Startup Items folder.       

Now when you start your computer, HyperCard will launch automatically a
the Home stack will open.    
Chapter 4: Creating and Modifying Stacks 4-45
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Chapter 5
Working with Cards and Backgrounds

When you build HyperCard stacks, you perform many tasks that involve 
creating and manipulating cards and backgrounds. You can add cards to
stack, rearrange the cards in a stack, or copy a background from one sta
another. 

This chapter gives specific instructions for working with cards and 
backgrounds. To do the tasks in this chapter, you must have your user lev
to Authoring or higher. For instructions on setting your user level, see “Us
Levels and Options” in Chapter 1. 
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Working with Cards        
A card is a rectangular area that can hold buttons, fields, and graphics. All c
in a stack are the same size. Each card is a composite of two layers—a 
foreground layer, called the card layer, and a background layer. You see 
elements of both layers when you look at a card, as if the card were a 
transparent layer in front of the background. Each layer can contain its ow
buttons, fields, and graphics.

Adding a new card to a stack        
When you add a new card to a stack, HyperCard always puts the new card
after the current card. The new card automatically acquires the backgroun
the current card. If you want to add a new card with a blank background, 
need to add a new background. (“Creating a New Background,” later in th
chapter, gives instructions.)           

To add a new card to the current stack, follow these steps: 

1. Go to the card you want the new card to follow.

If you want to add a new card at the end of the stack, go to the last ca
the stack by choosing Last from the Go menu (or by pressing x-4 or 
x-right arrow).

Current card

New card
Chapter 5: Working with Cards and Backgrounds
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2. Choose New Card from the Edit menu (or press x-N).

The new card is inserted immediately after the card you were looking 
when you chose New Card, with the same background as that card. T
new card appears on your screen. 

Creating a new first card
If you want to create a new card as the first card in the stack, follow these s

1. Choose First from the Go menu (or press x-1). 

The first card in the stack appears on the screen.

New card

Current card
Chapter 5: Working with Cards and Backgrounds 5-3
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2. Choose New Card from the Edit menu (or press x-N).     

The new card is added after the first card and has the same backgrou
the first card. 

The new card appears on the screen.

3. Choose First from the Go menu again.       

The first card in the stack appears on the screen again.

New card

Current card
Chapter 5: Working with Cards and Backgrounds
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4. Choose Cut Card from the Edit menu.       

This removes the first card in the stack and puts a copy of it onto the 
Clipboard. The card that was second in the stack is now first.   

❖ Putting the original first card back into the stack:To put the former first 
card back into the stack, go to the card you want the cut card to follow 
choose Paste Card from the Edit menu. The pasted card is added 
immediately after the card you were looking at when you chose 
Paste Card.❖          
Chapter 5: Working with Cards and Backgrounds 5-5
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Working with large cards             
When you’re working with a stack whose cards are larger than the screen
can see only a portion of a card at a time. To look at other parts of a card
is larger than the screen, you can use either of the following techniques: 

■ Press x-Shift-E and then drag the card around using the hand pointer (
The pointer turns into the hand when it is over the card. When you rele
the mouse button, the hand disappears. To move around the card sev
times in succession, press and hold the x key until you’re finished.     

■ Open the Scroll window by choosing Scroll from the Go menu, or by 
pressing x-E. Then use the Scroll window to scroll to other parts of 
the card. 

❖ You can work with small windows as well.You can also use either of these
techniques to view any card when the window is smaller than the card
(“Moving and Resizing the Card Window” in Chapter 1 explains how to
resize the card window.)❖

To limit the scrolling to either horizontal or vertical movement, hold down t
Shift key while you drag. 

To scroll to other parts of
the card, drag from the
middle of the rectangle.

The blank area represents 
the entire card.

The rectangle inside the 
blank region represents the 
part of the card you see on 
your screen.The pointer becomes a

hand when it’s in the
middle of the rectangle.
Chapter 5: Working with Cards and Backgrounds
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To hide the Scroll window, click its close box or press x-E. 

❖ Keep the card window no larger than the screen.When you’re working 
with a stack whose cards are larger than the screen, keep the card wi
small enough to fit on the screen. If you make the card window larger t
the screen, you can’t scroll around to see all the parts of the card. (Se
“Changing the Size of Cards” in Chapter 4 for instructions on making t
cards smaller.)❖         

Copying a card        
You can copy a card into another stack or to another location in the same s
When you copy a card, you copy everything associated with it including it
background, graphics, fields, text, buttons, and scripts. 

Here’s how to make a copy of a card: 

1. Go to the card you want to copy. 

2. Choose Copy Card from the Edit menu.      

This puts a copy of the current card on the Clipboard. 

3. Go to the card you want the copied card to follow. 

It can be in the current stack or in any other stack. 

4. Choose Paste Card from the Edit menu (or press x-V). 

The card is pasted immediately after the card you were looking at when
chose Paste Card. The copied card becomes the current card. 

If you’ve copied the card from a stack whose cards are a different size, 
HyperCard resizes the card so that it’s the same size as the other cards i
current stack. 

The copied card acquires the name of the original card (if the original card
a name). This means that, if the copy and the original are in the same stack
have two cards in the stack with the same name. You should rename one
them so that each card in your stack has a unique name. (“Naming a Card”
in this chapter gives instructions.) 

❖ Copying a card copies its scripts.When you copy a card from one place t
Chapter 5: Working with Cards and Backgrounds 5-7
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another, you copy the card’s script and any scripts associated with the
card’s buttons, fields, and background. Because scripts sometimes re
the characteristics of a particular stack, you can encounter problems (
as unfamiliar messages) after you copy a card. See “Copying Parts fro
Other Stacks” in Chapter 4 for the details.❖     

Moving a card                 
You can move a card to a different stack or to a different place within the s
stack. When you move a card, you also move everything associated with
including its background, graphics, fields, text (and text attributes), button
and scripts. 

To move a card, follow these steps:

1. Go to the card you want to move.

2. Choose Cut Card from the Edit menu.     

This removes the current card and puts a copy of it onto 
the Clipboard.

3. Go to the card you want the cut card to follow. 

It can be in the current stack or in any other stack.

4. Choose Paste Card from the Edit menu (or press x-V).       

The pasted card is placed immediately after the card you were looking
when you chose Paste Card. The pasted card appears on the screen.

If you move the card from a stack whose cards are a different size, 
HyperCard resizes the card so that it’s the same size as the other car
the current stack. 

❖ Moving a card moves its scripts.When you move a card from one place t
Chapter 5: Working with Cards and Backgrounds
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another, you move the card’s script and any scripts associated with th
card’s buttons, fields, and background. Because scripts sometimes re
the characteristics of a particular stack, you may encounter problems (
as unfamiliar messages) after you move a card. See “Copying Parts fr
Other Stacks” in Chapter 2 for instructions on how to correct the 
problem. ❖        

Making a card the first card in the stack
Moving a card to the first position in the stack requires several steps. First
have to make the card the second one in the stack, and then you have to
the first card out of the way. 

To move a card to the beginning of the stack, follow these steps:

1. Go to the card whose position you want to change.

2. Choose Cut Card from the Edit menu.

This removes the current card and puts a copy of it onto the Clipboard

3. Choose First from the Go menu (or press x-1).      

The first card in the stack appears.

4. Choose Paste Card from the Edit menu (or press x-V).      

The pasted card appears on the screen. It’s now the second card in the

5. Choose First from the Go menu again.

The first card in the stack appears again.
Chapter 5: Working with Cards and Backgrounds 5-9
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6. Choose Cut Card from the Edit menu.

This removes the first card from the stack and puts a copy of it onto th
Clipboard. The card that was second in the stack is now first.

7. Choose Paste Card from the Edit menu.

The original first card is now the second card in the stack.    

Getting information about a card     
Using the Card Info command, you can get information about the current c
and change some of its properties. Follow these steps to get information a
a card:

1. Make sure you have one of the General tools selected.

2. Choose Card Info from the Objects menu.

A dialog box like the one in the following figure appears:    

If this box is checked,
the Find command

won’t look for text on
this card.

This is the card’s 
positional number 
relative to the other 
cards in this stack.

Click here to see
the card script.    

Checking here is like
bending over the
corner of a page

in a book.
Chapter 5: Working with Cards and Backgrounds
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3. When you’re finished, click OK.

❖ Another way to open the Card Info dialog box:While any General tool is 
selected, press x-M to open the Message box; then type C and press 
Return. (This shortcut works only if your Home stack is the one that com
with HyperCard.)❖ 

Naming a card           
Generally, a card doesn’t have a name until you give it one. The card nam
one way HyperCard identifies a card. You can use the card name in the 
Message box to bring the card into view. And you can use the card name
refer to the card in scripts. 

To name a card or change its name, follow these steps: 

1. Make sure you have one of the General tools selected.

2. Choose Card Info from the Objects menu.

3. Type the name you want to use for this card.        

4. Click OK.

❖ Use letters, not numbers.It’s not a good idea to use a numeral as a card
name because one of the ways that HyperCard keeps track of cards i
stack is by positional numbers. HyperCard may, for example, look for c
number 12 (the twelfth card in the stack) when you try to go to the car

The name goes here.
Chapter 5: Working with Cards and Backgrounds 5-11



5-12

. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .

or 
r go 
ck, 

Get 
named “12.” ❖

Marking a card       
You can mark specific cards in a stack and perform operations on them. F
example, you can print all the marked cards, scan all the marked cards, o
from one marked card to the next. You can mark any of the cards in a sta
whether or not they’re adjacent to one another.

Marking a card with the Get Info dialog box
One way to mark a card is by setting the appropriate option in the card’s 
Info dialog box.

1. Go to the card you want to mark. 

2. Make sure you have one of the General tools selected.

3. Choose Card Info from the Objects menu. 
Chapter 5: Working with Cards and Backgrounds
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4. Check the option labeled Card Marked to select it.        

5. Click OK. 

To unmark a card, click Card Marked to deselect it. 

Marking a card with the Message box
You can also mark and unmark cards by typing in the Message box. 
Here’s how:    

1. Choose Message from the Go menu (or press x-M) to open the Message box (if it isn’t 
already open). 

2. Type any of the following messages, substituting the text and the field name, number, or ID 
you want to use in your criteria for marking cards:         

Click here to mark the
card. If you click again,

you unmark it.

This marks the 
current card.

This unmarks all the 
cards with a background 
field named City that 
contains the text 
“New York.”This unmarks

all the cards.
Chapter 5: Working with Cards and Backgrounds 5-13
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3. Press Return or Enter. 

Once you have a set of cards marked, you can perform operations on 
by typing messages into the Message box.   

Excluding fields from text searches      
You use the Find command (in the Go menu) to search for specific text in
fields of a stack. (“Looking for Specific Text” in Chapter 1 explains how to
search for text.) When you’re searching for specific text in a large stack, y
can speed your search by excluding any fields that you know do not contai
text you’re looking for. 

To prevent HyperCard from searching in the card fields and/or backgroun
fields that appear on any particular card, follow these steps: 

This prints all the 
marked cards.

This takes you to 
the next marked 
card in the stack.

This takes you to the
previous marked
card in the stack.

This shows you all the
marked cards quickly,

one at a time.
Chapter 5: Working with Cards and Backgrounds
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1. Go to the card whose fields you want to exclude from text searches. 

2. Make sure you have one of the General tools selected.

3. Choose Card Info from the Objects menu.

4. Check the Don’t Search Card option to select it.       

5. Click OK. 

HyperCard no longer searches in the fields that appear on this card (e
on the card layer or on the background layer).

When you want HyperCard to search in the fields that appear on this card a
click Don’t Search Card to deselect it. 

Deleting a card         
To remove the current card from the stack, choose Delete Card from the 
menu (or press x-Delete or x-Backspace). The current card disappears, an
you see the next card in the stack.       

❖ Immediate Undo can restore a deleted card.If you delete a card by 
mistake, you can bring it back by choosing Undo from the Edit menu be
you do anything else.❖         

You can’t delete the only card in a stack. If there’s only one card in the st
and you want to delete it, choose Delete Stack from the File menu. 

Click here to exclude
the card’s fields from

text searches.
Chapter 5: Working with Cards and Backgrounds 5-15



5-16

. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .

 
the 

n’t 
Protecting a card from deletion          
To protect a card from deletion, follow these steps: 

1. Go to the card you want to protect. 

2. Make sure you have one of the General tools selected.

3. Choose Card Info from the Objects menu. 

4. Check the Can’t Delete Card option to select it.        

5. Click OK. 

You can’t remove the card from the stack while the Can’t Delete Card
option is turned on. You can, however, delete the entire stack, taking 
protected card with it. 

If you want to delete just the card, first remove its protection by clicking Ca
Delete Card in the Card Info dialog box to deselect it. 

❖ Preventing changes to a card:To prevent changes to a card, you must 
protect the entire stack from modification.❖

Click here to
protect the card

from deletion.
Chapter 5: Working with Cards and Backgrounds
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If you try to delete a protected card, you’ll see the following dialog box: 

Working with Backgrounds      
A background serves as a template for a stack or for a related group of ca
within a stack. Whatever’s in a background is common to all cards associ
with that background. You place buttons, fields, and graphics in the 
background when you want them to appear on all the cards that share the
background. 

There can be millions of backgrounds in a stack. Every card in a stack co
have its own background, although that would defeat the purpose of 
backgrounds. Together, the elements in a background help communicate
purpose of the stack, or that section of the stack, by giving a similar appear
and function to the cards that share the background. This makes it much e
for other people to figure out what the stack is for and how to use it, and m
easier for you to create and modify the stack. You can make changes to m
cards at once just by changing elements in their common background.    

To see the background layer of the current card, choose Background from
Edit menu (or press x-B). When you choose Background, you toggle back a
forth between the card layer and the background layer.
Chapter 5: Working with Cards and Backgrounds 5-17
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When you’re in the background layer, the menu bar is striped, and a chec
mark appears to the left of the Background command in the Edit menu.   

To see how many cards share the current background, choose Bkgnd Info
the Objects menu.

When you’re in the
background layer,
 the menu bar has

diagonal stripes.

This number tells
you how many cards
in the stack share the
current background.
Chapter 5: Working with Cards and Backgrounds
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To see how many backgrounds there are in the current stack, choose Stac
from the Objects menu.  

For information about adding buttons, fields, and graphics to a background
Chapters 6, 7, and 8.

Creating a new background        
When you want some (but not all) of the cards in a stack to have a simila
appearance or to contain the same elements, you can create a new backg
to be shared by just those cards. To add a new background to a stack, ch
New Background from the Objects menu. This adds to your stack a new, em
card with a blank background, and moves you to the background layer of
card. The new card (and, consequently, the new background) is added 
immediately after the card you’re looking at when you choose New 
Background.       

This number tells you how 
many backgrounds are in 
the current stack.

Use this command to create a new background.
Chapter 5: Working with Cards and Backgrounds 5-19



5-20

. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .

e 

x 

r in 

to 
ard 
Moving between backgrounds      
When you’re in a stack that has more than one background, you can mov
between the different backgrounds by following these steps:

1. Open the Message box.       

2. Type any of the following:

3. Press Return or Enter. 

You go immediately to the first card with the specified background. 

If there’s no such background in the current stack, you see a dialog bo
telling you so.

For information on naming a background, see “Naming a Background” late
this chapter.      

Copying a background      
You can copy a background from one stack to another or from one place 
another in the same stack. To copy an existing background, you copy a c
that has that background. (When you copy a card, you copy everything 
associated with it, including its background.) 

To copy a background, follow these steps:

1. Go to a card that has the background you want to copy.

This message takes you to the first card 
of the next background in the stack.

This message takes you to the first card 
of the previous background in the stack.

This message takes you to the first card of 
the background named Employees.
Chapter 5: Working with Cards and Backgrounds



. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .

n it 

 (the 
ents 
d 
 by 

ripts 
ause 
 
y 
2. Choose New Card from the Edit menu (or press x-N). 

You choose New Card to get a card without any card buttons or fields o
(you’re interested only in the card’s background).

3. Choose Cut Card from the Edit menu.       

4. Move to the card you want the new background to follow.

It can be in the current stack or in another stack. 

5. Choose Paste Card from the Edit menu.    

The pasted card becomes the current card. 

6. To make another card with this background, immediately choose New Card from the 
Edit menu.

This creates a new card with the same background as the current card
card you just pasted). This new card contains only the background elem
of the copied card (that is, the background buttons, fields, graphics, an
script). You can create as many cards with this background as you like
repeating this step. 

❖ Copying a background copies its scripts.When you copy a background 
from one place to another, you copy the background’s script and any sc
associated with the buttons and fields that are in that background. Bec
scripts sometimes rely on the characteristics of a particular stack, you
may encounter problems (such as unfamiliar messages) after you cop
a background. See “Copying Parts from Other Stacks” in Chapter 4 
for instructions on how to remedy this problem.❖       

Making multiple copies of the same background 
You can get copies of identical backgrounds into a stack by following 
these steps:

1. Go to a card whose background you want to duplicate.

2. Choose Copy Card from the Edit menu.

3. Change any characteristic of the current background.

For example, change the background’s name.
Chapter 5: Working with Cards and Backgrounds 5-21
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4. Choose Paste Card from the Edit menu.

The copied card goes into the stack with a new background.

5. If you want, restore the change you made to the original background.

The two backgrounds are now exactly the same, except for the IDs.

Getting information about a background
Using the Bkgnd Info command, you can get information about the curren
background and/or change some of its properties. Here’s how:

1. Make sure you have one of the General tools selected.

2. Choose Bkgnd Info from the Objects menu.

A dialog box like the one in the next figure appears.          

3. When you’re finished, click OK.

Click here to see the 
background script.      

This is the number of cards
that use this background.

With this box checked, at
least one card must exist

that uses this background.

With this box checked, the
Find command won’t look at
any fields on cards that use

this background.
Chapter 5: Working with Cards and Backgrounds
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Naming a background               
Generally, a background doesn’t have a name unless you give it one. A 
background’s name is one way HyperCard identifies the background. You
use the background name in the Message box to bring the first card with 
background into view. And you can use a background’s name to address
background through scripts.

To name a background or change its name, follow these steps: 

1. Make sure you have one of the General tools selected.

2. Choose Bkgnd Info from the Objects menu.

3. Type the background’s name.

4. Click OK. 

Excluding background fields from text searches             
You use the Find command (in the Go menu) to search for specific text in
fields of a stack. (“Looking for Specific Text” in Chapter 1 explains how to
search for text.) When you’re searching for specific text in a large stack, y
can speed your search by excluding any fields that you know do not contai
text you’re looking for. 

To prevent HyperCard from searching in all of the background fields that 
belong to any particular background, follow these steps: 

1. Go to a card with the background whose fields you want to exclude from text searches. 

2. Make sure you have one of the General tools selected.

3. Choose Bkgnd Info from the Objects menu. 
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4. Check the Don’t Search Background option to select it:         

5. Click OK. 

❖ No background fields searched:Setting the Don’t Search Background 
option prevents HyperCard from searching in any fields on the current
background. To prevent HyperCard from searching in background fiel
only on specific cards, follow the steps in “Excluding Background Field
from Text Searches” earlier in this chapter.❖

Protecting a background                   
When you protect a background from deletion, you tell HyperCard not to al
the removal of the final card that has that background. 

To protect a background from deletion, follow these steps: 

1. Go to a card that has the background you want to protect. 

2. Make sure you have one of the General tools selected.

3. Choose Bkgnd Info from the Objects menu. 

Click here to exclude
the background’s

fields from text
searches.
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4. Check the Can’t Delete Background option to select it.         

5. Click OK. 

As long as the Can’t Delete Background option is turned on, you can’t
remove the last card with that background from the stack. (You can, 
however, delete the stack, taking the protected background with it.) 

To remove the background’s protection, click Can’t Delete Background in 
Bkgnd Info dialog box to deselect it.     

❖ Preventing changes to a background:You can protect a background from
deletion, but you can’t prevent changes to a background unless you pr
the entire stack from modification.❖   

Click here to protect
the background from

deletion.
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Deleting a background     
You can’t delete a background directly. To remove a background from a st
you must delete every card that uses that background. Follow these step

1. Go to a card that has the background you want to delete. 

2. Choose Delete Card from the Edit menu (or press x-Delete or x-Backspace).      

The card disappears unless it’s protected. If the card is protected, you 
dialog box telling you so. See “Protecting a Card from Deletion” elsewh
in this chapter for instructions on removing card protection. 

If you delete a card by mistake, you can bring it back by choosing Und
from the Edit menu before you do anything else.

3. Repeat steps 1 and 2 until you’ve removed from the stack every card that has the background 
you want to delete. 

When Can’t Delete Background is selected in the Bkgnd Info dialog box, y
can’t delete the final card with this background. You can, however, delete
stack, including the protected background. “Protecting a Background” ear
in this chapter gives information on setting and removing a background’s 
protection.       
Chapter 5: Working with Cards and Backgrounds
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Chapter 6
Working with Buttons      

Buttons are “hot spots” you click to make things happen in stacks. A button
take you to another card, show you a picture, launch an application, or pl
QuickTime movie.

This chapter explains how to do the following: 

■ create and modify buttons

■ use the ready-made buttons that come with HyperCard

■ use buttons to link information

To do all the tasks in this chapter, you must have your user level set to 
Scripting. (“User Levels and Options” in Chapter 1 tells you how to set yo
user level.)
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Button Basics                 
You use buttons to link any piece of information—a card, an idea, a picture
address—to any other piece of information in any way you like. But button
have powers beyond linking—they can play sounds, dial a phone, or prod
visual effects.

Behind every button is a script—you click the button, and HyperCard carr
out the HyperTalk commands in the script. You can create a link without 
writing the script that makes it work; HyperCard provides a mechanism to
it for you. You can also copy buttons with pre-programmed scripts from ot
stacks, including the Readymade Buttons stack that comes with HyperCa

Tools for working with buttons      
To work with buttons, you need the Button tool and the Browse tool. 

To make it easy to alternate among the tools, you can “tear off” the Tools
menu to create a movable Tools palette: Drag down through the menu pa
bottom edge.

Use the Button tool to create and modify buttons.       

Use the
Browse tool

to click
buttons.
Chapter 6: Working with Buttons
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You can use the following x-key shortcuts to choose the tools you need for
working with buttons:         

For a more thorough explanation of these tools, see “Using HyperCard To
in Chapter 4.

Button Info dialog box
You use the Button Info dialog box to get information about a button and to
button characteristics. 

To do this… …press this

Create a movable Tools palette Option-Tab

Choose the Browse tool x-Tab 

Choose the Button tool x-Tab-Tab 

Click here to choose a 
visual effect for the 
button.

Click here to link the button
to another card or stack.

Family and Auto Hilite determine 
the button’s highlighting behavior.

Unless Enabled is checked, the 
button will appear grayed out 
and won’t work.

Show Name determines 
whether the button’s name 
appears on the card.

Click here to set the
text attributes for

the name.

Changes to the button
appear here as you

make them.

You can store information 
in a button.
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To get to the Button Info dialog box:

1. Choose the Button tool ( ) from the Tools menu.

2. Click once on the button you want to work with.

3. Choose Button Info from the Objects menu.

Or, double-click the button you want to work with in step 2 and skip ste

Where should the button go?
Whenever you add a button to a stack, you need to decide whether you w
in the card layer or the background layer. To decide where to put the butt
consider where you want it to appear: 

■ If you want the button to appear on only one card, put it in the card lay

■ If you want the button to appear on every card in a stack, create a stack
a single background and put the button in the background layer. 

■ If you want the button to appear on some of the cards in the stack (bu
all of them), create a different background for those cards and put the
button in that background only. “Creating a New Background” in Chap
5 explains how to add a background to a stack. 

A background button appears in the same location on all cards that share
background. To add a button to a background, you must be in the backgr
layer; to add a button to a card, you must be in the card layer. 

❖ Wrong layer?The most common mistake in adding a button is putting 
in the card layer when you want it in the background layer. To find out
whether the button is in the background layer, press x-B to see just the 
background elements. If you put a button in the card layer by mistake,
“Moving a Button from the Card to the Background” later in this 
chapter.❖
Chapter 6: Working with Buttons
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Locating buttons              
Many of the buttons in stacks are easy to locate right away. But some bu
are harder to find, particularly transparent ones. You can locate the button
the current card and background using any of the following methods: 

■ While the Browse tool is selected, you can “peek” at the buttons by 
pressing and holding the x and Option keys. Gray rectangles appear 
around the buttons:        

■ When you choose the Button tool from the Tools menu, rectangles ap
around the buttons that don’t already have an outline:                 

Dotted rectangles
outline the buttons

in the card layer.

Thick gray rectangles 
outline the buttons in 
the background layer.

When you choose the Button tool and press x-Option, 
gray rectangles outline the visible buttons …

… and the 
hidden buttons.
Chapter 6: Working with Buttons 6-5
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Using Readymade Buttons        
HyperCard comes with a stack called Readymade Buttons that contains buttons 
you can copy and paste. These buttons have pre-programmed scripts tha
add power and versatility to your stacks. 

The Readymade Buttons stack includes buttons for launching application
playing sounds, making pictures disappear and reappear, creating pop-up
fields, and much more. It also includes special tools for creating custom-m
buttons. These buttons are designed to work in virtually any stack. They d
depend on your stack’s structure in any way.      

Copying ready-made buttons can make stack building easier and save you
of time. If you see a button in any stack that does something you like, cop
and paste it into your stack.         

Buttons that open stacks that come with HyperCard: Buttons that hide and show the card picture:

Buttons that open applications: A button that plays a sound:

A button that lets 
you search for 
text in a stack:

A button
that dials
the phone:

A button that 
takes you to 
the HyperCard
Help stack:

A button that creates a 
pop-up field, and 
opens and closes the 
field after it’s created:
Chapter 6: Working with Buttons
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Follow these steps to copy a ready-made button:      

1. Open the Readymade Buttons stack.

2. Go to the card that has the button you want to copy. 

3. Choose the Button tool ( ) from the Tools menu. 

4. Click the button you want to copy.

A moving dashed line surrounds the selected button. 

5. Choose Copy Button from the Edit menu.

This puts a copy of the selected button (including its script) on the 
Clipboard.

6. Go to the card or background where you want to put the copied button.

Use the arrow keys or commands in the Go menu to navigate between 
while the Button tool is selected. If you’re not sure whether to put the 
button in the card layer or the background layer, see “Where Should t
Button Go?” earlier in this chapter. 

7. Choose Paste Button from the Edit menu.

This takes a copy of the button that’s on the Clipboard, puts it onto the
current card or background, and selects it. 

8. While the button is still selected, drag it to where you want it on the card.         

If you place a button on the card layer and you really want it on the 
background layer, see “Moving a Button from the Card to the Backgrou
later in this chapter.

9. Choose the Browse tool and click the button to test it. 

You can look at the HyperTalk commands that make the button work by 
opening the button’s script (see “Opening a Button’s Script” later in this 
chapter). You can also change how a ready-made button looks (see “Chan
the Appearance of a Button” later in this chapter).        
Chapter 6: Working with Buttons 6-7
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Creating a Button            
Buttons come in many different styles and sizes. You can bring a button to
by linking it to another card or writing a script for it.      

Creating a transparent button
You can create a blank, transparent button very quickly.

1. Choose the Button tool ( ) from the Tools menu.

2. Move the pointer anywhere on the card where you want the new button to appear.

3. Press and hold down the x key while you drag diagonally. 

The button is automatically selected when you create it.

A newly created transparent button is, by definition, invisible (except for th
dotted line surrounding it when it’s selected) and doesn’t do anything. Yo
need to create a use for it and give it some visible substance, either by wr
a script for it or by using some of the options in the Button Info dialog box

Naming a button       
You can give a button a name if you want to display text on it, or if you wa
to address the button by name through scripts or the Message box. Follow 
steps to name a button:

1. Choose the Button tool ( ) from the Tools menu.

2. Click the button you want to name. 

3. Choose Button Info from the Objects menu (or double-click the button). 

The Button Info dialog box appears. 

4. Type a name for the button.         

It’s best to give the button a name that communicates its purpose.  

5.  Check the Show Name option to have the button name appear on the button.
Chapter 6: Working with Buttons
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Making a button unclickable
Sometimes it’s useful to create a button that you want to appear on a card
that you don’t want to be clickable yet. For example, you may want a butto
be clickable only after a user has selected text in a field or has made a sp
menu choice. 

To make a button unclickable, you turn off the Enabled checkbox in the Bu
Info dialog box. Follow these steps:

1. Choose the Button tool ( ) from the Tools menu.

2. Click the button you want to disable to select it. 

3. Choose Button Info from the Objects menu (or double-click the button).

The Button Info dialog box appears. 

4. Click the Enabled checkbox so that there is no “X” in it.

The button appears dimmed in the Button Preview window. It is 
unclickable until you turn Enabled back on again.

❖ A disabled button needs a re-enabling script.Disabling a button isn’t very 
useful unless you intend to enable it again. In most cases, you’ll need to
a script to do it—for example, using an if…then command to enable the 
button when some condition is met. The HyperTalk Reference stack sh
you how to do this.❖

Changing the Appearance of a Button          
Once you create or copy a button, you can change its appearance by resiz
changing its style, making it highlight when it’s clicked, showing or hiding i
name, or even dimming its name so that it’s unclickable. This section expl
how to make a button look the way you want it to. Another section later in 
chapter, “Working with Icons,” tells how to add, customize, and remove ico
from buttons.

❖ You can change background buttons from the card layer.You can change 
the appearance of both card buttons and background buttons while yo
working in the card layer. You don’t have to be in the background laye
modify background buttons.❖
Chapter 6: Working with Buttons 6-9
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Changing the size of a button      
To resize a button, follow these steps:

1. Choose the Button tool ( ) from the Tools menu.

2. Click the button you want to resize to select it.

A moving dashed line surrounds the selected button.

3. Drag from any corner of the button. 

To resize the button in one dimension only, either horizontally or vertica
hold down the Shift key while you drag from a corner.

❖ Creating a standard-size button:If you hold down the Shift key while you 
resize a rounded rectangle or standard button, HyperCard automatica
makes the button a standard height (the same height as the buttons 
produced by the New Button command).❖
Chapter 6: Working with Buttons
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Choosing a button’s style        
A button can have any one of many styles. The following figure shows so
examples:

Use the following steps to set any style. 

1. Choose the Button tool ( ) from the Tools menu.

2. Click the button to select it. 

3. Choose Button Info from the Objects menu. 

The Button Info dialog box appears.      

Button styles
Chapter 6: Working with Buttons 6-11
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4. Open the Style pop-up menu.  

5. Drag down to select the style you want to use.   

If you drag down far enough, the menu scrolls to show more choices. 
model of the button appears in a window in the dialog box.     

6. Click OK.      

About pop-up buttons
When you use any button style except pop-up, clicking the button causes
single action—for example, you go to a different card, dial a telephone, or o
an application. But pop-up buttons present a range of choices. 

Press here to see choices… …and drag to the one you want.

The current style 
is checked.
Chapter 6: Working with Buttons
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Pop-up buttons are like collapsed menus you can put anywhere. You can
examples of pop-up buttons in any Field Info or Button Info dialog box. The 
Style pop-up menu is actually a pop-up button.

The name of the button appears at the button’s side (assuming that the S
Name option is checked), with the currently selected item showing in the 
collapsed window. 

When you set a button’s style to pop-up in the Button Info dialog box, an 
editable field called Title Width appears. Into this field you type a width (in
pixels) for the button name area. As soon as you type a width, you see the 
of your entry reflected in the Button Preview window. 

To add a list of menu items for the button, click the Contents button in the
Button Info dialog box and type a new line for each item. Click OK when 
you’re finished.

To use pop-up buttons effectively, you need to write scripts for them. You 
conditional statements to decide what will happen when a user selects a 
particular item. (For more information, see the HyperTalk Reference stac

Changing the look of button text
You can change the font, style, or size of the name that’s displayed on a b
by choosing commands from the Font and Style menus and by selecting 
options in the Text Style dialog box. 

To set the look of a button’s name using the Font and Style menus, follow
these steps:

1. Choose the Button tool ( ) from the Tools menu.

2. Click the button you want to change to select it.

A moving dashed line surrounds the selected button. 
Chapter 6: Working with Buttons 6-13
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3. Choose from the Font and Style menus to set the font, style, and size of the button’s text.    

The button’s name is displayed in the font, style, and size you’ve chos

A check mark appears next
to the font you choose.

Choose one or more styles to 
format text. Choose Plain to 
remove all other styles.

The best point sizes for the 
selected font appear outlined.

Choose Other to select a 
point size not shown.
Chapter 6: Working with Buttons



. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .

ok. 
 can 

ith 

ou 
en 
 just 

it. 
If you prefer, you can use the Text Style dialog box to set the button’s text lo
To do so, select the button and choose Text Style from the Edit menu. You
also click the Text Style button in the Button Info dialog box. 

❖ Note: You can’t change the style of text that’s displayed on a button w
an icon. ❖

Highlighting
Highlighting inverts certain buttons when you click them. In HyperCard, y
control what the highlight looks like, whether or not a button highlights wh
you press it, and whether it highlights on all cards in a given background or
on specific cards.

Making a button highlight when it’s clicked        
You can design a button so that it highlights momentarily when you click 
Such a button provides visual feedback that you clicked it. 

Click to select or
deselect one or more

text styles.

Click to select the font you want. (Or, double-click to 
select the font and return to your work quickly.) 

Click to select a 
font size.

This shows what your 
text looks like.

Click here to determine how the text 
is aligned on the button.

To use a font 
size not listed, type 
it here.
Chapter 6: Working with Buttons 6-15
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To create a momentary highlight, follow these steps:

1. Choose the Button tool ( ) from the Tools menu. 

2. Double-click the button. 

The Button Info dialog box appears. 

3. In the Button Info dialog box, check the Auto Hilite option.          

4. Click OK.

Auto Hilite works as described for a button of any style, except for a check
or radio button. When Auto Hilite is in effect for a checkbox or radio butto
clicking the button once highlights it and leaves it highlighted. Clicking the
button again removes the highlight.       

With the Auto Hilite option turned off, you receive no visual feedback 
when you click a button. Pop-up buttons, however, always behave as if A
Hilite is turned on. 

Making a button appear highlighted on certain cards       
Normally when you click a background button for which Auto Hilite is turne
on in the Button Info dialog box, the button becomes highlighted on every c
with that background. A background button for which Auto Hilite is turned o
never becomes highlighted when you click it. 

Background buttons have an additional option called Shared Hilite. When
Shared Hilite is turned off, the highlight of the button can vary from card t
card—the button may appear highlighted on some cards, and not on othe
You can use this effect to signify that something is true for some cards bu
for others. Checkboxes and radio buttons are particularly good for this purp
Chapter 6: Working with Buttons
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To allow a background button’s highlight to vary from card to card, follow 
these steps: 

1. Choose the Button tool ( ) from the Tools menu. 

2. Click the button whose highlight you want to vary from card to card.

3. Choose Button Info from the Objects menu.

The Button Info dialog box appears. 

4. Click the Shared Hilite checkbox to deselect it.        

When a background button is first created, this option is turned on. 

5. Click the Auto Hilite checkbox to select it, if it isn’t already selected. 

6. Click OK. 

Now, if you want the button to appear highlighted on any particular card, y
have to go to that card and click the button.    

Click Shared Hilite to 
deselect it.

Click Auto Hilite 
to select it.
Chapter 6: Working with Buttons 6-17



6-18

. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .

lects 
re 
hen 
 

ach 

.

ber 

For 
y the 

ing 
Creating a family of buttons
You create a family of buttons when you want to make sure that a user se
only one out of a series of options. A button family is a group of two or mo
buttons that share the same family number in the Button Info dialog box. W
one button in a family is highlighted, all the other buttons in that family are
unhighlighted.

You can create up to 15 families on each card, and up to 15 families on e
background. To create a family of buttons, follow these steps:

1. Move to the card or background where you want to create the button family.

2. Choose New Button from the Objects menu.

A new button appears selected on the current card or background.

3. With the new button still selected, choose Button Info from the Objects menu.

The Button Info dialog box appears.

4. Select a style for the button from the Style menu.

You can use any style, but radio buttons are typically used for families

5. Select a family number from the Family menu. 

Unless you want to add this button to an existing family, choose a num
not already in use for a family in this domain.

6. Make other selections in the Button Info dialog box as appropriate to your needs.

7. Click OK.

8. Drag the button where you want it to be.

9. Repeat steps 2 to 8 for each button in this family.

Be sure to use the same family number for each button in this family.  
aesthetic reasons, you should also use the same button style (typicall
radio button style) for each button in the family.        

When you add a button to a family (that is, give it a family setting of anyth
except “none”), its Auto Hilite option is automatically turned on.
Chapter 6: Working with Buttons
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Family-making timesaver
If the only difference between buttons in a family is the button name, you 
save time by following these steps:

1. Follow steps 1 to 7 in the previous procedure.

2. Option-drag the new button where you want it to be.

This creates and drags an exact copy of the button.

3. Repeat step 2 as many times as necessary.

4. When you have created enough buttons, double-click each button to bring up its Button Info 
dialog box and rename the button.

You can add or remove a button from a family at any time. 

❖ Prime the highlight pump.When you first assign existing buttons to a 
family, some of the buttons may already be highlighted. Click any butt
in the family to set the initial highlight and to turn off all other 
highlights. ❖

Working with Icons        
Displaying an icon on a button is one good way to indicate visually what t
button does. An icon you assign to a button becomes part of the button. W
you select the button and drag it around on the card, the icon moves with

Assigning, changing, or removing an icon 
To assign a new icon to a button, change a button’s icon, or remove a but
icon, follow these steps:

1. Choose the Button tool ( ) from the Tools menu.

2. Double-click the button you want to work with. 

The Button Info dialog box appears. 

3. In the Button Info dialog box, click Icon. 

The Icon Chooser dialog box appears.
Chapter 6: Working with Buttons 6-19
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4. Select an icon for the button, or remove the icon.       

5. Click OK. 

Your button displays the icon you’ve chosen. 

Combining text with an icon       
You can add text to a button that already has an icon. Follow these steps

1. Choose the Button tool ( ) from the Tools menu. 

2. Double-click the button. 

The Button Info dialog box appears. 

To display an icon on the 
button (or assign the 
button a different icon), 
click to select the icon 
you want.

Click here if you want to 
remove the button’s icon.      

Scroll, if necessary, to 
find the icon you want to 
display on the button.   
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3. Type the text you want to add to the button in the Button Name field. 

4. Make sure the Show Name option is checked. 

5. Click OK. 

The text appears along with the icon on your button. To see all the text,
may have to enlarge the button: 

❖ Note: You can’t change the style of text on a button with an icon.❖

Creating a new icon           
Using the HyperCard Icon Editor, you can modify the icon displayed on a
button, create an icon of your own, add icons to your stacks, and copy an
move icons between stacks. To create a new icon, follow these steps:

1. Choose Icon from the Edit menu (or press x-I). 

The Icon Editor opens. If you haven’t created an icon, and no icons ar
attached to this stack, the New Icon dialog box appears and you can s
the next step. 

To resize the button, drag from any corner.
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2. Choose New Icon from the File menu (or press x-N). 

Any icon already in the Icon Editor clears, preparing for you to draw a
new icon.

3. Draw the icon using the icon tools and the commands in the Icon Editor menus.

See “Icon Editor Menus and Tools” later in this chapter for instructions

4. Give the icon a name and/or an ID, if you want.

HyperCard assigns a unique ID to each icon if you don’t provide one.

5. When the icon looks the way you want it, click OK to save the icon in your stack (or choose 
New Button from the Edit menu if you decide you want to assign the new icon to a button now). 
    

The Icon Editor closes and your card appears. Your new icon is saved
the current stack. You can see it in the Icon Chooser dialog box (and as
it to other buttons) whenever this stack is open. 

If you’ve chosen the New Button command, a selected button with the n
icon appears in the center of the card. 
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Modifying a button’s icon        
To modify the icon of an existing button, follow these steps:

1. Choose the Button tool ( ) from the Tools menu.

2. Click the button to select it.

3. Choose Button Info from the Objects menu (or double-click the button). 

The Button Info dialog box appears.     

4. Click Icon.

The Icon Chooser dialog box displays icons that are part of HyperCar
your Home stack, and any stacks or other files you have open that ha
icons assigned to them:       

The ID, name, and
file location of the

selected icon
The selected icon is 
the one currently 
assigned to the 
button.

You can change the 
icon on the button 
by clicking a 
different icon. 

Click here to edit the selected icon.       
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5. Click Edit.

If the selected icon isn’t part of the current stack, the following dialog 
box appears:

If the icon isn’t already part of the current stack, HyperCard makes a c
of the icon and adds it to the current stack. The Icon Editor opens:

6. Edit the icon using the icon tools and the commands in the Icon Editor menus.

See “Icon Editor Menus and Tools” later in this chapter.   

Click OK to add the
icon to the current

stack and edit the icon.

If you click Cancel, the Icon 
Editor closes without adding 
the icon to your stack.

Use the scroll bar to see and edit 
other icons attached to this stack.

HyperCard assigns a unique 
ID to each icon—or you 
can use your own.

What the icon looks like 

Number of icons 
attached to this stack
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7. Give the icon a name and an ID.

HyperCard assigns a unique ID to each icon if you don’t provide one.

8. When the icon looks the way you want it to, either click the scroll bar to go to another icon or 
click OK.

If you click the scroll bar in the Icon Editor to go to another icon after 
editing the current one, HyperCard asks whether you want to save 
your changes. 

The only icons you see when you move around in the Icon Editor are th
attached to the current stack. If the icon you’ve been working on was 
copied from another stack, the changes you make affect only the copy
the icon in the current stack. The original remains intact in the stack it ca
from (or in the HyperCard file, if it’s part of HyperCard).

When you click OK, the Icon Editor closes, and the edited icon appear
the button. This icon is now part of your stack. You can see it in the Ic
dialog box (and assign it to other buttons) whenever this stack is the cu
one. 

❖ Quick Icon Editor access:To open the Icon Editor quickly, choose the 
Button tool from the Tools menu, click the button whose icon you want
modify, and press x-I. ❖     

❖ About ID’s: An ID is a unique identification number that HyperCard 
attaches to objects (backgrounds, cards, fields, buttons—but not stack
and icons. HyperCard assigns the ID when the object or icon is created
ID remains unchanged for the life of an object; however, you can chan
the ID of an icon. In most cases, the ID of an object or icon is of intere
only to advanced HyperTalk scripters.❖
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Icon Editor menus and tools 
This section describes the menu items in the Icon Editor and the Icon Edi
tools for modifying an icon’s appearance. 

As you make changes to an icon in the Icon Editor, they’re reflected in the
small picture to the right of the magnified icon. 

Icon tools
The Icon Editor has three tools for working with icons: Pencil, Select, and
Hand. A tool appears when you roll the mouse over the icon editing area 
hold down a key as described in the following table. 

Shift-drag with any of the tools to limit vertical or horizontal movement.

Use this tool…
…by holding 
down this key... …to perform this function

Pencil (none) Turn a pixel on or off in the icon window (drag to turn on o
off more than one pixel).

Select Command Select some or all of the image in the icon window; then c
or paste.

Hand Option Move the current image around in the icon window. The 
image is clipped at the borders of the icon editing area.

As you create or edit the icon in 
the editing area to the left, you 
can see the actual icon size here.
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Icon Editor menus      
When the Icon Editor opens, the menu bar displays the following menus: F
Edit, Icon, and Special. You use the commands in these menus for 
manipulating icons and moving from one icon to another in the Icon Edito

File menu
The following table describes the commands in the File menu.

Edit menu
The Edit menu has the usual edit commands (Undo, Cut, Copy, Paste, C
The last command, New Button, creates a new button on the current card
background (if Background is the currently selected layer) using the imag
the icon currently in the Icon Editor. The Icon Editor closes, and you end 
back at the current card or background with the new button selected.

Command Keyboard shortcut What the command does

New Icon x-N Creates a new (blank) icon in Icon Editor dialog box,
first presenting the chance to save any unsaved 
changes to the current icon; clears the Icon Editor 
window; assigns a default ID to the new icon.

Close Icon Editor x-W Closes Icon Editor, presenting the chance to save an
unsaved changes to the current icon.

Duplicate Icon x-D Duplicates the current icon, first presenting the 
chance to save any unsaved changes to the current
icon.

Quit HyperCard x-Q Quits HyperCard, first presenting the chance to save
any unsaved changes to the current icon.
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Icon menu
The following table describes the commands in the Icon menu.

Command Keyboard shortcut What the command does

Erase Power key E* Erases the whole image of the current icon.

Pickup x-P Turns the pointer into a “snapshot” tool, a small box
that you can move anywhere on the screen. When yo
click, the image under the box appears in the Icon 
Editor.

Keep     x-K Saves any changes you’ve made to the icon without
leaving the Icon Editor.

Revert Power key R* Reverts to the last saved image of the icon, discardi
any changes you’ve made since.

First x-1 or x-← Goes to the first icon in the current stack. 

Prev x-2 or ← Goes to the previous icon in the current stack. 

Next x-3 or ↑ Goes to the next icon in the current stack. 

Last x-4 or x-↑ Goes to the last icon in the current stack. 

Find x-F Searches for a specific icon by name or ID. 

* Power keys work when you have the Power Keys option selected on the Preferences card
your Home stack. Striking a single key does the work of choosing a specific menu command
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Special menu
The following table describes the commands in the Special menu.

Working with a selected part of an icon
When an area of the icon is selected, the commands in the Special menu
only on the selected area, as do the commands Undo, Cut, Copy, Paste, 
Clear in the Edit menu. Power key O (the letter O, not zero) makes the sele
opaque (hiding whatever it’s over when it appears on a card), and Power k
makes it transparent (letting “white” areas show whatever is beneath when
icon appears on a card). 

If you Option-drag a selected area, you create a copy of the selection. 

Command Keyboard shortcut What the command does

Flip Horizontal Power key H* Flips the icon horizontally around an imaginary center
axis.

Flip Vertical Power key V Flips the icon vertically around an imaginary center axi

Frame Power key F Draws a border around the entire icon.

Gray Power key G Dims the icon.

Invert Power key I Makes the icon appear in inverse—black squares beco
white, and white squares become black. 

Mirror Horizontal Power key M Makes the right half of the icon a mirror image of the le
half.

Mirror Vertical Power key X Makes the bottom half of the icon a mirror image of the
top half.

   (not in menu) Power key [ Rotates the icon 90° counterclockwise. 

Rotate 90° Power key ] Rotates the icon 90° clockwise. 

Shadow Power key S Draws a shadow to the right and bottom of the image

* Power keys work when you have the Power Keys option selected on the Preferences card
your Home stack. Striking a single key does the work of choosing a specific menu command
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Duplicating an icon in the current stack          
To create an icon that looks similar to an icon you already have, start by 
duplicating the one you have. You can duplicate an icon in the current stac
copy it to another stack using the Icon Editor. 

To duplicate and modify an icon in the current stack, follow these steps:

1. Choose Icon from the Edit menu (or press x-I). 

2. Do one of the following:

■  Scroll through the icons to find the one you want to duplicate.

■ Choose Find from the Icon menu to search for the icon by name or

3. Choose Duplicate Icon from the File menu.        

HyperCard creates a new icon in the current stack that’s an exact cop
the original icon, except the ID of the copy is one number higher than 
ID of the original (or the next available ID, if that one is taken). Initially
the icon has no name. 

4. Edit the new icon. 

Use the methods described in “Icon Editor Menus and Tools” earlier in
this chapter.

5. Click OK to leave the Icon Editor and save the icon. 

Click the arrows or the
scroll bar to scroll through

the icons, one at a time.
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Getting an icon from another stack
You can’t see an icon in a stack, or assign it to a button, unless it’s stored
that stack, with your Home stack, or with HyperCard itself. If you see an ic
in another stack that you’d like to use in one of your stacks, you can copy
move it into your stack by following these steps:

1. Go to a stack that has the icon you want to copy or move. 

2. Choose Icon from the Edit menu (or press x-I). 

3. Scroll through the icons to find the one you want (or choose Find from the Icon menu to search 
for the icon by name or ID).        

❖ Another way to get to the icon:Select a button that has the icon on it (if 
there is one), and then press x-I. The Icon Editor opens with that icon 
displayed in it.❖ 

4. Choose Copy Icon from the Edit menu.     

This puts a copy of the current icon onto the Clipboard.     

5. Click OK to close the Icon Editor.

6. Go to the stack where you want the icon.

7. Choose Icon from the Edit menu.

8. Choose Paste Icon from the Edit menu.      

The pasted icon appears in the Icon Editor.

You can edit the new icon (as described in “Icon Editor Menus and Too
earlier in this chapter), click OK to leave the Icon Editor and save the ic
or click Cancel to discard the pasted icon and leave the editor.     

❖ Be sure to attach icons to your stack.An icon that you see in your stack 
might not be part of that stack—it could be part of your version of 
HyperCard or part of your Home stack. If an icon that you’re using isn
part of the stack, other people may be unable to see it when they use 
stack on their own systems. Icons that are attached to your stack appe
the Icon Editor. To attach an icon to your stack, select it in the Icon Choo
window; then click Edit. A dialog box appears if the icon is not already p
of your stack, asking if you want to make it so.❖
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Deleting an icon from a stack       
When you have icons in your stack that you no longer need, you can dele
them to save disk space. Follow these steps:

1. Choose Icon from the Edit menu to open the Icon Editor.

2. Scroll through the icons to find the one you want to delete (or choose Find from the Icon menu 
to search for the icon by name or ID). 

3. Choose Clear Icon from the Edit menu.        

This removes the icon from the stack for good—the Undo command c
bring it back. 

4. Click OK to close the Icon Editor.   

    

Linking Information             
To create a link between related pieces of information, you create a button
link it to another card or stack. When you click a button that’s linked to anot
card, that card appears immediately.

 Links are one way. To move back and forth between two cards, you need
links—one in each direction:
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You can link a button to a card or stack using any of the following method

■ Use the LinkTo box. 

■ Write a short script.

■ Use the special linking tools in the Readymade Buttons stack.

Using the LinkTo method        
To use the LinkTo method for linking a button to any card or stack, follow
these steps: 

1. Create a new button.

2. With the Button tool still selected, double-click the button you want to link .

The Button Info dialog box appears.         

3. In the Button Info dialog box, click LinkTo. 

The LinkTo box appears:

❖ LinkTo is not like standard dialog boxes.The LinkTo box doesn’t work 
like a standard Macintosh dialog box. You don’t respond right away wh
you see the LinkTo box; you first use the HyperCard navigation metho
(such as the Go menu commands) to locate the card or stack to which
want your button linked.❖ 

4. Before you click a button in the LinkTo box, go to the card you want to link the button to.

The LinkTo box doesn’t disappear—it stays on the screen while you m
from card to card. If the LinkTo box gets in your way, you can drag it b
its title bar to another location.

You can close the LinkTo
box without creating a link
by clicking the close box or

the Cancel button.
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5. When you’re looking at the card or stack you want to link the button to, click the option in the 
LinkTo box that reflects where you want the button to take you. 

Click the This Card option if you want to link the button to the current ca
Click the This Stack option to link the button to the first card in the curre
stack (no matter which card you’re looking at). 

After you click one of these options, HyperCard returns you to the card 
contains the button you’ve just linked with the button still selected. 

6. To test your new link, choose the Browse tool from the Tools menu and click the button.

You should end up on the card you’ve just linked to. If not, repeat the 
LinkTo procedure or try the scripting procedure described in the next 
section, “Scripting a Link.”      

❖ LinkTo replaces the previous link.If you use the LinkTo method to link a 
button that already has a link, the new link replaces the previous one.❖  

Scripting a link              
As an alternative to using the LinkTo box, you can write a script that links
button to another card or stack. To do this, you must have your user level s
Scripting, as explained in “User Levels and Options” in Chapter 1. 

Follow these steps to script a link: 

1. If you’re linking the button to a specific card, find out the card’s name, number, or ID. 

To find this information, go to the card and choose Card Info from the 
Objects menu. 
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The Card Info dialog box appears. Make a note of the card’s name, num
or ID:         

2. Go to the card that contains the button for which you’re creating a link. 

3. Press and hold the x and Option keys while you click the button once.

The button’s script opens. It should look like this:

4. If you didn’t create this button especially for this task, and if there’s any text in the script other 
than the figure, don’t go any further. 

The additional text indicates that the button is designed for another 
purpose. Unless you’re familiar with HyperTalk, it’s best to close the scr
by clicking its close box, and then create or find another button to link.

Card’s name

Card’s positional 
number relative to other 
cards in this stack

Card’s ID
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5. If the script looks like the figure, type any of the following, substituting the card name, card 
number, card ID, or stack name for the card or stack you want to link the button to: 

6. Press Enter.

7. To test your new link, choose the Browse tool from the Tools menu (if it isn’t already selected) 
and click the button. 

You should end up on the card you wrote the script for. If not, check y
script for typos and make sure the card name, number, or ID matches
one you typed in the script.                            

Adding a visual effect         
You can add visual effects to HyperCard buttons to make movement betw
cards and stacks more noticeable and visually interesting. For example, y
can add a visual effect that produces an image of a venetian blind closing
you move from one card to another. Or, you can add a visual effect that m
one card seem to fade away gradually as the next one appears.

Takes you to the card with the specified name

Takes you to the card with the specified number

Takes you to the card with the specified ID

Takes you to the stack with the specified name

Takes you to the card with the specified card 
name in the stack with the specified stack name
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To add a visual effect to a button, follow these steps:

1. Choose the Button tool ( ) from the Tools menu. 

2. Double-click the button. 

The Button Info dialog box appears. 

3. In the Button Info dialog box, click Effect. 

4. Choose a visual effect for the button: 

5. Click OK.

To test the new visual effect, choose the Browse tool from the Tools menu
click the button. You see the visual effect as you go to the card that the but
linked to. 

The name of the
selected visual effect

appears here.

Click one of these 
buttons to select how 
quickly the effect 
appears and disappears.

Click an item in this list to select a 
visual effect for your button.
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❖ Visual effects happen on links:You don’t see the visual effect unless the
button is linked to a card or stack. “Linking Information” earlier in this 
chapter explains how to link a button to a card or stack.❖ 

To see what all the visual effects do, repeat this procedure to assign diffe
visual effects to buttons. 

❖ Visual effects on multiple monitors:If you’re using more than one monitor
with your computer, the visual effect won’t show if the card window spa
across monitors.❖ 

Copying a Button        
You can duplicate a button on the same card, or copy a button to another 
background, or stack. When you copy a button, you also copy its attributes
style, name, icon, script, and so on. 

Copying a button on the same card         
To duplicate a button on the same card or background, follow these steps

1. Choose the Button tool ( ) from the Tools menu.

2. Click the button you want to copy to select it.

You can select the button from the card layer, whether it’s a card butto
a background button. A moving dashed line surrounds the selected bu

3. Option-drag the button.        

As you drag, you create an exact duplicate of the button. If the original
background button, the duplicate is a background button. If the origina
a card button, the duplicate is a card button. 

To limit its movement to a horizontal or vertical direction only, Shift-dra
the button.
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Copying a button to another card or background       
To copy a button to another card or background, follow these steps: 

1. Choose the Button tool ( ) from the Tools menu. 

2. Click the button you want to copy to select it. 

3. Choose Copy Button from the Edit menu.

You can also press x-C. A copy of the selected button (including its scrip
goes on the Clipboard, replacing whatever was on the Clipboard befo

4. Go to the card or background where you want the button to appear.

Use the arrow keys or commands in the Go menu to navigate 
between cards.

5. Choose Paste Button from the Edit menu.

You can also press x-V. The copy of the button on the Clipboard goes on
the current card or background, with the button selected. 

If you copied a background button to the card layer of the same card, 
copy is pasted directly over the original. To see the original, you have
drag the copy away. 

6. While it’s still selected, drag the button to where you want it. 

After you copy a button from another card or stack, test the button to make
it works properly. To test the button, choose the Browse tool and click the
button. If clicking the button produces a message that begins with “Can’t 
Understand …” or “Never heard of …”, see “Copying Parts from Other 
Stacks” in Chapter 4 for advice on how to proceed.         
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Moving a Button Around on a Card or Background
You can move a button wherever you like on the card or background. To 
reposition a button on the card or background, follow these steps:

1. Choose the Button tool ( ) from the Tools menu. 

2. Click the button you want to move to select it. 

Whether the button is in the card layer or the background layer, you c
select it from the card layer. A moving dashed line surrounds the sele
button. 

3. Drag either from the middle of the button or from one of its edges (not a corner): 

To limit its movement to a horizontal or vertical direction only, Shift-drag th
button. You can select and move only one button at a time. 

❖ Check the button on all cards:After you reposition a background button
look through the cards on which the button appears to make sure it isn
obscured by any card objects.❖         

Avoid dragging from the
corners or you’ll change

the size of the button.
Drag from the button’s 
center to move it.
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Moving elements from layer to layer              
HyperCard puts different kinds of elements into different layers. Together
these layers make up the card you see. 

Background buttons and fields collectively go on a different layer than do c
buttons and fields. Within each of these layers, HyperCard places each n
button or field you add (whether you’ve created it or copied it) on its own 
sublayer in front of the button or field that you added immediately before it. 
front of” means closer to you.

Background picture

Background buttons 
and fields

Card picture

Card buttons and fields

What you see when 
you look at the card

The background 
picture is fixed in a 
layer by itself—it’s 
always behind the 
background buttons 
and fields and all the 
card elements.

The card picture is also 
fixed in a layer by 
itself—it’s always 
behind the card buttons 
and fields, and in front 
of all the background 
elements.
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Button numbers and field numbers
HyperCard assigns numbers to the buttons and fields as you add them. Th
field you add is field number 1, the second is field number 2, and so on. 
Likewise, the first button you add is button number 1, the second is button
number 2, and so on. The numbers reflect how far away the elements are
you—the farther away an element is, the lower its number. These numbe
appear in the Button Info and Field Info dialog boxes as the card or backgro
button number or field number.     

Part numbers
Although HyperCard numbers the buttons and fields separately, it places 
new element immediately in front of the previous element (within the sam
layer), whether it’s a button or field. HyperCard also assigns a part number to 
each button and field. The element’s part number appears in its Info dialog 

While the button or field number refers to the position of that element (clo
or farther away from the front) within the set of other elements of its kind o
given card or background, the part number refers to the position of that elem
within the combined set of both buttons and fields on a given card or 
background. For example, if the ordering of buttons and fields within a car
card field 1, card field 2, card button 1, and card field 3, the part number of 
button 1 is 3.

This was added first.

This was added second.

This was added third.
This was added fourth.

This was added fifth.

This was added sixth.
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Overlapping parts
HyperCard numbers the card buttons and fields separately from the 
background buttons and fields. The card elements are always in front of a
background elements. 

This layering of buttons and fields becomes evident when the elements ove
Elements that are closer to you can obscure elements that are farther aw
this happens, you can either move the elements apart so they don’t overla
you can try either of the following: 

■ Reorder the buttons and fields. You can move any button or field close
farther, within its layer. 

■ Make some of the elements transparent, so you can see other elemen
through them. Buttons, fields, and graphics can all be made transpare
or opaque.

The following sections describe these solutions.          

Reordering elements                  
Overlapping buttons and fields can cause visual and functional problems 
your stack. For example, a button covered by a field (or by another button
can’t respond when you try to click it. To solve the problem of overlapping
buttons and fields, you can reorder them to bring the ones you need to se
use into full view. 

❖ Card objects are always in front of background objects:The buttons and 
fields in the card layer are always in front of the background buttons a
fields. Although you can reorder the background buttons and fields rela
to one another, you can never move them closer to you than any of the
elements. You can, however, make card elements transparent so you c
see through them to the background elements, as explained in the ne
section. ❖

❖ Button techniques work with fields:While the techniques mentioned in 
this section are phrased in terms of buttons, they work equally well for
fields. ❖ 
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To move a button closer or farther (relative to the other buttons and fields
the same layer), follow these steps:

1. Choose the Button tool ( ) from the Tools menu. 

2. Click the button you want to move closer or farther to select it. 

A moving dashed line surrounds the selected button. 

3. Choose Bring Closer from the Objects menu to move the button forward one position, or 
choose Send Farther to move it back one position.         

Each time you move a button back one position relative to another bu
in the same layer, its button number and part numbers in the Button In
dialog box decrease by one. Each time you move a button forward on
position relative to another button in the same domain (card or 
background), its button and part numbers increase by one. 

4. Repeat step 3 until the button is where you want it. 

5. Choose the Browse tool ( ) to deselect the button.

You can move the selected button all the way forward (giving it the highest 
number, equal to the sum of all the buttons and fields in its domain) or all
way backward (giving it a part number of 1) using these x-key shortcuts: 

As you reorder buttons, the numbers of all the affected buttons change to re
their new positions. Each button’s part and button numbers (shown in the
Button Info dialog box) reflect its front-to-back position, relative to the oth
elements in the same layer. (The button farthest away is button number 1
its part number will be the lowest of all the buttons in that layer. The close
button is to the front relative to other elements in the same layer, the high
its number.) 

To do this … Press

Send the button to the back. x-Shift- – (minus) 

Bring the button to the front. x-Shift- + (plus) 
Chapter 6: Working with Buttons
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❖ You can use scripts to reorder buttons:Sometimes it’s useful to reorder 
fields and buttons while a stack is running. In such a case—especially
your stack will be used by people who don’t know all of HyperCard’s 
subtleties—you must write a script to do it. For example, to make sure 
button “Home” is front-most, you can use a line of code like this:

   set the partNumber of card button "Home" ¬

   to the number of parts

See the HyperCard Script Language Guide for details. ❖

❖ The button and part numbers change, not the button ID:A button’s ID 
remains constant, no matter where the button is relative to other butto
and fields.❖    

Making a button opaque or transparent              
To see background or card elements through a button that covers them, yo
make the button transparent. Conversely, to give a button more prominen
you can make it opaque. 

Follow these steps to make a button opaque or transparent:

1. Choose the Button tool ( ) from the Tools menu.

2. Click the button you want to change to select it.

3. Choose Button Info from the Objects menu.      

4. Choose the appropriate button style from the Style pop-up menu to make the button opaque 
or transparent.    

5. Click OK.

❖ Most button styles are opaque:In one way or another, most button style
don’t let what’s beneath them show through. The only truly transparen
styles are the styles Transparent and Oval.❖
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Moving a Button Around in the Stack
You’ll often find after you’ve created a button that it’s in the wrong place—i
on the card layer when it should be on the background, it’s in the backgro
when it should be on the card layer, or it’s on the wrong card altogether. T
section shows you how to move a button around within the current stack.

Moving a button from the card to the background          
It’s easy to put a button in the card layer by mistake when you intend to p
in the background. If this happens, you can move the button from the card l
to the background layer (of the same card) by following these steps: 

1. Choose the Button tool ( ) from the Tools menu. 

2. Click the button you want to move to select it. 

A moving dashed line surrounds the selected button. 

3. Choose Cut Button from the Edit menu.      

This removes the button from the card and puts it on the Clipboard. 

4. Go to the background layer.

Choose Background from the Edit menu. 

5. Choose Paste Button from the Edit menu. 

This takes a copy of the button on the Clipboard, puts it in the current 
background, and selects it. The pasted button appears in the same po
from which it was cut. 

6. While it’s still selected, drag the button to where you want it.

Because you can’t see the elements in the card layer while you work in
background, you may be unable to tell whether you’re putting the butto
the right place. If this happens, you can choose Background from the 
menu again to go back to the card layer, and then select and drag the b
from the card layer. 
Chapter 6: Working with Buttons
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Moving a button from the background to the card      
Follow these steps to move a button from the background layer to the card 
of the same card: 

1. Choose the Button tool ( ) from the Tools menu. 

2. Click the button you want to move to select it. 

A moving dashed line surrounds the selected button. 

3. Choose Cut Button from the Edit menu.         

This removes the button from the background and puts it on the Clipbo

4. If you’re in the background layer, go to the card layer by choosing Background from the 
Edit menu. 

If you’re already in the card layer, skip this step. 

5. Choose Paste Button from the Edit menu. 

This takes a copy of the button on the Clipboard, puts it on the current c
and selects it. The pasted button appears in the same position from wh
was cut. 

6. While it’s still selected, drag the button to where you want it.
        

Moving a button to another card or background           
You can move a button to another card in the same stack, or to a card in an
stack. When you move a button, its attributes—it’s style, name, icon, scrip
and so on—move with it. 

Follow these steps to move a button to another card or background: 

1. Choose the Button tool ( ) from the Tools menu. 

2. Click the button you want to move to select it.

A moving dashed line surrounds the selected button. 
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3. Choose Cut Button from the Edit menu. 

This removes the selected button from the current card and puts it on 
Clipboard. 

4. Go to the card or background where you want to put the button.

Keeping the Button tool active, use the arrow keys or commands in the
menu to navigate between cards. 

5. Choose Paste Button from the Edit menu.        

This takes a copy of the button on the Clipboard, puts it on the current 
or background, and selects it. 

6. While the button is still selected, drag it to where you want it on the card. 

After you move a button from another card or stack, test the button to ma
sure it works properly. To test the button, choose the Browse tool and click
button. If clicking the button produces a message that begins with “Can’t 
understand …” or “Never heard of …”, see “Copying Parts from Other Stac
in Chapter 4 for advice on how to proceed.            

Opening a Button’s Script       
Looking at the script of a button is a good way to learn how the button wo
To look at a button’s script, you must have your user level set to Scripting. H
are four ways to open a button’s script:        

■ With the Browse tool or Button tool selected, press and hold the x key and 
the Option key while you click the button. 

■ With the Button tool selected, press and hold the Shift key while you 
double-click the button.          

■ Choose the Button tool from the Tools menu, click the button to select
and hold down the Shift key while you choose Button Info from the 
Objects menu.          

■ Choose the Button tool from the Tools menu, double-click the button t
open the Button Info dialog box, and then click Script. 

To close a script, click its close box or press Enter. (For details about 
HyperCard scripts, read the HyperCard Script Language Guide.)  
Chapter 6: Working with Buttons
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Deleting a Button        
You can remove a button from a stack by following these steps:

1. Choose the Button tool ( ) from the Tools menu. 

2. Click the button you want to delete to select it. 

3. Choose Clear Button from the Edit menu, or press Delete or Backspace.        

To retrieve a button you have just deleted, choose Undo from the Edit men
press x-Z).
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Chapter 7
Working with Text and Fields

Text is a major component of most HyperCard stacks, particularly stacks 
designed for managing large amounts of information. 

Most of the stack text is in fields—rectangular areas on a card where you ca
type and edit text easily. This chapter gives instructions for working with t
in fields. 

To do all the tasks in this chapter, you must have your user level set to 
Scripting. (“User Levels and Options” in Chapter 1 tells you how to set yo
user level.)
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Adding Visible Text         
HyperCard has three types of visible text: 

■ text stored in a field 

■ text attached to a button        

■ paint text 

For most purposes, it’s best to use fields to add text to a stack. Field text is
to edit; you can select any part of the text in a field and change it, move it, c
it, or delete it. You can also move field text around on a card by selecting 
dragging the field. And you can search for specific text in fields. 

You can use the Shared Text option to create a background field that disp
the same text on every card, which means you can create text labels mad
of editable text.         

You can also use buttons to add text labels to a card or background. A bu
can’t show much text, but button text is easy to move around on the card
because it moves when you move the button.

Paint text can’t be edited. Once you finish typing paint text, it “dries.” To 
change it, you have to erase it and retype it. Paint text is useful for adding
permanent label to a graphic. And you can create special effects with pain
using commands in the Options menu which appears whenever a Paint to
selected. (Chapter 8 describes paint text.)
7-2 Chapter 7: Working with Text and Fields
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Deciding Where a Field Belongs                   
To create a place for text, you add a field to a card or background. When
you add a field, you need to decide whether you want to put it in the card l
or the background layer. To decide where to put the field, consider where
want the field to appear, and where you want its text to appear: 

■ If you want the field and its text to appear only on one card, put the field
the card layer.        

■ If you want the field to appear on every card in the stack, or in a major
section of the stack, but you want to type different text into the field on e
card, put the field in the background layer. 

■ If you want the field to appear on every card in the stack, or in a major
section of the stack, and you want it to display the same text on each c
put the field in the background layer and turn on the Shared Text optio
the Field Info dialog box. 

■ If you want a field to appear on some of the cards in the stack, but not
of them, create a different background for those cards and put the fiel
that background only. (“Creating a New Background” in Chapter 5 
explains how to add a background to a stack.) 

A background field appears in the same location on all the cards that shar
background. 

Paint text in the card layer

Field text that changes 
from card to card

A background button that displays text
Chapter 7: Working with Text and Fields 7-3
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To add a field to a background, you must be in the background layer; to a
field to a card, you must be in the card layer. To go to the background lay
press x-B. When you’re in the background layer, stripes appear in the me
bar. If you press x-B repeatedly, you move back and forth between the car
layer and the background layer.         

❖ Wrong layer?The most common mistake in adding a field is putting it i
the card layer when you want it in the background layer. (To find out 
whether the field is in the background layer, press x-B to see just the 
background elements.) If you put a field in the card layer by mistake, s
“Moving a Field from the Card to the Background” later in this chapter.❖ 

Tools for Working with Fields          
To work with fields and field text, you need both the Field tool and the 
Browse tool: 

To make it easy to alternate between the tools, you can “tear off” the Too
menu to create a movable Tools palette. To do it, drag down past the bottom of
the menu or beyond either side.

You can use the following x-key shortcuts to choose the tools you need for
working with fields:  

To do this… …press this

Tear off Tools menu Option-Tab

Select Browse tool x-Tab 

Select Field tool x-Tab-Tab-Tab 

Use the Field tool for creating 
and manipulating fields.     

Use the Browse tool for 
entering and editing text 
(in addition to browsing).
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  Field Info dialog box
You use the Field Info dialog box to get information about a field and to s
field characteristics.

To get to the Field Info dialog box:

1. Choose the Field tool on the Tools menu.

2. Click the field you want to work with once.

3. Choose Field Info from the Objects menu.

You can also double-click the field you want to work with in step 2 and s
step 3.

Prevents text from being 
entered or changed.

Adds rules below text (except 
in scrolling fields).

Insertion point moves to next field 
when you press Return from last line.

Keeps space between lines constant 
even if text size of individual 
characters changes.

Stops automatic text wrap 
at right edge of field.

Prevents Find from 
looking in field.

Clicked line highlights 
in locked field.

User can Shift-select multiple
lines for highlighting in 
locked field.

Makes text in a background 
field appear on all cards 
in the background.

Layer of this object relative
to others in this domain

(card or background)

Layer of this field relative
to others in this domain

(card or background)

How this field looks
with the current
options selected

Adds margins along the left 
and right edges.
Chapter 7: Working with Text and Fields 7-5
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Copying ready-made fields         
HyperCard comes with a special stack called Readymade Fields that con
fields you can copy and paste into your stacks. These fields have 
pre-programmed scripts that add power and versatility to your stacks.     

The Readymade Fields stack includes fields that automatically display the 
time, current card number, or calendar months. This stack also has fields
expand or shrink when you click them, fields that perform calculations on
values you type into them, fields that sort their text alphabetically, fields th
perform metric conversions, and much more. 

You don’t need to know HyperTalk to make these fields work. You just ne
to understand what they do, so that you can use them appropriately in yo
stacks. These fields are designed to work in virtually any stack. They don
depend on your stack’s structure in any way. 

Fields that convert measurements you type in them:A field that always displays the current date:

A field that always displays the current 
card number:

A field that always displays the current time:
A field that always displays the current month’s 
calendar when you click it:

Fields that can perform calculations on 
numbers you type in them:
7-6 Chapter 7: Working with Text and Fields
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Copying ready-made fields makes stack building easier and saves you tim
Follow these steps to copy one of the ready-made fields:        

1. Open the Readymade Fields stack.

2. Go to the card that has the field you want to copy. 

3. Choose the Field tool from the Tools menu (or click it on the Tools palette). 

The pointer changes to an arrow ( ). 

4. Click the field you want to copy to select it.

A moving dashed line surrounds the selected field. 

5. Choose Copy Field from the Edit menu.        

6. Go to the card or background where you want to put the copied field.

Keeping the Field tool active, use the arrow keys or commands in the 
menu to navigate between cards. 

If you’re not sure whether to put the field in the card layer or the 
background layer, see “Deciding Where a Field Belongs” earlier in this
chapter. 

7. Choose Paste Field from the Edit menu.    

This takes a copy of the field from the Clipboard, puts it on the current c
or background, and selects it. 

8. While the field is still selected, drag it to where you want it on the card.

If you want to enter text into the field after you copy it, choose the Browse to
then click in the field and type. 

❖ Can’t type into the field?Make sure you’re working in the card layer. If 
you see stripes in the menu bar (indicating that you’re working in the 
background layer), press x-B to return to the card layer.❖ 
Chapter 7: Working with Text and Fields 7-7
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Creating a field       
To create a new field, follow these steps: 

1. Go to the card or background where you want to put the field. 

2. Make sure you have one of the General tools selected.

3. Choose New Field from the Objects menu.      

This automatically selects the Field tool and creates a new rectangular f
The field appears in the center of the card window and is selected, so
can move it or resize it easily. 

❖ Another method:You can create a new transparent field by choosing th
Field tool and then x-dragging diagonally.❖ 

You can have as many fields on a card or a background as can fit. Fields
overlap to any depth.

Choose the Field tool and x-drag from here…

… to here.
7-8 Chapter 7: Working with Text and Fields
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Entering and Editing Text in a Field                
Entering and editing text in a HyperCard field is just like working with any
other Macintosh text. You can click anywhere in the field and begin typing
delete text with the Delete or Backspace key; and drag to select text for 
copying, cutting, or editing. You can also copy text to and from a field by w
of the Clipboard to and from other fields and applications.         

❖ Where’s the field?A transparent, empty field is invisible when the Field
tool isn’t selected. This makes it difficult to locate the field when you’re
ready to enter text into it. One way to locate the field is to move the Brow
tool around; the pointer turns into an I-beam when it’s over an editable
field. Another way to locate a transparent field is to press Tab repeate
which moves you through each editable field on the current card and 
background, one field at a time. If the field has text in it, the text is 
highlighted; otherwise, the insertion point shows in that field.❖ 

To enter and edit field text, follow these steps:

1. Choose the Browse tool  from the Tools menu. 

2. Move the Browse tool over the field you want to edit.

The Browse tool pointer turns into an I-beam  when it’s over an editab
field. If you don’t see the I-beam pointer, read the next section, “Wher
the I-Beam Pointer?”           

3. Click inside the field to position the insertion point where you want to enter or edit text.

You can also select text you want to replace. If you click in an empty fie
the insertion point appears at the left edge of the line you click.
Chapter 7: Working with Text and Fields 7-9
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4. Start typing. 

If you type more text than can fit in a field, the remaining text goes off t
bottom of the field. But this text isn’t lost, it’s just hidden from view. To
see the hidden text, make the field bigger. 

To see text you’ve typed 
beyond the borders of 
a field … 

… enlarge the field by choosing the 
Field tool from the Tools menu and 
then dragging from any corner.
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Where’s the I-beam pointer?
Sometimes the Browse tool doesn’t turn into an I-beam ( ) when you mov
over a field that you want to edit. Here are some typical instances when t
happens, and what you can do about it:     

■ The field is locked. To unlock the field, follow the instructions in “Lockin
and Unlocking a Field” later in this chapter. 

■ The Shared Text option is turned on in the Field Info dialog box and you
working in the card layer rather than the background layer. Press x-B to go 
to the background layer. (See “Making Field Text Appear on Every Ca
later in this chapter for more information about the Shared Text option

■ The Shared Text option is not turned on in the Field Info dialog box, and 
you’re working in the background layer rather than the card layer. Pre
x-B to return to the card layer. 

■ Your user level is set to Browsing. For instructions on changing the us
level, see “User Levels and Options” in Chapter 1.

■ The text you’re trying to edit is either paint text or button text, not field te
To see whether it’s field text, choose the Field tool from the Tools men
and click the text. If the area becomes selected (surrounded by a mov
dashed line), it’s field text; otherwise, it’s not. See Chapter 6 for 
information about changing the text on a button, or Chapter 8 for 
information on changing paint text.              

Preventing text wrap in a field        
Normally when you type into a field, your text wraps when it reaches the ri
side of the field—that is, words that don’t fit completely on the line move t
the next line. You can customize a field so that its text doesn’t wrap. When
use this feature, you don’t see the text you type beyond the right side of the
unless you press Return as you type to move from line to line.

To prevent text from wrapping in a field, follow these steps:

1. Choose the Field tool  from the Tools menu.

2. Click the field to select it.

3. Choose Field Info from the Objects menu (or double-click the field). 

The Field Info dialog box appears.
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4. Click the Don’t Wrap checkbox to select it.         

5. Click OK. 

Text won’t wrap as you type in the field, and it disappears from view if you
type beyond the right edge. Any text you type beyond the right side of the f
is still there; it’s just hidden. You can see it by turning off Don’t Wrap or b
enlarging the field. 

When you turn on Don’t Wrap for a field that already has text in it, HyperCa
continues to put text on the first line of the field, extending beyond the rig
edge of the field, if necessary, until it comes to a Return character. The tex
was below the first line disappears from view, but it’s still in the field. You c
see it again by turning off Don’t Wrap.       

Click here to prevent text 
from wrapping in a field as 
you type. 
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Using arrow keys to move through text         
Normally, the arrow keys move you through cards. But when the Arrow Ke
in Text option is selected on the Preferences card in your Home stack, you
use the arrow keys to move the insertion point through text while you’re typ
in fields. This makes text editing easier. 

When Arrow Keys in Text is turned on and the insertion point is blinking in
field or the Message box, you use the Option key with the arrow keys to m
through cards in a stack.

➤  See also: “Arrow Keys in Text Option” in Chapter 1.

Moves insertion 
point left 
through text

Moves insertion 
point right 
through text

Moves insertion point down through 
lines in a field, or to the end of the 
line in the Message box

Moves insertion point up 
through lines in a field, or to 
the beginning of the line in 
the Message box
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Moving from one field to another            
While you’re entering text into fields, you can move from one editable field
the next by pressing Tab. When you press Tab, you go to the field with the 
higher field number. Field numbers are assigned to fields in the order you
them. The first field you add is field 1, the second is field 2, and so on. If t
insertion point is in field 3 and you press Tab, the insertion point moves to f
number 4; if there are only three fields, the insertion point moves from fiel
to field 1. 

Pressing Shift-Tab moves you backwards through the fields. Locked fields
excluded; you can’t Tab to a locked field. 

▲ Warning: When you tab to a field that already contains text, all the tex
selected. Typing at this point erases all the old text in the field and repla
it with what you type. To preserve the old text and add new text to it, cl
in the field where you want to type. If you accidentally erase all the old te
immediately choose Undo from the Edit menu.▲

Pressing Tab takes 
you from here…

to here…

to here…

… and finally 
back to here.
7-14 Chapter 7: Working with Text and Fields



. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .

r) 
enu 
A field’s number (which determines the field’s position in the tabbing orde
appears in the Field Info dialog box. Choose the Field tool from the Tools m
and double-click the field to see the Field Info dialog box.        

This number determines
the field’s position in the

tabbing order.
Chapter 7: Working with Text and Fields 7-15



. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .

 

 to 
t is 
If you have both card fields and background fields on the card, pressing 
Tab takes you from one field to the next, according to the sequence in the
next figure. 

If the Auto Tab option is turned on in the Field Info dialog box, you can go
the next field by pressing Return (instead of Tab) when the insertion poin
in the last visible line of the field. 

To turn on the Auto Tab option for a field, follow these steps:      

1. Choose the Field tool  from the Tools menu.

2. Double-click the field.

3. Click Auto Tab to select it.

4. Click OK.

❖ Note: Auto Tab doesn’t work for a scrolling field.❖           
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Undoing your typing               
To undo typing mistakes while you’re editing field text, you can do any of t
following: 

■ Erase text to the left of the insertion point, one character at a time, by 
pressing Delete or Backspace. 

■ Drag to select the incorrect text and retype it, or press Delete or Backs
to erase it.

■ Choose Undo from the Edit menu (or press x-Z). Undo undoes your last 
text editing (or stack editing) operation.

Choosing the Look of Field Text           
You can determine the look of field text in two ways:

■ You can set the default text format including the font, size, style, alignm
and line spacing for the field as a whole. 

■ You can set the font, size, and style for individual characters, words, o
phrases in the field. 

The default text format options you choose for the field apply to the whole
field. All text you type in the field has these attributes unless you style it 
individually. 

Setting default attributes for field text           
To choose the default text attributes for a field, follow these steps:

1. Choose the Field tool  from the Tools menu.

2. Select the field by clicking it.

3. Choose Field Info from the Objects menu (or double-click the field). 

The Field Info dialog box appears.

4. Click Text Style. 

The Text Style dialog box appears. 

❖ Alternate method:You can also open the Text Style dialog box by clickin
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to select the field with the Field tool, and then choosing Text Style from 
Edit menu (or pressing x-T). ❖ 

5. Choose from the options in the Text Style dialog box to set the default text format for the field.

6. When you’re finished, click OK. 

The text in the field appears in the new default format, and any new te
you type into the field acquires the same format. 

❖ Losing text tops?If you set one font size for a field and change it to a larg
size later, the tops of the characters can disappear. To fix this, turn of
Fixed Line Height option in the Field Info dialog box. Doing so lets the li
height of the field vary to accommodate the size of your text.❖

To set just the font, size, and style for a field, click the field with the Field to
chosen and make choices from the Font and Style menus. 

❖ Preset size, style, and font:Text for new HyperCard fields is preset to 
12-point plain Geneva left-aligned.❖                     

If Fixed Line Height is on, 
you can change the default 
number of points between 
lines here.       

Type here to use a 
font size not listed.

This is what your text 
looks like.

The alignment you select applies 
to all the lines in a field.       

Click to select or deselect
one or more text styles.

See “Grouping Text” later
in this chapter for an

explanation of this style.

Click to select a font. (Or, double-click 
to select the font and close this box.)

Click to select a font size 
(measured in points).    
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Setting attributes for individual pieces of text            
You can change the attributes for individual characters in a field, overriding
field’s default settings for those characters. Here’s how:

1. Choose the Browse tool from the Tools menu. 

2. Drag with the I-beam pointer to select the text you want to change. 

If you don’t see the I-beam pointer, consult “Where’s the I-beam Pointe
earlier in this chapter. 

3. Choose Text Style from the Edit menu and make the changes you want.

Alternatively, you can make choices from the Font and Style menus.

Click to choose a font; a
check mark appears

next to the selected font. Click to choose one or 
more styles. 

Click to choose a point size for 
the text. The best sizes for the 
selected font appear outlined.

Choose Other to select a 
point size not shown.
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You can use the following x-key shortcuts while you’re working with 
individual pieces of field text:           

❖ Varying text sizes:If you set varying text sizes within a field and you wan
the field’s line height to adjust to the different sizes, make sure the Fix
Line Height option is turned off. When you click Fixed Line Height to 
deselect it, the Show Lines option in the Field Info dialog box 
automatically turns off if it’s turned on.❖ 

Restoring text to the default format               
You can restore reformatted text to the default text format for the field (as
in the Text Style dialog box). Follow these steps: 

To do this … ...press this

Select all the text in the field x-A

* Bold the selected text x-Shift-B

* Condense the selected text x-Shift-C

Restore the selected text to the field’s default text format x-Shift-D

Restore the field to its previous contents, undoing all recent 
changes

x-Shift-Z

* Extend the selected text x-Shift-X

Change the selected text to the next font (alphabetically) x-Shift-F or x-Shift-[

Change the selected text to the previous font (alphabetically)x-Shift-]

* Group the selected text x-Shift-G

* Italicize the selected text x-Shift-I

* Outline the selected text x-Shift-O

* Underline the selected text x-Shift-U

Make the selected text a smaller font size x-Shift-<

Make the selected text a larger font size x-Shift->

Decrease the field’s line height x-Shift- – (minus)      

Increase the field’s line height x-Shift- + (plus)                    

* If the style is already in effect, pressing the x-key combination undoes it.
7-20 Chapter 7: Working with Text and Fields



. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .

” 

    

und 
 the 
1. Choose the Browse tool from the Tools menu. 

2. Drag with the I-beam pointer to select the text you want to change. 

If you don’t see the I-beam pointer, see “Where’s the I-beam Pointer?
earlier in this chapter. 

3. Press x-Shift-D.

The selected text is restored to the default attributes for the field.        

Making field text appear on every card        
Use the Shared Text option in the Field Info dialog box to create a backgro
field that displays the same text on every card. This option appears only in
Field Info dialog box for background fields.      

To get the same field text to appear on every card, follow these steps: 

1. Create a field in the background. 

See “Creating a Field” earlier in this chapter for instructions. 

2. Double-click the field.

The Field Info dialog box appears.
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3. Click the Shared Text checkbox to select it.         

4. Click OK. 

5. Choose the Browse tool  from the Tools menu.            

6. Go to the background layer (if you’re not already there) by pressing x-B.

7. Click in the field and type the text you want to display on every card.

When you finish, return to the card layer.

8. Choose Background from the Edit menu, or press x-B.

When the Shared Text option is turned on for a field, you can enter or edit
in the field only while you’re in the background layer. If you’re in the card 
layer, you won’t see the I-beam pointer when you move the Browse tool o
a field for which the Shared Text option is turned on.       

When you turn off Shared Text, the text you’ve entered in the background la
becomes hidden (although it’s still there), and you can edit the field only fr
the card layer.

Two sets of text
You can think of background fields as potentially having two different sets
text; the Shared Text setting determines which set of text you see: 

■ When you turn on Shared Text, any text you’ve entered in the backgro
layer appears, and text you’ve entered in the card layer disappears. 

■ When you turn off Shared Text, any text you’ve entered in the backgro
layer disappears, and text you’ve entered in the card layer appears. 

❖ Shared text isn’t searched.If the Shared Text option is turned on for a 
field, the Don’t Search option is turned on automatically. This means t
HyperCard doesn’t search in the field when you ask it to look for 
specific text.❖               
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Locating Fields         
Many of the fields in stacks are easy to locate right away, but some are ha
to find. You can use either of the following methods to locate all the fields
the current card and background: 

■ Choose the Field tool from the Tools menu. Lines appear in all the fiel
(except scrolling fields, which have a visible scroll bar).   

■ While the Browse tool is selected, you can look at both the buttons an
fields by pressing and holding the x, Shift, and Option keys. Gray 
rectangles appear around the buttons and fields. Then, while you’re s
holding down the x and Option keys, release the Shift key—the dotted
rectangles around the fields disappear. Pressing and releasing the Shi
repeatedly while holding down the x and Option keys makes the field 
rectangles appear and disappear.         

Changing the Appearance of a Field            
Once you’ve created or copied a field, you can change its appearance by
resizing it, changing its style, adding margins, or displaying lines in it. Thi
section explains how to make a field look the way you want it to. 

When you choose the 
Field tool… 

… lines appear in the fields.
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❖ Note: You can change the appearance of both card fields and backgro
fields while you’re in the card layer. You don’t have to be in the 
background layer to modify background fields.❖

➤  See also: “Choosing the Look of Field Text” earlier in this chapter.

Changing the size of a field         
You can change the size of a field whether or not it has text in it. When yo
change a field’s size, any text in it wraps appropriately to conform to the n
size (assuming that the Don’t Wrap option is turned off in the Field Info 
dialog box). 

To resize a field, follow these steps: 

1. Choose the Field tool  from the Tools menu. 

2. Click the field you want to resize to select it. 

A moving dashed line surrounds the selected field. 

Dotted rectangles outline the 
fields in the card layer.

Thick gray 
rectangles outline 
the fields in the 
background layer.
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3. Drag from any corner of the field:         

To resize the field in one dimension only, either horizontally or vertical
Shift-drag from a corner. 

If you shrink a field so that there’s not enough room for all the text, the tex
the bottom of the field disappears from view. But the text is still there—if y
enlarge the field (or you scroll the text in the case of a scrolling field), the t
becomes visible again. 

❖ Check all cards.After you resize a background field, look through any 
cards affected by the field change to make sure the text looks all right❖ 

Choosing a field’s style             
A field can have any one of five styles: transparent, opaque, rectangle, sha
or scrolling. (The style of a field has no bearing on the style of its text.)

Drag from any corner region to 
resize the field.

The background shows through 
transparent fields.

The scroll bar becomes gray 
when the text runs off the 
bottom of the field.
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To set the style for a field, follow these steps:

1. Choose the Field tool  from the Tools menu.

2. Click the field to select it. 

3. Choose Field Info from the Objects menu (or double-click the field). 

The Field Info dialog box appears. 

4. Press the Style pop-up menu and drag to the style you want to use.

A model of the field appears in a window in the dialog box. 

5. Click OK. 

❖ About scrolling: Choosing the Scrolling option adds a vertical scroll bar 
the selected field. You view text in a field with a scroll bar the same w
you view text in any scrollable window. (For details about scrolling in 
windows, see the documentation that came with your computer.)❖

You can use this procedure to change any field’s style, even after you type
into the field. The text remains unaffected.        

This is what the
field looks like.

Makes the field transparent, 
with no visible border.

Makes the field opaque 
without a visible border.

Makes the field opaque with 
a thin black border.

Makes the field opaque with 
a shadow along the right side 
and bottom.

Makes the field opaque, with 
a border and a scroll bar 
along the right side.
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Adding margins        
Adding margins to a field makes the text easier to read. When you add ma
to a field, you get extra space on the right and left sides of the text in the f
As a result, text may take up more vertical space. 

To add margins to a field, follow these steps: 

1. Choose the Field tool  from the Tools menu. 

2. Click the field to select it. 

3. Choose Field Info from the Objects menu (or double-click the field). 

The Field Info dialog box appears. 

4. Click the Wide Margins checkbox to select it.          

5. Click OK.           

Displaying lines in a field         
You can display lines in all field styles except scrolling fields. Lines are 
especially useful for making a transparent field visible so you can see whe
type in it. 

To display lines in a field, follow these steps: 

1. Choose the Field tool  from the Tools menu. 

2. Click the field to select it. 

3. Choose Field Info from the Objects menu (or double-click the field). 

The Field Info dialog box appears. 

4. Click the Show Lines checkbox to select it.
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5. Click OK.

Highlighting clicked lines         
You can automatically highlight the line that a user clicks in a field, treating 
clicked line as a selection from a list. For example, you can put a list of bo
in a field; and when the user clicks the name of a book, the name highligh
and (assuming you have included the appropriate scripts) the stack show
summary of that book’s most important elements in another field.

A field whose lines automatically highlight is called a list field. To create a list 
field, follow these steps:

1. Choose the Field tool  from the Tools menu. 

2. Click the field to select it. 

3. Choose Field Info from the Objects menu or (double-click the field). 

The Field Info dialog box appears. 

4. Click the field’s Lock Text checkbox to select it.

5. Click the field’s Auto Select box to select it.

The field’s Don’t Wrap option is automatically checked.

6. To let the user highlight multiple lines, click the Multiple Lines checkbox to select it.

7. Click OK.       

The user selects a single line by clicking it, or if Multiple Lines is also selec
in the Field Info dialog box, a range of lines by dragging or Shift-clicking.

❖ Scripting information:The number of the selected line(s) is returned in th 
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Naming a Field          
Each field can have a name associated with it. You use field names mostl
referring to fields through scripts or the Message box. A field name can h
up to 254 characters in it, and you can use any character in a field’s nam

Follow these steps to name a field: 

1. Choose the Field tool  from the Tools menu. 

2. Click the field you want to name to select it. 

3. Choose Field Info from the Objects menu (or double-click the field). 

The Field Info dialog box appears. 

4. Type a name for the field.        

5. Click OK.            

❖ Script writers take note:If you change the name of a field, be sure to 
change its name everywhere you refer to it in a script, too. For exampl
you rename a field “Wrigley” and you use the old name “Chester” in a
script, the script doesn’t work properly; it can’t find the field it needs.❖ 

Copying a Field     
You can duplicate a field on the same card, or copy it to another card, 
background, or stack. When you copy a field, you also copy its attributes (
is, its name, style, script, text format settings, and so on). You can copy a 
either with or without its text contents. 

Type here to add or 
change the field’s name.
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Copying a field on the same card          
Follow these steps to duplicate a field on the same card:

1. Choose the Field tool  from the Tools menu.

2. Click the field you want to copy to select it.

Whether the field is in the card layer or the background layer, you can
select it from the card layer. A moving dashed line surrounds the 
selected field. 

3. Option-drag the field. 

As you drag, you create an exact duplicate of the field. If the original is
background field, the duplicate is a background field. If the original is a
card field, the duplicate is a card field.       

To limit the new field’s movement to a horizontal or vertical direction onl
Shift-drag from the middle of the field.

❖ Option-drag can’t duplicate text.To duplicate a field with its text intact, 
you must copy and then Shift-paste the field. See the next section for 
detailed instructions.❖

Copying a field to another card or background         
To copy a field to another card or background, follow these steps:

1. Choose the Field tool from the Tools menu. 

2. Click the field you want to copy to select it. 

3. Choose Copy Field from the Edit menu.       

This makes a copy of the selected field (including its script) and puts it
the Clipboard. 

4. Go to the card or background where you want to put the field.

Use the arrow keys or commands in the Go menu to navigate between 
while the Field tool is selected. 
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5. Choose Paste Field from the Edit menu.

This takes a copy of the field that’s on the Clipboard, puts it on the curr
card or background, and selects it. 

If you copy the field and its text from the card layer to the background
layer, you can’t see the text until you return to the card layer at the en
this procedure.

If you copy a background field to the card layer of the same card, the c
is pasted directly over the original. To see the original, drag the copy a

❖ Note: To paste the field with its text intact, press and hold the Shift key
you paste.❖

6. While it’s still selected, drag the field to where you want it. 

If you copied the field and its text from the card layer to the backgroun
layer and the text isn’t visible, return to the card layer to see the text. 

Moving a Field Around on a Card or Background            
You can place a field wherever you like on the card or background. To 
reposition a field on the card or background, follow these steps:

1. Choose the Field tool  from the Tools menu. 

2. Click the field you want to move to select it.

Whether the field is in the card layer or the background layer, you can se
it from the card layer. A moving dashed line surrounds the selected fie

3. Drag from the middle of the field, or from one of its edges (not a corner).

To limit the field’s movement to horizontal or vertical directions only, 
Shift-drag from the middle of the field.

Drag from anywhere in this area 
(except from within the dotted lines) 
to move the field around.
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4. Click anywhere outside the field to deselect it (or choose the Browse tool). 

You can select and move only one field at a time.        

❖ Check for obscurities:After you reposition a background field, look 
through the cards in that background to make sure the moved field ha
become obscured. Because all objects on the background layer are b
objects on the card layer, a background field can become partially or to
covered by a button or field on the card.❖

When elements overlap                       
HyperCard puts different kinds of elements into different layers. Together
these layers make up the card you see. This layering of buttons and field
becomes evident when the elements overlap. Elements that are closer to
can obscure elements that are farther away. If this happens, you can eith
move the elements apart so they don’t overlap, or you can try either of th
following: 

■ Reorder the fields and buttons. You can move any field or button close
farther, within its layer. 

■ Make some of the elements transparent, so you can see other elemen
through them. (Buttons, fields, and graphics can all be made transpar
or opaque.)

For a detailed discussion of overlapping elements and of reordering, see 
“Moving Elements from Layer to Layer” in Chapter 6. While that discussio
focuses on buttons, what applies to buttons applies equally well to fields.  

Changing the opacity of a field         
To see background or card elements through a field that covers them, mak
field transparent. Conversely, to give a field more prominence, make it opa

Follow these steps to make a field opaque or transparent: 
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1. Choose the Field tool  from the Tools menu.

2. Click the field you want to change to select it.

3. Choose Field Info from the Objects menu (or double-click the field). 

The Field Info dialog box appears.

4. Choose an appropriate field style to make the field opaque or transparent.             

5. Click OK.        

Moving a Field Around in the Stack
You’ll sometimes find after you create a field that the field is in the wrong 
place. It’s on the card layer when it should be on the background, it’s in th
background when it should be on the card layer, or it’s on the wrong card
altogether. This section shows you how to move a field around within the
current stack.

Choosing this style makes the 
field transparent.

Choosing any other 
style makes the field 
opaque.
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Moving a field from the card to the background        
It’s easy to put a field in the card layer by mistake when you intend to put 
the background. If this happens, you can move the field from the card laye
the background layer (of the same card) by following these steps: 

1. Choose the Field tool  from the Tools menu. 

2. Click the field you want to move to select it. 

A moving dashed line surrounds the selected field. 

3. Choose Cut Field from the Edit menu.         

This removes the field from the card and puts it on the Clipboard. 

4. Choose Background from the Edit menu to the background layer.

5. Choose Paste Field from the Edit menu.

This takes a copy from the field on the Clipboard, puts it in the current
background, and selects it. The pasted field appears at the same posi
from which it was cut. If you pasted the text along with the field, you ca
see the text until you return to the card layer at the end of this procedu

❖ Note: To paste the field with its text intact, press and hold the Shift key
you paste. ❖

6. While it’s still selected, drag the field to where you want it.

Because you can’t see the elements in the card layer while you’re wor
in the background, you may not be able to tell whether you’re putting t
field in the right place. If this happens, you can press x-B to go back to the 
card layer, and then select and drag the field from the card layer. 

7. Choose Background from the Edit menu to return to the card layer.  

Now you’ll see any pasted text.           

Moving a field from the background to the card           
Follow these steps to move a field from the background layer to the card l
of the same card: 
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1. Choose the Field tool  from the Tools menu. 

2. Click the field you want to move to select it. 

A moving dashed line surrounds the selected field. 

3. Choose Cut Field from the Edit menu.      

A dialog box appears, asking you to confirm the deletion.

4. Click Delete in the dialog box to remove the field from the background and put it on 
the Clipboard. 

5. If you’re in the background layer, go to the card layer by pressing x-B. 

If you’re already in the card layer, skip this step. 

6. Choose Paste Field from the Edit menu.

This takes the cut field from the Clipboard, puts it on the current card, 
selects it. The pasted field appears at the same position from which it 
was cut. 

❖ Note: To paste the field with its text intact, press and hold the Shift key
you paste. ❖

7. While it’s still selected, drag the field to where you want it.            

Moving a field to another card or background        
You can move a field to another card in the same stack, or to a card in an
stack. When you move a field, its attributes (that is, its style, name, scripts,
so on) move with it. You can move a field either with or without its text. 

Follow these steps to move a field to another card or background:

1. Choose the Field tool  from the Tools menu. 

2. Click the field you want to move to select it. 

A moving dashed line surrounds the selected field. 

3. Choose Cut Field from the Edit menu.        
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If the field is a background field, a dialog box appears asking you to 
confirm the deletion.

4. Go to the card or background where you want to put the field. 

Use the arrow keys or commands in the Go menu to navigate between 
while the Field tool is selected. 

5. Choose Paste Field from the Edit menu.

This takes the cut field from the Clipboard, puts it on the current card 
background, and selects it. The pasted field appears at the same posi
from which it was cut. If you moved the field and its text from the card lay
to the background layer, you can’t see the text until you return to the c
layer (at the end of this procedure).

❖ Note: To paste the field with its text intact, press and hold the Shift key
you paste. ❖

6. While the field is still selected, drag it to where you want it. 

If you moved a field and its text from the card layer to the background la
and the text isn’t visible, choose Background from the Edit menu to ret
to the card layer and see the text. 

Locking and Unlocking a Field         
You can lock a field to prevent changes to its text. To lock a field, follow 
these steps:

1. Choose the Field tool  from the Tools menu.

2. Click the field to select it.

3. Choose Field Info from the Objects menu (or double-click the field). 

The Field Info dialog box appears.

4. Check the Lock Text option to turn it on.         

5. Click OK.         

When the Browse tool passes over a locked field, the tool doesn’t cha
to the I-beam pointer. This lets you know that you can’t edit the field. 
7-36 Chapter 7: Working with Text and Fields
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❖ Lock Text doesn’t stop scripting.Even though the Lock Text option of a 
field is turned on, the text in the field can be changed through a script 
through a HyperTalk command entered through the Message box.❖

Grouping Text         
When a field is locked, each individual word of text in the field has the 
potential to behave much like a button. By writing a script, you can make 
something happen when a user clicks a word in the field. 

You can also make any group of words or characters in a field respond in
same way to a single click in any part of that group of text. What happens w
you click text, whether or not it’s grouped, depends on the scripts in the st

To group text so that it responds to a click as a single unit, first make sure
field is unlocked (as described in the previous section, “Locking and Unlock
a Field”). Then follow these steps: 

1. Choose the Browse tool from the Tools menu.

2. Drag with the I-beam pointer to select the text you want to group. 

If you don’t see the I-beam pointer, see “Where’s the I-beam Pointer?
earlier in this chapter. 

3. Choose Group from the Style menu (or press x-Shift-G).        

To make grouped text responsive to clicks, you must write a script. (See 
HyperTalk Reference stack and HyperCard Script Language Guide for more 
information.)        

Excluding a Field from Text Searches          
You can prevent HyperCard from searching in any particular field during t
searches. Follow these steps: 

1. Choose the Field tool  from the Tools menu.

2. Click the field to select it.

3. Choose Field Info from the Objects menu.
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4. Check the Don’t Search option to turn it on. 

Unchecking the Don’t Search option turns it off.

5. Click OK.

➤   See also: “Excluding Fields from Text Searches” and “Excluding 
Background Fields from Text Searches” in Chapter 5.       

Deleting a Field
You can delete a field whether or not it has text in it. When you delete a fi
any text in the field is deleted as well. 

Follow these steps to delete a field: 

1. Choose the Field tool  from the Tools menu.        

2. Click the field you want to delete to select it. 

3. Choose Clear Field from the Edit menu (or press Delete or Backspace). 

If the field is a background field, a dialog box appears asking you to 
confirm the deletion.

To retrieve a field that you’ve deleted, immediately choose Undo from the E
menu (or press x-Z).

Click Delete to confirm that 
you want to remove the field.
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Chapter8
Working with Graphics      

This chapter describes the graphic elements you can create or manipulate
the Paint tools. Such elements include lines, shapes, patterns, pictures, a
paint text. 

This chapter explains how to do the following: 

■ create and edit black-and-white graphics

■ copy graphics from another stack or from the same stack

■ import graphics created by HyperCard or by other applications

■ use the many HyperCard tools for working with graphics

To do the tasks in this chapter, you must have your user level set at least
Painting. (The section “User Levels and Options” in Chapter 1 explains how
set your user level.)
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Adding Graphics to a Card or Background                     
Each card can have its own unique graphics in the card layer, plus backgr
graphics it shares with other cards. Whenever you add a graphic element
stack, you need to decide whether you want it in the card layer or the 
background layer:       

■ If you want the graphic to appear on every card in the stack, put it in th
background layer. A background graphic appears in the same location
all the cards that share the background. 

■ If you want the graphic to appear on only one card, add it to the card la

■ If you want the graphic to appear on some of the cards in the stack (bu
all of them), consider creating a different background for those cards a
putting the graphic in that background only. (“Creating a New 
Background” in Chapter 5 explains how to add a background to a stac

To add a graphic to a background, you must be in the background layer; to
a graphic to a card, you must be in the card layer. 

To go to the background layer, press x-B. When you’re in the background 
layer, stripes appear in the menu bar. If you press x-B repeatedly, you move 
back and forth between the card layer and the background layer. 

Tools for Working with Graphics       
To create and work with graphics, you use the Paint tools in the Tools me

The Paint tools
8-2 Chapter 8: Working with Graphics
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The functions of the Paint tools are described briefly in the figure that follo
Detailed instructions for using these tools appear throughout this chapter

 

To make it easy to alternate between the tools, you can “tear off” the Too
menu to create a movable Tools palette. To do this, drag down past the bottom
of the menu or beyond either side. (You can also press Option-Tab.) While
have the Tools palette open, you can select a tool by clicking it on the pal
     

Select tool 
selects graphics.

Brush paints with 
the current 
pattern.

Spray tool 
spritzes paint 
onto the screen in 
the current 
pattern.

Bucket fills 
enclosed areas and 
solid black areas 
with the current 
pattern.

Paint Text tool 
types text that’s 
part of a graphic.

Lasso selects 
non-rectangular
 graphics.

Eraser erases 
the part of a 
graphic you 
drag it over.

Rectangle tool 
draws 
rectangles.

Oval tool
draws ovals
and circles.

Regular
Polygon tool
creates polygons
with regular 
sides.

Pencil draws thin 
free-form lines.

Line tool draws 
straight lines.

Rounded Rectangle 
tool draws 
rectangles with 
rounded corners.

Curve tool draws 
free-form lines 
and shapes.

Polygon tool
creates polygons
with irregular 
sides.
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Graphics commands and menus
When a Paint tool is active, the File menu contains the Import Paint comm
use it to bring graphics created by other applications into HyperCard. 

When you choose one of the Paint tools, two new menus appear: Paint a
Options. The Objects, Font, and Style menus disappear temporarily while
you’re working with the Paint tools.  Use the commands in these menus t
create and manipulate graphics.  

➤  See also: “Using HyperCard Tools” in Chapter 4.

Selecting a Graphic         
Before you can modify, move, or copy a graphic, you must first select it. Th
are many different ways to select a graphic. The method you use depend
the shape and size of the particular graphic elements you want to select. 
section explains all the methods for selecting graphics. 

To select a graphic, you must be working in the same layer as the graphic. 
graphic is in the background layer, you can only select it from the backgro
layer. If it’s in the card layer, you can only select it from the card layer. If y
try to select a graphic and it doesn’t become selected, chances are the gr
is in the background layer and you’re working in the card layer. (It’s also 
possible that the element you’re trying to select is actually a button or fiel
Chapters 6 and 7 explain how to select buttons and fields.)      

Once you select a graphic, it stays selected until you choose a tool or clic
outside the selection. 

❖ Graphics are selected differently than are icons.An icon is part of a 
button. To select it, you have to select the button that displays it. If you
not sure whether a particular element is a graphic, choose the Button 
tool ( ) from the Tools menu, click the element, and drag it. If a movin
dashed line appears around the element and you can move it by drag
it’s a button. Chapter 6 gives instructions for working with buttons.❖       
8-4 Chapter 8: Working with Graphics
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Selecting a rectangular area
To select a rectangular graphic element or a rectangular area of a paint pic
follow these steps:       

1. Go to the card or background that contains the graphic element or the area you want to select. 

Pressing x-B takes you to the background layer. (When you’re in the 
background layer, stripes appear in the menu bar.) If you press x-B 
repeatedly, you move back and forth between the card layer and the 
background layer. If you don’t see the graphic you want while you’re in 
background layer, the graphic is in the card layer. 

2. Choose the Select tool ( ) from the Tools menu.

You can also click it on the Tools palette. The pointer changes to a 
crosshair (+).

3. Move the crosshair pointer to one corner of the area you want to select. 

4. Drag diagonally to the opposite corner of the area.

A moving dashed line surrounds the selected area. 

❖ For a tighter selection:To eliminate extra white space from the selectio
press the x key while you drag; when you release the mouse button, th
moving dashed line snaps in to select the smallest rectangular area 
surrounding the graphic.❖

If the area you select is too much or not enough, you can deselect the gra
by clicking the card outside the selection.        

x-drag diagonally with the Select tool from here… 

… to here.

The moving dashed line 
snaps around the graphic 
to eliminate extra white 
space from the selection.
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Selecting a nonrectangular area          
To select a nonrectangular graphic element or a nonrectangular area of a
picture, follow these steps:

1. Go to the card or background that contains the graphic element or the area you want to select. 

2. Choose the Lasso ( ) from the Tools menu (or click it on the Tools palette). 

The pointer turns into a lasso. 

3. Drag around the graphic you want to select.

You don’t need to drag completely around the graphic; HyperCard comple
the selection by drawing a straight line between the point where you start
dragging and the point where you stop. 

When you release the mouse button, the edges of the selected graphic shim
If there was any filled space surrounding the graphic on the same layer, i
eliminated from the selection.

❖ If you want to include the surrounding fill space:To lasso a graphic 
without eliminating the surrounding fill space, Option-drag with the Las
tool. This selects exactly the area you drag around.❖ 

If you select too much or not enough, you can deselect the graphic by clic
the card outside the selection.          

The tip of the line trailing out of the
Lasso determines what you select.

The edges of the selected 
graphic shimmer.
8-6 Chapter 8: Working with Graphics
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Selecting an individual graphic element      
There are several ways to select a single graphic element without any of th
space that surrounds it, including the method described in the preceding 
section, “Selecting a Nonrectangular Area.” This section describes two 
additional methods.

Use the following technique when you want to select a specific graphic elem
quickly and exclude the surrounding fill space, or if your hand isn’t steady
enough to use the Lasso with precision:

1. Go to the card or background that contains the graphic you want to select. 

2. Choose the Select tool ( ) from the Tools menu (or click it on the Tools palette). 

The pointer changes to a crosshair (+). 

3. Move the crosshair pointer to one corner of the graphic. 

4. Option-drag diagonally to the opposite corner of the graphic.

You can also choose Select from the Paint menu (or press x-S) after you 
drag to the opposite corner (instead of before you drag). This automatic
chooses the Lasso and selects the graphic.   

If the area you select is too much or not enough, click the card outside th
selection to deselect the graphic.             

Press and hold the Option key and drag 
diagonally with the Selection tool from 
here… 

The selected graphic 
shimmers.

… to here.
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You can use the following technique to select a graphic element that has 
breaks in it—that is, one composed entirely of connected black dots or 
surrounded by an unbroken line. This technique is useful for selecting sm
solid graphic elements. 

1. Go to the card or background that contains the graphic you want to select. 

2. Choose the Lasso from the Tools menu. 

3. Move the Lasso’s tip into the graphic.

4. Press the x key while you click the graphic. 

Immediately after you draw a single graphic element (and before you clic
anywhere), you can select the element you just created by choosing Select
the Paint menu. The Select command selects only the graphic element yo
created since the last time you pressed the mouse button. If you haven’t 
created a new graphic, the Select command selects all the graphics in the
in which you’re working.       

This technique is particularly useful if you have just drawn a shape very c
to or actually touching another shape, and you need to move the new sha
You can even draw a new shape on top of an old one, choose Select, and
drag the new shape away without changing the old shape. You can also us
Select command to select an area you just erased. 

If the Power Keys option is turned on (and the Message box is hidden), y
can press S instead of choosing Select. See “Using Power Keys” later in 
chapter for more information.       

Select the graphic by 
x-clicking it with the 
tip of the Lasso.

The edges of the 
selected graphic 
shimmer.
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Selecting all graphic elements on a card or background       
When your card or background picture is made up of several individual gra
elements, you can select them all at once to make changes to them, copy 
or move them.  

Select all the graphic elements in the current card layer or background la
(excluding the white space between them) by using one of these methods:

■ Choose Select from the Paint menu, or press x-S.   

■ Double-click the Lasso on the Tools palette.      

■ If the Power Keys option is turned on (and the Message box is hidden
press S. 

… but the background graphics don’t.

When you’re in the card
layer and you choose Select
from the Paint menu, all the

card graphics become
selected…
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Selecting the entire card picture or background picture       
When you want to copy, delete, or change the entire card picture or backgr
picture, you can select the whole picture in one rectangular selection the 
of the card.          

Select the entire picture by using one of these methods: 

■ Choose Select All from the Paint menu, or press x-A.   

■ Double-click the Select tool on the Tools palette. 

■ Choose the Lasso from the Tools menu, and then press the x key while you 
click the card or background.      

■ If the Power Keys option is turned on (and the Message box is hidden
press A. (See “Using Power Keys” later in this chapter for more 
information.) 

■ Choose the Select tool from the Tools menu and drag diagonally from 
corner of the card or background to the opposite corner. 

A moving dashed line surrounds the selected card or background picture
deselect the picture, click the card or background anywhere, or choose a
from the Tools menu.       
8-10 Chapter 8: Working with Graphics
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Copying Graphics That Come with HyperCard             
The easiest way to get art into your stacks is to copy graphics that already 
Copying graphics can simplify the stack-building process. HyperCard com
with several stacks that contain graphics you can copy and paste into 
your stacks. The Art Bits stack, for example, is filled with all kinds of 
illustrations. Here are some examples:          

When you see a graphic you like in one of these stacks, copy it and paste i
your stack. Follow these steps: 

1. Open the stack that contains the art.

2. Go to the card that has the graphic you want to copy. 

3. Select the graphic you want. 

For instructions on selecting a graphic, see “Selecting a Graphic” earlie
this chapter. 

4. Choose Copy Picture from the Edit menu.          

5. Go to the card or background where you want to put the graphic.

You can use the arrow keys or commands in the Go menu to navigate
between cards while you have the Select tool or Lasso selected. 

6. Choose Paste Picture from the Edit menu.

This takes a copy of the graphic from the Clipboard, puts it on the curr
card or background, and selects it. 
Chapter 8: Working with Graphics 8-11
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7. While the graphic is still selected, drag it to where you want it on the card. 

The graphic is opaque right after you paste it. To see through the graph
the elements behind it, select it (if it isn’t already selected) and choose
Transparent from the Paint menu.    

➤  See also: “Changing the Appearance of a Graphic” later in this 
chapter.     

Undoing Your Mistakes                
If you make a mistake while you’re working with the Paint tools and 
commands, you can undo your last operation by choosing Undo from the 
menu (or pressing x-Z, Esc, or the tilde) before you do anything else.        

You can erase a mistake by choosing the Eraser from the Tools menu an
dragging over the graphic. You must be working in the background layer 
erase a background graphic and in the card layer to erase a card graphic

To erase in a straight horizontal or vertical line, press Shift while you drag.
erase the entire graphic from the current layer, double-click the Eraser on
Tools palette.

➤  See also: “Reverting to the Last Version of a Graphic” later in this 
chapter.

Painting with Brush, Bucket, and Spray Tools               
Three of the tools in the Tools menu are analogous to everyday painting 
implements. These tools work much like the implements they represent:

■ Brush ( ) works like a paint brush.

■ Spray tool ( ) works like a can of spray paint.

■ Bucket ( ) works like a bucket full of paint.

You use these tools with the patterns in the Patterns menu. This section 
explains how.
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Painting with the Brush tool          
The Brush works like a paint brush; it leaves a swath of “paint” in its path. Y
can use the Brush to paint an area with any pattern. The HyperCard defa
pattern is solid black. 

Follow these steps to paint with the Brush:

1. Go to the card or background where you want the paint. 

2. Choose the Brush ( ) from the Tools menu (or click it on the Tools palette). 

The pointer changes to the current Brush shape. 

3. Drag where you want to paint. 

Paint appears in the current pattern where you drag. To paint in a stra
horizontal or vertical line, Shift-drag. 

❖ To erase with the Brush:x-drag with the Brush to erase any existing pain
in the path.❖      

If you want to paint with a different pattern, choose the pattern you want fr
the Patterns menu before you drag with the Brush. 
Chapter 8: Working with Graphics 8-13
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If you want to paint with a different brush shape, choose Brush Shape from
Options menu, or double-click the Brush on the Tools palette. The Brush Sh
dialog box appears:

The different brush shapes create different effects when you paint. The 
following figure shows some examples:       

A box appears around the 
selected brush shape.

Effect
Brush shape
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Painting with the Spray tool           
The Spray tool spritzes paint onto the screen in the selected pattern. 

Follow these steps to paint with the Spray tool: 

1. Go to the card or background where you want the paint. 

2. Choose the Spray tool ( ) from the Tools menu (or click it on the Tools palette). 

The pointer changes to the Spray tool pointer ( ).   

3. Drag where you want to paint. 

Spray paint appears in the current pattern where you drag. The more 
spray back and forth over the same area, the more the pattern becom
apparent. Some patterns don’t show up until you thoroughly covered 
an area.

Shift-drag to spray in a straight horizontal or vertical line. 

❖ To erase with the Spray tool:x-drag with the Spray tool to erase any 
existing paint.❖       

If you want to spray with a different pattern, choose from the Patterns me
before you drag.          

Filling an area with a pattern            
You fill any area on a card or background with a pattern by using either th
Bucket (in the Tools menu) or the Fill command (in the Paint menu). Befo
you fill an area, you choose the pattern you want to fill it with. 

This section describes two different methods for filling an area. The meth
you use depends on whether the area you want to fill is completely enclo

❖ Filling shapes: If you know before creating a shape that you want to fill 
with a pattern, you can fill the shape automatically as you draw it. For 
instructions, see “Drawing a Shape Filled with a Pattern” later in this 
chapter.❖
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Filling an enclosed area        
When you want to fill an area that’s completely enclosed (that is, complet
surrounded by an outline), follow these steps:

1. Go to the card or background that contains the enclosed area you want to fill. 

If the outline enclosing the area is in the background layer, go to the 
background layer. If it’s in the card layer, make sure you’re in the card
layer. If the outline is composed of several different graphic elements, t
must all be in one layer.

2. Choose the pattern you want from the Patterns menu.

3. Choose the Bucket ( ) from the Tools menu. 

Or click it on the Tools palette. The pointer changes to the Bucket. 

4. Move the Bucket pointer so that the tip of the stream pouring from it is within the enclosed 
space you want to fill, and then click:          

This is the part of the 
Bucket that dispenses paint.
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If there are any gaps in the outline that encloses the area you want to fill, p
spills out and fills the surrounding area, too. If this happens, immediately 
choose Undo from the Edit menu, or press x-Z, Esc, or the tilde. Then check
carefully for gaps in the outline before using the Bucket again; repair the g
using the Pencil, Line, or other appropriate tool.

❖ To check for gaps:Use FatBits from the Options menu to make checkin
for gaps easier. For details, see “Magnifying a Graphic for Editing” later
this chapter.❖

Filling an unenclosed area
To fill an area that isn’t completely enclosed by an outline or other graphi
follow these steps:

1. Go to the card or background that contains the area you want to fill. 

2. Choose the pattern you want from the Patterns menu.

3. Select the graphic element or the area you want to fill.

If you want to fill a specific graphic element, you can select it with eith
the Select tool or the Lasso as explained in “Selecting an Individual 
Graphic Element” earlier in this chapter. If you want to fill a blank area
select it with the Select tool as explained in “Selecting a Rectangular Ar

Enclosed area Gap
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4. Choose Fill from the Paint menu.      

The selected area fills with the current pattern.      

If the Power Keys option is turned on, you can press F instead of choosing
           

Creating Your Own Patterns
You can change any pattern in the Patterns menu or replace it with a patte
your own creation. When you change or create a pattern, the new pattern
saved with the stack you’re working in. To change or create a pattern, fol
these steps:    

1. Choose any graphics tool.

A title for the Patterns menu appears on the menu bar.

2. Click the pattern you want to replace on the Patterns menu or Patterns palette.

To create a Patterns palette, press Shift-Tab.

3. Choose Edit Pattern from the Options menu.

Or you can double-click the pattern on the Patterns palette in step 2 and
this step. The pattern editor appears with the pattern you selected.

4. Edit the pattern.

Clicking a black square makes it go away; clicking where there is no squ
makes one appear.          

Select the graphic you want to fill… … and choose Fill 
from the Paint menu.
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5. Click OK to save the new pattern.

The new pattern takes the place of the one that was selected in the 
Patterns menu.    

Changes you make to a pattern affect only graphics drawn with that patte
the future; graphics previously drawn with the old pattern retain the old pat

Using a pattern that appears on the card
You can replace a pattern in the Patterns menu with a pattern that appea
anywhere on the card. Follow these steps:  

1. Choose any graphics tool.

A title for the Patterns menu appears on the menu bar.

2. Click the pattern you want to replace on the Patterns menu or Patterns palette.

To create a Patterns palette, press Shift-Tab.

3. Choose Edit Pattern from the Options menu.

Or you can double-click the pattern on the Patterns palette in step 2 and
this step.

The pattern editor appears holding the pattern you selected.

4. Click the card to select the pattern you want to add to the palette.

The pattern you click replaces the pattern in the Edit Pattern dialog bo

A pattern’s definition area is 8 pixels by 8 pixels. The place where you c
is considered to be the center of the new pattern. So the pattern is de
as everything in a 4-pixel radius (or so) around the click point.

5. Click OK to save the pattern.            

The new pattern replaces the one selected. 
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Drawing Lines and Shapes        
The Tools menu provides tools for drawing lines and shapes— including 
circles, ovals, rectangles, polygons, and free-form shapes. This section 
explains how to create lines and shapes with these tools.       

➤  See also:  “Drawing Shapes with Patterns and Different Line Widths”
 later in this chapter.

Drawing a line or free-form shape               
To draw a straight line or a free-form line or shape, follow these steps:

1. Go to the card or background where you want the line or shape. 

2. Choose the tool you want to use from the Tools menu. 

If you want to draw a straight line, choose the Line tool ( ). To draw a
free-form line or shape, choose the Curve tool ( ). The pointer change
a crosshair (+).               

These tools are for 
drawing lines and shapes.
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3. Drag where you want to draw the line or shape. 

If you’re using the Line tool, Shift-drag to draw a straight line at a 15° angle 
from horizontal, or at an angle that’s a multiple of 15°. To change the angle of 
a straight line while you’re drawing it, change the direction of the mouse a
you drag.

When you use the Line tool, you can draw a straight line from its center p
by first turning on the Draw Centered option. To turn on Draw Centered, 
choose it from the Options menu. (A check mark appears next to it in the m
when this option is on.) To turn off Draw Centered, choose it again.

If the Power Keys option is turned on and the Message box is hidden, you
also press C to turn Draw Centered on or off. (“Using Power Keys” later in 
chapter explains the Power Keys option.)           

Drawing circles, ovals, and rectangles             
To draw a circle, oval, or rectangle, follow these steps:

1. Go to the card or background where you want the shape. 

2. Choose a tool from the Tools menu.      

To draw an oval or circle, choose the Oval tool ( ). To draw a rectangle
square, choose either the Rectangle tool ( ) or the Rounded Rectangle
( ) from the Tools menu. The Rounded Rectangle tool draws rectang
and squares with rounded corners.

The pointer changes to a crosshair (+).   
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3. Drag diagonally to draw the shape. 

Shift-drag to draw a perfect circle or square. 

To move the shape around on the card while you’re drawing it, press x 
before you release the mouse button. You can release the x key to continue 
creating the shape, and then press the x key again to move the shape. Onc
you release the mouse button, you have to select the shape before yo
move it (“Selecting a Graphic” earlier in this chapter explains how).

To draw a shape from the center outwards, first turn on the Draw Centere
option by choosing it from the Options menu. When Draw Centered is tur
on, a check mark appears next to it in the menu. To turn off Draw Centere
choose it again. 

If the Power Keys option is turned on and the Message box is hidden, you
also press C to turn Draw Centered on or off. (“Using Power Keys” later in 
chapter explains the Power Keys option.)               

To draw a circle, oval, or rectangle, select the appropriate 
tool; then drag diagonally from one corner…

… to the 
opposite corner.
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Drawing a regular polygon         
To draw a regular polygon (one whose sides are all the same length), foll
these steps:

1. Go to the card or background where you want the polygon. 

2. Choose the Regular Polygon tool ( ) from the Tools menu. 

The pointer changes to a crosshair (+).    

3. If you want to select the number of sides for your polygon, choose Polygon Sides from the 
Options menu (or double-click the Regular Polygon tool on the Tools palette).

 The Polygon Sides dialog box appears. 

This step and the next step are optional. If you don’t select the numbe
sides before you draw the polygon, it’s either a square (the default sha
or the last shape you selected in the Polygon Sides dialog box.

4. Click the shape that corresponds to the polygon you want to draw.  

The shape you select remains in effect until you change it by 
selecting a different shape.

A box appears around 
the selected shape.
Chapter 8: Working with Graphics 8-23



. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .

 

s 
ouse 
g a 

n. 
tes 
 

r 
. 

 

 

5. Drag diagonally to draw the polygon. 

To move the polygon around on the card while you’re drawing it, pressx 
before you release the mouse button. You can release the x key to continue 
creating the polygon, and then press the x key again to move the shape, a
long as you continue to press the mouse button. Once you release the m
button, you need to select the shape before you can move it (“Selectin
Graphic” earlier in this chapter explains how).

To rotate the polygon while you’re drawing it, drag with a circular motio
If you press Shift while you drag with a circular motion, the polygon rota
only in 15° increments, which makes it easier to position at exactly the
angle you want.

With the Regular Polygon tool, the shape is always drawn from the cente
outwards, whether or not Draw Centered is checked in the Options menu

Drawing an irregular polygon
To draw a polygon whose sides aren’t necessarily the same length, follow
these steps:

1. Go to the card or background where you want the polygon. 

2. Choose the Polygon tool ( ) from the Tools menu.    

The pointer changes to a crosshair (+).    

3. Click at the point where you want to begin the first side of the polygon. 

The Polygon tool works differently from the other tools; you don’t hold
down the mouse button to draw. 

… outward.
The polygon is drawn

from the center…
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4. Without holding down the mouse button, move the crosshair pointer to draw one side of 
the polygon. 

You can draw the side of the polygon at a 15° angle from horizontal, or at 
an angle that’s a multiple of 15°, by pressing the Shift key as you move th
mouse. To change the angle of the side while you’re drawing it, change
direction of the mouse as you drag.

5. When the side of the polygon is the length you want it, click to fix it in place. 

6. Repeat steps 4 and 5 for each additional side of the polygon. 

7. To finish the shape, click the starting point.

Alternatively, you can double-click or press x-Z at any point to stop 
drawing, whether or not the shape is complete. Pressing x-Z also deletes 
the line that was drawn since you last clicked.           

9. Click here to 
finish the shape.

8. Draw this side by 
moving the pointer 
without holding down 
the mouse button. 7. Click here.

6. Draw this side by 
moving the pointer 
without holding down 
the mouse button.

4. Draw this side by moving the pointer 
without holding down the mouse button.

3. Click here.

2. Draw this side by
moving the pointer

without holding down
the mouse button.

1. Click here to start
the shape.

(Follow the steps counter- 
clockwise around the graphic.)

5. Click here.
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Drawing with the Pencil         
You can use the Pencil to create free-form lines and shapes and touch 
up graphics.

To draw with the Pencil, choose it from the Tools menu and drag where y
want to draw. Shift-drag to draw a straight horizontal or vertical line with 
the Pencil.

Use the Pencil only for thin lines. The Pencil can only draw thin solid lines, 
shapes and pictures composed of thin solid lines. It can’t draw thick lines,
can it draw shapes or lines that have patterns. Use the Line tool for thick 
patterned lines.         

Drawing Shapes with Patterns and Different Line Widths
This section explains how to create lines and shapes that have patterns, 
lines and shape borders in varying line widths. 

Use these tools to draw shapes and lines with
patterns and different line widths.
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Drawing a shape filled with a pattern         
When you know before creating a shape that you’ll want it filled with a patte
you can fill the shape automatically as you draw it. Follow these steps:

1. Choose the pattern you want the shape to have from the Patterns menu.       

2. Choose Draw Filled from the Options menu to turn it on.       

When Draw Filled is turned on, a check mark appears next to it in the m
Choosing Draw Filled again turns it off.

❖ A shortcut: You can also turn Draw Filled on or off by double-clicking 
any of the shape tools on the Tools palette (except the Regular 
Polygon tool).❖ 

The Tools menu looks different when Draw Filled is turned on:

3. Draw the shape. 

Choose the tool for the shape you want to draw from the Tools menu,
then drag to draw the shape. (See “Drawing Lines and Shapes” earlie
this chapter for more detailed instructions.)

When you finish drawing the shape, it automatically fills with the 
selected pattern. 

The Tools menu 
when Draw Filled 
is turned off

The Tools menu 
when Draw Filled 
is turned on

A pattern appears inside 
the shape tools.
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❖ Draw Filled with the Curve tool and Polygon tool:If Draw Filled is turned 
on while you’re using the Curve tool or the Polygon tool, HyperCard dra
a straight line connecting your starting and ending points when you fin
drawing; then it fills the shape with the selected pattern.❖      

❖ Filled shapes without borders:To draw a filled, borderless shape, turn o
Draw Filled; then hold down the Option key while you draw the shape.❖

Drawing with different line widths            
Before you draw a line or shape, you can select the thickness of the line o
shape’s border. Follow these steps:

1. Choose Line Size from the Options menu (or double-click the Line tool on the Tools palette). 

The Line Size dialog box appears.           

2. To select a line thickness, click it:

HyperCard 
draws this line.

Using the Curve tool with 
Draw Filled turned off

Using the Curve tool with 
Draw Filled turned on

Click the line that represents the line 
width you want. 

A box appears around the 
selected line width.
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3. Draw the line or shape. 

Choose the tool for the line or shape from the Tools menu, and then dra
draw the shape. (See “Drawing Lines and Shapes” earlier in this chapte
more detailed instructions.)

❖ A shortcut for selecting line widths:When the Power Keys option is turned
on (and the Message box is hidden), you can type a number from 1 to
select a line width while any Paint tool is selected. (See “Using Power
Keys” later in this chapter for more information.)❖         

Moving a Graphic Around on a Card or Background          
You can place a graphic wherever you like on a card or background. To 
reposition a graphic on a card or background, follow these steps:

1. Go to the card or background that has the graphic you want to move.

2. Select the graphic.

“Selecting a Graphic” earlier in this chapter tells how to do it. 

3. Position the pointer over the selected graphic so that it changes to the arrow pointer.   

4. Drag the selected graphic.

Shift-drag to move the graphic straight horizontally or vertically.

❖ Can’t drag the graphic?If you think you selected a graphic but you can
drag it, you may be trying to move a background graphic from the card
layer. Press x-B and try again. If you still can’t drag it, it’s either a button
or a field. Chapters 6 and 7 explain how to move buttons and fields.❖ 

These power keys don’t 
work when the Line Size 
dialog box is open.

Power keys1                   2               3           4 or 5       6 or 7          8
Chapter 8: Working with Graphics 8-29



. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .

nds 
ows 

he 

e 

nd 
r in 
Creating Special Graphic Effects       
You can use the Paint tools in combination with one or more of the comma
in the Options menu to create a variety of special effects. This section sh
examples of the effects you can create. 

Drawing in multiples          
You can draw multiple lines or shapes using the Draw Multiple option in t
Options menu. 

To draw multiple lines or shapes in a single stroke, follow these steps:

1. Choose Draw Multiple from the Options menu to turn it on.           

When Draw Multiple is turned on, a check mark appears next to it in th
Options menu. Choosing Draw Multiple again turns it off. 

2. Draw a line or shape. 

Choose the tool for the line or shape you want from the Tools menu, a
then drag to draw the shape. (See “Drawing Lines and Shapes” earlie
this chapter for more detailed instructions.)

Draw Multiple works 
with these tools.
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To control the spacing between the multiple images, press the Option key
combination with a number from 1 to 9 before you drag. The higher the num
you type, the farther apart the images are. 

If the Power Keys option is turned on (and the Message box is hidden), you
press M to turn Draw Multiple on or off. (See “Using Power Keys” later in 
this chapter for more information.)           

Line tool Rectangle tool

Rounded 
Rectangle 
tool

Oval 
tool

Regular 
Polygon
tool

Draw Multiple
turned on

Draw Multiple
turned off

Draw Multiple and
Draw Centered

turned on

Option-3 Option-5 Option-7 Option-9
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Aligning graphics          
You can use the HyperCard Grid option to help you line up graphic eleme
and position them more precisely. To turn on the Grid option, choose it fro
the Options menu. When Grid is turned on, a check mark appears next to
the menu. Choosing Grid again turns it off. 

When Grid is turned on, the movement of the pointer is constrained to an
invisible grid whose lines are 8 pixels apart (just under one-eighth of an in
As you draw graphics with the Line tool and shape tools, or drag graphics
move them around, they’ll be aligned to this invisible grid. The grid also 
constrains the movement of the Select tool as you select graphics and th
movement of the I-beam as you try to position the insertion point to type 
Paint text.

❖ Grid works best with Grid-created graphics.The Grid option is most 
helpful for aligning graphics that were created with the Grid option turn
on. If you create graphics with Grid turned off and then turn Grid on, 
HyperCard has a difficult time aligning the graphics because their sizes
positions don’t conform to the grid’s intervals.❖    

If the grid were visible, it would 
look like this. The graphics you 
create while the Grid option is 
turned on are aligned to the grid. 
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You can create some interesting visual images when several options in th
Options menu are turned on at the same time. And you can add to the va
by holding down various modifier keys while you draw with different option
turned on. Experiment with different combinations to see what happens. 

If the Power Keys option is turned on (and the Message Box is hidden), y
can press G to turn Grid on or off. (See “Using Power Keys” later in this 
chapter for more information.)

Adding Paint Text                     
Paint text is text you create with the Paint Text tool. It looks like the text y
type in fields, but you use the Paint tools to create, move, copy, and chan
paint text. 

Paint text is especially useful when you need to include text as part of a pic
(for example, as a picture title or labels) or whenever you want text to beh
more like a picture than text. You can select both a picture and paint text at 
with the same tool and use the same commands on them. And you can c
special effects with paint text by using commands in the Paint and Option
menus (for example, Rotate, Slant, Distort, and Perspective). 

To add paint text to a card or background, follow these steps:

1. Go to the card or background where you want the Paint text.          

2. Choose the Paint Text tool ( ) from the Tools menu. 

The pointer changes to an I-beam ( ). 

The Grid option works 
with these tools.
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3. To select a font and style for the text, do one of the following:

■ Choose Text Style from the Edit menu

■ Press x-T. 

■ Double-click the Paint Text tool in the Tools palette. 

You see the Text Style dialog box.

The preset format for paint text is 12-point plain Geneva left-aligned w
a line height of 16 points. 

4. Choose from the options in the Text Style dialog box.       

The choices you make in this dialog box stay in effect until you change th
or until you restart HyperCard. The preset format is restored when you re
HyperCard.

Click to select the font you want. (You 
can also double-click to select the font 
and return to your work quickly.)

Click to select a font size 
(measured in points).

This number determines t
space between lines. 

To use a font size not 
listed, type it here.

This shows what 
your text looks like.

The alignment you
select applies to each

line you type.

Click to select or deselect
one or more text styles.
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5. Click where you want to position the insertion point and begin typing.

While you’re typing, you can press Delete or Backspace to delete one
character to the left of the insertion point. And you can press Return to 
a new line of text.

As long as the insertion point is still blinking, you can change the font,
style, and size of the text you’re typing by choosing Text Style from th
Edit menu and changing the settings in the Text Style dialog box. All t
text you typed since you last clicked or since you last pressed Enter is
changed to the new font, style, and size.

As soon as you click anywhere, choose another tool, choose Keep from t
Paint menu, switch into or out of the background, or move to another card
text becomes part of the picture (its attributes become fixed). To change 
text or its attributes, you have to erase it and start again.  

❖ Quick text pickup tip:To select paint text that you just finished typing, 
press x-S immediately, before you click anywhere.❖

❖ Paint text is not searchable.You can’t use the Find command to search fo
paint text. To HyperCard, paint text is just another graphic. If you think t
you’ll want to search later for what you’re typing now, create a field an
enter the text in the field using the Browse tool.❖      

Turning field text into paint text       
You can turn existing field text into paint text, if you decide that you’d like 
make it part of a picture. Follow these steps:

1. Choose the Browse tool from the Tools menu.

The pointer becomes an I-beam ( ) when you move it over the field. (If y
don’t see the I-beam, see “Where’s the I-beam Pointer?” in Chapter 7

2. Drag with the I-beam to select the field text you want to change.

3. Choose Copy Text from the Edit menu.            

Or, if want to remove the text from the field, choose Cut Text from the
Edit menu.
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4. Choose any Paint tool from the Tools menu.

5. Go to the card or background where you want the text.

6. Choose Paste Text from the Edit menu.        

The text appears in the center of the card, surrounded by a moving 
dashed line:

While the text is still selected, you can format it by choosing Text Style fro
the Edit menu and changing the settings in the Text Style dialog box. The
becomes part of the picture after you click outside the selected area.       

To change the shape of the 
selection, press the x key 
and drag from a corner.

To move the selected text, 
drag any part of it.
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When Elements Overlap            
HyperCard puts different kinds of elements into different layers, as shown
the following figure. Together, all these layers make up the card you see.

The graphics in the card layer (referred to collectively as the card picture)
behind all the buttons and fields in the card layer, but they’re in front of all 
elements in the background layer. This means graphics in the card layer 
obscure the background elements, but they can be obscured by the button
fields in the card layer. 

Graphics can also obscure one another. Graphics in the background laye
(referred to collectively as the background picture) can get lost behind grap
in the card layer, and a graphic that you created recently can cover graphic
were drawn earlier in the same layer. 

Background picture

Background buttons 
and fields

Card picture

Card buttons and fields

What you see when 
you look at the card.

The background 
picture is fixed in a 
layer by itself—it’s 
always behind the 
background buttons 
and fields and all the 
card elements.

The card picture is also 
fixed in a layer by 
itself—it’s always 
behind the card buttons 
and fields, and in front 
of all the background 
elements.
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When elements overlap so that some graphics obscure, or are obscured 
other elements, you can either rearrange the elements so they don’t overla
you can make some of the elements transparent so you can see other ele
through them. “Moving a Graphic Around on a Card or Background” earlier
this chapter explains how to reposition graphics on the card or background
next section explains how to make graphics opaque or transparent. (Chap
and 7 give instructions for rearranging buttons and fields and making them
opaque or transparent.) 

Making a graphic opaque or transparent                 
To see elements that are obscured by a graphic, make the graphic transp
Conversely, to make a graphic more prominent, make it opaque. 

Follow these steps to make a graphic opaque or transparent:

1. Select the graphic.

“Selecting a Graphic” earlier in this chapter gives instructions. 

2. Choose Transparent or Opaque (as appropriate) from the Paint menu.   

A graphic 
element…

… made opaque 
and moved.

A graphic 
element…

… made transparent 
and moved.
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When you first create or paste a graphic, it’s opaque; that is, it covers the
graphics beneath it. You can make the new graphic transparent by choos
Transparent immediately after you create it (before you click anywhere) o
you pasted it, by choosing Transparent while it’s still selected. Transpare
affects just the graphic you created since the last time you pressed the m
button if nothing else is selected. 

If the Power Keys option is turned on, you can press O to make the selec
graphic opaque, or press T to make it transparent. (“Using Power Keys” l
in this chapter explains the Power Keys option.)                

Changing the Appearance of a Graphic          
HyperCard includes many commands and options for changing the look o
existing graphic, including commands that edit a picture pixel by pixel and
commands that flip a graphic upside down or backwards. This section 
describes all the ways you can modify graphics and Paint text.

➤  See also: • “Using Power Keys” in this chapter
• “Using Modifier Keys with Paint Tools” in this chapter
• “Double-Clicking Paint Tools” in this chapter

Magnifying a graphic for editing            
You can zoom in on a section of a picture to do close-in finish work and e
your picture one pixel (dot) at a time. Follow these steps:

1. Select the part of the picture you want to work on.

“Selecting a Graphic” earlier in this chapter gives instructions. 

2. Do one of the following:

■ Choose FatBits from the Options menu.

■ Double-click the Pencil on the Tools palette.

■ Choose the Pencil tool; then press the x key while you click the part of 
the graphic you want to edit. 
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HyperCard zooms in on the part of the graphic you selected (or x-clicked 
with the Pencil) and magnifies it. If nothing is selected and you haven’
x-clicked anything with the Pencil, HyperCard zooms in on the graphi
you were just working with (or on the center of the card if you weren’t 
working on a graphic).

3. Edit the graphic. 

You can use any of the Paint tools to modify the graphic; they all work
the magnified scale. 

When the Pencil is selected, 
you add or remove a single 
pixel at a time by clicking.

This window displays an actual-size version of the graphic 
that reflects changes as you make them.

You move the window
by dragging from here.

You close the window by
clicking its close box.
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If you want to edit a different part of the picture, Option-drag the magnif
graphic with the hand pointer. 

4. When you’re finished editing the graphic, turn off FatBits by doing any of the following:

■ Choose FatBits from the Options menu.

■ Click in the little window that shows the actual-size version of 
the graphic.

■ Double-click the Pencil on the Tools palette.

■ Press Option-F.

■ With the Pencil selected, x-click the magnified picture.

■ Choose the Browse tool ( ), the Button tool ( ), or the Field tool (
from the Tools menu.                

As you drag the card with the hand 
pointer, this window shows the 
actual-size version of the part of the 
card you’re looking at.

To see a different section of the card, press 
Option while you drag the card with the hand 
pointer.
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Changing the size of a graphic          
To resize a graphic, follow these steps:

1. Select the graphic.

2. x-drag from a corner or an edge of the selected graphic. 

❖ Can’t drag the graphic?If you think you selected a graphic but you can
drag it, you may be trying to resize a background graphic from the car
layer. Press x-B and try again. If you still can’t drag it, it’s either a button
or a field. (Chapters 6 and 7 explain how to move buttons and fields.)❖

Changing the pattern of a graphic           
There are three ways to change the pattern of a graphic:

■ Use the Fill command to fill the graphic with a different pattern.

■ Use the Bucket to “pour” a different pattern into the graphic.

■ Use the Pickup command to give the graphic the same pattern as ano
graphic on the card.

The original 
graphic

To resize it 
proportionately, 
press x-Shift and 
drag from a corner.

To make it wider, narrower, 
taller, or shorter, press x 
and drag from an edge.
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Using the Fill command to change a graphic’s pattern      
Using the Fill command is the most reliable way to change the pattern of 
graphic. To change the pattern of a graphic using the Fill command, follow
these steps:

1. Select the graphic.

“Selecting a Graphic” earlier in this chapter gives instructions. 

2. Choose the Fill pattern you want from the Patterns menu.

3. Choose Fill from the Paint menu. 

The selected graphic acquires the selected pattern. 

If you just created a graphic element and you haven’t clicked anywhere, the
command works on the new element (that is, just the element you created 
you last pressed the mouse button).

If the Power Keys option is turned on, you can press F instead of choosing
See “Using Power Keys” later in this chapter for more information. 

Using the Bucket to change a graphic’s pattern          
Using the Bucket to change the pattern of a graphic works best when you 
to fill a solid dark area with a lighter pattern. If you try to use this technique
fill a lightly patterned area with a darker pattern, the results are unpredicta
the pattern may change, but not necessarily to the one that you selected. 
try to use this technique to fill a dark non-solid area with a lighter pattern, 
may not see any change at all.

The original 
graphic

1. Select the
 graphic.

2. Choose a pattern. 3. Choose Fill from
  the Paint menu.
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❖ Make sure the area is enclosed.Use the Bucket to change a graphic’s 
pattern only if the graphic is completely enclosed. Otherwise, paint ca
spill out and fill the surrounding area.❖

To change a graphic’s pattern with the Bucket, follow these steps: 

1. Go to the card or background that contains the graphic. 

2. Choose the Fill pattern you want from the Patterns menu.

3. Choose the Bucket ( ) from the Tools menu. 

You can also click it on the Tools palette. The pointer changes to a buc

4. Move the Bucket so that the tip of the stream pouring from it is within the graphic, and 
then click.          

If paint spills out into the surrounding area, immediately choose Undo from
Edit menu, or press Esc or the tilde.                

This is the part of the Bucket 
that dispenses paint.
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Using the Pickup command to change a graphic’s pattern      
To give a graphic the same pattern as another image on the card, follow 
these steps:

1. Select the graphic you want to change.

2. Drag the selected graphic over the part of the card that has the pattern you want to give 
the graphic. 

3. While the graphic is still selected, choose Pickup from the Paint menu (or if the Power Keys 
option is turned on, press P).

The selected graphic picks up the pattern of the image behind it, wheth
not that image is a pattern. 

Leave the graphic selected. Don’t click outside the selection. 

4. Drag the selected graphic away.

❖ If the pattern doesn’t change:If you selected a graphic in the card layer
and it doesn’t acquire the pattern behind it when you choose Pickup, o
the graphic disappears, the pattern is probably in the background laye
graphic can only pick up a pattern in the same layer. If there’s no patte
behind the graphic in the same layer, the graphic turns white.❖      

1. Select the 
graphic. 
(Its edges 
will 
shimmer.)

2. Move the 
selected 
graphic over 
the pattern 
you want to 
give it.

3. Choose Pickup 
from the Paint 
menu.

4. Drag the 
graphic 
away.
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Inverting a graphic          
To invert a graphic so that white becomes black and black becomes white
follow these steps:

1. Select the graphic.

“Selecting a Graphic” earlier in this chapter gives instructions. 

2. Choose Invert from the Paint menu.         

If you just created a graphic element and you haven’t clicked anywhere
Invert command works on the new element (that is, just the element y
created since you last pressed the mouse button).

If the Power Keys option is turned on, you can press I instead of choosing
Invert. (“Using Power Keys” later in this chapter explains the Power 
Keys option.)          

1. Select the graphic. 2. Choose Invert from the Paint menu.
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Making a graphic darker or lighter            
To darken or lighten a graphic, follow these steps:

1. Select the graphic.

2. Choose Darken from the Paint menu to make the graphic darker, or choose Lighten to 
lighten it.          

Choosing the Darken command darkens the selected graphic by rand
turning white pixels black. Choosing the Lighten command randomly tu
black pixels white. If you choose either of these commands repeatedly
more pixels are changed each time.        

If you just created a graphic element and you haven’t clicked anywhere, t
Darken and Lighten commands work on the new element (that is, just the
element you created since you last pressed the mouse button).      

If the Power Keys option is turned on, you can press D instead of choosin
Darken, or L instead of choosing Lighten. Pressing and holding D makes 
selected graphic darker and darker; pressing and holding L makes it lighte
lighter. (See “Using Power Keys” later in this chapter for more 
information.)     

The original graphic 1. Select the graphic. 2. Choose Darken from 
the Paint menu.

The original graphic 1. Select the graphic. 2. Choose Lighten from 
the Paint menu.
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Outlining a graphic             
To add an outline to a graphic, follow these steps:

1. Select the graphic.

2. Choose Trace Edges from the Paint menu.       

An outline appears around the parts of the selected graphic that were
originally black. Each time you choose Trace Edges, another outline 
is added. 

If you just created a graphic element and you haven’t clicked anywhere
Trace Edges command works on the new element (that is, just the ele
you created since you last pressed the mouse button).           

If the Power Keys option is turned on, you can press E instead of choosin
Trace Edges. Pressing and holding E keeps adding outlines. (See “Using P
Keys” later in this chapter for more information.)

The original 
graphic

Trace Edges 
once

Trace Edges 
twice

Trace Edges 
three times
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Rotating a graphic 90°            
To rotate a graphic 90°, follow these steps:

1. Select the graphic.

2. Choose Rotate Left from the Paint menu to rotate the selected graphic 90° to the left, or 
choose Rotate Right to rotate it 90° to the right.       

If you just created a graphic element and you haven’t clicked anywhere, t
Rotate Left and Rotate Right commands work on the new element (that is,
the element you created since you last pressed the mouse button).

If the Power Keys option is turned on, you can press [ (the left bracket ke
instead of choosing Rotate Left, or ] (the right bracket key) instead of choo
Rotate Left. If you press and hold one of these power keys, the graphic k
rotating. (See “Using Power Keys” later in this chapter for more information

“Slanting, Rotating, or Distorting a Graphic” later in this chapter explains h
to rotate a graphic in increments smaller than 90°.         
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Flipping a graphic vertically or horizontally       
To flip a graphic vertically or horizontally, follow these steps:

1. Select the graphic.

2. Choose Flip Vertical from the Paint menu to flip the selected graphic vertically, or choose Flip 
Horizontal to flip it horizontally.              

If you just created a graphic element and you haven’t clicked anywhere
Flip Vertical and Flip Horizontal commands work on the new element (t
is, just the element you created since you last pressed the mouse but

If the Power Keys option is turned on, you can type V instead of choosing 
Vertical, or type H instead of choosing Flip Horizontal. If you press and ho
one of these power keys, the graphic keeps flipping. (“Using Power Keys” l
in this chapter explains the Power Keys option.)       
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Slanting, rotating, or distorting a graphic                      
You can slant or add perspective to a graphic, or rotate or distort it. Follow
these steps:

1. Select a rectangular area with the Select tool ( ).

You must select the area as described in “Selecting a Rectangular Are
earlier in this chapter. (A Lasso selection doesn’t work.)

2. From the Options menu, choose Rotate, Slant, Distort, or Perspective.            

Choose the command that describes the effect you want to create with
graphic. A rectangle with handles appears around the selected graphi

3. Drag the handles to change the graphic’s appearance. 

The handles remain around the graphic until you click outside it. You c
drag the handles as many times as you like to create the effect you w

4.  When you’re finished, click outside the graphic.

These commands work with all graphics, including Paint text. Experiment w
them to see what kinds of effects you can create. You can return a graph
its original state by choosing Undo or by pressing x-Z, Esc, or the tilde, no 
matter how many times you dragged its handles.        

Drag the handles to 
change the appearance 
of the graphic.
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Using Power Keys            
When the Power Keys option is turned on, you can perform an operation 
graphic by pressing a key instead of making a menu choice. 

To turn on Power Keys, check the Power Keys box on the Preferences ca
the Home stack. The Power Keys option is available at the Painting and hi
user levels. You can also turn on the Power Keys option by choosing it fro
the Options menu, visible whenever a Paint tool is selected. 

You’ll find examples of the use of the power keys in earlier sections of thi
chapter. All the power keys and their effects are listed in the following tab

❖ The Paint Text tool turns off power keys.When you’re using the Paint Text
tool, the power keys are temporarily disabled.❖     

Command Power key Menu

Black pattern B Patterns

Darken D Paint

Draw Centered (on/off) C Options

Draw Multiple (on/off) M Options

Fill F Paint

Flip Horizontal H Paint

Flip Vertical V Paint

Grid (on/off) G Options

Invert I Paint

Lighten L Paint

Opaque O Paint 

Pickup P Paint

Revert R Paint

Rotate Left [ Paint

Rotate Right ] Paint

Select S Paint

Select All A Paint

Trace Edges E Paint

Transparent T Paint 

White pattern W Patterns
8-52 Chapter 8: Working with Graphics



. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .

u 
he 
fier 
Using Modifier Keys with Paint Tools          
When you hold down modifier keys (Command, Shift, or Option) while yo
drag with different Paint tools, you alter the effects of some of the tools. T
following table lists the effects. (Paint tools that aren’t affected by the modi
keys aren’t listed.)    

Modifier key

Tool Command Shift Option

Select Selects tightly Moves selection 
horizontally or vertically

Duplicates selection

Lasso Lassos everything Moves selection 
horizontally or vertically

Duplicates selection

Line No effect Draws at 15° angles Draws with pattern

Eraser Erases in white Erases straight horizontally 
or vertically

No effect

Pencil Enters/leaves 
FatBits

Draws straight horizontally 
or vertically

No effect

Rectangle No effect Draws a square Creates a patterned 
border

Curve No effect No effect Creates a patterned 
border

Brush Erases what you 
paint over

Paints straight horizontally 
or vertically

No effect

Spray Erases what you 
spray over

Sprays straight horizontally 
or vertically

No effect 

Rounded Rectangle No effect Draws square with round 
corners

Creates a patterned 
border

Polygon No effect Draws at 15° angles Creates a patterned 
border

Oval No effect Draws a circle Creates a patterned 
border

Regular Polygon No effect Rotates in 15° increments Creates a patterned 
border
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Double-Clicking Paint Tools          
You can double-click certain Paint tools on the Tools palette as a shortcu
choosing menu commands. The following table shows the effects of 
double-clicking Paint tools. 

Saving the Graphics on a Card or Background                
While you’re working on the graphics of a particular card or background, 
changes you make to the graphics are stored in a temporary location; the
not automatically saved to your disk, as are your other changes. HyperCa
assumes that you may decide to throw away your graphics changes, so i
doesn’t save them automatically along with everything else. This gives you
freedom to experiment with the Paint tools and then get back your origina
graphics. 

Double-click this… …to do this

Brush Bring up Brush Shape dialog box

Bucket Hide/show Patterns menu

Curve tool Turn on/off Draw Filled option

Eraser Erase entire picture

Lasso Lasso every element on current card/background

Line tool Bring up Line Size dialog box 

Oval tool Turn on/off Draw Filled option

Paint Text tool Bring up Text Style dialog box

Pencil Turn on/off FatBits 

Polygon tool Turn on/off Draw Filled option

Regular Polygon tool Bring up Polygon Sides dialog box

Rectangle tool Turn on/off Draw Filled option

Rounded Rectangle tool Turn on/off Draw Filled option

Select tool Select entire picture
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To save all the graphics on the current card or background use one of the
following methods:

■ Choose Keep from the Paint menu (or press x-K).

■ Switch to or from the background layer by pressing x-B. 

■ Go to another card or stack. 

■ Quit HyperCard.

Reverting to the Last Version of a Graphic        
While you’re working with graphics, you can retrieve the last saved version
the graphics on the current card or background by choosing Revert from 
Paint menu. Choosing Revert restores the graphics you had on the curren
or background before you last saved them with one of the methods descr
in the preceding section, “Saving the Graphics on a Card or Background.

❖ Revert is different from Undo.Revert undoes all the changes you made 
the graphics on the current card or background since they were last sa
whereas Undo undoes only the most recent unsaved change.❖ 

You can also restore a portion of the last saved version of the picture on 
current card or background by selecting the part you want to restore and 
choosing Revert. “Selecting a Graphic” earlier in this chapter includes 
instructions for selecting part of a picture.

The Revert command is most useful when you’re creating graphics in sta
Once you complete a stage and it’s just the way you want it, you can “free
it with the Keep command. Then you can begin work on the next stage, 
confident that your last stage is saved and that you can start over from th
point, if necessary. 

If the Power Keys option is turned on (and the Message box is hidden), you
press R instead of choosing Revert. “Using Power Keys” earlier in this cha
explains the Power Keys option.           
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Copying a Graphic         
This section explains how to duplicate a graphic on the same card and ho
copy a graphic to another card, background, or stack. 

Copying a graphic on the same card           
To make a duplicate of a graphic on the same card or background, follow
these steps:

1. Go to the card or background that has the graphic you want to duplicate.

2. Select the graphic.

3. Position the pointer over the selected graphic so that the pointer changes to an arrow.

4. Option-drag the selected graphic.

As you drag, you create an exact duplicate of the graphic. Shift-drag t
move the copy straight horizontally or vertically.

❖ Can’t drag the graphic?If you think you selected a graphic but you can
drag it, you may be trying to duplicate a background graphic from the c
layer. Press x-B and try again. If you still can’t drag it, it’s either a button
or a field. Chapters 4 and 5 explain how to move buttons and fields.❖ 

x-Option-drag to make multiple copies of the graphic. A trail of copies follo
the pointer. You can preset the spacing between each image in the trail b
pressing Option along with a number from 1 to 9 before you drag. The lar
the number you type, the greater the spacing between the copies.           

Option-1 pressed before 
dragging

Option-7 pressed before 
dragging
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To copy a graphic to a different card or background, follow these steps:

1. Go to the card or background that has the graphic you want to copy.          

2. Select the graphic.

3. Choose Copy Picture from the Edit menu.         

4. Go to the card or background where you want to put the graphic.

You can use the arrow keys, the navigator palette, or commands in the
menu to move between cards while you have the Select tool or the La
selected. 

5. Choose Paste Picture from the Edit menu.       

This takes a copy of the graphic from the Clipboard, puts it on the curr
card or background, and selects it. The graphic is pasted in the same 
position it was copied from. If there’s a button or field in the same locati
the pasted graphic is hidden behind it as explained in “When Element
Overlap” earlier in this chapter. Try moving the button or field to see th
graphic. 

6. If you want to reposition the graphic, drag it to where you want it while it’s still selected. 

A graphic is opaque right after you paste it. To see through the graphi
the elements behind it, select it and choose Transparent from the 
Paint menu.                   

Moving a Graphic from the Card to the Background            
It’s easy to put a graphic in the card layer by mistake when you intend to p
in the background. If this happens, you can move the graphic from the ca
layer to the background layer of the same card by following these steps: 

1. Go to the card that has the graphic you want to copy.

You must be in the card layer to move a card graphic. If you see stripe
appear in the menu bar, you’re in the background layer. Press x-B to go to 
the card layer. 

2. Select the graphic.
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3. Choose Cut Picture from the Edit menu.           

4. Go to the background layer.

5. Choose Paste Picture from the Edit menu. 

This takes a copy of the graphic from the Clipboard, puts it in the curre
background, and selects it. The graphic is pasted in the same position i
copied from. If there’s a button or field in the same location on the 
background layer, the pasted graphic is hidden behind it as explained
“When Elements Overlap” earlier in this chapter. Try moving the button
field to see the graphic.     

6. If you want to reposition the graphic, drag it to where you want it while it’s still selected. 

Moving a Graphic to Another Card or Background            
To move a graphic to a different card or background, follow these steps:

1. Go to the card or background that has the graphic you want to move.

2. Select the graphic.

3. Choose Cut Picture from the Edit menu.     

4. Go to the card or background where you want to put the graphic.

Use the arrow keys or commands in the Go menu to navigate between 
while the Select tool or the Lasso is selected. 

5. Choose Paste Picture from the Edit menu.       

This takes a copy of the graphic from the Clipboard, puts it on the curr
card or background, and selects it. The graphic is pasted in the same 
position it was copied from. If there’s a button or field in the same locati
the pasted graphic is hidden behind it as explained in “When Element
Overlap” earlier in this chapter. Try moving the button or field to see th
graphic. 

6. If you want to reposition the graphic, drag it to where you want it while it’s still selected. 

A graphic is opaque right after you paste it. To see through the graphic to
elements behind it, select it and choose Transparent from the Paint menu.
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Importing a Graphic            
You can bring any MacPaint-format picture into HyperCard by following 
these steps:

1. Make sure you have one of the Paint tools selected.

2. Choose Import Paint from the File menu.        

A directory dialog box appears. 

3. Use the directory dialog box to locate and open the file with the picture you want to use. 

HyperCard pastes the imported picture onto the current card or 
background, starting with the upper-left corner of the imported picture

❖ Preparing to import a picture:Before you import a picture, make sure th
part of the picture you want to paste is in the document’s upper-left cor
or make sure the card you want to paste it on is large enough to 
accommodate the picture, including any blank space that’s in the upper
corner of the picture. “Changing the Size of Cards” in Chapter 4 expla
how to adjust the card size.❖

Once you import a picture, you can work with it just as if you’d created it i
HyperCard. 

❖ Bringing in graphics via the Clipboard:You can bring any picture into 
HyperCard via the Clipboard. Copy the picture to the Clipboard first; 
then paste it into HyperCard using the Paste Picture command in the 
Edit menu.❖   

Exporting a Snapshot of a Card and/or Background       
You can take a snapshot of the current card and background or of just the
current background and save it as a MacPaint document. To do it, use the 
Export Paint command in the File menu. (This command is available only 
when a Paint tool is selected.) Follow these steps: 

1. Move to the card you want to capture as a snapshot.

Or, to get a shot of just the background, move to the appropriate 
background layer.
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2. Choose Export Paint from the File menu.        

A directory dialog box for saving a file appears.

3. Use the directory dialog box to specify where you want the file saved and type a name for 
the file.

4. Click OK. 

Export Paint creates a MacPaint document that contains the image of th
current card and/or background and saves it on a disk under the name
give it. The image of the full-sized graphic gets saved, even if you’re us
FatBits. 

HyperCard exports only a picture of the card and/or background. The sav
picture has none of the functional attributes of the card—for example, the
scripts aren’t saved with the picture. If you have a palette, the Message box
FatBits window, or the Scroll window open on the screen, their images ar
included with the exported picture. 
               

Creating a Miniature Picture of a Card               
You can create a miniature picture of a card, like the miniatures you see w
you choose Recent from the Go menu. Follow these steps: 

1. Go to the card you want to capture as a miniature picture.

2. Choose Copy Card from the Edit menu. 

3. Go to the card or background where you want to put the miniature picture. 

4. Press and hold the Shift key while you choose Paste Card from the Edit menu (or press 
x-Shift-V).

The miniature appears selected in the center of the card window.

This is just a picture of a card—none of the normal card attributes or scr
from the original card are pasted with the miniature.
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Deleting a Graphic          
To delete a graphic, you can use any of the following techniques:

■ To delete a new graphic just after you add it (before you click anywhe
else), press Delete, Backspace, or Clear, or choose Clear Picture from
Edit menu. This is not reversible; you can’t bring back a graphic that w
deleted immediately after it was added.

■ To delete any graphic, first select it using one of the techniques descr
in “Selecting a Graphic” earlier in this chapter. Then press the Delete,
Backspace, or Clear key, or choose Clear Picture from the Edit menu.
you delete a selected graphic by mistake, you can bring it back by 
immediately choosing Undo from the Edit menu or pressing x-Z, Esc, or 
the tilde.           

■ To erase any graphic, choose the Eraser ( ) from the Tools menu and
over the graphic. (To erase a background graphic, you must be workin
the background layer. To erase a card graphic, you have to be in the c
layer.) Shift-drag to erase in a straight horizontal or vertical line.        

❖ The background revealed:If you see a picture appearing under the Eras
as you drag it over a card picture, you’re exposing a part of the backgro
that was covered by an opaque card picture. If you don’t want the 
background elements to show, you can cover them by x-dragging with the 
Eraser. (This “erases” with white paint.) Of course, you can go to the 
background layer and delete the elements, but first check to make sure
aren’t needed on the other cards that share the background.❖

■ To erase the entire picture on the current card or background, double-
the Eraser on the Tools palette. This wipes out the picture on the curr
card or background, and then selects the tool you were using just before
double-clicked the Eraser. This technique is useful for cleaning up you
screen after you’ve been experimenting with the Paint tools. (If you 
double-click the Eraser by accident, choose Undo from the Edit menu
immediately, or press x-Z, Esc, or the tilde.) 
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Chapter 9
Printing         

This chapter explains how to print information in a stack. You can print a sin
card, specific cards in a stack, an entire stack, the contents of a field, or a r
that displays the contents of specific fields. You can also create different re
templates for a stack and copy and paste report templates from one stack
another. 

If you’re familiar with HyperTalk, you have even more printing options—fo
example, you can print a specific rectangular area of a card, a range of 
consecutive cards, or a document from another application. The HyperTa
Reference stack describes these options.

You can do most of the tasks described in this chapter no matter what your
level is set to. The text tells you if a specific user level is called for.
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Preparing to Print         
Before you can print with HyperCard, you must have the appropriate prin
driver (also called printing resource) for your printer in your System Folde
You must also make sure that your printer’s icon is selected in the Choos
desk accessory. The documentation that came with your computer descr
how to install printer drivers and how to use the Chooser.

Once you have the appropriate printer driver installed and selected, you c
give HyperCard information about your paper and printing preferences by
using the Page Setup command before you print. 

❖ Use Page Setup if something changes.If the settings in the Page Setup 
dialog box reflect your paper size and printing preferences, you don’t n
to use the Page Setup command until you want to change the settings
do, however, need to use Page Setup whenever you change the printe
you’re using (for example, when you change from an ImageWriter to a
LaserWriter).❖

To change the settings in the Page Setup dialog box, follow these steps:

1. Make sure you have one of the General tools selected.

2. Choose Page Setup from the File menu.   

The Page Setup dialog box appears. The options in this dialog box va
depending on what kind of printer and which version of system softwa
you have. 
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3. Select the options you want in the Page Setup dialog box:

4. Click OK.

The options you select in the Page Setup dialog box are saved with th
current stack. They’re in effect when you print the stack (or any part of
using the Print Field, Print Card, Print Stack, or Print Report command

You can change the Page Setup settings at any time by repeating this 
procedure.       

Click the option
that describes

the size of
your paper.

Print 
vertically

Print 
horizontally

Click here for 
additional 
options.

These options 
aren’t available 
for the 
ImageWriter.Print 

vertically
Print 
horizontally

Click the option
that describes

the size of
your paper.
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Printing a Single Card  
To print a single card in a stack, follow these steps:

1. Go to the card you want to print. 

2. Make sure you have one of the General tools selected.

3. Choose Print Card from the File menu (or press x-P).

HyperCard prints the current card according to the settings you selecte
the Page Setup dialog box.

❖ Displaying the Print dialog box:To display the Print dialog box, hold 
down the Shift key when you choose Print Card. That way, you can se
options such as “print quality” and “number of copies.”❖

Printing an Entire Stack     
To print all the cards in the current stack, follow these steps:

1. Make sure you have one of the General tools selected.

2. Choose Print Stack from the File menu.

The Print Stack dialog box appears. 
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3. Select the options you want in the Print Stack dialog box:

❖ If you have a LaserWriter:When the Precision Bitmap Alignment (4% 
reduction) option is selected in the LaserWriter Page Setup dialog box
measurements you see for Margins, Size, and Spacing in the Print Sta
dialog box are slightly larger than they appear on the printed page.❖

This area shows the
layout of the printed

page.

Change the margins by 
dragging either corner 
handle.

Click here to print successive 
cards from the top of the 
page or from left.

Click here to add the date, 
time, stack name, and/or 
page number to the header.

Click here to insert 
a tab between 
items in the 
header. 

Click these buttons to view 
the page margins, card 
size, or card spacing 
at the right.

Press here to see a pop-up 
menu for choosing the size 
of printed cards.

To space the cards, drag
any card image other

than the one in the
upper-left corner.

To add text to the
header, type here.

Press here to see a 
pop-up menu for choosing 
the unit of measurement 
for the dimensions shown 
below.

This option spaces cards 
so you can fold the 
printed sheet down the 
middle without creasing 
any card’s image.
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4. Click Print.

The Print dialog box appears. The options in this dialog box vary, 
depending on what kind of printer and which version of system softwa
you have. For information about these options, see the documentation
came with your computer.

5. Select the options you want in the Print dialog box, and click OK.

HyperCard prints the cards in the current stack according to the settings
selected in the Page Setup dialog box, the Print Stack dialog box, and
Print dialog box. 

Once you print a stack, HyperCard remembers the format and header you
for that stack. The next time you print the same stack with the Print Stack
command, HyperCard displays the same format and header in the Print S
dialog box.     
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Printing Specific Cards      
To print specific cards in the current stack (instead of printing the entire sta
follow these steps:

1. Mark the cards you want to print.

To mark a card, check the Card Marked option in that card’s Card Info
dialog box. Your user level must be set to 4 or higher on the User 
Preferences card of the Home stack to see the Objects menu. 

You can also mark cards using HyperTalk commands. For more 
information refer to the HyperCard Script Language Guide.

2. Make sure you have one of the General tools selected.

3. Choose Print Stack from the File menu.

The Print Stack dialog box appears. 

4. Select the options you want in the Print Stack dialog box.

5. Click “Marked cards” as shown here:

6. Click Print.

The Print dialog box appears. The options in this dialog box vary, 
depending on what kind of printer and which version of system softwa
you have. The documentation that came with your computer describe
these options.

Click here to print only the
marked cards in the stack.
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7. Select the options you want in the Print dialog box and click OK.

HyperCard prints the marked cards in the current stack according to th
settings you’ve selected in the Page Setup dialog box, the Print Stack d
box, and the Print dialog box. 

Once you print specific cards in a stack, HyperCard remembers the forma
header you used for that stack. The next time you print the same stack wit
Print Stack command, the same format and header appear in the Print St
dialog box. However, you need to tell HyperCard each time you want to p
only the marked cards in a stack by clicking “Marked cards” in the Print St
dialog box; otherwise, it assumes you want to print all the cards in the sta

Printing the Text in a Specific Field      
To print the text that appears in a specific field on a particular card or 
background, follow these steps:

1. Go to the card that has the text you want to print. 

2. Make sure you have one of the General tools selected.

3. Choose Print Field from the File menu.    

The Print Field dialog box appears. To specify print quality and other 
options, hold down the Shift key as you choose Print Field. The stand
Print dialog box appears after you finish step 5. 
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4. Select the field whose text you want to print: 

5. Click OK.

HyperCard prints the text in the specified field according to the setting
you’ve selected in the Page Setup dialog box and the Print Field dialog 
If you’re printing a background field that contains different text on ever
card, HyperCard prints only the text that appears in the field on the 
current card.       

Printing a Report      
You can prepare custom reports that display the field text in a stack in any
you like. You can create and save up to 16 report templates for a stack. Y
could, for example, create a table-style report template, a template for prin
the results of calculations, and a template for printing labels—all for the sa
stack. You can also copy and paste report templates from one stack to an

You can control the appearance and placement of each element in a 
report—including the font, size, and style of the text. You can also choose
invert a report item, and to build a frame around it. Reports, however, con
no graphics. 

This list shows either all the card fields 
or all the background fields on the 
current card or background, depending 
on whether “Card fields” or 
“Background fields” is selected above.

This box shows some of the 
text in the selected field.

Click here to print background fields.

Select this option to print the
field just as it appears on the

card. If you turn off this
option, HyperCard prints the

field using the full width of
the paper.

Click here to print card fields.

Click the field you
want to print.
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To print a report from the current stack, follow these steps:

1. Make sure you have one of the General tools selected.

2. Choose Print Report from the File menu.

The Print Report dialog box appears. 

3. If you’ve created a report template you want to use, choose it from the Reports menu.

HyperCard dims the File menu and displays a special Edit menu plus 
Reports menu. To create your own report template now, click Cancel 
go to the next section, “Creating a Report Template.”

4. Click “Marked cards” if you want your report to include only text from the marked cards in 
the stack.

Or, if you want to print text from all the cards in the stack, skip this ste
“All cards” is the preset option. When it’s selected, text from all the 
cards prints.

❖ If you have a LaserWriter:When the Precision Bitmap Alignment (4% 
reduction) option is selected in the LaserWriter Page Setup dialog box
measurements you see for Margins, Size, and Spacing in the Print Re
dialog box are slightly larger than on the printed page. It’s a good idea
turn off the Precision Bitmap Alignment option before you print a 
report. ❖

5. Click Print.

The Print dialog box appears. 

Click here to print only from the
marked cards in the stack.
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6. Select the options you want in the Print dialog box and click OK.

HyperCard prints text from the cards in the current stack according to w
you decided in step 4, the settings in the current report template, and 
settings in the Page Setup and Print dialog boxes.     

❖ Mailing labels: If you want to print mailing labels on a LaserWriter, be 
sure to use only labels made especially for LaserWriters or 
photocopiers.❖ 

Creating a Report Template        
To create a report template for the current stack, follow these steps:

1. Make sure you have one of the General tools selected.

2. Choose Print Report from the File menu.

The Print Report dialog box appears, and the menu bar changes. 

3. Choose New Report from the Reports menu.      

A dialog box appears so that you can name your report template. 
HyperCard automatically inserts “Untitled Report” into the Report Nam
box. To enter a new name, just type it. You don’t need to select “Untit
Report” first. 

If you don’t give your report template a new name, your report templat
named “Untitled Report” even if an existing report already has that na

Type a name for your
report template here

and then click OK.
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4. In the Print Report dialog box, set up the layout for your report: 

For more exact control over margins, cell size, and cell spacing, selec
Precision adjustments. That way, measurements change in increment
single pixels.

If you can’t decide on a layout now, go on to step 5. You’ll have anoth
chance later in this procedure to use this dialog box to set up or adjus
the layout.

5. Do one of the following:

■ Choose Report Items from the Edit menu.      

■ Press x-E.

■ Double-click any cell in the Print Report dialog box.

Click these buttons to view the 
page margins, cell size, or cell 
spacing at the right.

Click to insert a Tab 
between items in 
the header. 

Click these icons to add
the date, time, stack
name, and/or page

number to the header.

You change the margins by 
dragging either corner handle.

Click to print successive cards’ cells from the top of 
the printed page to the bottom or from left to right.

Click “Dynamic 
height” to make each 
cell as deep as 
necessary to show 
all its text.

To resize the cells,
drag from here.

Each cell represents
the area reserved for

one card’s text.

To add text to the 
report header, 
type here.

Press here to see a 
pop-up menu for 
choosing the unit of 
measurement for the 
dimensions shown 
below.
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The Report Items dialog box appears with a new menu bar. You use t
dialog box to specify what text you want in your report by adding repo
items. The report items you specify print for each card. 

6. Choose New Item from the Items menu to add an item to the report (or press x-N). 

A small rectangle appears, outlined by a moving dashed line to indicate
it’s selected. This rectangle represents one item of your report.

7. While the item is still selected, choose Item Info from the Items menu (or double-click 
the item). 

The Item Info dialog box appears.    

This represents the
area reserved for a

cell (one card’s text).

The ruler reflects the unit of
measurement you selected

from the pop-up menu in
the Print Report dialog box.

When the cells are larger 
than the area shown in this 
dialog box, these scroll 
bars become active.
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8. Specify the contents of the item: 

If you want the item to be the contents of a card field, you must specify
card field (by its name, number, or ID). To do so, type a HyperTalk 
description of the card field into the box labeled “Contents of item.” Fo
example, you could type any of the following to specify a card field:    

card field “Name” 

card field 5 

card field ID 7 

You can type a text string or a HyperTalk expression 
(such as the number of this card ) here … 

The report item prints in
the number of columns

specified here. (The text
doesn’t appear in

columns in the Report
Items dialog box, but it

prints in columns.)

Select Font, Style, and/or Size to format the 
contents of the box labeled “Contents of item.” 
(The font, style, and size you choose here affect 
only the printed report—not the field itself.)

These pop-up 
menus become 
active when 
you turn on 
Font or Size.

… or click a field
in this list to specify
a background field
as the report item.

You can enclose the item within 
a frame, or put lines along one 
or more sides as you see fit.

Check this to have the item
appear as white text against

a black background.
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You can also define an item to be any text you want by simply typing t
text between quotation marks in the “Contents of item” box. Or you ca
define the item to be a particular word or words from a field—or any te
or value you can describe with HyperTalk—by typing the appropriate 
HyperTalk expression into the “Contents of item” box. Here are some 
examples:

"This text appears in every cell."

word 2 of background field "Name"

first line of background field "Name"

word 1 to 5 of background field "Job"

the number of this card

See the HyperTalk Reference stack or the HyperCard Script Language 
Guide for more information about HyperTalk expressions.

❖ For non-scripters:The “Contents of item” box is an advanced feature. 
You can either type some text between quotation marks into this box, 
skip it entirely and click a field name from the “Background fields” list th
appears below it.❖

9. Select whatever options you want.

You can set the font, size, style, and alignment for the text of the item
well as the number of columns the item prints in. You can also choose
have this item appear in inverted text (white text on a black field), as w
as within a frame of from one to four sides.

10. Click OK.     

You return to the Report Items dialog box. The small rectangle, still 
selected, contains the text you specified in the Item Info dialog box. If y
specified fields, the text comes from the specified fields on the current c

To resize the item, drag it from any corner. To move it, drag it from the
middle. To nudge a selected report item one pixel at a time, press the
arrow keys. 
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You can cut, copy, and paste items to and from the Report Items dialog
using commands in the Edit menu. You can also duplicate an item by 
Option-dragging it. 

11. Repeat steps 6 through 10 to add more items to your report.

12. When you’ve added all the items you want, click OK to return to the Print Report dialog box.

Refine your layout in the Print Report dialog box if necessary.

13. Do one of the following:

■ Click Print to print a report now.

Follow the steps in the section called “Printing a Report” earlier in 
this chapter.

■ Click Cancel if you choose not to print.

14. Click Save to save the changes to your report template.

Copying or Moving a Report Template to Another Stack            
If you have a report template for one stack that you think would work well
another stack, you can copy or move it by following these steps:

1. Go to the stack that has the template you want to copy or move.

2. Make sure you have one of the General tools selected.

3. Choose Print Report from the File menu.

4. From the Reports menu, choose the report template you want to copy or move.

5. Do one of the following:

■ Choose Copy Report from the Edit menu to copy the report templat

■ Choose Cut Report if you want to move it.      
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6. Click Cancel to close the Print Report dialog box.

7. Go to the stack to which you want to add the report template.

8. Choose Print Report from the File menu.

9. Choose Paste Report from the Edit menu.     

The layout of the pasted report template appears in the Print Report di
box and its name appears in the Reports menu. 

10. Do one of the following:

■ Click Print if you want to print a report using this template now.

■ Click Save if you want to use this template later. 

You may have to redefine the report items (for example, change the field na
in the Item Info dialog box for each item) so that the template works in the n
stack. Follow the instructions in the preceding section, “Creating a Repor
Template,” for defining report items.       

❖ Scripting information:To copy a template from one stack to another, 
use the command 
copy template templateName  to stack stackName . ❖
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Renaming a Report Template    
To rename a report template, follow these steps:

1. Go to the stack that has the template you want to rename.

2. Make sure you have one of the General tools selected.

3. Choose Print Report from the File menu.

4. Choose the report template you want to rename from the Reports menu.

5. Choose Report Name from the Edit menu.    

A dialog box like the following appears:

6. After you’ve typed a new name for the template, click OK. 

Deleting a Report Template       
To delete a report template from a stack, follow these steps:

1. Go to the stack that has the template you want to delete.

2. Make sure you have one of the General tools selected.

3. Choose Print Report from the File menu.

4. Choose Delete Report from the Edit menu.       

A confirmation dialog box appears for deleting the report template.

5. Click OK to delete the report template. 
9-18 Chapter 9: Printing
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A
A4 letter-size paper, 9-3
“About” buttons, creating, 3-35 to 3-37
“action” placeholder, 3-42
adding

buttons, 2-24 to 2-25
cards, 2-11 to 2-12, 3-18, 5-2 to 5-5
fields to stack backgrounds, 3-14 to 3-18
graphics to stack backgrounds, 3-29

aligning
graphics, 8-32 to 8-33
overlapping elements, 6-44 to 6-46, 7-31, 8-37 t

8-38
See also moving (rearranging)

America Online, as source of stacks, xxi
ampersands (&&) in scripts, 3-31
“anotherAction” placeholder, 3-44
“answer” command, 3-39
AppleShare file servers, user access settings, 4-41
applications

opening, 1-42 to 1-43
saving stacks as stand-alone, 4-32 to 4-33
search paths for, 1-13
arrow button customization, 2-29 to 2-30
arrow keys

moving through cards, 1-39
moving through text versus through stacks, 1-1

to 1-12, 7-12
Arrow Keys in Text (checkbox), 1-10 to 1-12, 7-12
arrow symbol pointer, 2-4
Art Bits stack, 3-29, 4-27, 8-11
authoring, 1-9, 2-23
Authoring (user level), 1-9
Auto Hilite option, 3-7, 6-16
automatic saving, 1-45, 2-10, 4-18
Auto Select option, 7-27

B
Back command, 1-24, 1-39, 2-8
background art

adding graphics, 3-29
copying, 2-42 to 2-43
example, 6-42

Background Art button, 2-42 to 2-43
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background buttons
copying, 2-44 to 2-46
example, 6-42

Background command, 2-26, 4-23, 5-17
background fields

printing, 9-9
searching for text in, 1-33 to 1-34
for stacks, 2-47 to 2-51

background layers, 2-25 to 2-27, 3-5, 4-5 to 4-8, 5-2
illustration, 6-42

backgrounds
buttons in, 6-4, 6-47 to 6-49
copying, 4-26, 5-20 to 5-22
creating, 5-19
deleting, 5-26
described, 5-17
displaying, 4-6, 5-17
fields in, 5-23 to 5-24, 7-31 to 7-35
for message handlers, 3-63 to 3-64
moving between, 5-20
naming, 5-23
protecting, 5-24 to 5-25
shared text in, 7-21
toggling between card layer, 4-25
See also graphics

BBS (bulletin boards), as sources of stacks, xxi
beeps, 3-59 to 3-64, 3-65 to 3-69
Bkgnd Info command, 2-26, 2-53, 4-23, 5-18, 5-22
Blind Typing option, 1-12 to 1-13
“boing” sounds, 3-60 to 3-64, 3-65 to 3-69
Bold command, 2-11
boldface type, 2-11, 7-18, 7-19

as used in this book, xix
bookmarks (turned down corners). See marking cards
Bring Closer command, 6-45
Browse tool, 1-23, 1-41, 4-10, 6-2, 7-4
browsing

between backgrounds, 5-20
through fields, 7-13 to 7-15
through stacks, 1-21 to 1-30, 2-6 to 2-7
through text, 1-10 to 1-12, 7-12
See also finding
Index-2 Index
Browsing (user level), 1-9
File and Edit menu versions in, 1-10
stack protection from, 4-39

Brush Shape option, 8-14
Brush tool, 4-10, 8-3, 8-12 to 8-13
Bucket tool, 4-10, 8-3, 8-14 to 8-16, 8-43 to 8-44
bulletin boards, as sources of stacks, xxi
Button Info command, 2-28, 4-20, 6-3 to 6-4

Effect options, 6-38 to 6-39
examples of Readymade, 6-6
LinkTo box, 6-34 to 6-35
Script option, 6-49

button numbers, 6-43
buttons  

background, 2-44 to 2-46
copying, 2-31 to 2-33, 6-39 to 6-40
correcting overlapping, 6-44 to 6-46
creating, 2-24 to 2-25, 6-8
creating families of, 6-18 to 6-19
creating “Next” and “Previous,” 3-19 to 3-21
deleting, 2-27, 6-50
described, 4-7 to 4-8, 6-1 to 6-2
disappearing, 3-21
finding, 1-26, 6-5
highlighting, 3-54, 4-20, 6-15 to 6-19
icons for, 2-30 to 2-31
linking to cards or stacks, 1-4, 4-20, 6-33 to 6-3
moving, 2-46, 6-4, 6-41 to 6-49
naming, 3-19, 6-8
for navigating stacks, 1-27
numbering of, 6-43
for opening applications, 1-43
for opening stacks, 2-4
overlapping with fields, 6-44 to 6-46
pop-up, 6-12 to 6-13
preventing user access to, 4-39, 6-9
for quitting, 3-42 to 3-45
ready-made, 6-7
resizing, 6-10
restyling, 6-11 to 6-15
selecting with Button tool, 4-13
for sorting, 3-38 to 3-41
for sounds, 3-59 to 3-64
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Button tool, 2-27, 4-10, 4-13, 4-19, 6-2, 6-8, 6-41

C
calculations, ready-made field for displaying, 7-6
calendar, ready-made field for displaying, 7-6
“Cancel” buttons, creating, 3-43
Can’t Delete Background option, 5-25
Can’t Delete Card option, 5-15 to 5-16
“Can’t modify this stack” message, 1-18
Can’t Peek option, 4-39
“Can’t understand arguments of ...” message, 3-24
capitalization. See case sensitivity
Card Info command, 1-28, 4-22, 5-10

Don’t Search Card option, 5-14
card layers

described, 3-5, 4-5 to 4-8, 5-2
placement of buttons in, 6-4
shared text in, 7-21
toggling between background layer, 4-25
See also graphics; overlapping element correction

Card Marked option, 5-12
card numbers

deleting fields by, 2-33
ready-made field for displaying, 7-6

cards
accessing by name/number/ID, 1-28 to 1-29
adding, 2-11 to 2-12, 3-18, 5-2 to 5-5
backgrounds, 2-25 to 2-27
copying, 5-7
deleting, 5-15
described, 1-3, 5-2
examples, 4-2 to 4-4
getting information about, 5-10
Index, 3-48 to 3-49
marking, 5-12 to 5-13

marking for printing, 9-7, 9-10
moving, 5-8
moving to first position, 5-9
naming, 5-11
printing, 9-4, 9-7 to 9-8
renaming, 2-16
sizing, 4-26, 4-29 to 4-31
viewing all in stack, 1-29 to 1-30, 2-6 to 2-7
viewing large, 1-38, 5-5 to 5-6
viewing previously viewed, 1-39 to 1-40
See also graphics; stacks; windows

carriage returns
in scripts, 3-34
and wrapping of text at ends of lines, 2-10

case sensitivity
for passwords, 1-17, 4-35
for scripts, 3-9

CD-ROM, stacks on, 1-44 to 1-45
centering drawn lines, 8-21
characters

deleting, 1-42
formatting, 7-18 to 7-20

Clear Button command, 6-50
Clear Field command, 7-37
Clear Icon command, 6-32
Clear Picture command, 8-61
clicking, buttons, 1-27
clip art (Art Bits stack), 3-29, 4-27, 8-11
Close Icon command, 6-27
Close Stack command, 1-21
closing

Message box, 2-18
stacks, 1-21
windows, 2-13
See also hiding

column selection for printing, 9-14
commands

described, 3-56
for handling graphics, 8-2 to 8-4, 8-52 to 8-54
naming, 3-68
undoing, 1-42, 4-24 to 4-25
See also individual commands by name; Messag

box; message handlers; Power keys
comments in scripts, 3-40 to 3-41

for stack access, 1-7, 1-15, 1-27
for stack information, 1-21
transparent, 6-8, 6-46
unclickable (disabled), 6-9
See also fields; Home button; icons; Next button; 

Previous button

buttons (Continued)
Index Index-3
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compacting of stacks, 1-21, 4-23, 4-33
Compact Stack command, 1-21
CompuServe, as source of stacks, xxi
condensed fonts, 7-18, 7-19
“condition” placeholder, 3-42
“container” placeholder, 3-31
containers, 3-30
converting

measures in ready-made fields, 7-6
stacks from earlier versions of HyperCard, 1-19

1-21, 4-24
text to Paint text, 8-36

Convert Stack command, 1-19
copies to print, 9-6
copy and paste operations, 2-21 to 2-23
Copy Button command, 2-32, 2-44 to 2-45
Copy Card command, 5-7, 8-60
Copy current background option, 4-26
Copy Field command, 7-7, 7-28 to 7-30
Copy Icon command, 6-31
copying

background art, 2-42 to 2-43
background buttons, 2-44 to 2-46
backgrounds, 4-26, 5-20 to 5-22
buttons, 2-31 to 2-33, 6-39 to 6-40
cards, 5-7
fields, 7-28 to 7-30
graphics, 2-21 to 2-23, 8-56 to 8-57
icons, 6-30 to 6-32
ready-made buttons, 6-7
ready-made fields, 7-6 to 7-7
ready-made graphics, 3-29, 8-11 to 8-12
report templates, 9-16 to 9-17
stacks, 4-18, 4-31 to 4-32
stacks from templates, 4-26

Copy Picture command, 2-22, 8-11, 8-57
Copy Report command, 9-16
cover pages to print, 9-6
crosshair pointer, 8-5, 8-20 to 8-21
cursor

setting to busy (spinning beach ball), 3-55
See also pointers

“cursor” global property, 3-56
Curve tool, 4-10, 8-3, 8-20

with Draw Filled option, 8-28
Index-4 Index
customizing
arrow buttons, 2-29 to 2-30
fields using shared text, 2-36 to 2-38, 7-2, 7-10,

7-20 to 7-21
Home button, 2-28 to 2-29
Home cards, 4-43 to 4-44
Home stack, 4-43 to 4-45
HyperCard from Preferences card, 1-8
reports using templates, 9-11 to 9-18
stacks, 2-23 to 2-40
stacks using templates, 4-24

Cut Card command, 5-8
Cut Field command, 7-33 to 7-35
Cut Picture command, 8-58
Cut Report command, 9-16
Cut Text command, 2-10 to 2-11

D
Darken command, 8-47
data. See cards; text
date

adding at printtime, 9-5
entering today’s, 2-19
ready-made field for displaying, 7-6

Debug button, 3-66
Debugger menu, 3-66
defaults

for field text, 7-16
for fonts, 7-17
restoring text to, 7-20

Delete Card command, 5-15, 5-26
Delete key, 1-42, 2-33, 7-37, 8-61
Delete Report command, 9-18
Delete Stack command, 4-42
deleting  

backgrounds, 5-26
buttons, 2-27, 6-50
cards, 5-15
characters, 1-42
fields, 2-33, 7-37
graphics, 8-61
icons, 6-32
Paint text, 8-35
passwords, 4-40
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diacritical mark searches, 1-30
directories

moving up levels in, 1-6
See also folders

disabled buttons, 6-9
disk renaming, 1-13
Distort option, 8-51
documents

opening with applications, 1-42 to 1-43
search paths for, 1-13
See also cards; reports; stacks

“doMenu” command, 3-44
Don’t Search Background option, 5-24
Don’t Search Card option, 5-14
Don’t Search option, 3-57, 7-21, 7-37
Don’t Wrap check box, 7-11
Draw Centered option, 8-22, 8-31
Draw Filled option, 8-27 to 8-28
drawing lines and shapes, 8-20 to 8-29
Draw Multiple option, 8-30 to 8-31
Duplicate Icon command, 6-27, 6-30

E
editing

buttons, 6-10 to 6-15
fields, 2-33 to 2-34
icons, 6-23 to 6-29
magnified graphics, 8-39 to 8-41
text, 1-42, 2-10 to 2-11, 7-9 to 7-15
See also formatting

Edit menu, 1-10
Background command, 2-26, 4-23, 5-17
Clear Button command, 6-50
Clear Field command, 7-37
Clear Icon command, 6-32
Clear Picture command, 8-61
Copy Button command, 2-32, 2-44 to 2-45

preventing for cards, 4-22, 5-14 to 5-15
preventing for stacks, 4-36
report templates, 9-18
search paths, 1-14
stacks, 4-42

deleting (Continued)
Index
Copy Card command, 5-7, 8-60
Copy Field command, 7-7, 7-28 to 7-30
Copy Icon command, 6-31
Copy Picture command, 2-22, 8-11, 8-57
Copy Report command, 9-16
Cut Card command, 5-8
Cut Field command, 7-33 to 7-35
Cut Picture command, 8-58
Cut Report command, 9-16
Cut Text command, 2-10 to 2-11
Delete Card command, 5-15, 5-26
Delete Report command, 9-18
Icon command, 6-21
New Button command, 6-27
New Card command, 2-11 to 2-12, 3-18, 5-3
Paste Card command, 5-7, 5-8
Paste Field command, 7-7, 7-30, 7-33 to 7-35
Paste Picture command, 2-22 to 2-23, 8-11, 8-5
Paste Report command, 9-17
Paste Text command, 2-11
Report Items command, 9-12 to 9-13
Report Name command, 9-18
Text Style command, 2-35, 6-15, 7-16, 7-18
Undo command, 1-42, 4-24 to 4-25, 5-15, 7-15

Edit Pattern option, 8-18
Effect options, 6-38 to 6-39
electronic bulletin boards, as sources of stacks, xxi
“else” statement, 3-45
empty scripts, 3-62
empty shells, 4-28
empty space

checking for gaps in filled graphics, 8-17
eliminating from selected graphics, 8-5, 8-6

“end” command, 3-14
“end if” command, 3-42
“end repeat” command, 3-47
entering

date, 2-19, 9-5
Paint text, 8-33 to 8-35
text, 1-41 to 1-42, 2-9 to 2-10, 7-9 to 7-12
time, 3-31, 9-5
and undoing entries, 1-42, 4-24 to 4-25, 5-15, 

7-15
See also editing; erasing
Index-5
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Erase command, 6-28
Eraser tool, 4-10, 8-3, 8-12, 8-61
erasing

with Brush tool, 8-13
graphics, 8-61
search paths, 1-14
with Spray tool, 8-15
text or typing mistakes, 7-15
with Undo command, 1-42, 4-24 to 4-25, 5-15, 

7-15
with “white paint,” 8-61

Esc key
to undo paint operations, 8-12
to view previous card, 1-39

exiting HyperCard, 1-21, 1-45
exporting/importing graphics, 8-59 to 8-60
Export Paint command, 8-59 to 8-60
“expression” placeholder, 3-31
extended fonts, 7-18, 7-19

F
FatBits option, 8-17, 8-39 to 8-41
Field Info command, 4-22, 7-5

Auto Select option, 7-27
Auto Tab option, 7-15
Don’t Search option, 7-37
Don’t Wrap check box, 7-11
for field number, 7-14
Fixed Line Height option, 7-17, 7-19
Lock Text option, 7-27, 7-35
Multiple Lines option, 7-27
Shared Text option, 2-37, 7-20 to 7-21
Show Lines option, 7-19, 7-26 to 7-27
Style option, 7-25
Text Style option, 7-16
Wide Margins check box, 7-26

field numbers, 6-43, 7-14
fields

advancing pointer to next, 3-18
background, 2-47 to 2-51
as containers, 3-32
copying, 7-28 to 7-30
correcting overlapping, 7-31
creating and placing, 2-35 to 2-38, 3-14 to 3-18

7-3 to 7-4
Index-6 Index
defined, 2-9, 7-1
deleting, 2-33, 7-37
editing, 2-33 to 2-34
excluding from searches, 4-39, 5-14
finding, 3-18, 7-22
finding specific text in, 1-32 to 1-34
formatting (styling), 7-16 to 7-21, 7-24 to 7-25
labeling, 2-36 to 2-37
for labels, 3-32 to 3-34
list type, 7-27
locking, 7-35
margins, 4-22, 7-26, 9-5, 9-9, 9-12
moving, 7-30 to 7-35
naming, 7-28
numbering, 6-43, 7-14
overlapping with buttons, 6-44 to 6-46
pop-up, 3-34 to 3-35
printing, 9-8 to 9-9
ready-made, 7-6 to 7-7
retrieving deleted, 7-37
selecting with Field tool, 4-13
shared text, 2-36 to 2-38, 7-2, 7-10, 7-20 to 7-2
sizing, 7-23 to 7-24
transparent, 7-24, 7-25, 7-31
See also buttons; text

Field tool, 2-33, 2-37, 4-10, 4-13, 4-21, 7-4, 7-8
File menu

Close Icon command, 6-27
Close Stack command, 1-21
Delete Stack command, 4-42
Duplicate Icon command, 6-27, 6-30
Export Paint command, 8-59 to 8-60
Import Paint command, 8-4, 8-59
New Icon command, 6-22, 6-27
New Stack command, 2-41 to 2-42, 4-26 to 4-2
Open Stack command, 1-15 to 1-16, 2-5
Page Setup command, 9-2 to 9-3
Print Card command, 9-4
Print Field command, 9-8 to 9-9
Print Report command, 9-10
Print Stack command, 9-4 to 9-6
Protect Stack command, 1-10, 4-34
Quit HyperCard command, 1-21, 1-45
Save a Copy command, 2-14, 4-32 to 4-33
variation by user level, 1-10
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files
locating, 1-13
saving, 2-14
See also cards; stacks

file servers
user access settings, 4-41
using stacks on, 1-44

file transfers of graphics, 8-59 to 8-60
Fill command, 8-18, 8-42 to 8-43
filling graphics, 8-15 to 8-17
fill space, eliminating from selected graphics, 8-5, 8
Find button, 2-30 to 2-31
“find” command, 3-58
Find command (Go menu), 1-24, 1-30
Find command (Icon menu), 6-28
finding

buttons, 1-26, 6-5
disabling for fields or backgrounds, 4-22, 4-23
fields, 7-22
help with Find Topic button, 2-56 to 2-57
stacks, 1-13 to 1-14
text, 1-30 to 1-35, 2-20 to 2-21
unworkable with Paint text, 8-35
See also browsing

Find Topic button, 2-56 to 2-57
First command (Go menu), 1-24, 2-8, 5-3
First command (Icon menu), 6-28
Fixed Line Height option, 7-17, 7-19
“flash” command, 3-60
Flip Horizontal command (Paint menu), 2-22, 8-50
Flip Horizontal command (Special menu of Icon 

Editor), 6-29
flipping

graphics, 8-46 to 8-50
icons, 6-29

Flip Vertical command (Paint menu), 8-50
Flip Vertical command (Special menu of Icon Editor)

6-29
folders

moving up levels in directories, 1-6
opening HyperCard, 2-2
renaming, 1-13

Font menu, 6-14
Index
fonts
defaults for field text, 7-17
defaults for Paint text, 8-34
selecting for Paint text, 8-34
selecting for report templates, 9-14
selecting for text, 7-18, 7-19

foreground layers of cards, 3-5
See also backgrounds

formatting
characters, 7-18 to 7-20
fields, 7-16 to 7-21
restoring text to defaults, 7-20
See also editing

Frame command (Special menu of Icon Editor), 6-2
functions, 3-56

G
gaps in filled graphics, 8-17
General tools, 4-9, 4-12
GEnie, as source of stacks, xxi
global properties, 3-54
global variables, 3-40
Go command, 1-28
Go menu, 1-23 to 1-25, 2-8

Find command, 1-30
First command, 5-3
Help command, 1-43, 2-55 to 2-56
Home command, 1-24, 1-40, 2-8
Scroll command, 1-24, 1-36 to 1-37, 1-38

“go to” command, 5-13
graphics  

aligning, 8-32 to 8-33
caution for editing on reduced-size cards, 4-31
commands, tools, power keys and menus for 

handling, 8-2 to 8-4, 8-52 to 8-54
copying, 2-21 to 2-23, 8-56 to 8-57
correcting overlapping elements, 8-37 to 8-38
darkening/lightening, 8-47
deleting, 8-61
described, 8-1
drawing lines and shapes, 8-20 to 8-29
filling areas, 8-15 to 8-17
flipping, 8-46, 8-50
Index-7
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Gray command (Special menu of Icon Editor), 6-29
Grid option, 8-32 to 8-33
grouping text, 7-36
Group option, 7-36

H
hand (Browse tool), 2-4, 4-10
handlers. See message handlers
Hand tool, 6-26
help, 1-43 to 1-44, 2-54 to 2-57
Help command, 1-24, 1-43, 2-55 to 2-56
hidden buttons, 6-5
“hide me” command, 3-37 to 3-38
hiding

menu bars, 1-22
Message box, 1-30
navigator palette, 1-26
options as protection for stacks, 1-10, 1-17, 4-3

to 4-41
Scroll window, 1-37, 5-6
Tools palette, 4-11
See also viewing

importing/exporting, 8-59 to 8-60
miniatures of, 8-60
moving, 8-29
moving to/from background, 8-57 to 8-58
multiples, 8-30 to 8-31
opaque or transparent, 8-38 to 8-39
outlining, 8-48
painting with Brush tool, 8-12 to 8-13
painting with Spray tool, 8-15
with Paint text, 8-33 to 8-36
patterns, 8-18 to 8-19, 8-42 to 8-45
ready-made, 3-29, 8-11 to 8-12
reverting to last version of, 8-55
rotating, slanting or distorting, 8-49 to 8-51
saving, 8-54 to 8-55
selecting, 4-14, 8-4 to 8-10, 8-42, 8-46, 8-56
sizing, 8-39 to 8-42, 8-60
undoing mistakes, 8-12
See also visual effects

graphics (Continued)
Index-8 Index
highlighting
buttons, 3-54, 4-20, 6-15 to 6-19
clicked lines of text, 7-27

hilite properties, 3-54
Home button

creating, 3-6 to 3-7
customizing, 2-28 to 2-29
testing, 3-9

Home cards, 1-7, 2-15 to 2-16
customizing, 4-43 to 4-44

Home command, 1-24, 1-40, 2-9
Home menu, Rename This Card command, 2-16
Home stack

activating, 2-13
adding buttons to, 3-11
customizing, 4-43 to 4-45
described, 2-14 to 2-17
returning to, 1-40, 2-4
starting HyperCard from, 1-4 to 1-6

HyperCard
accessing stacks from earlier versions of, 1-19
described, 1-2 to 1-4
quitting, 1-21, 1-45
references and guides, xviii
starting, from Systems 6 and 7, 4-44 to 4-45
starting with Home stack, 1-4 to 1-6
starting with stack other than Home, 1-6
See also customizing

HyperCard Tour, 2-2 to 2-3
HyperTalk

described, 1-2, 1-22, 2-19, 3-1
rules of syntax, 3-24 to 3-25
See also scripts

HyperTalk Reference stack, 1-44
hyphens (--), as comment indicators, 3-40

I
I-beam pointer, 1-41, 2-4, 2-10, 7-10 to 7-11
Icon Chooser dialog box, 6-22, 6-23
Icon command, 6-21
Icon Editor, 6-24 to 6-25, 6-26 to 6-29
Icon menu, 6-28
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39
icons(Continued)
attaching to stacks, 6-32
for browsing stacks, 1-25 to 1-26
cartoon balloons, 3-35
choosing for buttons, 2-30 to 2-31, 6-19 to 6-20
combining with text, 6-20 to 6-21
copying, 6-30 to 6-32
creating, 6-21 to 6-22
deleting, 6-32
for help, 1-43
for Home button, 3-7
for Home stack, 1-40
for HyperTalk Reference stack, 1-43
inverting, 6-29
modifying, 6-23 to 6-29
for printers, 9-2
for stacks, 1-4, 1-15
See also buttons

ID
of buttons, 6-46
of cards, 1-28 to 1-29, 1-32 to 1-33, 6-35, 6-37
field numbers, 6-43, 7-14
of objects, 6-15

“if” command, 3-41 to 3-42, 3-44 to 3-46
nesting, 3-46

ImageWriter printers, 9-3, 9-6
importing/exporting graphics, 8-59 to 8-60
Import Paint command, 8-4, 8-59
Index buttons, 3-49 to 3-51
Index cards, 3-47 to 3-49
indexes, 3-50 to 3-54
insertion point, 1-11

See also pointers
inverse print, 9-14 to 9-15
Invert command (Paint menu), 8-46
Invert command (Special menu of Icon Editor), 6-29
inverting

graphics, 8-46
icons, 6-29

italics, 7-18, 7-19
Item Info command, 9-13 to 9-15
Items menu

Item Info command, 9-13 to 9-15
New Item command, 9-13
Index
K
Keep command, 6-28, 8-54 to 8-55
keywords in scripts, 3-14

L
label fields, 3-32 to 3-34
labels

for background fields, 2-51
for fields, 2-36 to 2-37

labels (mailing), printing, 9-11
landscape orientation of printing, 9-3
LaserWriter printers, 9-3, 9-5, 9-6
Lasso tool, 2-21, 4-10, 4-14, 8-3, 8-6
Last command (Go menu), 1-24, 2-8
Last command (Icon menu), 6-28
launching. See opening; starting
layers. See backgrounds; card layers
legal-size paper, 9-3
letter-size paper, 9-3
Lighten command, 8-47
lines (graphics)

drawing, 8-20 to 8-26, 8-30
selecting thickness, 8-28 to 8-29
for underlining text, 2-48

lines of text, highlighting, 7-27
lines (rules), showing in fields, 7-26 to 7-27
Line tool, 2-48, 4-10, 8-3, 8-20 to 8-21

with Draw Multiple option, 8-31
linking

buttons to cards or stacks, 1-4, 4-20, 6-33 to 6-
renaming and broken links, 4-29

LinkTo box, 6-34 to 6-35
list fields, 7-27
local variables, 3-40
location properties, 3-54
locking

fields, 7-35
stacks, 1-6, 4-18
See also padlock symbol

“lock screen” command, 3-52, 3-53
Lock Text option, 3-57, 7-27, 7-35
loops, 3-46 to 3-47, 3-49 to 3-54
Index-9
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M
mailing label printing, 9-11
margins

adjusting for printed output, 9-5, 9-9
setting in fields, 7-26
setting on report templates, 9-12

“mark” command, 5-13
Marked Cards option, 9-7, 9-10
marking cards, 5-12 to 5-13

for printing, 9-7, 9-10
maximizing. See sizing
measures

ready-made field for converting, 7-6
See also units of measurement

“me” command, 3-36
memory

penalties of too many open applications, 1-43
requirements for windows, 1-20

menu bars
hiding/displaying, 1-22
for Icon Editor, 6-27
stripes in background layer, 4-25 to 4-26, 5-18

menus
Home menu, 2-16
Icon menu, 6-28
Items menu, 9-13 to 9-15
as pop-up buttons, 6-12 to 6-13
Reports menu, 9-11
See also Edit menu; File menu; Go menu; Objects 

menu; Options menu; Paint menu; 
Style menu; Tools menu

Message box
for accessing specific cards, 1-28 to 1-29
calling message handlers, 3-69
closing, 2-18
entering commands into, 1-12 to 1-13, 2-18 to 

2-19
for finding text, 1-30
for help, 1-43
for HyperTalk Reference stack, 1-43
for marking cards, 5-13
for moving between backgrounds, 5-20
for opening applications, 1-42 to 1-43

for opening stacks, 1-15, 1-17
putting values into, 3-30 to 3-31
for returning to Home stack, 1-40

Message command, 1-24
message handlers

calling from Message box, 3-69
calling handlers, 3-65 to 3-68
described, 3-13, 3-59
intercepting, 3-68 to 3-69
placing, 3-61 to 3-64
sound buttons, 3-59 to 3-60
and subprocedures, 3-70 to 3-71

miniatures of graphics, 8-60
minimizing. See sizing
Mirror Horizontal command (Special menu of Icon 

Editor), 6-29
Mirror Vertical command (Special menu of Icon 

Editor), 6-29
“mouseStillDown” command, 3-28
“mouseUp/Down” command, 3-36
moving around (navigating). See browsing
moving (rearranging)

buttons, 6-41 to 6-49
cards, 5-8, 5-9
drawn shapes, 8-22
fields, 7-30 to 7-35
graphics, 8-29, 8-57 to 8-58
objects, 4-17
overlapping elements, 6-44 to 6-46, 7-31, 8-37 t

8-38
report templates, 9-16 to 9-17
windows, 1-35, 2-13

Multiple Lines option, 7-27

N
name properties, 3-54
naming

backgrounds, 5-23
buttons, 3-19, 6-8
cards, 5-11
commands, 3-68
fields, 7-28
Index-10 Index
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icons, 6-22
report templates, 9-11
stacks, 2-42, 4-28 to 4-29
See also renaming

navigating. See browsing
navigator palette, 1-25 to 1-26
nesting “if” structures, 3-46
New Background command, 5-19
New Button command, 3-38 to 3-41, 6-27
New Card command, 2-11 to 2-12, 3-18, 5-3
New Field command, 2-35, 2-47, 7-8
New Icon command, 6-22, 6-27
New Item command, 9-13
New Stack command, 2-41 to 2-42
Next button

adding visual effects, 3-22 to 3-23
creating, 3-19 to 3-20
modifying script for card skimming, 3-25 to 3-27

Next command (Go menu), 1-24, 2-8
Next command (Icon menu), 6-28
Next Window command, 1-24
Notes field, 2-38 to 2-39

O
objects

correcting overlapping, 6-44 to 6-46, 7-31, 8-37 
to 8-38

described, 4-17
See also backgrounds; buttons; cards; fields; 

moving (rearranging); stacks
Objects menu

for accessing cards, 1-28
Bkgnd Info command, 2-26, 2-53, 4-23, 5-18, 

5-22
Bring Closer command, 6-45
Button Info command, 2-28, 4-20, 6-3 to 6-4
Card Info command, 1-28, 3-48, 4-22, 5-10
Field Info command, 4-22, 7-5, 7-11, 7-16, 7-25 

to 7-28, 7-36 to 7-37
New Background command, 5-19
New Button command, 3-38 to 3-41
New Field command, 2-35, 2-47, 7-8

Scripting user level for, 3-4
Send Farther command, 6-45
Stack Info command, 4-23, 5-19

“OK” buttons, creating, 3-44
“on” command, 3-14
opaque buttons, 6-46
Opaque command, 8-38 to 8-39
opaque fields, 7-24, 7-25, 7-31
opaque graphics, 8-38 to 8-39
“openCard” command, 3-33
opening

HyperCard folder, 2-2
HyperCard Tour, 2-2 to 2-3
stacks, 1-6, 1-15 to 1-20, 2-4 to 2-5
stacks in new windows, 1-16, 1-20, 2-13, 4-27

Open Stack command, 1-15 to 1-16, 2-5
Open stack in new window option, 1-16, 1-20, 2-13,

4-27
Options menu, 8-4

Brush Shape option, 8-14
Distort option, 8-51
Draw Centered option, 8-22
Draw Filled option, 8-27 to 8-28
Draw Multiple option, 8-30 to 8-31
Edit Pattern option, 8-18 to 8-19
FatBits option, 8-17, 8-39 to 8-41
Grid option, 8-32 to 8-33
Perspective option, 8-51
Polygon Sides option, 8-23
Rotate option, 8-51
Slant option, 8-51

orientation of printing, 9-3
outlining

fonts, 7-17, 7-18
graphics, 8-48

Oval tool, 4-10, 8-3, 8-21 to 8-22
with Draw Multiple option, 8-31

overlapping element correction
buttons, 6-44 to 6-46
fields, 7-31
graphics, 8-37 to 8-38
Index Index-11
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padlock symbol

for locked stacks, 1-6, 1-18, 4-18, 4-37
removing, 4-37
for unconverted stacks, 1-19, 4-24

page numbering at printtime, 9-5
page ranges to print, 9-6
Page Setup command, 9-2 to 9-3
painting

graphics with Brush tool, 8-12 to 8-13
graphics with Spray tool, 8-15

Painting (user level), 1-9
Paint menu, 8-4

Darken command, 8-47
Fill command, 8-18, 8-42 to 8-43
Flip Horizontal command, 2-22, 8-50
Flip Vertical command, 8-50
Invert command, 8-46
Keep command, 8-54 to 8-55
Lighten command, 8-47
Opaque command, 8-38 to 8-39
Pickup command, 8-45
Revert command, 8-55
Rotate Left/Right commands, 8-49
Select All command, 8-10
Trace Edges command, 8-48
Transparent command, 8-38 to 8-39

Paint text
converting text into, 8-35 to 8-36
deleting, 8-35
described, 7-2
entering, 8-33 to 8-35
slanting, rotating and distorting, 8-49 to 8-51
unsearchable, 8-35

Paint Text tool, 8-3
Paint tools, 4-9, 4-10, 4-12, 8-2 to 8-3

tilde with, 1-39
paper size, 9-3
part numbers, 6-43
passwords, 1-17, 4-34 to 4-38

removing, 4-40
Paste Card command, 5-7, 5-8
Paste Field command, 7-7, 7-30, 7-33 to 7-35
Index-12 Index
Paste Picture command, 2-22 to 2-23, 8-11, 8-58
Paste Report command, 9-17
Paste Text command, 2-11
patterns, 8-18 to 8-19, 8-42 to 8-45

painting with Brush tool, 8-13
Patterns menu, 8-18 to 8-19
Patterns palette, 8-18
Pencil tool, 4-10, 6-26, 8-3, 8-26
Perspective option, 8-51
Pickup command, 6-28, 8-45
pictures. See graphics
“play” command, 3-60
pointers

advancing to next field, 3-18
arrow symbol, 2-4
crosshair, 8-5, 8-20 to 8-21
I-beam, 1-41, 2-4, 2-10, 7-10 to 7-11
insertion point for moving through text, 1-11
pointing hand (Browse tool), 2-4, 4-10
setting to busy (spinning beach ball), 3-56

Polygon Sides option, 8-23
Polygon tool, 4-10, 8-3, 8-23 to 8-25

with Draw Filled option, 8-28
pop-up buttons, 6-12 to 6-13
pop-up fields, 3-34 to 3-35
portrait orientation of printing, 9-3
Power keys

disabled with Paint Text tool, 8-52
for graphics, 8-10
for icons, 6-29
turning on, 1-12

Precision Bitmap Alignment option, 9-10. 9.5
Preferences card

accessing, 1-8
described, 1-7, 2-16 to 2-17

Prev command (Go menu), 1-24, 2-8
Prev command (Icon menu), 6-28
Previous button

adding visual effects, 3-23 to 3-25
creating, 3-19 to 3-21
modifying script for card skimming, 3-27 to 3-28

Print Card command, 9-4
“print” command, 5-13
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printers
ImageWriter, 9-3, 9-6
LaserWriter, 9-3, 9-5, 9-6, 9-10

Print Field command, 9-8 to 9-9
printing

cards, 9-4, 9-7 to 9-8
fields, 9-8 to 9-9
mailing labels, 9-11
preparations for, 9-2 to 9-3
reports, 9-9 to 9-11
selecting inverse print, 9-14
stacks, 9-4 to 9-6

Print Report command, 9-10
Print Stack command, 9-4 to 9-6

Marked Cards option, 9-7
Private Access option, 4-34
programming language. See HyperTalk
properties, 3-54
“property” placeholder, 3-54
protecting

backgrounds from deletion, 5-24 to 5-25
cards from deletion, 5-15
stacks, 1-10, 1-17, 4-34 to 4-41

Protect Stack command, 1-10, 4-34 to 4-35
“put” command, 3-30 to 3-31

Q
question mark (button), 1-21
Quit buttons, 3-42 to 3-45
quitting HyperCard, 1-21, 1-45
quotation marks

in scripts, 3-31
in text searches, 1-30, 2-20

R
RAM requirements for windows, 1-20
Readymade Buttons stack, 2-31, 4-27, 6-6
Readymade Fields stack, 4-27, 7-6 to 7-7
ready-made graphics, 3-29, 4-27, 8-11 to 8-12
ready-made stack elements, 4-8
Recent command, 1-24, 1-40

Rectangle command, 3-32
Rectangle tool, 4-10, 8-3, 8-21 to 8-22

with Draw Multiple option, 8-31
rectangular fields, 7-24
Regular Polygon tool, 4-10, 8-3

with Draw Multiple option, 8-31
Rename This Card command, 2-16
renaming

and broken links between stacks, 4-29
cards, 2-16
report templates, 9-18
stacks, 4-28 to 4-29
See also naming

“repeat” command, 3-46 to 3-47, 3-49 to 3-54
“repeat with” command, 3-50
Report Items command, 9-12 to 9-13
Report Name command, 9-18
reports

creating templates for, 9-11 to 9-18
printing, 9-9 to 9-11

Reports menu, New Report command, 9-11
report templates

copying or moving, 9-16 to 9-17
creating, 9-11 to 9-16
deleting, 9-18
described, 9-9
naming, 9-11
renaming, 9-18

resizing. See sizing
restoring. See Undo command
Revert command

for graphics editing, 8-55
for icon editing, 6-28

Rotate 90° (Special menu of Icon Editor), 6-29
Rotate Left/Right commands, 8-49
Rotate option, 8-51
rotating

graphics, 8-24, 8-51
icons, 6-29

Rounded Rectangle tool, 4-10, 8-3, 8-21 to 8-22
with Draw Multiple option, 8-31
Index Index-13
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S
Save a Copy command, 2-14, 4-32
saving

automatic, 1-45, 2-10, 4-18
copies of files, 2-14
graphics, 8-54 to 8-55
new patterns, 8-19
stacks as stand-alone applications, 4-32 to 4-33

screen
flashing, 3-60
freezing with “lock screen” command, 3-52, 3-53
See also windows

Scripting (user level), 1-9
selecting, 2-17, 3-3 to 3-4

Script option, 6-49
scripts

case sensitivity, 3-9
caution on renaming fields, 7-28
caution on reusing, 4-17 to 4-18, 4-27 to 4-28, 5
described, 3-1, 3-10, 4-5, 4-17
empty, 3-62
and grouping text, 7-36
for Home buttons, 3-8 to 3-9
for linking buttons to cards or stacks, 6-35 to 6-3
for “Next” and “Previous” buttons, 3-20 to 3-21
opening on buttons, 6-49
preventing user halts of, 4-40
rules of syntax, 3-24 to 3-25
for visual effects, 3-22 to 3-25

Scroll command, 1-24, 1-36 to 1-37, 1-38
scrolling fields, 7-24
searching. See finding
search paths, 1-13
Search Paths cards, 1-7, 1-13 to 1-14
Select All command, 8-10
selecting

buttons, 2-27
cards and stacks, 1-11 to 1-12, 2-4
fields, 3-18
graphics, 4-14, 8-4 to 8-10
icons, 6-26

Select tool, 4-10, 4-14, 6-26, 8-3, 8-5
Index-14 Index
Send Farther command, 6-45
“set” command, 3-54 to 3-56
Shadow command (Special menu of Icon Editor), 6-2
shadow fields, 7-24
shadowing, 7-18, 7-19
Shared Hilite option, 6-16 to 6-17
shared text fields

described, 2-36, 7-2, 7-10, 7-20
disabling, 7-21
entering text into, 2-37 to 2-38, 7-20 to 7-21

Shared Text option, 2-37 to 2-38, 7-20 to 7-21
Shift-Tab keys, 7-13
“show” command, 3-38
showing

lines (rules) in fields, 7-26 to 7-27
names of buttons, 6-8
See also viewing

Show Lines option, 7-19, 7-26 to 7-27
Show Name option, 6-8
sizing

buttons, 6-10
cards, 4-29 to 4-31
fields, 7-23 to 7-24
graphics, 8-39 to 8-42, 8-60
Notes field, 2-38 to 2-39
printed cards, 9-5
stacks, 2-39 to 2-40
text, 2-34
windows, 1-36 to 1-37

slanting graphics, 8-51
Slant option, 8-51
soft returns in scripts, 3-34
Sort buttons, 3-38 to 3-41
sorting, 3-38 to 3-41
sound buttons, 3-59 to 3-64, 3-65 to 3-69
Special menu (Icon Editor), 6-29
Spray tool, 4-10, 8-3, 8-12 to 8-13
Stack Info command, 4-23, 5-19
Stack Kit card, 2-15

Background Art button, 2-42 to 2-43
Readymade Buttons command, 2-32

Stack overview buttons, 1-21
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stacks
attaching icons to, 6-32
browsing, 1-10 to 1-12, 1-20, 1-21 to 1-30, 1-39
closing, 1-21
compacting, 1-21, 4-23, 4-33
converting from earlier versions of HyperCard, 

1-19, 1-21, 4-24
creating and verifying, 2-41 to 2-53, 4-14 to 4-18

4-25 to 4-32
customizing, 2-23 to 2-40
deleting, 4-42
described, xvii, 1-1, 1-3 to 1-4
designating as “Home,” 1-5
examples, 4-2 to 4-4
finding, 1-13 to 1-14
locking, 1-6, 4-18
modifying, 4-17 to 4-25
naming, 2-42, 4-28 to 4-29
opening, 1-6, 1-15 to 1-17, 2-4 to 2-5
opening from earlier versions of HyperCard, 1-1
opening in new windows, 1-16, 1-20, 2-13, 4-27
opening multiple, 1-20
opening password-protected, 1-17
opening write-protected, 1-18
printing, 9-4 to 9-6
protecting, 1-10, 4-34 to 4-41
renaming, 4-28 to 4-29
resizing, 2-39 to 2-40
saving as stand-alone applications, 4-32 to 4-3
saving copies, 4-18, 4-31 to 4-32
search paths for, 1-13
sources of, xxi, 1-44 to 1-45
templates for, 4-24
using on file servers, 1-44
See also cards; text

Stack Templates stack, 4-24, 4-27
starting

applications, 1-42 to 1-43
HyperCard, 1-4 to 1-6, 2-2, 4-44, 4-46
See also opening

Startup Items folder, putting HyperCard into, 4-45
statements in scripts, 3-10
strings in scripts, 3-31
Index
Style menu, 2-29
Bold command, 2-11
for button styles, 6-12
for field styles, 7-25
Group option, 7-36
Rectangle command, 3-32
Shadow command, 3-35
for text formats, 6-14
Transparent option, 2-29

subprocedures, 3-70 to 3-71
syntax for HyperTalk, 3-24 to 3-25
System 6, quick-starting HyperCard from, 4-44
System 7, quick-starting HyperCard from, 4-45
system messages, 3-10, 3-65

See also message handlers; scripts

T
Tab key, 3-18, 7-13, 7-14, 7-15
templates

for reports, 9-11 to 9-18
for stacks, 4-24
See also backgrounds; shared text fields

text
boldface, 2-11
combining with icons, 6-20 to 6-21
converting to Paint text, 8-35 to 8-36
editing, 1-42, 2-10 to 2-11, 7-9 to 7-15
entering, 1-41 to 1-42, 2-9 to 2-10, 7-9 to 7-12
finding, 1-30 to 1-35, 2-20 to 2-21
formatting individual characters, 7-18 to 7-20
formatting in fields, 7-16 to 7-17
formatting on buttons, 6-13 to 6-15
grouping, 7-36
printing from specific fields, 9-8 to 9-9
recalling erased with Undo, 7-13
resizing, 2-34
wrapping at ends of lines, 2-10, 3-34, 7-11, 7-2
See also cards; Paint text; shared text fields

Text Style button, 2-34
Text Style command, 2-35, 6-15, 7-16, 7-18
text wrap. See wrapping of lines
“then” command, 3-41 to 3-42
Index-15
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tilde (~)
to undo paint operations, 4-24, 8-12
to view previous card, 1-39

time
adding at printtime, 9-5
displaying in Message boxes, 3-31
ready-made field for displaying, 7-6

“time” function, 3-56
titles, for background fields, 2-47
Tools menu, 4-9 to 4-12

accessing, 1-23, 6-2 to 6-3
Brush tool, 4-10, 8-3, 8-12 to 8-13
Bucket tool, 4-10, 8-3, 8-12 to 8-16, 8-43 to 8-4
Button tool, 2-27, 4-10, 4-13, 4-19, 6-2, 6-8, 6-4
Curve tool, 4-10, 8-3, 8-20, 8-28
Eraser tool, 4-10, 8-3, 8-12
Field tool, 2-33, 2-37, 4-10, 4-13, 4-21
Lasso tool, 2-21, 4-10, 4-14, 8-3, 8-6
Line tool, 2-48, 4-10, 8-3, 8-20 to 8-21
Oval tool, 4-10, 8-3, 8-21 to 8-22
Paint tools, 8-2 to 8-3
Pencil tool, 4-10, 6-26, 8-3, 8-26
Polygon tool, 4-10, 8-3, 8-23 to 8-25, 8-28
Rectangle tool, 4-10, 8-3, 8-21 to 8-22
Rounded Rectangle tool, 4-10, 8-3, 8-21 to 8-22
Select tool, 4-10, 4-14, 6-26, 8-3, 8-5
Spray tool, 4-10, 8-3, 8-15
“tearing off” to move, 4-11, 6-2

Tools palette, 4-11, 6-2
Trace Edges command, 8-48
transparent buttons, 6-8, 6-46
Transparent command, 2-29, 8-38 to 8-39
transparent fields, 7-24, 7-25, 7-31
transparent graphics, 8-38 to 8-39
turned-down corners of cards. See marking cards
typing. See entering
Typing (user level), 1-1, 1-9

File and Edit menu versions in, 1-10
stack protection from, 4-39
Index-16 Index
U
unclickable buttons, 6-9
underlining, 7-18, 7-19

with Line tool, 2-48
Undo command, 1-42, 4-24 to 4-25, 5-15, 7-15
units of measurement

selecting for printed output, 9-5
selecting for report templates, 9-12

user access
restricting for stacks, 4-34 to 4-41
setting on AppleShare file servers, 4-41

user considerations
in background design, 5-17
in stack design, 4-14 to 4-17

user groups, for HyperCard, xxi
“userLevel” property, 3-54
user levels

options, 1-8 to 1-13
setting, 1-1, 1-8, 4-37 to 4-39

User Preferences card, 3-54

V
“value of” function, 3-58
values in containers, 3-30, 3-31
variables

described, 3-38
global and local, 3-40

viewing
all cards in stack, 1-29 to 1-30, 2-6 to 2-7
button names, 6-8
large cards, 1-38, 5-5 to 5-6
previously viewed cards, 1-39 to 1-40
See also hiding

visual effects
adding to “Next” and “Previous” buttons, 3-22 to

3-25
for linked cards or stacks, 6-38 to 6-39
selecting for buttons, 4-20
See also graphics
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WELL, The, as source of stacks, xxi
white space elimination for selected graphics, 8-5, 8-6
Wide Margins check box, 7-26
windows

closing, 2-14
moving, 1-35, 2-13
opening stacks in new, 1-16, 2-13
RAM requirements for, 1-20
resizing, 1-36 to 1-37
See also cards

word wrap. See wrapping of lines
wrapping of lines, 2-10, 7-23

disabling in fields, 7-11
not applicable to scripts, 3-34

write-protection for stacks, 1-18
Index Index-17
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